Subject: [Cbor] Martin Vigoureux's No Objection on draft-ietf-cbor-array-tags-07: (with COMMENT)

From: Martin Vigoureux via Datatracker <[email-masked]>
Date: Mon, 30 Sep 2019 02:11:43 -0700

Martin Vigoureux has entered the following ballot position for
draft-ietf-cbor-array-tags-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-cbor-array-tags/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Hello,

thank you for this document. I have a minor question.

   IEEE 754 binary floating numbers are always signed.  Therefore, for
   the float variants ("f" == 1), there is no need to distinguish
   between signed and unsigned variants; the "s" bit is always zero.
Since IEEE 754 binary floating numbers are always signed, I would have thought
that s=1 would be used in conjunction with f=1. For my understanding, what was
the reason for choosing s=0 instead?

Thank you

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 30 Sep 2019 14:50:02 +0200

On Sep 30, 2019, at 11:11, Martin Vigoureux via Datatracker <[email-masked]> wrote:
> […]

Indeed, the current exposition makes s=0 for floating point this a little unexpected.
The structure of the assigments was worked out before that exposition was written.
(Essentially, it has the “usual” numbers under s=0 and “unusual” ones under s=1, as signed integers are a bit unusual in the constrained space. f=1 is floating point so we can use a contiguous range of 24 tag numbers with fs = 00, 01, 10.)
When we wrote up the current exposition and noticed the oddity, we didn’t really want to change the assignment again — this draft has a long history.  So we considered the benefit of keeping the arrangement stable more important than avoiding the oddity.

Thank you for reading this to the level of detail where this oddity became apparent!

Grüße, Carsten