Subject: [Cbor] Roman Danyliw's No Objection on draft-ietf-cbor-array-tags-07: (with COMMENT)

From: Roman Danyliw via Datatracker <[email-masked]>
Date: Tue, 01 Oct 2019 07:01:29 -0700

Roman Danyliw has entered the following ballot position for
draft-ietf-cbor-array-tags-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-cbor-array-tags/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Section 1.1.  Per “this document uses the notation familiar from the
programming language C” and subsequent reference in Section 3.1, please provide
a reference to the relevant C standard.

Section 3.2.  Please provide a reference for a version of C++.

Section 8.2.  Per [TypedArray], please provide a URL or more complete citation

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 1 Oct 2019 16:46:47 +0200

Hi Roman,

> On Oct 1, 2019, at 16:01, Roman Danyliw via Datatracker <[email-masked]> wrote:
> 
> 

Good points.  Now in https://github.com/cbor-wg/array-tags/commit/ee36dae682028e19abd162a81b0adb768d703140
> Section 8.2.  Per [TypedArray], please provide a URL or more complete citation

This is a historical reference which unfortunately no longer resolves.
It is too bad that historical references cannot be qualified as such in the RFC format.
I wouldn’t mind to erase this part of history from the draft if historical references of this kind are not acceptable.
(Another example of this reference is at https://www.khronos.org/registry/webgl/specs/1.0.2/#refsTYPEDARRAYS .)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 1 Oct 2019 16:53:31 +0200

> This is a historical reference which unfortunately no longer resolves.

With archive.org, it does:

https://web.archive.org/web/20110207024413/http://www.khronos.org/registry/typedarray/specs/latest/

Should we go for that?

Grüße, Carsten

---

From: Roman Danyliw <[email-masked]>
Date: Tue, 1 Oct 2019 23:20:02 +0000

Hi Carsten!

> On Oct 1, 2019, at 10:54 AM, Carsten Bormann <[email-masked]> wrote:
> 

That would work for me. It’s an informative reference so I don’t see an issue.

Thanks for tracking it down.

Roman

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 2 Oct 2019 10:11:56 +0200

> That would work for me. It’s an informative reference so I don’t see an issue.

Now
https://github.com/cbor-wg/array-tags/commit/3e85dd9a4fcf5b54923506a802502cc289ff7314

Grüße, Carsten