Subject: [Cbor] CBOR Interim: 2019-10-09

From: Francesca Palombini <[email-masked]>
Date: Tue, 8 Oct 2019 13:18:08 +0000

Hi all,

An agenda has been posted for tomorrow’s interim:

Webex: https://ietf.webex.com/ietf/j.php?MTID=m1237a98124111de3a4c4e61dfaca05d5
Agenda: https://datatracker.ietf.org/meeting/interim-2019-cbor-17/materials/agenda-interim-2019-cbor-17-sessa
Time: https://www.worldtimebuddy.com/?qm=1&lid=12,100,5,8&h=100&date=2019-10-9&sln=15-16

Talk to you tomorrow,
Francesca

Hello,
CBOR Working Group invites you to join this Webex meeting.

CBOR WG Conference Call
Occurs every 2 week(s) on Wednesday effective Wednesday, May 22, 2019 until Wednesday, November 6, 2019 from 5:00 PM to 6:00 PM, (UTC+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna
5:00 pm  |  Europe Summer Time (Amsterdam, GMT+02:00)  |  1 hr

Meeting number (access code): 641 760 157

Meeting password: UPAt9rBn

Add to Calendar<https://ietf.webex.com/ietf/j.php?MTID=m1d0636069a28bd7c8cc090e741565c8c>
When it's time, join the meeting<https://ietf.webex.com/ietf/j.php?MTID=m1237a98124111de3a4c4e61dfaca05d5>.

Join by phone
1-650-479-3208<tel:%2B1-650-479-3208,,*01*641760157%23%23*01*> Call-in toll number (US/Canada)

Can't join the meeting?<https://collaborationhelp.cisco.com/article/WBX000029055>

IMPORTANT NOTICE: Please note that this Webex service allows audio and other information sent during the session to be recorded, which may be discoverable in a legal matter. By joining this session, you automatically consent to such recordings. If you do not consent to being recorded, discuss your concerns with the host or do not join the session.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 9 Oct 2019 13:31:38 +0200

> Agenda: https://datatracker.ietf.org/meeting/interim-2019-cbor-17/materials/agenda-interim-2019-cbor-17-sessa

Uh oh.  Instead of doing what I was supposed to do, I added a pull request for an alternative take at wellformedness errors, including Laurence’s examples but sorting them into slightly different classes (and adding a few).  Maybe we can discuss this later today.

For some reason the CI fails (with an error that I have seen before but never could locate), so it’s best to look at the actual source of the new appendix:

https://github.com/cbor-wg/CBORbis/pull/114/files

(We can reorder appendixes later, if we really want to do this, so I added at the end.)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 9 Oct 2019 14:24:51 +0200

On Oct 9, 2019, at 13:31, Carsten Bormann <[email-masked]> wrote:
> 
> including Laurence’s examples but sorting them into slightly different classes (and adding a few)

Below is the result of applying

puts DATA.read.scan(/^\* .*(?:\n  .*)+/).map { |x|
  x.sub(/.*:/m, "").gsub(/[\s\n]+/m, " ").split(",").map(&:strip)
}.flatten

to this section (in case you wonder how to extract the data).  Use “p” instead of “puts” above to get the same in a JSON array.  (Throwing the examples against a couple of my CBOR implementations exposes that in both cases I missed checking that the strings enclosed inside indefinite length strings are definite length.  Thanks, Laurence.)

Grüße, Carsten

18
19
1a
1b
19 01
1a 01 02
1b 01 02 03 04 05 06 07
38
58
78
98
9a 01 ff 00
b8
d8
f8
f9 00
fa 00 00
fb 00 00 00
41
61
5a ff ff ff ff 00
5b ff ff ff ff ff ff ff ff 01 02 03
7a ff ff ff ff 00
7b 7f ff ff ff ff ff ff ff 01 02 03
81
81 81 81 81 81 81 81 81 81
82 00
a1
a2 01 02
a1 00
a2 00 00 00
9f
9f 01 02
bf
bf 01 02 01 02
81 9f
9f 80 00
9f 9f 9f 9f 9f ff ff ff ff
9f 81 9f 81 9f 9f ff ff ff
1c
1d
1e
3c
3d
3e
5c
5d
5e
7c
7d
7e
9c
9d
9e
bc
bd
be
dc
dd
de
fc
fd
fe
5f 00 ff
5f 21 ff
5f 61 00 ff
5f 80 ff
5f a0 ff
5f c0 00 ff
5f e0 ff
7f 41 00 ff
5f 5f 41 00 ff ff
7f 7f 61 00 ff ff
81 ff
82 00 ff
a1 ff
a1 ff 00
a1 00 ff
a2 00 00 ff
9f 81 ff
9f 82 9f 81 9f 9f ff ff ff ff
bf 00 ff
bf 00 00 00 ff

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 9 Oct 2019 15:50:32 +0200

On Oct 9, 2019, at 13:31, Carsten Bormann <[email-masked]> wrote:
> 
> Instead of doing what I was supposed to do, I added a pull request

Two more:

* Remove the idea of strict mode. Discuss validity checking instead (#116)

* Explain how deterministic encoding is building on preferred serialization (#115)

https://github.com/cbor-wg/CBORbis/pulls

(CI still doesn’t work.  Hmm.)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 9 Oct 2019 18:06:26 +0200

> (CI still doesn’t work.  Hmm.)

The branch gh-pages was gone from github (but still present on my working copy, so I just had to push it).  How did that happen…  But at least I now know what to do.

Redoing all the CI builds for the pull requests now.

Grüße, Carsten