Subject: [Cbor] CBOR logo experiment

From: Jonathan Beri <[email-masked]>
Date: Sat, 30 May 2020 10:21:20 -0700

I had a moment of inspiration this morning and thought I'd experiment with
a CBOR logo. I'm by no means a designer, so any feedback welcome:

Font: Hacked designed by David Libeau <https://davidlibeau.fr/>and licensed
under Creative Commons by 4.0
<https://creativecommons.org/licenses/by-sa/4.0/legalcode>.
In HTML: H1, font-weight normal, color #333

I might try a colored font version too.

Let me know what you think!

-- 
Jonathan Beri
linkedin.com/in/jonathanberi <https://www.linkedin.com/in/jonathanberi/>

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 31 May 2020 03:13:11 +0200

Hi Jonathan,

> On 2020-05-30, at 19:21, Jonathan Beri <[email-masked]> wrote:
> 

(Insert apologies if, at this time of the day, my autopilot is automatically switching into prof-talks-to-student mode here.  I’ve been chided for that before.  Then mix in the Whitsunday mood…)

So what is the message that you are trying to convey with this logo?
Let me try to guess through the eyes of a random instance of a persona looking at data representation formats.

We have the base form of the logo, which looks like some old-fashioned (or really, outdated?), 1950’s, FORTRANy thing; black and white of course.
It seems that ancient logo bequeathed from the ancestors then has incurred some damage through transmission errors and looks a bit unstable now.  Needs lots of cleanup before use.
Not good for the squeaky clean product (security, banking, …) I’m building right now.

To provide some contrast, let me do a quick proposal for a list of branding properties that a CBOR logo maybe should convey (or at least not actively counteract):

— stable
— efficient, concise, … (I think that’s where the image is closest)
— and related to that: somewhat minimal, but not simpler
— approachable, friendly, easy to use
— open for new business (extensible, with low ceremony for that)

It probably would require a genius to convey all of these properties in one logo.
I’m not that genius, so for cbor.me I settled with the same basic idea you used (just say CBOR), and just threw in the font Palatino and the color #663399 (please excuse my rusty HTML if you do examine the site).
That’s where I stopped…

Yes, it requires a lot of background to even see in what ways that is actually somewhat minimal (history questions: What is (was) minimal about #663399 [1]?  What is (was) almost minimal about Palatino [2]?).

So I’d love to see if someone came up with something better.

If you are looking for something completely different: we also have Stefanie Gerdes’ design for a sea boar [3].  But that is maybe more of a mascot than a logo.  I’d like that in plush.

Grüße, Carsten

PS.: Here are the answers for the two history questions, and a pointer to the sea boar, in case you care:

[1]: https://en.wikipedia.org/wiki/Web_colors#Web-safe_colors
[2]: https://en.wikipedia.org/wiki/PostScript_fonts#Core_Font_Set
[3]: http://www.tzi.de/~cabo/sea-boar.png

---

From: Jonathan Beri <[email-masked]>
Date: Sun, 31 May 2020 09:41:14 -0700

No apologies necessary! I thought of this as an experiment. The inspiration
came from wanting to create an icon for the new subreddit
<https://www.reddit.com/r/CBOR/> I created. I wanted something with the
visual flair usually found on the site. The basic meaning I was trying to
convey

1) a compressed packet, which includes data as visualized by the little
bits of characters
2) transmission or movement of data

and I wanted to use web-safe fonts and CSS so it could be used in
many places, though I did need a PNG for Reddit. I too agree that a good
logo design requires a certain type of genius - and unfortunately I don't
fit the bill. And as I stared at the logo I think it connotes data
corruption as someone else mentioned and not the type of messaging we want.
Experiment 1 marked as a success - will not use. I think for now the
wordmark on cbor.me works for me. I generated a new PNG logo for Reddit
using https://htmlcsstoimage.com/:

Hopefully someone might improve the design one day!

Thanks for the feedback :)

On Sat, May 30, 2020 at 6:13 PM Carsten Bormann <[email-masked]> wrote:

> (Insert apologies if, at this time of the day, my autopilot is
> automatically switching into prof-talks-to-student mode here.  I’ve been
> chided for that before.  Then mix in the Whitsunday mood…)
>
> We have the base form of the logo, which looks like some old-fashioned (or
> really, outdated?), 1950’s, FORTRANy thing; black and white of course.
> It seems that ancient logo bequeathed from the ancestors then has incurred
> some damage through transmission errors and looks a bit unstable now.
> Needs lots of cleanup before use.
> To provide some contrast, let me do a quick proposal for a list of
> branding properties that a CBOR logo maybe should convey (or at least not
> actively counteract):
>
> — stable
> I’m not that genius, so for cbor.me I settled with the same basic idea
> you used (just say CBOR), and just threw in the font Palatino and the color
> #663399 (please excuse my rusty HTML if you do examine the site).
> That’s where I stopped…
>
> Yes, it requires a lot of background to even see in what ways that is
> actually somewhat minimal (history questions: What is (was) minimal about
> #663399 [1]?  What is (was) almost minimal about Palatino [2]?).
>
> If you are looking for something completely different: we also have
> Stefanie Gerdes’ design for a sea boar [3].  But that is maybe more of a
> mascot than a logo.  I’d like that in plush.
>
> Grüße, Carsten
>

---

From: Christoph Engelbert <[email-masked]>
Date: Sun, 31 May 2020 18:45:17 +0200

Hey folks,

In a past presentation I loved to explain CBOR that way: https://www.slideshare.net/ChristophEngelbert/cbor-the-better-json#30 <https://www.slideshare.net/ChristophEngelbert/cbor-the-better-json#30>

Maybe that gives some directional idea ;-)

Cheers,
Chris

PS: Yeah those are the Simpsons. Blocky but definitely recognizable :D

> On 31. May 2020, at 18:41, Jonathan Beri <[email-masked]> wrote:
> 
> No apologies necessary! I thought of this as an experiment.. The inspiration came from wanting to create an icon for the new subreddit <https://www.reddit.com/r/CBOR/> I created. I wanted something with the visual flair usually found on the site. The basic meaning I was trying to convey
> 
> 1) a compressed packet, which includes data as visualized by the little bits of characters
> and I wanted to use web-safe fonts and CSS so it could be used in many places, though I did need a PNG for Reddit. I too agree that a good logo design requires a certain type of genius - and unfortunately I don't fit the bill. And as I stared at the logo I think it connotes data corruption as someone else mentioned and not the type of messaging we want. Experiment 1 marked as a success - will not use. I think for now the wordmark on cbor.me <http://cbor.me/> works for me. I generated a new PNG logo for Reddit using https://htmlcsstoimage.com/ <https://htmlcsstoimage.com/>:
> 
> On Sat, May 30, 2020 at 6:13 PM Carsten Bormann <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Jonathan,
> 
> > On 2020-05-30, at 19:21, Jonathan Beri <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> 
> I’m not that genius, so for cbor.me <http://cbor.me/> I settled with the same basic idea you used (just say CBOR), and just threw in the font Palatino and the color #663399 (please excuse my rusty HTML if you do examine the site).
> That’s where I stopped…
> 
> [1]: https://en.wikipedia.org/wiki/Web_colors#Web-safe_colors <https://en.wikipedia.org/wiki/Web_colors#Web-safe_colors>
> [2]: https://en.wikipedia.org/wiki/PostScript_fonts#Core_Font_Set <https://en.wikipedia.org/wiki/PostScript_fonts#Core_Font_Set>
> [3]: http://www.tzi.de/~cabo/sea-boar.png <http://www.tzi.de/~cabo/sea-boar.png>
> 
> 
> 
> -- 
> Jonathan Beri
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor