Subject: [Cbor] 🔔 WGLC on draft-ietf-cbor-date-tag-01

From: Francesca Palombini <[email-masked]>
Date: Mon, 15 Jun 2020 07:44:40 +0000

CBOR wg,

This starts a two weeks WG last call on https://tools.ietf.org/html/draft-ietf-cbor-date-tag-01 , ending on *Monday, 29th June*. Note that the IANA registrations have already gone through, see https://www.iana.org/assignments/cbor-tags/cbor-tags.xhtml .

Please send inputs to the mailing list that you have read the document and do or do not feel it is ready to progress, along with any issues that you believe need to be dealt with.

We will discuss any open issues we’ve gotten during the interim meeting scheduled for Wednesday, July 1st.

CBOR Chairs
Jim & Francesca

On 10/06/2020, 00:00, "CBOR on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    A New Internet-Draft is available from the on-line Internet-Drafts directories.
    This draft is a work item of the Concise Binary Object Representation Maintenance and Extensions WG of the IETF.

            Title           : Concise Binary Object Representation (CBOR) Tags for Date
            Authors         : Michael B. Jones
                              Anthony Nadalin
                              Jörg Richter
    	Filename        : draft-ietf-cbor-date-tag-01.txt
    	Pages           : 5
    	Date            : 2020-06-09

    Abstract:
       The Concise Binary Object Representation (CBOR, RFC 7049) is a data
       format whose design goals include the possibility of extremely small
       code size, fairly small message size, and extensibility without the
       need for version negotiation.

       In CBOR, one point of extensibility is the definition of CBOR tags.
       RFC 7049 defines two tags for time: CBOR tag 0 (RFC 3339 date/time
       string) and tag 1 (Posix "seconds since the epoch").  Since then,
       additional requirements have become known.  This specification
       defines a CBOR tag for an RFC 3339 date text string, for applications
       needing a textual date representation without a time.  It also
       defines a CBOR tag for days since the Posix epoch, for applications
       needing a numeric date representation without a time.  It is intended
       as the reference document for the IANA registration of the CBOR tags
       defined.

    The IETF datatracker status page for this draft is:
    https://datatracker.ietf.org/doc/draft-ietf-cbor-date-tag/

    There are also htmlized versions available at:
    https://tools.ietf.org/html/draft-ietf-cbor-date-tag-01
    https://datatracker.ietf.org/doc/html/draft-ietf-cbor-date-tag-01

    A diff from the previous version is available at:
    https://www.ietf.org/rfcdiff?url2=draft-ietf-cbor-date-tag-01

    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.

    Internet-Drafts are also available by anonymous FTP at:
    ftp://ftp.ietf.org/internet-drafts/

    _______________________________________________
    CBOR mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/cbor

---

From: Mike Jones <[email-masked]>
Date: Tue, 16 Jun 2020 01:20:09 +0000

I believe that this (very short!) specification is ready for publication.  I plan to incorporate Jim's suggestions at the same time as WGLC comments that come in.

				-- Mike

-----Original Message-----
From: CBOR <[email-masked]> On Behalf Of Francesca Palombini
Sent: Monday, June 15, 2020 12:45 AM
To: [email-masked]
Subject: [Cbor] 🔔 WGLC on draft-ietf-cbor-date-tag-01

CBOR wg,

CBOR Chairs
Jim & Francesca

    Abstract:

---

From: Jim Schaad <[email-masked]>
Date: Wed, 24 Jun 2020 17:17:39 -0700

Hey people, I would really like to see a couple of more comments from people even if it is just - yeah looks good to me.

Jim

> This starts a two weeks WG last call on https://tools.ietf.org/html/draft-ietf-
> cbor-date-tag-01 , ending on *Monday, 29th June*. Note that the IANA
> registrations have already gone through, see
> https://www.iana.org/assignments/cbor-tags/cbor-tags.xhtml .
> 
> Please send inputs to the mailing list that you have read the document and do
> or do not feel it is ready to progress, along with any issues that you believe
> need to be dealt with.
> 
> On 10/06/2020, 00:00, "CBOR on behalf of [email-masked]" <cbor-
> [email-masked] on behalf of [email-masked]> wrote:
> 
> 
>     This draft is a work item of the Concise Binary Object Representation
> Maintenance and Extensions WG of the IETF.
>

---

From: [email-masked] (Dale R. Worley)
Date: Wed, 24 Jun 2020 21:28:14 -0400

Jim Schaad <[email-masked]> writes:
> Hey people, I would really like to see a couple of more comments from
> people even if it is just - yeah looks good to me.

Not that I'm an expert in time, but reviewing -01, I couldn't find any
tricky ambiguity about leap seconds, which is where time formats usually
fall down -- RFC 3339 specifies how leap seconds are to be designated,
and when counting days, leap seconds are automatically included.

Since tag numbers are not a limited resource, there's no need to worry
whether this is the best possible way to encode these data.

So it looks good to me.

Dale