Subject: Re: [Cbor] Review draft-ietf-cbor-date-tag-01

From: Mike Jones <[email-masked]>
Date: Fri, 12 Jun 2020 18:51:49 +0000

Thanks for your review, Jim.  My replies are inline below...

Is it time to start WGLC so others also get their reviews in?  I'll note that the IANA registrations have already occurred at https://www.iana.org/assignments/cbor-tags/cbor-tags.xhtml.

-----Original Message-----
From: Jim Schaad <[email-masked]> 
Sent: Thursday, June 11, 2020 11:48 AM
To: [email-masked]
Cc: [email-masked]
Subject: Review draft-ietf-cbor-date-tag-01

* Is there any chance that you can upgrade to using the v3 of xml2rfc schema?  If not then there is not an issue as the RFC Editor will do it.

I haven't really learned all the ins and outs of the new syntax yet, so I'd have more confidence with the RFC Editor doing it correctly than me.

* Introduction:  I prefer the abstract form of /date but not a time/date without a time/

I agree and will make this change in the next published draft.

* While this is something that is clear to me, I got a recent comment when I suggested that this be used elsewhere of, "But how does this work with time zones?".  Based on that I think that there needs to be some text about why time zones are not of interest here.

Agreed and will do.

* Section 3- I think that the second paragraph would be wise to distinguish between a point in time and a date when looking at access control decisions.

I understand your point in general.  Is there particular text that you'd suggest that I incorporate?

Jim

				Thanks again,
				-- Mike

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Jun 2020 07:42:40 +0200

I sent some nits from a quick review of -01 to the authors.

The one item that will need a little more work:
I also agree with Jim that we need to say something about the timezone-lessness of the two tags.

Grüße, Carsten

---

From: Mike Jones <[email-masked]>
Date: Wed, 1 Jul 2020 00:41:25 +0000

Hi Jim,

I've applied these changes in https://tools.ietf.org/html/draft-ietf-cbor-date-tag-02.

				Thanks again,
				-- Mike

-----Original Message-----
From: Jim Schaad <[email-masked]> 
Sent: Thursday, June 11, 2020 11:48 AM
To: [email-masked]
Cc: [email-masked]
Subject: Review draft-ietf-cbor-date-tag-01

Agreed and will do.

Jim

				Thanks again,
				-- Mike

---

From: Jim Schaad <[email-masked]>
Date: Tue, 30 Jun 2020 18:13:22 -0700

> From: Mike Jones <[email-masked]>
> Sent: Tuesday, June 30, 2020 5:41 PM
> I've applied these changes in
https://tools.ietf.org/html/draft-ietf-cbor-date-
> tag-02.
> Is it time to start WGLC so others also get their reviews in?  I'll note
that the
> IANA registrations have already occurred at
> https://www.iana.org/assignments/cbor-tags/cbor-tags.xhtml.
> 
> * Is there any chance that you can upgrade to using the v3 of xml2rfc
schema?
> If not then there is not an issue as the RFC Editor will do it.
> 
> I haven't really learned all the ins and outs of the new syntax yet, so
I'd have
> more confidence with the RFC Editor doing it correctly than me.
> 
> * Introduction:  I prefer the abstract form of /date but not a time/date
without
> a time/
> * While this is something that is clear to me, I got a recent comment when
I
> suggested that this be used elsewhere of, "But how does this work with
time
> zones?".  Based on that I think that there needs to be some text about why
time
> zones are not of interest here.
> 
> Agreed and will do.
> 
> * Section 3- I think that the second paragraph would be wise to
distinguish
> between a point in time and a date when looking at access control
decisions.
> 
> I understand your point in general.  Is there particular text that you'd
suggest
> that I incorporate?

No I don't have any text in mind. 

Jim

---

From: Mike Jones <[email-masked]>
Date: Wed, 1 Jul 2020 01:42:52 +0000

I created text.

-- Mike

________________________________
From: Jim Schaad <[email-masked]>
Sent: Tuesday, June 30, 2020 6:13:22 PM
To: Mike Jones <[email-masked]>; [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [EXTERNAL] RE: Review draft-ietf-cbor-date-tag-01

that the
schema?
I'd have
without
I
time
time
distinguish
decisions.
suggest

Jim