Subject: [Cbor] Last Call: <draft-ietf-cbor-tags-oid-05.txt> (Concise Binary Object Representation (CBOR) Tags for Object Identifiers) to Proposed Standard

From: The IESG <[email-masked]>
Date: Wed, 03 Mar 2021 08:14:09 -0800

The IESG has received a request from the Concise Binary Object Representation
Maintenance and Extensions WG (cbor) to consider the following document: -
'Concise Binary Object Representation (CBOR) Tags for Object
   Identifiers'
  <draft-ietf-cbor-tags-oid-05.txt> as Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits final
comments on this action. Please send substantive comments to the
[email-masked] mailing lists by 2021-03-24. Exceptionally, comments may
be sent to [email-masked] instead. In either case, please retain the beginning
of the Subject line to allow automated sorting.

Abstract

   The Concise Binary Object Representation (CBOR, RFC 8949) is a data
   format whose design goals include the possibility of extremely small
   code size, fairly small message size, and extensibility without the
   need for version negotiation.

   The present document defines CBOR tags for object identifiers (OIDs).
   It is intended as the reference document for the IANA registration of
   the CBOR tags so defined.

The file can be obtained via
https://datatracker.ietf.org/doc/draft-ietf-cbor-tags-oid/

No IPR declarations have been submitted directly on this I-D.

The document contains these normative downward references.
See RFC 3967 for additional information: 
    rfc6256: Using Self-Delimiting Numeric Values in Protocols (Informational - IRTF Stream)

---

From: Russ Housley <[email-masked]>
Date: Wed, 3 Mar 2021 12:11:14 -0500

I had to read Section 2 several time to fully understand it, and I was not sure I got it right until I worked through the examples in Section 3.  I think a small change would have helped me.

The text says "...MUST be a syntactically valid BER representation of an object identifier ...", but this is not fully correct.  It is the value portion of the BER representation.  The CBOR encoding does not carry (and dies not need to carry) the type of length bytes of the BER representation.

Russ 

> On Mar 3, 2021, at 11:14 AM, The IESG <[email-masked]> wrote:
> 
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 4 Mar 2021 10:43:24 +0100

> The text says "...MUST be a syntactically valid BER representation of an object identifier ...", but this is not fully correct.  It is the value portion of the BER representation.  The CBOR encodin…

Indeed.

Now https://github.com/cbor-wg/cbor-oid/pull/8

Thank you!

Grüße, Carsten

---

From: Francesca Palombini <[email-masked]>
Date: Tue, 30 Mar 2021 08:45:55 +0000

The PR looks good, thanks Russ for pointing this out. If you have any more comments please let us know, otherwise I will push the button as soon as the draft is updated.

Francesca

On 04/03/2021, 10:44, "last-call on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

    Indeed.

    Thank you!

    Grüße, Carsten

    -- 
    last-call mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/last-call

---

From: Russ Housley <[email-masked]>
Date: Tue, 30 Mar 2021 09:53:29 -0400

The PR fully resolves my comment.

Russ

> On Mar 30, 2021, at 4:45 AM, Francesca Palombini <francesca.palombini=[email-masked]> wrote:
>