Subject: [Cbor] Reminder: CBOR WG Virtual Meeting on 2021-12-15

From: Barry Leiba <[email-masked]>
Date: Mon, 13 Dec 2021 11:33:11 -0500

Reminder:
We're resuming the one-hour Wednesday meetings every second week,
beginning this week, 15 Dec, at 15:00 UTC.  Information for this
meeting is here:

Datatracker: https://datatracker.ietf.org/meeting/interim-2021-cbor-20/session/cbor
Notes: https://notes.ietf.org/notes-ietf-interim-2021-cbor-20-cbor
Meetecho: https://meetings.conf.meetecho.com/interim/?short=c5973c8b-23b9-4af9-99de-3c404c16196e

Please go to the notes and add to the agenda.

Please go to the notes and add your name to volunteer to help take notes.

And we'll see you on Wednesday.

Barry

---

From: Ira McDonald <[email-masked]>
Date: Mon, 13 Dec 2021 11:38:02 -0500

Hi,

Once again, the ISO 24089 Road Vehicles: Software Update project has a
colliding call
this Wednesday.  Good luck in the CBOR call.

Cheers,
- Ira

On Mon, Dec 13, 2021 at 11:33 AM Barry Leiba <[email-masked]>
wrote:

> Datatracker:
> https://datatracker.ietf.org/meeting/interim-2021-cbor-20/session/cbor
> Meetecho:
> https://meetings.conf.meetecho.com/interim/?short=c5973c8b-23b9-4af9-99de-3c404c16196e
>
> _______________________________________________
> CBOR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cbor
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Dec 2021 15:00:27 +0100

> beginning this week, 15 Dec, at 15:00 UTC.  Information for this

I put in a trial balloon (which I’m willing to roll back if we arrive elsewhere): 

Html: https://www.ietf.org/archive/id/draft-ietf-cbor-file-magic-07.html
Diff: https://www.ietf.org/rfcdiff?url2=draft-ietf-cbor-file-magic-07

This now clearly separates the case of adding a CBOR header to non-CBOR Content-Formats from the CBOR Sequence Tag.  It also repairs the examples, and adds an Appendix C that discusses CBOR headers to non-CBOR data identified by CoAP Content-Formats.

Technically, there would be no need to separate 55800 and 55801 (a 55801 tag will work with any data that normally would have a 55800 tag); but I found it clearer to provide this separation.

Let’s discuss this in 1 h…

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 Dec 2021 13:25:40 -0500

Carsten Bormann <[email-masked]> wrote:
    > This now clearly separates the case of adding a CBOR header to non-CBOR
    > Content-Formats from the CBOR Sequence Tag.  It also repairs the
    > examples, and adds an Appendix C that discusses CBOR headers to
    > non-CBOR data identified by CoAP Content-Formats.

    > Technically, there would be no need to separate 55800 and 55801 (a
    > 55801 tag will work with any data that normally would have a 55800
    > tag); but I found it clearer to provide this separation.

I'm happy to allocate/use tag 55801.

    > Let’s discuss this in 1 h…

Sorry, I started another thread because I read my email out of order, and I
had a conflict for the CBOR meeting.