Subject: charter update

From: Kireeti Kompella <[email-masked]>
Date: Mon, 15 Nov 2004 07:51:02 -0800 (PST)

Hi All,

If you have suggested charter updates, please send them to Adrian and
me.  Please keep this subject line (simply reply to this mail).

The deadline is Friday Nov 19, 17:00 PST.

Thanks,
Kireeti.
-------

---

From: "Zafar Ali" <[email-masked]>
Date: Wed, 17 Nov 2004 10:29:59 -0500

Hi Kireeti, 

- L1 VPN (Re: Alex question on this subject at CCAMP WG meeting, due to lake
of time I was not able to come to microphone but I would like to take this
opportunity to mention that we do see interest in this work from the SPs and
IMO CCAMP should add this work to the CCAMP Charter). 

- PCE Requirements. 

- Graceful shutdown of TE resources, if we find it outside the current
scope.

- Deployment consideration for GMPLS, if we find it outside the current
scope. 

- MPLS/ GMPLS interworking, if we find it outside the current scope. 

Thanks

Regards... Zafar

>-----Original Message-----
>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of Kireeti Kompella
>Sent: Monday, November 15, 2004 10:51 AM
>To: [email-masked]
>Subject: charter update
>
>
>Hi All,
>
>If you have suggested charter updates, please send them to 
>Adrian and me.  Please keep this subject line (simply reply to 
>this mail).
>

---

From: Tomonori TAKEDA <[email-masked]>
Date: Fri, 19 Nov 2004 10:30:49 +0900

Hi,

- L1VPNs:
     Define control and measurement plane mechanisms to support L1VPNs.
     Analize applicability of these mechanisms.

As we discussed in CCAMP WG, the work would be expected to be around the 
use and application of GMPLS protocols to support L1VPN services. (Note: 
services does not necessary mean to external customers, can be applicable 
to internal usage as well.) There may be minor protocol extensions needed 
for this.

- Implementation/Interoprability experience

Best regards,

>The deadline is Friday Nov 19, 17:00 PST.

-----
Tomonori TAKEDA
NTT Network Service Systems Lab.
Phone: +81-422-59-7434

---

From: Kireeti Kompella <[email-masked]>
Date: Tue, 23 Nov 2004 22:22:19 -0800 (PST)

On Mon, 15 Nov 2004, Kireeti Kompella wrote:

> If you have suggested charter updates, please send them to Adrian
> and me.

Thanks all for your input.  I have the following items; for each,
please say "Yes" (should be added to CCAMP charter), "No" (should not
be added) or "-" (don't care).  I'll remind you once again that not
all items will make it onto the new charter.

Please keep this subject line (simply reply to this mail).  The
deadline is Friday Dec 3, 17:00 PST.

1) MPLS-GMPLS migration
2) GMPLS interoperability issues
3a) should the IETF take on L1VPNs?
3b) if yes to 3a, should this be done in CCAMP?
4) Waveband switching
5) Control plane work
6) Decoder ring for addresses
7) Deployment considerations for GMPLS
8) PCE requirements
9) QoS control

A rough idea of what each of the above entails follows.

1) MPLS-GMPLS migration
	implementation shift from "MPLS" objects to "GMPLS" objects
	BCP on deployment migration for the same

2) GMPLS interoperability issues
	what addresses to use where
	nits/clarifications of the specs
	guidelines for path computation & constraints
	survay

3) L1VPN work items
	identify protocol extensions needed
	state what can already be done with what we have
	do the actual protocol work for requirements that are not met
	liaisons to SG13 as needed

5) Control plane work
	resiliency
	graceful shutdown

6) Decoder ring for addresses
	for each address field, identify its nature and ITU equivalent
	(may overlap with part of (2))

4, 7-9 are obvious or have been elaborated on the mailing list.

Kireeti.
-------

PS: The topic of GTTP has carefully been avoided.  More later.

---

From: dimitri papadimitriou <[email-masked]>
Date: Wed, 24 Nov 2004 10:20:29 +0100

hi kireeti,

 > 1) MPLS-GMPLS migration

yes

 > 2) GMPLS interoperability issues

yes

 > 3a) should the IETF take on L1VPNs?

yes

 > 3b) if yes to 3a, should this be done in CCAMP?

as first option (note: with the current standpoint, could this done 
elsewhere ?)

 > 4) Waveband switching

yes (note: need more support as rather limited since so far)

 > 5) Control plane work

yes ("document" CP resiliency and GS)

 > 6) Decoder ring for addresses

part of this work is in (2) and other should be part of the ongoing ASON 
work

 > 7) Deployment considerations for GMPLS

is this an embryon of "gmplsops" ? in favor

 > 8) PCE requirements

yes

 > 9) QoS control

yes

---

Kireeti Kompella wrote:

> .

---

From: Loa Andersson <[email-masked]>
Date: Wed, 24 Nov 2004 10:48:01 +0100

Kireeti,

I tend to agree with Dimitri, one concern is that
this could be rather big, do we want to prioritize
or is that implied in the numbering

/Loa

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                            [email-masked]

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 24 Nov 2004 02:53:44 -0800 (PST)

Hi Loa,

> or is that implied in the numbering

It is rather big, as I am trying to capture all the ideas of the
community.  I don't expect that all the proposals will get enough
support for "rough consensus"; in any case, even if all of them did,
the IESG would very quickly prune the list :-)

There is *no* intended priority in the numbering!

Kireeti.
-------

---

From: JP Vasseur <[email-masked]>
Date: Wed, 24 Nov 2004 06:45:42 -0500

Hi Kireeti,

yes
yes
yes
yes
yes
> 6) Decoder ring for addresses
-
yes
> 8) PCE requirements
More precisely "PCE requirements for Inter-domain" which is the main 
objective of the potential future WG.
Other PCE requirements amy either be done in the PCE WG or may come 
from other WG in the future,
yes

JP.

---

From: Loa Andersson <[email-masked]>
Date: Wed, 24 Nov 2004 15:03:09 +0100

Kireeti,

not entirely happy to let the IESG do the pruning,
so the most important to me is 5 (control plane)
and 8 (PCE requirments)

/Loa

-- 
Loa Andersson

---

From: "Zafar Ali" <[email-masked]>
Date: Wed, 24 Nov 2004 09:01:49 -0500

Kireeti, 

Reply in-lined.

Thanks

Regards... Zafar

<snip>
>1) MPLS-GMPLS migration

Yes, .... You may like to rename it as from name it appears that there is a
lot of overlap of this with "7) Deployment considerations for GMPLS". 

>2) GMPLS interoperability issues

Yes, 

>3a) should the IETF take on L1VPNs?

Yes, 

>3b) if yes to 3a, should this be done in CCAMP?

Yes, 

>5) Control plane work

Yes, but the name is too board, may like to rename it, e.g., Control plane
resiliency and GS. 

>7) Deployment considerations for GMPLS

Yes, 

>8) PCE requirements

Yes,

---

From: "Igor Bryskin" <[email-masked]>
Date: Wed, 24 Nov 2004 09:55:57 -0500

My vote is in-line.
Igor

----- Original Message ----- 
From: "Kireeti Kompella" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, November 24, 2004 1:22 AM
Subject: New charter

> deadline is Friday Dec 3, 17:00 PST.
Yes

> 2) GMPLS interoperability issues
Yes

> 3a) should the IETF take on L1VPNs?
Yes

> 3b) if yes to 3a, should this be done in CCAMP?
Yes

> 5) Control plane work
Yes, but should be stated more clearly.
In addition to waht other people said I'd like to add:
Managing of control plane partitioned LSPs 

Yes,

> 8) PCE requirements
Yes, and I'd like it not to be limited by inter-domain LSPs

> 9) QoS control
I am not sure about that. Isn't MPLS/GMPLS is mostly about already ?

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 24 Nov 2004 08:21:16 -0800 (PST)

> not entirely happy to let the IESG do the pruning,

Okay, Loa -- you are right.

All: instead of Yes/No, can you pick the four most important items
from your point of view?  Thanks!

(To those who already replied, sorry to make you do this again!)

Kireeti.
-------

---

From: "Zafar Ali" <[email-masked]>
Date: Wed, 24 Nov 2004 11:46:29 -0500

>Sent: Wednesday, November 24, 2004 11:21 AM
>To: Loa Andersson
>Cc: [email-masked]
>Subject: Re: New charter
>
>
>All: instead of Yes/No, can you pick the four most important 
>items from your point of view?  Thanks!
>

Hi Kireeti, 

My pick for the four items is (in this order),

- PCE requirements
- GMPLS interoperability issues (incl. MPLS-GMPLS migration), as "GMPLS
interoperability issues" and "MPLS-GMPLS migration" are overlapping in
nature. 
- Control plane work
- L1VPN

N.b. Items (in this order)... waveband switching, QoS control and Decoder
ring for addresses are lowest priority (don't care) for me.  

Thanks

Regards... Zafar 

><snip>
>>
>>1) MPLS-GMPLS migration
>
>Yes, .... You may like to rename it as from name it appears 
>that there is a lot of overlap of this with "7) Deployment 
>considerations for GMPLS". 
>

Important, 

>>2) GMPLS interoperability issues

Very important, 

>>3a) should the IETF take on L1VPNs?

Important, 

>>3b) if yes to 3a, should this be done in CCAMP?

Important, 

>>4) Waveband switching

Don't care, 

>>5) Control plane work
>
>Yes, but the name is too board, may like to rename it, e.g., 
>Control plane resiliency and GS. 
>

Very Important. 

>>6) Decoder ring for addresses

Don't care, 

>>7) Deployment considerations for GMPLS

Important, 

>Yes, 

Very important, 

>>9) QoS control

Don't care, 

<snip>

---

From: dimitri papadimitriou <[email-masked]>
Date: Wed, 24 Nov 2004 19:37:09 +0100

all items have their importance - but as there is a poll for the most 
urgent items:

1. 1) + 2) + 7) - all related(*)
2. 8)
3. 9)
4. 3a) (and yes in CCAMP)

note: 5) will follow sooner or later

---

From: Gert Grammel <[email-masked]>
Date: Wed, 24 Nov 2004 18:46:40 +0100

Hi Kireeti,

yes

yes

yes

yes

-

---

From: "Igor Bryskin" <[email-masked]>
Date: Wed, 24 Nov 2004 14:23:58 -0500

Four most important:
1), 3), 5) and 8)

Next two:
2) and 7)

Igor

---

From: Kohei Shiomoto <[email-masked]>
Date: Thu, 25 Nov 2004 11:05:39 +0900

Hi Kireeti and all,

All items look important but I would propose the following items.
----- top four ----------
1+7 (they are related)
2+6* (they seem related)
3 (within CCAMP)
8
*note 5 seems related to 2+6
----- next ---------------
9 if 8 is done in PCE-WG.

-------------------
1) MPLS-GMPLS migration

Kind regards

---
Kohei Shiomoto, NTT

-- 
Kohei Shiomoto, Ph.D
NTT Network Service Systems Laboratories
3-9-11 Midori, Musashino, Tokyo 180-8585, Japan
Phone +81 422 59 4402    Fax +81 422 59 4549

---

From: Tomonori TAKEDA <[email-masked]>
Date: Thu, 25 Nov 2004 13:44:29 +0900

Hi,

IMO, all items are important, but here is my vote.

Top four:
1) MPLS-GMPLS migration
2) GMPLS interoperability issues
3) L1VPNs (and yes in CCAMP)
8) PCE requirements

Next:
5) Control plane work

-----
Tomonori TAKEDA

---

From: Eiji Oki <[email-masked]>
Date: Thu, 25 Nov 2004 17:22:51 +0900

Hi Kireeti and all, 

Most important items: 
1) MPLS-GMPLS migration
3) L1VPNs in CCAMP
8) PCE requirements

Next important items: 

Thank you.
Eiji

On Tue, 23 Nov 2004 22:22:19 -0800 (PST)

---

From: Tomohiro Otani <[email-masked]>
Date: Thu, 25 Nov 2004 19:38:50 +0900

Hi Kireeti,

I support them rechartered in CCAMP WG and am personally
intereted in MPLS/GMPLS migration and deployment consideration
of GMPLS to accelarate actualGMPLS deployment.

CCAMP WG is suitable for discussing about L1VPN.

With best regards,

tomo

----------------------------------
Tomohiro Otani
KDDI R&D Laboratories, Inc.
----------------------------------

---

From: Tomohiro Otani <[email-masked]>
Date: Thu, 25 Nov 2004 19:40:09 +0900

Hi Kireeti,

I support them rechartered in CCAMP WG and am personally
interested in MPLS/GMPLS migration and deployment consideration
of GMPLS to accelerate actual GMPLS deployment.

With best regards,

tomo

---

From: "Tom Petch" <[email-masked]>
Date: Thu, 25 Nov 2004 11:09:51 +0100

> 1) yes  MPLS-GMPLS migration
> 2) yes  GMPLS interoperability issues
> 3a) no should the IETF take on L1VPNs?
> 3b) no  if yes to 3a, should this be done in CCAMP?
> 4) no   Waveband switching
> 5) yes  Control plane work
> 6) no   Decoder ring for addresses
> 7) yes  Deployment considerations for GMPLS
> 8) no   PCE requirements
> 9) no   QoS control
> 

Tom Petch
NW Networks

---

From: Yakov Rekhter <[email-masked]>
Date: Thu, 25 Nov 2004 12:22:52 -0800

Kireeti,

> 1) MPLS-GMPLS migration

yes.

> 2) GMPLS interoperability issues

yes.

> 3a) should the IETF take on L1VPNs?

yes.

> 3b) if yes to 3a, should this be done in CCAMP?

yes.

Yakov.

---

From: Loa Andersson <[email-masked]>
Date: Fri, 26 Nov 2004 14:37:37 +0100

All,

there seems to be a majority for doing L1VPN in
ccamp, I don't particular object, but remember the
arguments when we placed the L3VPN and L2VPN in
the Internet Area. The main argument was that
the Internet Area deals with end-2-end services
over the Interent, thus VPNs belongs in the
Internet Area.

If we decides that L1VPN don't go together with
L2/L3VPNs in the Internet Area we should at least
have some motivation for this. What is it?
Is L1VPN not an end-2-end services or is it not
an Internet Service?

/Loa

-- 
Loa Andersson

---

From: Kireeti Kompella <[email-masked]>
Date: Fri, 26 Nov 2004 19:11:46 -0800 (PST)

Hi Loa,

On Fri, 26 Nov 2004, Loa Andersson wrote:

> there seems to be a majority for doing L1VPN in ccamp, I don't
> particular object, but remember the arguments when we placed the
> L3VPN and L2VPN in the Internet Area.

Thanks for articulating this -- I've been thinking about this as well.

> The main argument was that the Internet Area deals with end-2-end
> services over the Interent, thus VPNs belongs in the Internet Area.
>
> If we decides that L1VPN don't go together with L2/L3VPNs in the
> Internet Area we should at least have some motivation for this.
> What is it?  Is L1VPN not an end-2-end services or is it not an
> Internet Service?

I've come up with four reasons why CCAMP is a better venue for L1VPNs:

a) L1VPNs are definitely not an end-to-end service -- I don't think
   we'll see end-hosts with OC-48s (or even fiber GE) and GMPLS
   signaling any time soon.  However, it is clearly possible for end
   hosts to connect to an L2 or L3VPN.
b) L1VPNs are not necessarily an Internet service (well, for that
   matter, neither are L2VPNs).
c) Most of the work for L1VPNs is done -- starting a new WG for this
   will hinder progress, and also expand work to fill out a whole WG.
   The bulk of the work is documenting what we already have that works.
d) L1VPNs are distinctly different from L2 and L3 VPNs -- in the
   latter, the PEs do all the heavy lifting, and the CEs are then
   immediately connected.  In L1VPNs, the PEs do discovery and
   information exchange, but the *CEs* must do the signaling to set up
   the (currently) desired CE topology.  To do the signaling, the CEs
   must exchange information with the PEs.

This last part requires tight coordination with the CCAMP WG, both for
signaling (GMPLS UNI), and also for information exchange (pretty much
the same as for GMPLS inter-domain).  This is for me the most
important reason why this work should be kept in CCAMP rather than
creating up a new WG.

Kireeti.
-------

---

From: Scott W Brim <[email-masked]>
Date: Sat, 27 Nov 2004 08:12:47 -0500

> Is L1VPN not an end-2-end services or is it not

Is it that L2 and L3 VPNs are services on top of the infrastructure
provided by the network, but L1VPNs can allocate the infrastructure
resources themselves?  L1VPNs aren't (necessarily) "over" anything?  In
G.805-speak, unlike L2 and L3 VPNs, they aren't necessarily path layer
networks.  It is an end-to-end service, but not necessarily an Internet
service (the control of it is)?

---

From: Kireeti Kompella <[email-masked]>
Date: Sat, 27 Nov 2004 09:48:43 -0800 (PST)

On Sat, 27 Nov 2004, Scott W Brim wrote:

> resources themselves?

That's a good way of putting it.

> L1VPNs aren't (necessarily) "over" anything?  In G.805-speak, unlike
> L2 and L3 VPNs, they aren't necessarily path layer networks.  It is
> an end-to-end service, but

You'll have to define "end-to-end service" ...

> not necessarily an Internet service (the control of it is)?

Yes, that's also true.

Kireeti.
-------

---

From: Loa Andersson <[email-masked]>
Date: Sun, 28 Nov 2004 08:48:16 +0100

Kireeti,

definitely agree with c :). And I think that a,b and d summarizes
why I've called L1VPNs not Virtual Private Networks but Virutal
PUBLIC Networks (no I'm not suggesting a name change, just want
to point at a crtical difference in service model).

I support doing L1VP(ublic)N in ccamp.

/Loa

PS
Hmmm... no OC48's to end-hosts? Who said that 3 or 4 computers was
all the world needed? Testbeds are today known to do GE to end
stations :)

/Loa

-- 
Loa Andersson

---

From: "Vishal Sharma" <[email-masked]>
Date: Sun, 28 Nov 2004 22:00:20 -0800

Kireeti,

Responses in-line...

-Vishal

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Kireeti Kompella
> Sent: Tuesday, November 23, 2004 10:22 PM
> To: [email-masked]
> Subject: New charter

<snip>

> 1) MPLS-GMPLS migration                       Yes
> 2) GMPLS interoperability issues              Yes
> 3a) should the IETF take on L1VPNs?           Yes
> 3b) if yes to 3a, should this be done in CCAMP?   Yes
> 4) Waveband switching                          --
> 5) Control plane work                          Yes
> 6) Decoder ring for addresses                  --
> 7) Deployment considerations for GMPLS         Yes
> 8) PCE requirements                           Shouldn't this be done in
PCE itself??
> 9) QoS control                                Tentative yes, depends on
what is
                                                involved.

---

From: [email-masked]
Date: Mon, 29 Nov 2004 14:20:04 +0100

Hi,

Kireeti Kompella wrote:

>1) MPLS-GMPLS migration			YES
>2) GMPLS interoperability issues	YES
>3a) should the IETF take on L1VPNs?	YES
>3b) if yes to 3a, should this be done in CCAMP?	YES
>4) Waveband switching			YES
>5) Control plane work			YES
>6) Decoder ring for addresses		cf 2)
>7) Deployment considerations for GMPLS	YES
>8) PCE requirements			YES
>9) QoS control				YES
>  
>

top 4:
1: 1) + 2) + 7)
2: 5)
3: 3) a+b
4: 8)

then

4) and 9)

Emmanuel

---

From: Arthi Ayyangar <[email-masked]>
Date: Mon, 29 Nov 2004 09:58:22 -0800 (PST)

Kireeti,

My pick for the four most important items are:-

o 7) and in order for 7) to work out, we would need to address 1) and 2)
o 3)
o 8)
o 5)

thanks,
-arthi