Subject: Comment on draft-shiomoto-ccamp-gmpls-mrn-reqs-00.txt

From: "Stephen Shew" <[email-masked]>
Date: Thu, 11 Nov 2004 15:02:26 -0500

I was not able to be at the CCAMP meeting today but do have some comments on
draft-shiomoto-ccamp-gmpls-mrn-reqs-00.txt     
 
It seems that the goals of the draft could be accomplished more simply by
adopting the layer architecture as defined in ITU-T Recommendations G.805
and G.809.  By doing this, the specific boundaries between TDM, LSC, etc.
don't have to be articulated as they are just layer networks.  Also, the
designation of TDM does not include the notions of the layers within that
(e.g., DS3, STS-1, VC4, etc.) which are important to transport equipment.
Adopting the layer architecture also enables a client layer to be supported
by an inverse multipling layer such as provided by Virtual Concatenation.
Here a layer of finer granularity is use to support a layer of coarser
granularity.

Stephen Shew         Voice: 613-763-2462  Fax: 613-763-8385
Nortel - Optical Networks  email: [email-masked] 
P.O. Box 3511, Station C 
Ottawa, ON K1Y 4H7

---

From: dimitri papadimitriou <[email-masked]>
Date: Thu, 11 Nov 2004 22:46:35 +0100

stephen, just to clarify, the slides discussed during this morning 
meeting explain the document'scope = multi-REGION-networks

where REGIONs are based on Switching Capability (SC) as being defined in 
the LSP hierarchy document:

<http://www.ietf.org/internet-drafts/draft-ietf-mpls-lsp-hierarchy-08.txt>

the discussion is not about data plane layering/relationship or other 
specific aspects related to the data plane layer architecture (ex: 
G.805), in brief, the discussion is all about control plane -> in the 
present context a multiple SC control plane

note: for those that where not present at the meeting the slides 
discussed can be found at:

<http://home.clara.net/olddog/61/draft-shiomoto-ccamp-gmpls-mrn-reqs-00.ppt>
---

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 12 Nov 2004 02:17:52 -0000

Hi Stephen,

> draft-shiomoto-ccamp-gmpls-mrn-reqs-00.txt

Glad you were able to review the draft. Thanks for taking the time.
The slides for this and the other CCAMP drafts discussed at the meeting can be found at
http://www.olddog.co.uk/61/ccamp.htm

> Here a layer of finer granularity is use to support a layer of coarser

Thank you for the pointer to G.805 and G.809.  It is very important to attempt to align
the terminologies so that we can discover whether the architectures are the same and
whether they are trying to address the same problem space. It is also always good to try
not to reinvent the wheel.

As you have no doubt noticed, the GMPLS architecture and problem space require the
capability to signal and route across multiple instances of what the ITU-T terms a
transport layer. We would gladly look at any architecture you have in this space. Can you
point us at the ITU-T document(s) that describe the architecture and solutions for routing
and signaling across multiple layers?

Thanks,
Adrian

PS As pointed out by several people in other emails, I'm not sure if we mean exactly the
same thing when we say multi-region
and multi-layer. It would be valuable if you could read the GMPLS architecture RFC and the
hierarchy draft and comment on whether you see these terms in the IETF context as matching
perfectly with ITU-T terms.