Subject: GMPLS topics and issues of study

From: "Richard Rabbat" <[email-masked]>
Date: Wed, 10 Nov 2004 11:27:10 -0800

Hi all,
 
Based on Isocore interoperability testing results from the past few months,
we've found the following issues to have caused some confusion and
differences in implementation.  We'll list them here in no specific order
under 3 major headings.
 
Addressing:
1. relationship between TE Router ID and OSPF router ID 
1.1 where to use TE Router ID, OSPF Router ID and IPCC Address 
 
2: IP reachability (what ID's are reachable IP addresses)
 
3: what address is used in the signaling message in the ERO/RRO
 
4: what is used in in the IF_ID_RSVP_HOP
4.1: IP v4 Next/Previous Hop address
4.2: IPv4 address in the value field
 
5:  what is used in the destination IPv4 address in the session object 
 
6:  what is used in the sender IPv4 address in sender object template
 
7:  what is used as the Router ID in LSP_TUNNEL_INTERFACE_ID
 
RSVP message contents:
 
1: ERO/RRO: choice of outgoing vs. incoming interface ID
 
2: Forwarding destination of Path message with ERO
 
Control channel:
 
1: Best practice where multiple IP hops lie between adjacent nodes
 
2: use of redundant/multiple IPCC. best practices 
 
We're in the process of putting together what we hope to be a comprehensive
list of topics that may cause interop concerns. If people have thoughts
about other concerns as well, it would be great if you can email them to the
list or contact us directly.
 
Yumiko Kawashima
Ashok Narayanan
Eiji Oki
Lyndon Ong
Vijay Pandian
Rajiv Papneja   
Richard Rabbat
Hari Rakotoranto
Kohei Shiomoto
Tomonori Takeda

---

From: "Richard Rabbat" <[email-masked]>
Date: Wed, 10 Nov 2004 13:46:02 -0800

Please note that the list under "Addressing" that we compiled and sent out
is based on the Isocore interoperability testing.
The other items:
--
RSVP message contents:
1: ERO/RRO: choice of outgoing vs. incoming interface ID
2: Forwarding destination of Path message with ERO
Control channel:
1: Best practice where multiple IP hops lie between adjacent nodes
--
are from another source so we can combine these issues as well.
Richard

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Richard Rabbat
Sent: Wednesday, November 10, 2004 11:27 AM
To: [email-masked]
Cc: 'Rajiv Papneja'; 'Ashok Narayanan'; 'Eiji Oki'; 'Pandian, Vijay'; 'Ong,
Lyndon'; 'Hari Rakotoranto'; [email-masked];
[email-masked]; [email-masked]
Subject: GMPLS topics and issues of study

Hi all,

Addressing:

 

 
 
RSVP message contents:

 
Control channel:

 
 
Yumiko Kawashima
Ashok Narayanan
Eiji Oki
Lyndon Ong
Vijay Pandian
Rajiv Papneja   
Richard Rabbat
Hari Rakotoranto
Kohei Shiomoto
Tomonori Takeda