Subject: TR : I-D ACTION:draft-leroux-ccamp-gmpls-mrn-eval-00.txt

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Wed, 2 Mar 2005 22:51:40 +0100

Hi all,

Here is a new draft evaluating current GMPLS protocols wrt MRN
requirements.
Your comments on this new draft would be highly appreciated.

Best Regards,

JL

To: i-d-announce at ietf.org 
Subject: I-D ACTION:draft-leroux-ccamp-gmpls-mrn-eval-00.txt 
From: Internet-Drafts at ietf.org 
Date: Tue, 15 Feb 2005 10:14:38 -0500 

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: Evaluation of existing GMPLS Protocols against
Multi Region Networks
	Author(s)	: J. Le Roux, et al.
	Filename	: draft-leroux-ccamp-gmpls-mrn-eval-00.txt
	Pages		: 11
	Date		: 2005-2-14
	
This document provides an evaluation of Generalized Multi-Protocol 
   Label Switching (GMPLS) protocols and mechanisms against the 
   requirements for Multi Region Networks (MRN).   
   In addition, this document identifies areas where additional 
   protocol extensions or procedures are needed to satisfy the 
   requirements of Multi Region Networks, and provides guidelines for 
   potential extensions.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-leroux-ccamp-gmpls-mrn-eval-00
.txt

---

From: Igor Bryskin <[email-masked]>
Date: Thu, 3 Mar 2005 11:45:03 -0800 (PST)

JL,

I have a couple of comments/suggestions.

1.	The draft says that currently GMPLS does not have a
mechanism to provision virtual FAs. I don’t think this
is correct – I believe we could use the same mechanism
as was suggested in
draft-ietf-ccamp-gmpls-recovery-e2e-signaling (section
9.3) for signaling of Secondary LSPs
2.	I agree that we need TE link adaptation
capabilities to be advertised along with other TE link
attributes such as switching capabilities, protection
capabilities, etc. I suggest also adding TE link
termination capabilities to this list, i.e. decoupling
of these capabilities from adaptation capabilities: 
to terminate LSP in a particular layer and to adopt
into it LSPs of one or more higher layers are separate
resources and could be considered separately in the
inter-layer path computations;
3.	Everything that is said about regions, region
boundaries, etc. is also applicable for layers
contained within regions. I suggest to do what we have
already done in the PCE WG documents and
presentations: replace word region with word layer
everywhere apart from where signaling specific aspects
are discussed.

Thanks,
Igor

--- LE ROUX Jean-Louis RD-CORE-LAN
<[email-masked]> wrote:

> Subject: I-D
> ACTION:draft-leroux-ccamp-gmpls-mrn-eval-00.txt 
> .txt

		
__________________________________ 
Celebrate Yahoo!'s 10th Birthday! 
Yahoo! Netrospective: 100 Moments of the Web 
http://birthday.yahoo.com/netrospective/

---

From: dimitri papadimitriou <[email-masked]>
Date: Fri, 04 Mar 2005 03:21:18 +0100

igor - i let to jl the opportunit to respond in much more in details but 

> 9.3) for signaling of Secondary LSPs

there is no mechanism to setup/delete "virtual FAs" as part of GMPLS 
signaling protocol today the secondary LSP concept, even if the latter 
may look similar to the virtual FA concept - note: this is explicitly 
mentioned as part of the recovery document

however, the advertisement of the corr. TE link must be identical to 
what currently exist for fully provisioned FAs

> inter-layer path computations;

would you let us know what is missing in terms of termination 
capabilities - before we expand on this ?

> everywhere apart from where signaling specific aspects

i suggest you take a look at section 3.1 of
<http://www.ietf.org/internet-drafts/draft-shiomoto-ccamp-gmpls-mrn-reqs-01.txt>
it may help in understand the region vs layer concepts

> .