Subject: Re: Failure definition w.r.t. SONET/SDH and Protection/Restoration

From: Amit 70405 <[email-masked]>
Date: Thu, 24 Mar 2005 18:01:48 +0800

Hi Adrian,
   Do you mean to say that Data plane & Control plane protection should be independant of each other??
   If so, in case of MSP protection in SDH, 
    Control plane should not have any control over the resource pool 
     used for MSP switch.
   This may lead to lot of unused resource in the network.
Regards,
Amit.

----- Original Message -----
From: Diego Caviglia <[email-masked]>
Date: Thursday, March 24, 2005 4:03 pm
Subject: Re: Failure definition w.r.t. SONET/SDH and Protection/Restoration

> 
> Hi Adrian,
>           thanks for taking part to this discussion.
> 
> Please find my comments in line.
> 
> Regards
> 
> Diego
> 
> 
> 
> "Adrian Farrel" <[email-masked]> on 23/03/2005 15.58.42
> 
> Please respond to "Adrian Farrel" <[email-masked]>
> 
> To:    "Diego Caviglia" <[email-masked]>, 
> <[email-masked]>cc:    <[email-masked]>
> 
> Subject:    Re: Failure definition w.r.t. SONET/SDH and
>       Protection/Restoration
> 
> 
> Hi,
> 
> My initial reaction is that this is way out of scope for CCAMP for 
> a bunch
> of reasons. In particular order:
> 
> - The GMPLS control plane does not necessarily want to define data
>  plane failures. Rather, it wants to signal (report) errors and allow
>  the control plane state (and data plane state) to remain in place.
> [dc] Agreed and that was my initial point.  Which kind of data 
> plane (e.g.
> SDG) defects
> have to advertised to control plane to trigger restoration?  Given 
> thatcontrol plane is concerned in restore the data plane it should 
> also define
> what is a failure.  It is a fiber break or we have also to 
> consider other
> defects? Of course we have.  What happens if one restoration TNE 
> consideras failure only Loss Of Light (LOS) while the other starts 
> restoration even
> if there is a e.g. Loss Of Pointer?  Is that acceptable?
> 
> - Control plane and data plane protection actions need to be carefully
>  separated.
> [dc] Agreed.
> 
> - Decisions that trigger control plane protection actions are
>  fundamentally implementation choices.
> [dc] Here we are.  This is the point.  IMHO CCAMP should provide some
> guidance on this.
> 
>  Maybe we should make a statement that this type
>  of thing SHOULD be configurable so that there is some sort of
>  consistency within a network.
> [dc] Something like "..control plane restoration mechanism SHOULD be
> triggered as the SNC/I defined in ITU-T G.783 (section 12.1.1.1).
> 
> - Existing alarm procedures should not be impacted by the use of 
> GMPLS.[dc] Absolutely agreed
> 
> - Data plane technology is not what we do.
> [dc] Absolutely agreed
> 
> But I'm open to discussion.
> 
> Finally, to follow on Sasha's comments, such a draft would 
> probably be
> informational.
> [dc] Ok for me no problem on that.
> 
> Cheers,
> Adrian
> 
> ----- Original Message -----
> From: "Diego Caviglia" <[email-masked]>
> To: "Sasha Vainshtein <Sasha" <[email-masked]>
> Cc: "ccamp <ccamp" <[email-masked]>
> Sent: Wednesday, March 23, 2005 2:01 PM
> Subject: RE: Failure definition w.r.t. SONET/SDH and 
> Protection/Restoration
> 
> 
> >
> > May be Adrian can put come light on the question you raised.
> >
> > Regards
> >
> > Diego
> >
> >
> >
> > Sasha Vainshtein <[email-masked]> on 23/03/2005 14.44.23
> >
> > To:    "'Diego Caviglia'" <[email-masked]>
> > cc:    ccamp <[email-masked]>
> >
> > Subject:    RE: Failure definition w.r.t. SONET/SDH and
> >        Protection/Restoratio        n
> >
> >
> > Diego,
> > I do not see any technical problems with placing such
> > a definition in an Internet-Draft.
> >
> > But there may be problems associated with the IETF process:
> >
> > 1. Do you want to pursue this activity in the CCAMP WG?
> >    I am not sure this is really in the scope as defined
> >    by the CCAMP Charter
> >
> > 2. For interoperability the IETF document should be
> >    a Standards Track RFC. On the other hand, CCAMP is in
> >    the Routing Area meaning that you need an implementation
> >    to publish a Standards Track RFC - but what could be
> >    considered as an implementation in this case?
> >
> > Regards,
> >                                   Sasha Vainshtein
> > email:                         [email-masked]
> <[email-masked]>
> > phone:                       +972-3-7569993 (office)
> > fax:                            +972-3-6487779
> > mobile:                      +972-52-8674833
> >
> >
> > > -----Original Message-----
> > > From: Diego Caviglia [[email-masked]]
> > > Sent: Wednesday, March 23, 2005 3:37 PM
> > > To: Sasha Vainshtein
> > > Cc: ccamp
> > > Subject: RE: Failure definition w.r.t. SONET/SDH and
> > > Protection/Restoratio n
> > >
> > >
> > >
> > > Hi Sasha,
> > >                        I agree with you but in any case for
> > > interop issues
> > > and for sake of clarity I'd like to have that written in some IETF
> > > document.
> > >
> > > Regards
> > >
> > > Diego
> > >
> > >
> > >
> > >
> > >
> > > Sasha Vainshtein <[email-masked]> on 23/03/2005 12.23.12
> > >
> > > To:    "'Diego Caviglia'" <[email-masked]>
> > > cc:    [email-masked]
> > >
> > > Subject:    RE: Failure definition w.r.t. SONET/SDH and
> > >        Protection/Restoratio  n
> > >
> > >
> > > Diego and all,
> > > IMHO it is reasonable to assume that a failure is
> > > a defect that results in sending downstream AIS
> > > (and upstream RDI) as consequent action(s).
> > >
> > > For SDH consecutive actions for each defect
> > > are specified in ITU-T G.783.
> > >
> > > Note also that for some defects the consecutive action
> > > can be disabled by configuration. Hence I'd say that
> > > the same defect can be a failure in one case and
> > > not a failure in another case. The typical example
> > > is Trail Identifier Mismatch (TIM).
> > >
> > > Hopefully this note will help.
> > >
> > > Regards,
> > >                                   Sasha Vainshtein
> > > email:                         [email-masked]
> > > <[email-masked]>
> > > phone:                       +972-3-7569993 (office)
> > > fax:                            +972-3-6487779
> > > mobile:                      +972-52-8674833
> > >
> > >
> > > > -----Original Message-----
> > > > From: Diego Caviglia [[email-masked]]
> > > > Sent: Wednesday, March 23, 2005 1:06 PM
> > > > To: [email-masked]
> > > > Subject: Failure definition w.r.t. SONET/SDH and
> > > > Protection/Restoration
> > > >
> > > >
> > > > Hi all,
> > > >               is it defined somewhere, with respect to
> > > > SDH/SONET, which
> > > > defect has to be consider as a failure?
> > > >
> > > > It seems to me that for interoperability could be useful to
> > > > have a list of
> > > > defect that must be considered as failure, the same applies
> > > > for defect that
> > > > optionally can be considered as defect.
> > > >
> > > > May be also a communication between restoration TNEs in order
> > > > to agree on
> > > > the list could be useful.
> > > >
> > > > Does anyone agree on that?
> > > >
> > > > Regards
> > > >
> > > > Diego
> > > >
> > > > PS I apologise if the list is defined somewhere but I wasn't
> > > > able to find
> > > > it.
> > > >
> > > >
> > > >
> > > >
> > >
> > >
> > >
> > >
> > >
> > >
> >
> >
> >
> >
> >
> >
> >
> >
> 
> 
> 
> 
> 
> 
> 
> 
> 
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 24 Mar 2005 11:40:01 -0000

Hi Amit,

>    Do you mean to say that Data plane & Control plane protection should
be independant of each other??

No, I mean that they MAY be independent.
In particular, if you are using the control plane *and* the data plane to
manage protection on the same set of resources you are bound to get in a
horrible mess.

Seems more reasonable that you would apply data plane protection first and
then apply control plane protection at a higher level.

>    This may lead to lot of unused resource in the network.

It is certain that each layer of protection that you install MAY result in
unused resources. Building multiple layers of protection will, therefore,
potentially build up more and more unused resources. It is the job of
CCAMP to produce the tools that allow operators to build the protection
schemes that they want. It's not really our business to tell them which
schemes to build and when.

Cheers,
Adrian

---

From: Igor Bryskin <[email-masked]>
Date: Thu, 24 Mar 2005 11:25:23 -0800 (PST)

Hi,

I agree that recovery supervised by data and control plane should be correlated in a sense that control plane shouldn’t not trigger any recovery activities before giving a chance to the data plane (of course, capable of doing so) to provide the recovery. In fact, the similar strategy could be applied as in case of a multi-layer recovery, when, say, a higher layer does not start recovery procedures immediately on the fault detection, rather, waits for some time to let the lower layer(s) do the job, and starts recovery  only if the fault situation still exists after the hold off time.

Igor

Amit 70405 <[email-masked]> wrote: 

Hi Adrian,

----- Original Message -----
From: Diego Caviglia 
Date: Thursday, March 24, 2005 4:03 pm
Subject: Re: Failure definition w.r.t. SONET/SDH and Protection/Restoration

> "Adrian Farrel" on 23/03/2005 15.58.42
> 
> Please respond to "Adrian Farrel" 
> 
> To: "Diego Caviglia" , 
> cc: 
> 
> From: "Diego Caviglia" 
> To: "Sasha Vainshtein 
> Cc: "ccamp 
> > Sasha Vainshtein on 23/03/2005 14.44.23
> >
> > To: "'Diego Caviglia'" 
> > cc: ccamp 
> >
> > > Sasha Vainshtein on 23/03/2005 12.23.12
> > >
> > > To: "'Diego Caviglia'" 
> > > cc: [email-masked]
> > >

---------------------------------
Do you Yahoo!?
 Yahoo! Small Business - Try our new resources site!