Subject: Re: RE : RE : TR : I-D ACTION:draft-leroux-ccamp-gmpls-mrn-eval-00.txt

From: [email-masked]
Date: Fri, 4 Mar 2005 23:51:02 +0100

>> I wouldn't be so expeditious...
>> Actually we could use a similar mechanism but
>> definitely not the same.
>> Secondary LSP are dedicated to Shared Meshed
>> Restoration.
>> IMHO this would be bad to use the Protection object
>> for soft-FAs. Semantics
>> are pretty different...
>>
>
>IB>>Well, are they? They give you a way to signal a
>requirement not to commit resources for an LSP until
>further notice and also to require their commitment
>when it becomes necessary. Why not to allow working
>LSP to be signaled as Secondary according to the
>mentioned draft? Then it would be possible even to
>signal protected virtual FAs, which is not as stupid
>as it may sound :=)

Sorry but this sounds really bad...
Please let me know then how do you signal protected virtual FAs?

IB>> You signal both working and protection LSPs of the FA as Secondary. At
the time when you decide to make FA "real" you re-signal working or both
LSPs (depending on protection type) as Primary. Don't see why this wouldn't
work.

DP> because what do you do in case the primary (virtual) FA-LSP fails ? you
are simply going to activate the secondary (virtual) FA-LSP which is in
clear
opposition with the notion of virtual-FA - the reason is again because you
are trying to use one bit i.e. S to say something in a context (protection
object) for which it has not been designed for

---

From: "Igor Bryskin" <[email-masked]>
Date: Fri, 4 Mar 2005 18:05:17 -0500

> object) for which it has not been designed for

IB>> Oh-Oh, what do you mean by "primary (virtual) FA-LSP fails" and  "you
are simply going to activate the secondary (virtual) FA-LSP "?  I activate
protection LSP if I have a failure in the *data plane* of the working LSP.
But working LSP of the virtual FA does not have any data plane yet, there is
nothing that can trigger the protection LSP activation and switchover.

Igor