Subject: Re: RE : RE : TR : I-D ACTION:draft-leroux-ccamp-gmpls-mrn-eval-00.txt

From: Igor Bryskin <[email-masked]>
Date: Sat, 5 Mar 2005 06:31:57 -0800 (PST)

Dimitri,

See at the bottom

> >
> >IB>>Well, are they? They give you a way to signal a
> >requirement not to commit resources for an LSP
until
> >further notice and also to require their commitment
> >when it becomes necessary. Why not to allow working
> >LSP to be signaled as Secondary according to the
> >mentioned draft? Then it would be possible even to
> >signal protected virtual FAs, which is not as
stupid
> >as it may sound :=)
>
> Sorry but this sounds really bad...
> Please let me know then how do you signal protected
virtual FAs?
>
> IB>> You signal both working and protection LSPs of
the FA as Secondary.
At
> the time when you decide to make FA "real" you
re-signal working or both
> LSPs (depending on protection type) as Primary.
Don't see why this
wouldn't
> work.
>
> DP> because what do you do in case the primary
(virtual) FA-LSP fails ?
you
> are simply going to activate the secondary (virtual)
FA-LSP which is in
> clear
> opposition with the notion of virtual-FA - the
reason is again because you
> are trying to use one bit i.e. S to say something in
a context (protection
> object) for which it has not been designed for
>

IB>> Oh-Oh, what do you mean by "primary (virtual)
FA-LSP fails" and  "you
are simply going to activate the secondary (virtual)
FA-LSP "?  I activate
protection LSP if I have a failure in the *data plane*
of the working LSP.
But working LSP of the virtual FA does not have any
data plane yet, there is
nothing that can trigger the protection LSP activation
and switchover.

DP> but they are associated to resources they do not
use - and the control plane role is to ensure that
when they need to be activated resources can be used -
the question JL raises is the problem of "how do i
protect a virtual FA" and the response is if you are
using the S bit for telling i am a virtual FA you can
not use it anymore to ensure protection of a primary
(and even less a secondary !) - this said an secondary
LSP exists only within the context of its primary

IB>>Here is what I have in mind.

A network operator configures a mesh of virtual FAs.
Working FA LSPs are signaled as Secondary. Once they
are established the FA TE link ends are advertised.
Resources for these LSPs are allocated on the links
the LSPs are going through, however, they are not
committed (not bound into cross-connects). Two or more
virtual FA LSPs may share the resources on common
links. This is especially true for those of them that
are unlikely to become real at the same time.
Furthermore, polices could be such that virtual FA LSP
resources could be allowed to get pre-empted by real
(not necessarily FA-) LSPs. The mentioned resources
also could be involved in mesh restoration schemes and
even be bound into extra traffic LSPs. 

When a virtual FA transforms into real FA, its working
FA-LSP is re-signaled as Primary. At this time, the
allocated resources are bound into FA-LSP
cross-connects. Naturally, all other LSPs – virtual or
real – that share resources with the FA-LSP in
question are notified and need to be recomputed and/or
re-signaled.

A virtual FA could be provisioned as protected in a
sense that when it becomes real it will have a certain
protection scheme already in place. Path computation
for backup LSPs of virtual FAs is performed just like
of real FAs, that is, by assuming that associated
working LSPs are Primary (fully built) LSPs.
Regardless of the protection type backup LSPs of
virtual FAs are always signaled as Secondary. At the
time when a virtual FA is transformed into real one
(that is, when its working LSP becomes Primary) its
backup LSP(s) may be activated as well (e.g. 1+1
protection) or may be left Secondary until the working
LSP data plane failure is detected (e.g. shared
protection).

Igor

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: dimitri papadimitriou <[email-masked]>
Date: Sat, 05 Mar 2005 16:03:18 +0100

igor - i will provide a detailed answer concerning a clean method to 
deal with "virtual FAs" that does not rely on the use of the protection 
object (and therefore would deliver a clean method to provide signaling 
for protected "virtual FAs"

hopefully we can discuss this during this IETF meeting,

thanks,
- dimitri.

Igor Bryskin wrote:

> .

---

From: Igor Bryskin <[email-masked]>
Date: Sat, 5 Mar 2005 10:50:54 -0800 (PST)

Excellent. Looking forward to the discussion.
Hopefully, I’ll get to understand what is not clean
about the mechanism I suggested.

Before we start the discussion, I’d like to make clear
that all I am asking is a capability to provision
working LSPs as Secondary LSPs. Note that this is a
generic mechanism, and signaling of virtual FAs is one
of possibly many applications that can make use of it.
For example, on many occasions I hear a requirement
from service providers to provide a way of
provisioning a service when part of network resources
are not in place yet with actual service activation
after all resources are installed. This is necessary
to make sure that resources that are in place are not
“grabbed” by other dynamically provisioned services.
This problem could be easily solved by the suggested
mechanism. 

Lastly, despite what you and JL are saying,
provisioning of virtual FAs has a lot to do with
recovery. It is usually a MUST requirement for FAs to
be protected. In this case if you provision virtual FA
as unprotected, and, while it is transformed into real
FA, try to compute/provision protection LSP, the
computation may fail despite that two disjoint paths
do exist and could be determined if they were computed
at the same time. Therefore, it should be possible to
compute working and protection (possibly multiple as
in case of segment protection) path(s) for virtual FA
and signal them, associating them together, without
committing network resource for neither of them.

See you in Minneapolis,
Igor

--- dimitri papadimitriou <[email-masked]>

> > Tired of spam?  Yahoo! Mail has the best spam

		
__________________________________ 
Celebrate Yahoo!'s 10th Birthday! 
Yahoo! Netrospective: 100 Moments of the Web 
http://birthday.yahoo.com/netrospective/

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 5 Mar 2005 16:30:28 -0000

Why are we talking about signaling virtual FA LSPs?
I thought the point of a virtual FA was that it was entirely putative.

Seems like you are talking about something more solid than a virtual FA
LSP.

Adrian

----- Original Message ----- 
From: "dimitri papadimitriou" <[email-masked]>
To: "Igor Bryskin" <[email-masked]>
Cc: <[email-masked]>; "Igor Bryskin"
<[email-masked]>; "LE ROUX Jean-Louis RD-CORE-LAN"
<[email-masked]>; <[email-masked]>
Sent: Saturday, March 05, 2005 3:03 PM
Subject: Re: RE : RE : TR : I-D
ACTION:draft-leroux-ccamp-gmpls-mrn-eval-00.txt