Subject: Re: Nortel Networks Statement on IPR claimed in draft-ietf-ccamp-loose-path-reopt-00.txt

From: JP Vasseur <[email-masked]>
Date: Tue, 3 May 2005 14:31:04 -0400

Hi,

First of all, thanks to the CCAMP WG chair for helping out in the  
resolution of this issue.

The draft represents an important technique which, in our opinion, is a  
valuable addition to the management and operation of LSPs in MPLS and  
GMPLS networks especially where those LSPs traverse multiple domains.  
We have looked at this function carefully, but do not believe that it  
can be achieved by any other technique that would not also be  
potentially covered by this IPR disclosure. Therefore we propose the  
following steps:

1. Text is added to the I-D as follows.

The procedures described in this document are the subject of an  
Intellectual Property Rights claim. For this reason, the procedures are  
entirely optional within an MPLS or GMPLS network. Implementations that  
do not support the procedures described in this document will  
interoperate seamlessly with those that do.
Further, an implementation that does not support the procedures  
described in this document will not be impacted or implicated by a  
neighboring implementation that does implement the procedures.

An ingress implementation that chooses not to support the procedures  
described in this document may still achieve re-optimization by  
periodically issuing a speculative make-before-break replacement of an  
LSP without trying to discovery whether a more optimal path is  
available in a downstream domain. Such a procedure would not be in  
conflict with any mechanisms not already documented in [RFC3209] and  
[RFC3473].

2. The I-D should be updated with comments arising from the WG last  
call.

3. The I-D should be progressed as an informational RFC

Thanks.

JP.

On Apr 7, 2005, at 8:52 AM, Adrian Farrel wrote:

> Please see below a response from the Counsel for Nortel Networks with
> regard to my enquiry about their IPR disclosure for
> draft-ietf-ccamp-loose-path-reopt-00.txt.
>
> The working group must now decide whether it wishes to pursue the
> techniques described in the I-D notwithstanding the IPR claim, or  
> whether
> it should seek out an alternative technology.
>
> Discussion please.
>
> Thanks,
> Adrian
> ----- Original Message -----
> From: "Michelle Lee" <[email-masked]>
> To: "Adrian Farrel" <[email-masked]>
> Cc: "'Kireeti Kompella'" <[email-masked]>; "Richard Weiss"
> <[email-masked]>
> Sent: Wednesday, April 06, 2005 5:54 PM
> Subject: RE: Nortel Networks Statement on IPR claimed in
> draft-ietf-ccamp-loose-path-reopt-00.txt
>
>
>> Dear Mr. Farrel,
>>
>> Thank you for your email.
>>
>> Unfortunately, I am not in a position to answer these questions
>> specifically, especially since they would require my providing
> privileged
>> and/or confidential information. We believe, however, our intentions  
>> are
>> clearly set forth in and by our conforming disclosure and declaration
>> statement to IETF with respect to IETF Internet Draft
>> draft-ietf-ccamp-loose-path-reopt-00.txt, and that experts in the area
> can
>> probably better determine relevance of the identified patent therein.
>>
>> Kind Regards,
>> Michelle Lee
>> Counsel, IP Law
>> Nortel Networks
>>
>>
>>  -----Original Message-----
>> From: Adrian Farrel [mailto:[email-masked]]
>> Sent: Monday, March 21, 2005 4:32 PM
>> To: [email-masked]; [email-masked]
>> Cc: 'Kireeti Kompella'; [email-masked]
>> Subject: Nortel Networks Statement on IPR claimed in
>> draft-ietf-ccamp-loose-path-reopt-00.txt
>>
>>
>>
>> Dear Richard and Michelle,
>>
>> Thank you for submitting your Patent Disclosure
>> (
>>
> <http://www.ietf.org/ietf/IPR/nortel-ipr-draft-ietf-ccamp-loose-path- 
> reopt
> -0
>> 0.txt>
>>
> http://www.ietf.org/ietf/IPR/nortel-ipr-draft-ietf-ccamp-loose-path- 
> reopt-00
>> .txt)
>> with respect to IETF Internet Draft
>> draft-ietf-ccamp-loose-path-reopt-00.txt.
>>
>> I would be grateful if you could clarify two points to help me
> understand
>> this discolsure further.
>>
>> 1. The disclosure states that:
>>      Nortel Networks U.S. Patent No. 6,560,654 entitled "Apparatus and
>>      method of maintaining timely topology data within a link state
> routing
>>      network" may contain claims that may be necessary for practicing  
>> a
>>      resulting IETF Standard based on this Internet Draft.
>>   Could you provide more detail about what aspects of
>>   draft-ietf-ccamp-loose-path-reopt-00.txt you believe may be impacted
> by
>>   this disclosure?
>>
>> 2. Can you clarify whether the "fair, reasonable, reciprocal, and
>>    non-discriminatory terms" referenced in the disclosure include the
>>    intention, in the event that the referenced draft becomes an  
>> Internet
>>    Standard, not to assert the patent except that some party asserts a
>> patent
>>    patent it owns or controls against Nortel?
>>    By way of an example of wording that covers this intention, can I
> draw
>>    your attention to a completely unrelated IPR disclosure at
>>
> <http://www.ietf.org/ietf/IPR/cisco-ipr-draft-ietf-tcpm-tcpsecure.txt>
>> http://www.ietf.org/ietf/IPR/cisco-ipr-draft-ietf-tcpm-tcpsecure.txt
>>
>> Thank you for any clarification you are able to offer.
>>
>> Please note that I am copying this email to Kireeti Kompella who
> co-chairs
>> the IETF's CCAMP working group with me. The CCAMP working group
> developed
>> the Internet-Draft in question
> (draft-ietf-ccamp-loose-path-reopt-00.txt)
>> and so I am also copying this email to the CCAMP mailing list.
>>
>> Best regards,
>> Adrian Farrel
>> --
>> Adrian Farrel
>> Old Dog Consulting
>> Phone: +44 (0) 1978-860944
>> Fax: +44 (0) 870-130-5411
>> [email-masked] <mailto:[email-masked]>
>>
>>
>>
>>
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 13 May 2005 18:18:14 +0100

JP,

Thanks for your proposals.

After consultation, I find that under the new IPR rules we do not make
specific reference to IPR disclosures in I-Ds or RFCs. Instead, the
boilerplate says that there "may be" IPR claims, and refers the reader to
the Web pages. This is a future-proof technique.

Therefore, I have tweaked your suggestions below.

> neighboring implementation that does implement the procedures.

Replace this paragraph with...
The procedures described in this document are
entirely optional within an MPLS or GMPLS network. Implementations that
do not support the procedures described in this document will
interoperate seamlessly with those that do.
Further, an implementation that does not support the procedures
described in this document will not be impacted or implicated by a
neighboring implementation that does implement the procedures.

> conflict with any mechanisms not already documented in [RFC3209] and

Second paragraph is fine.

> 2. The I-D should be updated with comments arising from the WG last

Yes please.

> 3. The I-D should be progressed as an informational RFC

Yes. This is advisable.

Please update the I-D and submit it. I will then forward it to Alex for AD
review.

Cheers,
Adrian

---

From: JP Vasseur <[email-masked]>
Date: Wed, 25 May 2005 12:30:08 -0400

Hi Adrian,

draft-ietf-ccamp-loose-path-reopt has been republished with the agreed 
changes.

Thanks.

JP.