Subject: RE: Final draft of response to the OIF

From: "Mack-Crane, T. Benjamin" <[email-masked]>
Date: Mon, 29 Aug 2005 09:11:32 -0500

Hi Huub,

See in-line below.

Regards,
Ben

> -----Original Message-----
> From: Huub van Helvoort [mailto:[email-masked]] 
> Sent: Friday, August 26, 2005 10:56 AM
> To: Mack-Crane, T. Benjamin
> Cc: Adrian Farrel; [email-masked]
> Subject: Re: Final draft of response to the OIF
> 
> Hello Ben,
> 
> You wrote:
> 
> > I proposed a simple (and I think technically sound) solution to
> > item #1 and saw no objections, however the answer has not changed.
> > 
> > I do not understand the reason for different encodings for
> > VC-4 and STS-3c SPE.  I think they should be the same, unless
> > there is a technical need to distinguish them.
> 
> If there is agreement that they should be the same, we should
> also look at higher order contiguous concatenated signals:
> i.e. STS-12c == VC-4-4c, STS-48c == VC-4-16c, STS-192c == VC-4-64c
> STS-768c == VC-4-256c

These signals are already encoded the same way (for instance see
examples 3 and 9 in RFC 3946).

> 
> > I also do not understand the RCC=1 NCC=1 encoding, since the rule
> > contained in the current RFC actually makes more sense. 
> 
> However indicating the number of signals concatenated in NCC
> makes your first objective impossible: STS-3Xc == VC-4-Xc
> so there will always be a difference of a factor 3 between
> STS and VC-4 encoding

All the encodings of contiguous concatenated signals use VC-4
(STS-3c SPE) as the base, so the NCC values are the same.  This
was done to align SONET and SDH encodings.

> 
> > If there is
> > only
> > one signal element, there is no contiguous concatenation, 
> by definition.
> 
> In fact a single signal is always contiguous concatenated  ;-)
> 
> > So I fail to see the usefulness of these encodings.
> 
> NCC = 1 would normally not occur, so it could be used for
> this specific case of SONET signals transported in an
> SDH world, or SDH signals transported in SONET land.
> And if these signals would not cross borders the value
> NCC > 1 can be used.

The SDH and SONET encodings have been aligned in all cases
except this one (VC-4, STS-3c SPE).  So these should also
be aligned.

> 
> > Regards,
> > Ben
> 
> Cheers, Huub.
> 
> -- 
> ================================================================
>               http://members.chello.nl/hhelvoort/
> ================================================================
> Always remember that you are unique...just like everyone else...
> 
============================================================
The information contained in this message may be privileged
and confidential and protected from disclosure. If the reader
of this message is not the intended recipient, or an employee
or agent responsible for delivering this message to the
intended recipient, you are hereby notified that any reproduction,
dissemination or distribution of this communication is strictly
prohibited. If you have received this communication in error,
please notify us immediately by replying to the message and
deleting it from your computer. Thank you. Tellabs
============================================================

---

From: Richard Rabbat <[email-masked]>
Date: Tue, 30 Aug 2005 13:57:59 -0700

Ben,
Adrian's final draft of the response is most inclusive. From what you 
said earlier, it seems that you've already coded it in one way 
(whichever) but are accepting both sets of values for NCC & RCC (both 1 
or 0).
Is there an engineering problem with the text of the response besides 
that you would be able to remove those couple of lines of code? if so, 
we should solve it.
Richard.