Subject: RE: MIB Dr. review of draft-ietf-ccamp-gmpls-tc-mib-09.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 17 Mar 2006 15:32:23 +0100

Inline

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: Wednesday, March 15, 2006 17:17
> To: [email-masked]
> Cc: [email-masked]; Wijnen, Bert (Bert); Dan Romascanu (E-mail);
> Adrian Farrel (E-mail); Bill Fenner (E-mail); Alex Zinin (E-mail)
> Subject: Re: MIB Dr. review of draft-ietf-ccamp-gmpls-tc-mib-09.txt
> 
> 
> 
> On Mar 15, 2006, at 12:32 AM, <[email-masked]> wrote:
> 
> >
> > Hi Tom and Adrian,
> >
> > Due to the updates to the 2 other GMPLS MIB documents
> > wanted to re-review this document.
> >
> > I did have one minor comment which was
> > the naming convention used, specifically
> > the use of the TC on the end of the names of these
> > Textual Conventions.
> >
> >    GmplsFreeformLabelTC
> >    GmplsLabelTypeTC
> >    GmplsSegmentDirectionTC
> >
> > Could this "TC" be removed?  Sorry to not catch this
> > earlier.
> 
> 	The "TC" was appended to remove the ambiguity
> between the variable and TC names. This is actually a
> warning from SmiLint too.  Something like "Warning: object and
> TC differ only in case".
> 

Note that it is a warning. So it is not mandatory to change.
I agree with the warning in that it is better to not have exactly the
same names for TCs and for and object descriptors (variable names).
Not sure that adding TC at the end of the TC descriptor is the
best solution, but it is one way to do things.

> > The reason is that this is not consistent with
> > other Textual Conventions.
> 
> 	I tried to make all TCs end in "TC" for
> the reason stated above. I will go back and 2x check
> the others and make things consistent.
> 
Consistency is also a good thing as I have always been saying (I think).

So do I take from this we should expect a new rev?

Bert
> 	--Tom
> > Thanks,
> >     Joan

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 17 Mar 2006 17:07:42 -0600

> So do I take from this we should expect a new rev?

	Hi Bert,

	Yes. I spoke with Joan offline yesterday and am
working on incorporating all of her changes. I should have something
on Monday and will email to her directly to review my
fixes/changes.  I will post an update as soon as the ID gate opens.

	--Tom