Subject: RE: Polling for two new working group I-Ds

From: "O'Connor, Don" <[email-masked]>
Date: Wed, 15 Aug 2007 17:22:32 -0500

Adrian

I do not believe that draft-nadeau-ccamp-gmpls-oam-requirements-01.txt should be a work group document until two clarifications / improvements are made to the current text, and we have agreement that the requirements specification will be socialized with ITU and IEEE 802.1 by way of an appropriate liaison. The two changes to the text that I request are

1) In Section 1 Introduction, please change the sentence

"This document describes requirements for data plane operations and management (OAM) for Generalized Multi-Protocol Label Switching (GMPLS) networks"

to

"This document describes requirements for control plane operations and management (OAM) for Generalized Multi-Protocol Label Switching (GMPLS) networks. It also describes OAM requirements associated with the interaction between the GMPLS Control Plane and Data Plane OAM."

2) In Section 4 General Requirements, please change the sentence

"The general requirements described in this section are based on those described for point-to-point MPLS in [RFC4377]."

to

"For MPLS-TE/GMPLS networks, the general requirements described in this section are based on those described for point-to-point MPLS in [RFC4377]."

Considering that ITU SG 15 has responsibility for SDH / SONET and WDM data planes and IEEE 802.1 has responsibility for the 802.1ah PBB and 802.1ay PBB-TE data planes, including data plane OAM - the ID should be sent to these SDOs with an appropriate liaison. 

IEEE 802.1 is also doing PBB / PBB-TE MIBs and ITU SG 4 is responsible for the management of SDH / SONET / WDM networks, so any new management requirements that this ID identifies, will be relevant to the purview of these SDOs

Regards

Don 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Adrian Farrel
Sent: Monday, August 13, 2007 10:33 AM
To: [email-masked]
Subject: Polling for two new working group I-Ds

Hi,

In Chicago we considered the possibility of two new CCAMP drafts. Please 
give your opinions:

1. draft-chen-ccamp-isis-interas-te-extension-00.txt
This is a partner draft to draft-ietf-ccamp-ospf-interas-te-extension-00.txt
The draft was discussed at the ISIS working group and several questions of 
detail were raised.
Thus, accepting this I-D now, does not imply that we would not change the 
mechanism.

2. draft-nadeau-ccamp-gmpls-oam-requirements-01.txt
This work is a charter milestone, and Deborah and I are both co-authors, so 
we are likely to be influenced in favour of adoption. So please voice your 
opinions loud and clear.

Thanks,
Adrian

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 15 Aug 2007 19:19:24 -0400

Although I agree with you on the change
and the point of sending liaison statements,
I do not see how this should preclude the document
from being accepted as a CCAMP WG draft.  Liaison
statements, their handling and transmission are issues
that are orthogonal to the creation of WG drafts.

	--Tom

> Adrian
>
> I do not believe that draft-nadeau-ccamp-gmpls-oam- 
> requirements-01.txt should be a work group document until two  
> clarifications / improvements are made to the current text, and we  
> have agreement that the requirements specification will be  
> socialized with ITU and IEEE 802.1 by way of an appropriate  
> liaison. The two changes to the text that I request are
>
> "This document describes requirements for data plane operations and  
> management (OAM) for Generalized Multi-Protocol Label Switching  
> (GMPLS) networks"
>
> to
>
> "This document describes requirements for control plane operations  
> and management (OAM) for Generalized Multi-Protocol Label Switching  
> (GMPLS) networks. It also describes OAM requirements associated  
> with the interaction between the GMPLS Control Plane and Data Plane  
> OAM."
>
>
> "The general requirements described in this section are based on  
> those described for point-to-point MPLS in [RFC4377]."
>
> to
>
> "For MPLS-TE/GMPLS networks, the general requirements described in  
> this section are based on those described for point-to-point MPLS  
> in [RFC4377]."
>
> Considering that ITU SG 15 has responsibility for SDH / SONET and  
> WDM data planes and IEEE 802.1 has responsibility for the 802.1ah  
> PBB and 802.1ay PBB-TE data planes, including data plane OAM - the  
> ID should be sent to these SDOs with an appropriate liaison.
>
> IEEE 802.1 is also doing PBB / PBB-TE MIBs and ITU SG 4 is  
> responsible for the management of SDH / SONET / WDM networks, so  
> any new management requirements that this ID identifies, will be  
> relevant to the purview of these SDOs
>
> Regards
>
> Don
>

---

From: dimitri papadimitriou <[email-masked]>
Date: Thu, 16 Aug 2007 09:41:41 +0200

i would argue along the same line

the question for now is about - need for such document - (imho it is the 
case ack'ing that there are also additional considerations that could be 
taken into for next releases as topic matures)

ps: the main issue is do we have enough good understanding about the 
control plane operations in the field to write a useful document (to 
achieve this i hope we will gather such feedback from the list)

-d.

Thomas D. Nadeau wrote:
>> I do not believe that draft-nadeau-ccamp-gmpls-oam-requirements-01.txt 
>> should be a work group document until two clarifications / 
>> improvements are made to the current text, and we have agreement that 
>> the requirements specification will be socialized with ITU and IEEE 
>> 802.1 by way of an appropriate liaison. The two changes to the text 
>> that I request are
>>
>> "This document describes requirements for control plane operations and 
>> (GMPLS) networks. It also describes OAM requirements associated with 
>> the interaction between the GMPLS Control Plane and Data Plane OAM."
>>
>>
>> "The general requirements described in this section are based on those 
>> described for point-to-point MPLS in [RFC4377]."
>>
>> to
>>
>> this section are based on those described for point-to-point MPLS in 
>> [RFC4377]."
>>
>> Considering that ITU SG 15 has responsibility for SDH / SONET and WDM 
>> data planes and IEEE 802.1 has responsibility for the 802.1ah PBB and 
>> 802.1ay PBB-TE data planes, including data plane OAM - the ID should 
>> be sent to these SDOs with an appropriate liaison.
>>
>> IEEE 802.1 is also doing PBB / PBB-TE MIBs and ITU SG 4 is responsible 
>> for the management of SDH / SONET / WDM networks, so any new 
>> management requirements that this ID identifies, will be relevant to 
>> the purview of these SDOs
>>
>> Regards
>>
>> Don
>>
>> This is a partner draft to 
>> draft-ietf-ccamp-ospf-interas-te-extension-00.txt
> .

---

From: Tomohiro Otani <[email-masked]>
Date: Wed, 22 Aug 2007 15:37:05 +0900

Hi Dimitri,

Sorry for the delay of the response.

As Adrian mentioned, in order to improve the document, we need more
feedback from operational people more than myself. After the meeting,
I talked with Dave about the feedback and Wataru will also add some
comments.  Indeed, we are also happy to reflect comments raised in
the list as a revised version.

So, as Tom mentioned, once it is accepted as a WG draft, it should
be accelerated more.

Regards,

Tomo

dimitri papadimitriou さんは書きました:
>>> I do not believe that 
>>> draft-nadeau-ccamp-gmpls-oam-requirements-01.txt should be a work 
>>> group document until two clarifications / improvements are made to 
>>> the current text, and we have agreement that the requirements 
>>> specification will be socialized with ITU and IEEE 802.1 by way of an 
>>> appropriate liaison. The two changes to the text that I request are
>>>
>>> responsible for the management of SDH / SONET / WDM networks, so any 
>>> new management requirements that this ID identifies, will be relevant 
>>> to the purview of these SDOs
>>>
>>> Regards
>>>
>>> Don
>>>