Subject: Recharter - Last Chance

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 16 Aug 2007 10:11:26 +0100

Hi,

Following from the small comments received on the list, here is the modified 
charter update proposal.

This is your last chance to comment before we send it to the IESG for 
approval.

Adrian and Deborah

===

First paragraph

OLD
The CCAMP working group coordinates the work within the IETF defining
a common control plane and a separate common measurement plane for
physical path and core tunneling technologies of Internet and telecom
service providers (ISPs and SPs), e.g. O-O and O-E-O optical switches,
ATM and Frame Relay switches, MPLS, GRE, in cooperation with the MPLS
WG.

NEW
The CCAMP working group coordinates the work within the IETF defining
a common control plane and a separate common measurement plane for
physical path and core tunneling technologies of Internet and telecom
service providers (ISPs and SPs), e.g. O-O and O-E-O optical switches,
TDM switches, Ethernet switches, ATM and Frame Relay switches, and
MPLS and GRE in cooperation with the MPLS WG.

===

New paragraph in the list of Scope bullets.
Suggest to place it after:
"- Definition of MIB modules and other OAM techniques relevant to the
   protocols and extensions specified within the WG."
and before:
"CCAMP WG currently works on the following tasks:"

- Work on GMPLS procedures and extensions to support source-
  controlled and explicitly-routed Ethernet data paths for
  Ethernet data planes that are already approved by an SDO with
  responsibility for the Ethernet data plane. It is expected that
  the primary SDO in this case is the IEEE. Note that the
  specification or modification of Ethernet data planes is out of
  scope.

===

Final paragraph

OLD
In doing this work, the WG will work closely with at least the
following other WGs: MPLS, ISIS, OSPF, IDR, L1VPN and PCE. The WG
will also cooperate with the ITU-T.

NEW
In doing this work, the WG will work closely with at least the
following other WGs: MPLS, ISIS, OSPF, IDR, L1VPN, and PCE. The
WG will also cooperate with the ITU-T and the IEEE 802.1.

===

Milestone revisions (see below for full revised milestone list)

OLD
  Jan 2006    First version WG I-D for Protocol solutions for MLN/MRN
NEW
  Sep 2007    First version WG I-D for Protocol solutions for MLN/MRN
---
OLD
  Mar 2006    First version WG I-D GMPLS OAM Requirements
NEW
  Sep 2007    First version WG I-D GMPLS OAM Requirements
---
OLD
  Apr 2006    First version of WG I-D for additional MIB module to cover 
RSVP-TE signaling extensions
NEW
  Nov 2007    First version of WG I-D for additional MIB module to cover 
RSVP-TE signaling extensions
---
OLD
  Jun 2006    Submit Informational I-D for Analysis of inter-domain issues 
for disjoint and protected paths for IESG review
NEW
  Oct 2007    Submit Informational I-D for Analysis of inter-domain issues 
for disjoint and protected paths for IESG review
---
OLD
  Oct 2006    Submit MPLS to GMPLS migration strategies I-D for IESG review
NEW
  Sep 2007    Submit MPLS-TE to GMPLS migration strategies I-D for IESG 
review
---
OLD
  Nov 2006    Submit ASON Routing solutions I-D for IESG review
NEW
  Jan 2008    Submit ASON Routing solutions I-D for IESG review
---
OLD
  Dec 2006    Submit Requirements for Multi-Layer and Multi-Region Networks 
I-D for IESG review
NEW
  Oct 2007    Submit Requirements for Multi-Layer and Multi-Region Networks 
I-D for IESG review
---
OLD
  Jan 2007    Submit MPLS-GMPLS interworking requirements and solutions I-D 
for IESG review
NEW
  Sep 2007    Submit MPLS-TE/GMPLS interworking requirements I-D for IESG 
review
---
OLD
  Feb 2007    Submit Evaluation of existing protocols for MLN/MRN for IESG 
review
NEW
  Oct 2007    Submit Evaluation of existing protocols for MLN/MRN for IESG 
review
---
OLD
  Mar 2007    Submit OSPF-TE/GMPLS MIB module for MIB doctor and IESG review
NEW
  Dec 2007    Submit OSPF-TE/GMPLS MIB module for MIB doctor and IESG review
---
OLD
  Jun 2007    Submit GMPLS OAM Requirements I-D for IESG review
NEW
  Feb 2008    Submit GMPLS OAM Requirements I-D for IESG review
---
OLD
  Aug 2007    Submit Protocol solutions for MLN/MRN I-D for IESG review
NEW
  Mar 2008    Submit Protocol solutions for MLN/MRN I-D for IESG review
---
OLD
  Dec 2007    Submit MIB module for RSVP-TE signaling extensions for MIB 
doctor and IESG review
NEW
  Apr 2008    Submit MIB module for RSVP-TE signaling extensions for MIB 
doctor and IESG review
---
OLD
  Dec 2007    Recharter or close Working Group
NEW
  Dec 2008    Recharter or close Working Group
---
NEW
  Oct 2007    First version WG I-Ds for GMPLS source-controlled and 
explicitly-routed Ethernet networks
---
NEW
  May 2008    Submit protocol extensions for GMPLS source-controlled and 
explicitly-routed Ethernet networks for IESG review

====

Goals and Milestones (full revised milestone list)

Done    Post strawman WG goals and charter
Done    Identify and document a limited set of candidate solutions for 
signalling and for measurement. Among candidate control solutions to be 
considered are the existing GMPLS drafts.
Done    Build appropriate design teams
Done    Submit WG document defining path setup portions of common control 
plane protocol
Done    Submit WG document defining common measurement plane protocol
Done    Submit LMP MIB to IESG
Done    Submit protection & restoration documents to IESG
Done    Submit ASON signaling requirements doc to IESG
Done    Submit GMPLS MIBs to IESG
Done    Produce CCAMP WG document for generic tunnel tracing protocol
Done    Produce CCAMP WG document for multi-area/AS signaling and routing
Done    Submit ASON routing requirements doc to IESG
Done    Submit revised charter and milestones to IESG for IESG consideration 
of more detailed deliverables and determination of usefulness of 
continuation of WG
Done    First version WG I-D for Advertising TE Node Capabilities in ISIS 
and OSPF
Done    First version WG I-D for Automatic discovery of MPLS-TE mesh 
membership
Done    Submit ASON Routing evaluation I-D for IESG review
Done    Cross-WG review of I-D for Advertising TE Node Capabilities in ISIS 
and OSPF
Done    First version WG I-D MPLS to GMPLS migration strategies
Done    First version WG I-D Requirements for Multi-Layer and Multi-Region 
Networks
Done    First version WG I-D for Evaluation of existing protocols for 
MLN/MRN
Done    First version of WG I-D for ASON Routing solutions
Done    Submit RSVP-TE extensions for inter-domain signaling I-D for IESG 
review
Done    Submit Per-domain path computation signaling I-D for IESG review
Done    First version of WG I-D for OSPF-TE/GMPLS MIB module
Done    Submit GMPLS signaling in support of Call Management I-D for IESG 
review
Done    First version WG Informational I-D for Analysis of inter-domain 
issues for disjoint and protected paths
Done    Submit I-D for Advertising TE Node Capabilities in ISIS and OSPF for 
IESG review
Done    Submit GMPLS/ASON lexicography I-D for IESG review
Done    First version WG I-D MPLS-GMPLS interworking requirements and 
solutions
Done    Submit LSP Stitching I-D for IESG review
Done    Submit I-D for Automatic discovery of MPLS-TE mesh membership for 
IESG review
Done    Submit GMPLS routing and signaling interoperability advice I-D for 
IESG review
Sep 2007    First version WG I-D for Protocol solutions for MLN/MRN
Sep 2007    First version WG I-D GMPLS OAM Requirements
Sep 2007    Submit MPLS-TE to GMPLS migration strategies I-D for IESG review
Sep 2007    Submit MPLS-TE/GMPLS interworking requirements I-D for IESG 
review
Oct 2007    First version WG I-Ds for GMPLS source-controlled and 
explicitly-routed Ethernet networks
Oct 2007    Submit Informational I-D for Analysis of inter-domain issues for 
disjoint and protected paths for IESG review
Oct 2007    Submit Requirements for Multi-Layer and Multi-Region Networks 
I-D for IESG review
Oct 2007    Submit Evaluation of existing protocols for MLN/MRN for IESG 
review
Nov 2007    First version of WG I-D for additional MIB module to cover 
RSVP-TE signaling extensions
Dec 2007    Submit OSPF-TE/GMPLS MIB module for MIB doctor and IESG review
Jan 2008    Submit ASON Routing solutions I-D for IESG review
Feb 2008    Submit GMPLS OAM Requirements I-D for IESG review
Mar 2008    Submit Protocol solutions for MLN/MRN I-D for IESG review
Apr 2008    Submit MIB module for RSVP-TE signaling extensions for MIB 
doctor and IESG review
May 2008    Submit protocol extensions for GMPLS source-controlled and 
explicitly-routed Ethernet networks for IESG review
Dec 2008    Recharter or close Working Group

====
Thanks,
Adrian

---

From: "PAPADIMITRIOU Dimitri" <[email-masked]>
Date: Thu, 30 Aug 2007 21:13:18 +0200

adrian

> explicitly-routed Ethernet networks for IESG review

is that actually realistic ? knowing that work at IEEE 
started on March 2007 and expected to take a couple of
cycles ?

from the PAR 
<http://standards.ieee.org/board/nes/projects/802-1Qay.pdf>

Expected Date of Submission for Initial Sponsor Ballot: 
August 2010 Projected Completion Date for Submittal to 
RevCom: February 2011

hence, assuming this work that started in March 2007 may
be stabilized by mid-2008 - how to achieve that milestone?
should it not be something like Dec. 2008.

in case the work items are expected to be achieved in a
presence of multiple steps like initially considered i 
would suggest then start working on functional specs &
specific specs that could be delivered once the IEEE 
spec. further stabilizes.

just tyring to prevent yet another milestone change in a
couple of months

-d. 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Thursday, August 16, 2007 11:11 AM
> To: [email-masked]
> Subject: Recharter - Last Chance
> 
> Hi,
>