Subject: RE: [mpls] Updates to draft-ietf-ccamp-mpls-graceful-shutdown

From: "AISSAOUI Mustapha" <[email-masked]>
Date: Thu, 6 Nov 2008 12:04:48 -0600

Hi Ali,
I have an issue with not providing backwards compatibility with the
"Notify" error code and the error sub-codes for link and node
maintenance defined in RFC 4736. This draft has been using these codes
for almost four years now and it is not acceptable they get changed in
last call.

Furthermore, draft-ietf-mpls-gmpls-lsp-reroute-02.txt suggests backwards
compatibility must be provided when required. I believe this is one of
those cases. When draft-ietf-mpls-gmpls-lsp-reroute-02.txt passes WG
last call, it makes perfect sense to require new applications to start
using it.

Regards,
Mustapha. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Zafar Ali (zali)
> Sent: Wednesday, October 29, 2008 12:35 PM
> To: Lou Berger
> Cc: [email-masked]; Newton, Jonathan; [email-masked]; 
> [email-masked]; Anca Zamfir (ancaz)
> Subject: Re: [mpls] Updates to draft-ietf-ccamp-mpls-graceful-shutdown
> 
> Hi Lou-  
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]] On Behalf Of Lou Berger
> > Sent: Wednesday, October 29, 2008 11:56 AM
> > To: Zafar Ali (zali)
> > Cc: Lou Berger; Adrian Farrel; [email-masked]; [email-masked]; 
> > [email-masked]; Anca Zamfir (ancaz); Newton, Jonathan
> > Subject: Re: Updates to draft-ietf-ccamp-mpls-graceful-shutdown
> > 
> > Zafar,
> > 
> > Why does the document define new error codes (and why 4)?  
> Is it that 
> > the reroute document isn't sufficient clear on how to 
> indicated each 
> > of the 4? Is it some other reason?
> > 
> 
> This is because headend may be able to compute alternate 
> route ("reroute" action) for mb4b differently, depending on 
> the resource under graceful shutdown, as detailed in the 
> document. Hence one code is define for TE node, TE link, 
> component link of a bundled TE link, and label resource, each. 
> 
> Thanks
> 
> Regards... Zafar 
> 
> <snip>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Thu, 6 Nov 2008 16:26:54 -0500

Mustapha- 

I think once we address Lou's comment, that will also address your
comment. So please wait for the new revision. We can try to publish it
during the IETF week. 

Thanks

Regards... Zafar 

> From: AISSAOUI Mustapha [mailto:[email-masked]] 
> Sent: Thursday, November 06, 2008 1:05 PM
> To: Zafar Ali (zali); Lou Berger
> Subject: RE: [mpls] Updates to draft-ietf-ccamp-mpls-graceful-shutdown
> 
> Hi Ali,
> I have an issue with not providing backwards compatibility 
> with the "Notify" error code and the error sub-codes for link 
> and node maintenance defined in RFC 4736. This draft has been 
> using these codes for almost four years now and it is not 
> acceptable they get changed in last call.
> 
> Furthermore, draft-ietf-mpls-gmpls-lsp-reroute-02.txt 
> suggests backwards compatibility must be provided when 
> required. I believe this is one of those cases. When 
> draft-ietf-mpls-gmpls-lsp-reroute-02.txt passes WG last call, 
> it makes perfect sense to require new applications to start using it.
> 
> Regards,
> Mustapha. 
> 
> > From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> > Of Zafar Ali (zali)
> > This is because headend may be able to compute alternate route 
> > ("reroute" action) for mb4b differently, depending on the resource 
> > under graceful shutdown, as detailed in the document. Hence 
> one code 
> > is define for TE node, TE link, component link of a bundled 
> TE link, 
> > and label resource, each.
> > 
> > Thanks
> > 
> > Regards... Zafar
> > 
> > <snip>