Subject: [CCAMP] Q on FEC type in draft-ietf-ccamp-wson-signal-compatibility-ospf-00.txt

From: Dirk Schroetter <[email-masked]>
Date: Wed, 3 Feb 2010 14:35:35 +0100

Folks,

is there a particular reason why the FEC type Sub-TLV only makes provisions for FEC types defined in G.709/G.709V as standard FEC types ? I understand that vendor-secific ones are supported, but why not extend the list of "standard" ones by the FEC types defined in G.975.1 (even though they strictly would only apply to submarine systems) ?

Best Regards,

/Dirk

---

From: Young Lee <[email-masked]>
Date: Wed, 03 Feb 2010 09:52:45 -0600

Hi Dirk,

We have updated the FEC type Sub-TLV that incorporates G.975.1. The update
will be shortly published. They are at the minimum:

 FEC ID
--------
	3	G.975.1 Concatenated FEC (RS(255,239)/CSOC(n0/k0=7/6,J=8))
	4	G.975.1 Concatenated FEC (BCH(3860,3824)/BCH(2040,1930))
	5	G.975.1 Concatenated FEC (RS(1023,1007)/BCH(2407,1952))
	6	G.975.1 Concatenated FEC (RS(1901,1855)/Extended Hamming
Product Code (512,502)X(510,500))
	7	G.975.1 LDPC Code
	8	G.975.1 Concatenated FEC (Two orthogonally concatenated BCH
codes)
	9	G.975.1 RS(2720,2550)
	10	G.975.1 Concatenated FEC (Two interleaved extended BCH
(1020,988) codes) 

Where RS stands for Reed-Solomon and BCH for Bose-Chaudhuri-Hocquengham.

If you have any question, please let me know. Thanks. 

Regards,
Young

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Dirk Schroetter
Sent: Wednesday, February 03, 2010 7:36 AM
To: [email-masked]
Subject: [CCAMP] Q on FEC type
indraft-ietf-ccamp-wson-signal-compatibility-ospf-00.txt

Folks,

is there a particular reason why the FEC type Sub-TLV only makes provisions
for FEC types defined in G.709/G.709V as standard FEC types ? I understand
that vendor-secific ones are supported, but why not extend the list of
"standard" ones by the FEC types defined in G.975.1 (even though they
strictly would only apply to submarine systems) ?

Best Regards,

/Dirk
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Dirk Schroetter <[email-masked]>
Date: Wed, 3 Feb 2010 17:08:24 +0100

Hi YOung,

perfect. That answers my question.

/Dirk