Subject: [CCAMP] Limitations in "OAM Configuration Framework"...

From: Greg Bernstein <[email-masked]>
Date: Mon, 22 Feb 2010 10:34:48 -0800

Hi Attilla, co-authors and CCAMPers, I like the "OAM Configuration 
Framework" draft and the corresponding RSVP SDH & OTN extensions, since 
some of these issues are very similar to those seen in Wavelength 
Switched Optical Networks (WSON).

In WSON we have a need to specify a particular operation (say 
regeneration) take place at a particular intermediate node along a path.
It seems that the current "OAM Configuration Framework" details don't  
include such a case. While we have in general:
(a) Maintenance End Points (MEPs)
(b) Maintenance Intermediate Points (MIP)
There is a statement in section 4.1: "...the establishment of OAM MIP 
entities is required at every transit node of the signalled LSP...".  
This seemed to me to indicate the ability to configure processing at all 
intermediate nodes or none. Is this correct?

It also seemed to me that this would preclude using this mechanism for 
configuring tandem connection monitoring (TCM) OAM. Note G.709 has 
particularly good TCM facilities. Was there another set of drafts in the 
works that would include TCM configuration?
This would probably look more like some of the functionality that we 
need for WSONs.

Regards

Greg B.

-- 
===================================================
Dr Greg Bernstein, Grotto Networking (510) 573-2237

---

From: Peng He <[email-masked]>
Date: Tue, 23 Feb 2010 16:25:50 -0500

continued with Greg's comments, so according to this Section 4.1
"...the establishment of OAM MIP entities is required at every transit
node of the signalled LSP...", there is no flexible choice to select
several (not all) transit node(s) to configure MIP(s)? that is, either
no MIP, or MIPs on all nodes?

Regards,
Peng

On Mon, Feb 22, 2010 at 1:34 PM, Greg Bernstein
<[email-masked]> wrote:
> Framework" draft and the corresponding RSVP SDH & OTN extensions, since some
> of these issues are very similar to those seen in Wavelength Switched
> Optical Networks (WSON).
>
> In WSON we have a need to specify a particular operation (say regeneration)
> take place at a particular intermediate node along a path.
> entities is required at every transit node of the signalled LSP...".  This
> seemed to me to indicate the ability to configure processing at all
> This would probably look more like some of the functionality that we need
> for WSONs.
>
> Regards
>
> Greg B.
>
> --
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>

---

From: Attila Takacs <[email-masked]>
Date: Wed, 24 Feb 2010 07:59:59 +0100

Hi Greg,

Based on the discussions at the last IETF on the scalability of configuring functions on intermediate nodes selectively, we thought that it would be practical to break out the discussion on segment OAM/TCM configuration to a new document. It is in the works now, and we plan to publish the initial version by the deadline. 

Last time we scratched the HOP_ATTRIBUTES option, in this new draft we want to review other alternatives for configuring intermediate nodes that popped up in the discussions in Hiroshima and on the list. Based on that summary/comparison we may move on and nail down a solution.

There seems to be a more general interest to configure intermediate nodes, besides TCM/segment OAM, we have WSON and I also heard about some local recovery related ideas. If this is the case we should look for a solution that fits best the different use-cases.

Best regards,
Attila

> -----Original Message-----
> From: Greg Bernstein [mailto:[email-masked]] 
> Sent: Monday, February 22, 2010 7:35 PM
> To: [email-masked]; Attila Takacs
> Subject: Limitations in "OAM Configuration Framework"...
> 
> Hi Attilla, co-authors and CCAMPers, I like the "OAM 
> Configuration Framework" draft and the corresponding RSVP SDH 
> & OTN extensions, since some of these issues are very similar 
> to those seen in Wavelength Switched Optical Networks (WSON).
> 
> It seems that the current "OAM Configuration Framework" 
> details don't include such a case. While we have in general:
> (b) Maintenance Intermediate Points (MIP) There is a 
> statement in section 4.1: "...the establishment of OAM MIP 
> This seemed to me to indicate the ability to configure 
> processing at all intermediate nodes or none. Is this correct?
> 
> It also seemed to me that this would preclude using this 
> mechanism for configuring tandem connection monitoring (TCM) 
> OAM. Note G.709 has particularly good TCM facilities. Was 
> there another set of drafts in the works that would include 
> TCM configuration?
> This would probably look more like some of the functionality 
> that we need for WSONs.
> 
> Regards
> 
> Greg B.
> 
> --

---

From: Attila Takacs <[email-masked]>
Date: Wed, 24 Feb 2010 08:01:48 +0100

Hi Peng,
Your observation is correct with regards to the OAM framework. 
For selective configuration of MIPs please see my mail to Greg.
Thanks,
Attila 

> From: Peng He [mailto:[email-masked]] 
> Sent: Tuesday, February 23, 2010 10:26 PM
> To: Greg Bernstein
> Cc: [email-masked]; Attila Takacs
> Subject: Re: [CCAMP] Limitations in "OAM Configuration Framework"...
> 
> continued with Greg's comments, so according to this Section 
> 4.1 "...the establishment of OAM MIP entities is required at 
> every transit node of the signalled LSP...", there is no 
> flexible choice to select several (not all) transit node(s) 
> to configure MIP(s)? that is, either no MIP, or MIPs on all nodes?
> 
> Regards,
> Peng
> 
> 
> 
> > Framework" draft and the corresponding RSVP SDH & OTN extensions, 
> > since some of these issues are very similar to those seen in 
> > Wavelength Switched Optical Networks (WSON).
> >
> details don't
> > (b) Maintenance Intermediate Points (MIP) There is a statement in 
> > section 4.1: "...the establishment of OAM MIP entities is 
> required at 
> > every transit node of the signalled LSP...".  This seemed to me to 
> > indicate the ability to configure processing at all 
> intermediate nodes 
> mechanism for 
> > particularly good TCM facilities. Was there another set of 
> drafts in 
> > the works that would include TCM configuration?

---

From: Greg Bernstein <[email-masked]>
Date: Wed, 24 Feb 2010 07:43:28 -0800

Thanks for the update Attila, our WSON signaling draft has a requirement 
for some type of mechanism for selectively configuring  intermediate 
nodes along a path but we are not committed to any one solution at this 
point. It would be great if your new draft summarizes the options and 
makes a recommendation.
Let me know if you need any assistance.

Cheers

Greg