Subject: [CCAMP] [OSPF-General-Constraints] updated //Re: New Version Notification for draft-zhang-ccamp-general-constraints-ospf-ext-00

From: Fatai Zhang <[email-masked]>
Date: Mon, 13 Sep 2010 09:34:54 +0800

Hi all,

We have submited [draft-zhang-ccamp-general-constraints-ospf-ext-00], which is based on [draft-zhang-ccamp-rwa-wson-routing-ospf] that has been around for  a long time.

The main updates are based on the discussion in the Maastricht meeting and they are as follows:
(1)Renamed from:"OSPF Extensions in Support of RWA in WSONs" to: "OSPF-TE Extensions for General Network Element Constraints"
(2)Made it general by following "draft-ietf-ccamp-general-constraint-encode"
(3)Some editorial updates

Note that OEO stuff is still covered in [draft-ietf-ccamp-wson-signal-compatibility-ospf].

Any comments or suggestions are appreciated.

To co-chairs: Do you think if it is ready to be a WG document?

Best Regards
 
Fatai
 
----- Original Message ----- 
From: "IETF I-D Submission Tool" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Friday, September 10, 2010 5:33 PM
Subject: New Version Notification for draft-zhang-ccamp-general-constraints-ospf-ext-00

> 
> A new version of I-D, draft-zhang-ccamp-general-constraints-ospf-ext-00.txt has been successfully submitted by Fatai Zhang and posted to the IETF repository.
> 
> Filename: draft-zhang-ccamp-general-constraints-ospf-ext
> Revision: 00
> Title: OSPF-TE Extensions for General Network Element Constraints
> Creation_date: 2010-09-10
> WG ID: Independent Submission
> Number_of_pages: 13
> 
> Abstract:
> Generalized Multiprotocol Label Switching can be used to control a 
> wide variety of technologies including packet switching (e.g., MPLS), 
> time-division (e.g., SONET/SDH, OTN), wavelength (lambdas), and 
> 
> 
> 
> <Zhang>
> 
> 
> 
> 
> 
> Expires March 2011
> 
> 
> 
> 
> 
>  [page 1] 
> 
> draft-zhang-ccamp-general-constraints-ospf-ext-00.txt
> September 2010 
> 
> 
> spatial switching (e.g., incoming port or fiber to outgoing port or 
> fiber). In some of these technologies network elements and links may 
> impose additional routing constraints such as asymmetric switch 
> connectivity, non-local label assignment, and label range limitations 
> on links. This document describes OSPF routing protocol extensions to 
> support these kinds of constraints under the control of Generalized 
> MPLS (GMPLS).
>                                                                                  
> 
> 
> The IETF Secretariat.
> 
> 
>

---

From: Fatai Zhang <[email-masked]>
Date: Tue, 14 Sep 2010 09:14:24 +0800

Hi all,

The main updates are based on the discussion in the Maastricht meeting and they are as follows:
(1)Renamed from:"OSPF Extensions in Support of RWA in WSONs" to: "OSPF-TE Extensions for General Network Element Constraints"
(2)Made it general enough by following "draft-ietf-ccamp-general-constraint-encode"
(3)Some editorial updates

Best Regards
 
Fatai