Subject: Re: [CCAMP] WSON Info draft: Any additional comments?

From: "Filippo Cugini" <[email-masked]>
Date: Mon, 6 Sep 2010 11:50:50 +0200

Hi Greg,

just a couple of clarifications:
- Link info: in Sect 6, it is mentioned "additional link related
constraints". What is the relationship between the novel Link TLV and the
Type 2 Link TLV. For example, is the related novel Link TLV designed to be
used in combination with the type 2 TLV or just by itself (i.e., no type 2
TLV in WSONs)?
- Is the ResourcePool (e.g., FEC, modulation, etc in ResourceBlockInfo)
designed to describe also Add/Drop tributaries?

Thanx
  Filippo

----- Original Message ----- 
From: "Greg Bernstein" <[email-masked]>
To: "CCAMP" <[email-masked]>
Sent: Monday, August 30, 2010 4:35 PM
Subject: [CCAMP] WSON Info draft: Any additional comments?

>  Hi CCAMPers, at the Maastricht meeting we discussed taking the WSON RWA
> information model draft to last call.
> Are there any additional comments? Remember this is an informational
> overview document that sets the stage for the two standards track encoding
> documents.
>
> Cheers
>
> Greg B.
>
> -- 
> ===================================================
> Dr Greg Bernstein, Grotto Networking (510) 573-2237
>
>
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: Greg Bernstein <[email-masked]>
Date: Wed, 08 Sep 2010 08:28:33 -0700

Hi Filippo, good to hear from you again!
See comments below.

Cheers

Greg B.

> used in combination with the type 2 TLV or just by itself (i.e., no 
--> This is a decision that will be made in the OSPF extensions draft 
and is not decided in either the WSON Info or Encoding related drafts. 
Pierre Peloso and Fatai Zhang have some opinions on this issue in their 
drafts.
> designed to describe also Add/Drop tributaries?
--> Yes,  in the sense that add/drop tributaries might go through OEO or 
other processing elements. So we could have some resource pools for 
wavelength conversion for "through ports", and a bunch of OEO elements 
dedicated to add/drop ports. In such a case we'd might need to model 
these as two different types of resource blocks and these would 
definitely have different interconnection properties.
>
> Thanx
>  Filippo
>
>
> ----- Original Message ----- From: "Greg Bernstein" 
> <[email-masked]>

---

From: "PELOSO, PIERRE (PIERRE)" <[email-masked]>
Date: Fri, 17 Sep 2010 12:35:37 +0200

Hi Greg and Filippo,

Exactly in-line with Greg remark, some work is undergoing in order to figure out exactely the layout of TLVs.
That explains the comment that was expressed already during the CCAMP meeting in Maastricht, concerning the fact that both info and encoding drafts should not be concluded in an unchangeable way that would preclude the layout done inside OSPF. Hence my feeling that last-call is premature for these drafts, which does not challenge the quality of their content, but the layout not being fixed, makes the conclusion on this work hard to set imho.

Cheers.

- p

P.S. I had no access to emails these later days, which explains the dealy in entering the discussion. 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Greg Bernstein
Envoyé : mercredi 8 septembre 2010 17:29
À : Filippo Cugini
Cc : CCAMP
Objet : Re: [CCAMP] WSON Info draft: Any additional comments?

Cheers

Greg B.

On 9/6/2010 2:50 AM, Filippo Cugini wrote:
> constraints". What is the relationship between the novel Link TLV and 
> the Type 2 Link TLV. For example, is the related novel Link TLV 
> designed to be used in combination with the type 2 TLV or just by 
> itself (i.e., no type 2 TLV in WSONs)?
--> This is a decision that will be made in the OSPF extensions draft
and is not decided in either the WSON Info or Encoding related drafts. 
Pierre Peloso and Fatai Zhang have some opinions on this issue in their drafts.
> - Is the ResourcePool (e.g., FEC, modulation, etc in 
> ResourceBlockInfo) designed to describe also Add/Drop tributaries?
--> Yes,  in the sense that add/drop tributaries might go through OEO or
other processing elements. So we could have some resource pools for wavelength conversion for "through ports", and a bunch of OEO elements dedicated to add/drop ports. In such a case we'd might need to model these as two different types of resource blocks and these would definitely have different interconnection properties.
>>  Hi CCAMPers, at the Maastricht meeting we discussed taking the WSON 
>> RWA information model draft to last call.
>> overview document that sets the stage for the two standards track 
>> encoding documents.
>>
>> Cheers
>>
>> Greg B.
>>
>> --