Subject: [CCAMP] draft-ashok-ccamp-gmpls-ospf-g709 - comment on Multistage Muxing support

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 9 Nov 2010 04:35:19 +0100

Hi authors,

I don't understand how multistage muxing is addressed in the draft.
Section 7.2 states:

       Assume OTU3 interface that supports switching at line rate ODU3
       and lower rates - ODU0, ODU1, ODU2, ODU2e & ODUflex via
       multiplexing.

        [snip]

       ODUk Switching Capability Specific Information:
       +===============+================+===========================+
       |  Signal Type  | Bandwidth Type |  Available ODUs at Prio P |
       +===============+================+===========================+
       |    3 (ODU3)   | 0 (Max-Lsp-Bw) |            1              |
       +---------------+----------------+---------------------------+
       |    5 (ODU0)   | 0 (Max-Lsp-Bw) |            32             |
       +---------------+----------------+---------------------------+
       |    1 (ODU1)   | 0 (Max-Lsp-Bw  |            16             |
       +---------------+----------------+---------------------------+
       |    2 (ODU2)   | 0 (Max-Lsp-Bw) |            4              |
       +---------------+----------------+---------------------------+
       |    12 (ODU2e) | 0 (Max-Lsp-Bw) |            3              |
       +---------------+----------------+---------------------------+
If this is multistage muxing advertisement, you're implicitly assuming that Advertising ODU0, 1, 2, 2e and 3 *all* muxing combinations are supported:
- Single stage. E.g:
ODU0 into ODU1
ODU0 into ODU2
ODU0 into ODU3
ODU1 into ODU3
ODU2 into ODU3
and so on...

- Dual stage. E.g.
ODU0 into ODU1 into ODU2
ODU0 into ODU1 into ODU3
And so on...

- Triple stage e.g.
ODU0 into ODU1 into OUD2 into ODU3
And so on...

What if a node supports only a subset of those capabilities?

Thanks,
Daniele

DANIELE CECCARELLI
System & Technology - DU IP & Broadband

Via L.Calda, 5
Genova, Italy
Phone +390106002512
Mobile +393346725750
[email-masked]
www.ericsson.com

 <http://www.ericsson.com/>

This Communication is Confidential. We only send and receive email on the basis of the term set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>

---

From: Rajan Rao <[email-masked]>
Date: Mon, 8 Nov 2010 21:05:01 -0800

Danielle,

The path computing node shouldn't care where in the hierarchy a service is carried (e.g ODU0 LSP).  Link to link basis the hierarchy can & will vary (e.g. as OTN evolves).  The signaling decides what mux layer(s) to use to support the service locally.

What we advertise for a link is the ODUjs that a node can switch independent of what HO-ODU layer(s) it sits on.  This is all that is required for path computation.  The hierarchy information is local and is not flooded.

Thanks
Rajan

From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Tuesday, November 09, 2010 11:35 AM
To: [email-masked]
Subject: [CCAMP] draft-ashok-ccamp-gmpls-ospf-g709 - comment on Multistage Muxing support

Hi authors,

- Dual stage. E.g.
ODU0 into ODU1 into ODU2
ODU0 into ODU1 into ODU3
And so on...

- Triple stage e.g.

Thanks,
Daniele

DANIELE CECCARELLI

Via L.Calda, 5
Genova, Italy
Phone +390106002512
Mobile +393346725750

---

From: John E Drake <[email-masked]>
Date: Tue, 9 Nov 2010 01:14:25 -0800

Hi,

This my understanding of how it should work, based upon what we have done to date with other technologies.   In the most complicated case we would have a bunch of ODUk plumbing (component links) between a pair of nodes.  Based upon the multiplexing capabilities of the various ODUk links, we would figure which ODUjs we supported and how many of each out we can switch.

We shouldn't have to advertise anything wrt the ODUk plumbing.  If we have to, then we won't be able to support link bundling, which I took to be a hard requirement.

Thanks,

John

Sent from my iPhone

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rajan Rao
Sent: Monday, November 08, 2010 9:05 PM
To: Daniele Ceccarelli; [email-masked]
Cc: Yalin Wang
Subject: Re: [CCAMP] draft-ashok-ccamp-gmpls-ospf-g709 - comment on Multistage Muxing support

Danielle,

Thanks
Rajan

Hi authors,

- Dual stage. E.g.
ODU0 into ODU1 into ODU2
ODU0 into ODU1 into ODU3
And so on...

- Triple stage e.g.

Thanks,
Daniele

DANIELE CECCARELLI

Via L.Calda, 5
Genova, Italy
Phone +390106002512
Mobile +393346725750

---

From: Rajan Rao <[email-masked]>
Date: Tue, 9 Nov 2010 04:06:47 -0800

John,

We have an example covering link bundling case in section-7.3 of the draft

http://tools.ietf.org/html/draft-ashok-ccamp-gmpls-ospf-g709-02

The muxing hierarchy on each component link could be entirely different and is not known outside of the 2 nodes involved in bundling. This is no different from unbundled-Telink case.

Thanks
Rajan

From: John E Drake [mailto:[email-masked]]
Sent: Tuesday, November 09, 2010 5:14 PM
To: Rajan Rao; Daniele Ceccarelli; [email-masked]
Cc: Yalin Wang; [email-masked]
Subject: RE: [CCAMP] draft-ashok-ccamp-gmpls-ospf-g709 - comment on Multistage Muxing support

Hi,

Thanks,

John

Sent from my iPhone

Danielle,

Thanks
Rajan

Hi authors,

- Dual stage. E.g.
ODU0 into ODU1 into ODU2
ODU0 into ODU1 into ODU3
And so on...

- Triple stage e.g.

Thanks,
Daniele

DANIELE CECCARELLI

Via L.Calda, 5
Genova, Italy
Phone +390106002512
Mobile +393346725750