Subject: [CCAMP] The availability issue

From: Weiqiang Sun <[email-masked]>
Date: Wed, 10 Nov 2010 15:01:44 +0800

Hi Al,

Thanks for pointing out the possible misuse of this IPPM term.  Please
understand that by saying ³LSP is available², we are saying that ³all
cross-connects along the LSP have been setup and the LSP is ready to carry
traffic.²

Do you think that adding the above statement into the current text will
resolve your concern?

Thanks,
Weiqiang

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 10 Nov 2010 09:14:10 -0000

Hello,

I checked draft-shiomoto-ccamp-switch-programming-03.txt

We use the word "available" only twice in the draft. Both times we do so only in
a full English sentences...

   Forwarding Information Base (LFIB) [RFC4221]. Where there is
   admission control and resource reservation associated with the data
   forwarding path (such as the allocation of data buffers) [RFC3209]
   this can be treated as part of the cross-connect programming process
   since before the resources are correctly allocated and reserved, the
   LSP will not be available to forward data in the manner agreed to
   during the signaling protocol exchange.

and

   In this text "valid for forwarding" should be taken to mean that it
   is safe for the LSR that sends the Path message to receive data, and
   that the LSR will forward data correctly. The text does not mean that
   the label is "acceptable for use" (i.e., the label is available to be
   cross-connected).

I'd like to hear Al's view, but I don't think that these two uses of the word
need to be changed.

Cheers,
Adrian

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Weiqiang Sun
> Sent: 10 November 2010 07:02
> To: [email-masked]
> Cc: [email-masked]
> Subject: [CCAMP] The availability issue
>
> Hi Al,
>
understand 
> that by saying “LSP is available”, we are saying that “all cross-connects
along the LSP
> have been setup and the LSP is ready to carry traffic.”
>
resolve your
> concern?

---

From: Al Morton <[email-masked]>
Date: Wed, 10 Nov 2010 04:32:42 -0500

I don't think the switch-programming instances need to be
changed either, they seem to be general enough.

I felt that the performance metric in draft-*-dpm-
was dependent on attaining a state, and calling that
"Available" was potentially misleading.

When Weiqiang Sun and I talked after the meeting,
I think we agreed that changing the
term in -dpm would be best. BTW, it's not an IPPM or BMWG term,
but Availability is a special term in MEF,
ITU-T, ATIS in the US, and others standards bodies.

hope this helps,
Al

At 04:14 AM 11/10/2010, Adrian Farrel wrote:
>We use the word "available" only twice in the draft. Both times we 
>do so only in a full English sentences...
>
> > that by saying "LSP is available", we are saying that "all cross-connects
>along the LSP
> > have been setup and the LSP is ready to carry traffic."
> >

---

From: Weiqiang Sun <[email-masked]>
Date: Thu, 11 Nov 2010 09:05:15 +0800

Al,

As agreed upon, the 12 instances of "available" in the dpm draft will vanish
in our next revision.

Adrian, Please do accept my sincere apology for my misleading statement on
the origin of this term. I invented it :).

Best,
Weiqiang

On 11/10/10 5:32 PM, "Al Morton" <[email-masked]> wrote:

> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: Lou Berger <[email-masked]>
Date: Thu, 11 Nov 2010 09:26:36 +0800

Weiqiang,
While I'm certainly sensitive to avoiding terminology overload and 
confusion, I think the concept of “all cross-connects along the LSP have 
been setup and the LSP is ready to carry traffic" is an important one in 
our context. Do you plan to replace "available" with a new term? If so, 
what are you planing to use (and is Al okay with it)?

Much thanks,
Lou

On 11/11/2010 09:05 AM, Weiqiang Sun wrote:
> On 11/10/10 5:32 PM, "Al Morton"<[email-masked]>  wrote:
>
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 11 Nov 2010 01:45:34 -0000

I suggest "ready for use"

A

> -----Original Message-----
> From: Lou Berger [mailto:[email-masked]]
> Sent: 11 November 2010 01:27
> To: Weiqiang Sun
> Cc: Al Morton; [email-masked]; [email-masked]
> Subject: Re: [CCAMP] The availability issue
> 
> Weiqiang,
> confusion, I think the concept of "all cross-connects along the LSP have

---

From: Al Morton <[email-masked]>
Date: Wed, 10 Nov 2010 20:53:05 -0500

works for me,
Al

---

From: Lou Berger <[email-masked]>
Date: Thu, 11 Nov 2010 10:32:07 +0800

Most excellent!

Thank you.

Lou

---

From: Weiqiang Sun <[email-masked]>
Date: Thu, 11 Nov 2010 13:57:24 +0800

"ready for use" sounds perfect to me.
Thanks, Adrian.

Weiqiang