Subject: [CCAMP] Discussion of multi-stage solutions

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 31 Mar 2011 11:09:52 +0200

Hi,

<speaking as an individual>

A couple of thoughts that we didn't have time to talk about in the meeting. The
chairs may be right that the framework document can help us understand which
scenarios we need to address.

1. We don't generally optimize for special cases.
   That means we should pick a solution that we can apply across the board.
   Separating out a solution that is optimized for a particular case (e.g.
single-
   hop) would only be valuable if the savings are really large.

2. What is an LSP?
   Historically we have ted ourselves in knots by failing to clearly understand
   that an LSP is a data plane thing (a "connection") and also a the control 
   plane representation of the data pane thing (i.e. control plane, signaling
   state). It is helpful to try to maintain a 1:1 mapping between the terms
   in our work.

Cheers,
Adrian

---

From: Khuzema Pithewan <[email-masked]>
Date: Thu, 31 Mar 2011 02:23:41 -0700

Hi,

On point#2. I agree with you that a LSP is control plane equivalent of a dataplane connection. But, not all data plane connection need to be modeled in control plane as lsp. We need to model only those dataplane connection in control plane as lsp (or FA), that matters in path computation, or need to be monitored for faults/restoration in control plane.

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 31 Mar 2011 17:35:41 +0200

Hi Khuzema,

I agree with Adrian. If i correctly understood your proposal, when and ODU0 LSP is requested, the LSRs should allocate the labels for ODU2 besides allocating the labels for ODU0? In such a way the 1:1 mapping is lost.

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

A couple of thoughts that we didn't have time to talk about in the meeting. The chairs may be right that the framework document can help us understand which scenarios we need to address.

2. What is an LSP?

Cheers,
Adrian

---

From: Sidd Aanand <[email-masked]>
Date: Thu, 31 Mar 2011 11:38:31 -0400

Daniele,

Can you please explain why would we allocate labels for ODU2 when an ODU-0 LSP is requested?

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Thu, 31 Mar 2011 23:44:08 +0800

Hi Sidd,

This question should ask Khuzema, why there are multi labels for ODU0 connection request?

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 31 Mar 2011 17:49:32 +0200

It was an example of multi-stage label application.

>Multi-stage label is useful when switching of a ODU layer requires terminating more than one HO-ODU/OTU.
>It eliminates the need of FA creation by carrying 2 timeslot information of 2 layers in one label.

Please correct if my understanding is not correct.

Thanks,
Daniele 

-----Original Message-----
From: Sidd Aanand [mailto:[email-masked]] 
Sent: giovedì 31 marzo 2011 17.39
To: Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Fri, 01 Apr 2011 00:00:51 +0800

Hi Sidd,

This question should go to Khuzema, why there are multi labels for ODU0 connection request?

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Khuzema Pithewan <[email-masked]>
Date: Thu, 31 Mar 2011 09:09:01 -0700

Hi,

If I correctly understand Daniel's example, ODU2 is not a LSP in control plane, it is just a local ODU2 endpoint in data plane. So the ODU0 lsp sets up ODU2<-ODU0 layer because it is mandated by restrictive multiplexing hierarchy on interface.

This is in context of draft draft-khuzema-ccamp-gmpls-signaling-g709-01. The ppt is located @ http://www.ietf.org/proceedings/80/slides/ccamp-24.pptx

Please refer to examples in draft and ppt for better understanding.

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Fri, 01 Apr 2011 00:31:22 +0800

Hi Khuzema,

Actually, you don't answer Daniele's question. We know that you don't assume this ODU2 is a LSP. 

Daniele asked you: for example, in your slide 9, for the ODU1 connection request, why you need to allocate the TSs for ODU2->ODU3 besides allocating the TSs for ODU1? In this way, 1:1 mapping is lost. 

You should just follow the GMPLS principle to answer this question.

In addition, what is your opinion on Adrian's comment 1?

In my presentation, I asked a lot of questions and list a number of the issues about multi-stage labels. These questions and issues should be clarified clearly.

Fatai 

Thanks

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: [email-masked]
Date: Fri, 1 Apr 2011 00:44:38 +0800

Hi Khuzema, 

May I understand the multi-stage label in you draft based on the following 
example.
Assume H2 just has the ODU2 and ODU3 switching capability.
There are some so many services (e.g., several ODU0 and three ODU2) across 
the core network (40G) from different direction. H1 and H3 are the service 
aggregation end points.
There are two choice for e2e ODU0 service. One is to use ODU2 FA between 
H1 and H3. Another is to use ODU3 FA between H1 and H3.
Service provider may prefer ODU3 FA (i.e.,  a big pipe for service 
aggregation) for some specific consideration, for example, less ODU2 
services within core network is to make service management, OAM and 
prorection easy.

So what type of FA may depend on the network planning. Control Plane 
should not restrict this application where we must create ODU2.
After the creation ODU3 tunnel between H1 and H3 and the signalling 
message of e2e ODU0 arrive at H1, it must must carry some information 
about which ODU2 is in ODU3 then which ODU0 is in ODU2. That is why your 
draft propose a multi-stage label.

Xihua Fu

Khuzema Pithewan <[email-masked]> 
发件人:  [email-masked]
2011-04-01 上午 12:09

收件人
Fatai Zhang <[email-masked]>, Sidd Aanand 
<[email-masked]>, Daniele Ceccarelli 
<[email-masked]>, "[email-masked]" 
<[email-masked]>, 'CCAMP' <[email-masked]>
抄送

主题
Re: [CCAMP] Discussion of multi-stage solutions

Hi,

If I correctly understand Daniel's example, ODU2 is not a LSP in control 
plane, it is just a local ODU2 endpoint in data plane. So the ODU0 lsp 
sets up ODU2<-ODU0 layer because it is mandated by restrictive 
multiplexing hierarchy on interface.

This is in context of draft draft-khuzema-ccamp-gmpls-signaling-g709-01. 
The ppt is located @ 
http://www.ietf.org/proceedings/80/slides/ccamp-24.pptx

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; 
[email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

This question should ask Khuzema, why there are multi labels for ODU0 
connection request?

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema 
Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" 
<[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Can you please explain why would we allocate labels for ODU2 when an ODU-0 
LSP is requested?

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

I agree with Adrian. If i correctly understood your proposal, when and 
ODU0 LSP is requested, the LSRs should allocate the labels for ODU2 
besides allocating the labels for ODU0? In such a way the 1:1 mapping is 
lost.

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

On point#2. I agree with you that a LSP is control plane equivalent of a 
dataplane connection. But, not all data plane connection need to be 
modeled in control plane as lsp. We need to model only those dataplane 
connection in control plane as lsp (or FA), that matters in path 
computation, or need to be monitored for faults/restoration in control 
plane.

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of 
Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

A couple of thoughts that we didn't have time to talk about in the 
meeting. The chairs may be right that the framework document can help us 
understand which scenarios we need to address.

1. We don't generally optimize for special cases.
   That means we should pick a solution that we can apply across the 
board.
   Separating out a solution that is optimized for a particular case (e.g.
single-
   hop) would only be valuable if the savings are really large.

2. What is an LSP?
   Historically we have ted ourselves in knots by failing to clearly 
understand
   that an LSP is a data plane thing (a "connection") and also a the 
control 
   plane representation of the data pane thing (i.e. control plane, 
signaling
   state). It is helpful to try to maintain a 1:1 mapping between the 
terms
   in our work.

Cheers,
Adrian

---

From: Rajan Rao <[email-masked]>
Date: Thu, 31 Mar 2011 10:00:32 -0700

Fatai,

There is no disagreement on point#1.  The proposal is optimized solution, a scalable solution & an operator friendly solution depending on the deployment scenarios.

With the introduction of IMCDs in routing draft we are admitting that muxing restrictions do exist. This is inevitable in the evolution of OTN. 

If you have muxing restrictions on every hop in your network, you have 2 choice.  (A) have FAs on every segment or in certain parts of the network (B) use the label proposed in the draft.  Option (B) eliminates the need to have FA on every-hop in such scenarios. This is the key point you are missing.

Note that once you have FAs, it restrict the type of service you can carry (pl refer to examples in the draft).

Hope this helps.

Thanks
Rajan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai 

Thanks

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Fri, 01 Apr 2011 01:12:00 +0800

Hi Rajan,

You said you agreed with point #1, so we don't need to optimize for the special cases. 

So the things are very clear, even though you did not answer our other questions directly.

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai 

Thanks

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Khuzema Pithewan <[email-masked]>
Date: Thu, 31 Mar 2011 10:13:40 -0700

Xihua,

Thanks for example. This clearly demonstrates that the applicability of multi-stage label is not just limited to point-to-point physical links but rather in general applicable to any TE Link (may be FA). The stages in multi-stage label is decided based on service needs. In this case over ODU3 FA, there is a need to have ODU0 and ODU2 LSPs. ODU2 LSP is single stage and ODU0 requires 2-stage.

Thanks
Khuzema

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, March 31, 2011 6:45 PM
To: Khuzema Pithewan
Cc: [email-masked]; 'CCAMP'; [email-masked]; Daniele Ceccarelli; Sidd Aanand; Fatai Zhang
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

May I understand the multi-stage label in you draft based on the following example.
Assume H2 just has the ODU2 and ODU3 switching capability.
There are some so many services (e.g., several ODU0 and three ODU2) across the core network (40G) from different direction. H1 and H3 are the service aggregation end points.
There are two choice for e2e ODU0 service. One is to use ODU2 FA between H1 and H3. Another is to use ODU3 FA between H1 and H3.
Service provider may prefer ODU3 FA (i.e.,  a big pipe for service aggregation) for some specific consideration, for example, less ODU2 services within core network is to make service management, OAM and prorection easy.

So what type of FA may depend on the network planning. Control Plane should not restrict this application where we must create ODU2.
After the creation ODU3 tunnel between H1 and H3 and the signalling message of e2e ODU0 arrive at H1, it must must carry some information about which ODU2 is in ODU3 then which ODU0 is in ODU2. That is why your draft propose a multi-stage label.

Xihua Fu

2011-04-01 上午 12:09

收件人

Fatai Zhang <[email-masked]>, Sidd Aanand <[email-masked]>, Daniele Ceccarelli <[email-masked]>, "[email-masked]" <[email-masked]>, 'CCAMP' <[email-masked]>

抄送

主题

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message -----
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Rajan Rao <[email-masked]>
Date: Thu, 31 Mar 2011 10:40:23 -0700

Fatai,

If you have fewer such restricted links, yes it is an optimization.  The point you are missing is when you have 100s of such links in the network you gain scaling and ease of operation benefits.  This is our main point.

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai 

Thanks

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Fri, 01 Apr 2011 01:52:34 +0800

Hi Rajan,

I think we should focus on the questions to discuss something. It does not make sense to say something by flying in the air. I think all the people are waiting for the scenarios from the practical deployments.

Please answer Daniele's question first.

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai 

Thanks

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Rajan Rao <[email-masked]>
Date: Thu, 31 Mar 2011 14:43:38 -0700

Fatai,

Can you be more specific please? Which one of the following are you referring:

- multi-stage muxing is not a reality?
- restricted hierarchy is not a reality?
- network consisting of the above is not a reality?

Every scenario we discussed in the past 4 months for routing-draft-merge was related to the above cases. 

You raise a good point on the practical deployment. This is the feedback we are looking for from the WG. If you have data available please share. May be we don't need IMCDs to begin with.  This will definitely simplify both routing and signaling extensions.

Thanks
Rajan  

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai 

Thanks

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Fri, 01 Apr 2011 13:19:05 +0800

Rajan,

Obviously, the answer to all your questions is "YES", because this is the part of the premise for muxing hierarchy and this is why we are talking about FA and non-FA(multi-stage labels). The only disagreement between us is whether non-FA(multi-stage labels) is applicable or not.

I have repeated Daniele's question, and I would like to repeat once more as follows:

=====================================================================================================================
For the example in your slide 9 (Is this specific enough?), for the ODU1 connection request, why GMPLS should allocate the TSs for ODU2->ODU3 besides allocating the TSs for ODU1? In this way, 1:1 mapping is lost. 

Could you give the WG an example to show that when signal type X in Traffic Parameters is requested, GMPLS will allocate the labels for signal type Y additionally?

====================================================================================================================

P.S., I will be on the plane to wait for your answers and keep silent for a few days because of my vacations.

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 5:43 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan  

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:53 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 1:40 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Thanks
Rajan

-----Original Message-----
From: Fatai Zhang [mailto:[email-masked]] 
Sent: Thursday, March 31, 2011 7:12 PM
To: Rajan Rao; Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Cc: Rajan Rao
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Rajan,

Fatai

Thanks

----- Original Message ----- 
From: "Rajan Rao" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Cc: "Rajan Rao" <[email-masked]>
Sent: Friday, April 01, 2011 1:00 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Fatai,

Hope this helps.

Thanks
Rajan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 6:31 PM
To: Khuzema Pithewan; Sidd Aanand; Daniele Ceccarelli; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

Fatai 

Thanks

----- Original Message ----- 
From: "Khuzema Pithewan" <[email-masked]>
To: "Fatai Zhang" <[email-masked]>; "Sidd Aanand" <[email-masked]>; "Daniele Ceccarelli" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Friday, April 01, 2011 12:09 AM
Subject: RE: [CCAMP] Discussion of multi-stage solutions

Hi,

Thanks
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatai Zhang
Sent: Thursday, March 31, 2011 5:44 PM
To: Sidd Aanand; Daniele Ceccarelli; Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Sidd,

Fatai

Thanks

----- Original Message ----- 
From: "Sidd Aanand" <[email-masked]>
To: "Daniele Ceccarelli" <[email-masked]>; "Khuzema Pithewan" <[email-masked]>; <[email-masked]>; "'CCAMP'" <[email-masked]>
Sent: Thursday, March 31, 2011 11:38 PM
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Daniele,

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 31, 2011 9:06 PM
To: Khuzema Pithewan; [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi Khuzema,

My 2c

BR
Daniele

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Khuzema Pithewan
Sent: giovedì 31 marzo 2011 11.24
To: [email-masked]; 'CCAMP'
Subject: Re: [CCAMP] Discussion of multi-stage solutions

Hi,

Best Regards
Khuzema

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, March 31, 2011 11:10 AM
To: 'CCAMP'
Subject: [CCAMP] Discussion of multi-stage solutions

Hi,

2. What is an LSP?

Cheers,
Adrian