Subject: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

From: Oscar González de Dios <[email-masked]>
Date: Mon, 17 Mar 2014 16:38:49 +0000

Dear CCAMP Colleagues,

We have prepared a first draft of the text for the liaison ITU-T - IETF CCAMP regarding clarifications in Flexi–Grid. Thanks for the contributions sent to us by email.

We would gladly appreciate your feedback in the liaison text. Please find attached the proposed text with comments from a review by Deborah. Also, for those of you allergic to non-standard file formats, please find bellow the plain text:

* Please comment on future changes regarding the values of nominal central frequency (NCF) granularity or channel spacing (CS) [currently 6.25 GHz] and slot width granularity [currently 12.5 GHz], as defined in G.694.1. Is ITU-T considering alternative values in the foreseeable future? If yes, is it correct to assume, that the always following holds, w.r.t. slot width granularity and CS? SWG = 2 * CS [Note: changes in these values may impact the need for code-points]

* Clarification on the maximum values of the slot width (m parameter) and expected use cases (e.g. to cover the whole C band). Knowing these values is required since it has an impact on its encoding.

* Clarification on the need for “hitless” and “hitless” capabilities. Is ITU-T considering any hitless procedure, such as resizing / restoration of a network media channel (in terms of its frequency slot)?
* Examples of cases where hitless capabilities may be considered are:
- Case 1: Recovery where the new network media channel uses a diverse path
- Case 2: shrink / enlarge frequency slot width, invariant NCF (n)
- Case 3: shift the NCF (n), maintaining the frequency slot width (m)

* Clarification regarding the discussed use case where an optical tributary signal is to be supported by multiple network media channels, as in “An OTUCn is carried in its entirety over one optical channel layer connection, which is considered to be supported by multiple network media channels”, where a (co-routed) group of network media channels which must be managed as a single entity – set up, restored, and cross-connected. If this is on scope, what is the estimated availability of ITU-T Recommendation (amendments?) covering this new requirement?
[Note: CCAMP has considered so far the following requirement: “The control plane architecture SHOULD allow multiple media channels to be logically associated.  The control plane SHOULD allow the co-routing of a set of media channels logically associated”.]

* G.872 defines that a media channel may carry more than one OCh-P signal. It also defines that a network media channel is a specific use of media channel with a single OCh-P.  Clarification is needed on the definition and application of network media channel and its support of multiple OCh-Ps

Looking forward to receiving your feedback,

Oscar and Ramon

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 17 Mar 2014 18:20:44 +0100

Hola Oscar and Ramon.

Thank you for preparing this liaison.

> We have prepared a first draft of the text for the liaison ITU-T - IETF
> CCAMP regarding clarifications in Flexi–Grid. Thanks for the
> contributions sent to us by email.
>
> We would gladly appreciate your feedback in the liaison text. Please
> find attached the proposed text with comments from a review by Deborah.
> Also, for those of you allergic to non-standard file formats, please
> find bellow the plain text:

I have some comments/remarks added in the attached file because
it was almost impossible to insert in the plain text.

Hasta pronto, Huub.

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样

---

From: [email-masked]
Date: Tue, 18 Mar 2014 09:47:39 +0800

Hi All,

I have a few minor changes to draft text. 
The relationship between optical tributary signal from Q6 and network 
media channel from Q12 is 1 to 1.
ITU-T hasn't reach aggreement to use terminology OCh-P which is supported 
by multiple medial channels. I suggest we don't need to  mention this.
We should only mention when this requirement will be documented in ITU-T 
Recommendation. This requirement may be described as "An OTUCn is 
supported by multiple network media channels. These NMCs must be 
co-routed. They must be recoveried and cross-connected  at the same time."

Xihua

Huub van Helvoort <[email-masked]> 
发件人:  "CCAMP" <[email-masked]>
2014-03-18 上午 01:20
请答复 给
[email-masked]

收件人
Oscar González de Dios <[email-masked]>, CCAMP <[email-masked]>
抄送

主题
Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Hola Oscar and Ramon.

Hasta pronto, Huub.

-- 
*****************************************************************
               请记住，你是独一无二的，就像其他每一个人一样
[附件 "db_liaison_rev_5_hvh.docx" 被 付锡华117829/user/zte_ltd 删除
]_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Iftekhar Hussain <[email-masked]>
Date: Tue, 18 Mar 2014 04:46:10 +0000

Hi,

Regarding OCh-P, thee text is referring to the “in force” ITU doc namely,  G.872, and requesting clarification from the ITU experts. What do you mean it is not defined by ITU?

Thanks,
Iftekhar
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, March 17, 2014 6:48 PM
To: [email-masked]
Cc: CCAMP; CCAMP
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Hi All,

I have a few minor changes to draft text.
The relationship between optical tributary signal from Q6 and network media channel from Q12 is 1 to 1.
ITU-T hasn't reach aggreement to use terminology OCh-P which is supported by multiple medial channels. I suggest we don't need to  mention this.
We should only mention when this requirement will be documented in ITU-T Recommendation. This requirement may be described as "An OTUCn is supported by multiple network media channels. These NMCs must be co-routed. They must be recoveried and cross-connected  at the same time."

Xihua

Huub van Helvoort <[email-masked]<mailto:[email-masked]>>
发件人:  "CCAMP" <[email-masked]<mailto:[email-masked]>>

2014-03-18 上午 01:20
请答复 给
[email-masked]<mailto:[email-masked]>

收件人

Oscar González de Dios <[email-masked]<mailto:[email-masked]>>, CCAMP <[email-masked]<mailto:[email-masked]>>

抄送

主题

Hola Oscar and Ramon.

Hasta pronto, Huub.

--
*****************************************************************
              请记住，你是独一无二的，就像其他每一个人一样
[附件 "db_liaison_rev_5_hvh.docx" 被 付锡华117829/user/zte_ltd 删除]_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp

---

From: [email-masked]
Date: Tue, 18 Mar 2014 14:31:08 +0800

Hi Iftekhar,

If you refer to current "in force" G.709 or G.872, you can't get any 
describtion on an OCh-P is supported by multiple network media channels. 
This is what I mean.

Xihua

Iftekhar Hussain <[email-masked]> 
2014-03-18 下午 12:46

收件人
"[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>
抄送
CCAMP <[email-masked]>, CCAMP <[email-masked]>
主题
RE: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Hi,
 
Regarding OCh-P, thee text is referring to the “in force” ITU doc 
namely,  G.872, and requesting clarification from the ITU experts. What do 
you mean it is not defined by ITU?
 
Thanks,
Iftekhar
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, March 17, 2014 6:48 PM
To: [email-masked]
Cc: CCAMP; CCAMP
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding 
Flexi-grid

Hi All, 

Xihua 

请答复 给
[email-masked]

收件人

主题

Hola Oscar and Ramon.

Hasta pronto, Huub.

---

From: Jonas Mårtensson <[email-masked]>
Date: Tue, 18 Mar 2014 08:59:44 +0000

Hi Oscar and Ramon,

A minor comment on the first point of the proposed liaison: I don't think G.694.1 talks about channel spacing in the context of flexible grid, only "nominal central frequency granularity" and "slot width granularity". Therefore I propose to change the text as follows:

NEW:

* Please comment on future changes regarding the values of nominal central frequency granularity [currently 6.25 GHz] and slot width granularity [currently 12.5 GHz], as defined in G.694.1. Is ITU-T considering alternative values in the foreseeable future? If yes, is it correct to assume, that the following always holds, w.r.t. slot width granularity (SWG) and nominal central frequency granularity (NCFG)? SWG = 2 * NCFG [Note: changes in these values may impact the need for code-points]

/Jonas

From: CCAMP [mailto:[email-masked]] On Behalf Of Oscar González de Dios
Sent: den 17 mars 2014 17:39
To: CCAMP
Subject: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Dear CCAMP Colleagues,

We have prepared a first draft of the text for the liaison ITU-T - IETF CCAMP regarding clarifications in Flexi-Grid. Thanks for the contributions sent to us by email.

* Clarification on the need for "hitless" and "hitless" capabilities. Is ITU-T considering any hitless procedure, such as resizing / restoration of a network media channel (in terms of its frequency slot)?

* Clarification regarding the discussed use case where an optical tributary signal is to be supported by multiple network media channels, as in "An OTUCn is carried in its entirety over one optical channel layer connection, which is considered to be supported by multiple network media channels", where a (co-routed) group of network media channels which must be managed as a single entity - set up, restored, and cross-connected. If this is on scope, what is the estimated availability of ITU-T Recommendation (amendments?) covering this new requirement? 
[Note: CCAMP has considered so far the following requirement: "The control plane architecture SHOULD allow multiple media channels to be logically associated.  The control plane SHOULD allow the co-routing of a set of media channels logically associated".]

Oscar and Ramon

________________________________________

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Tue, 18 Mar 2014 09:49:34 +0000

Hi, Xihua, Iftekhar,

  There is apparently misunderstanding between you two.  Iftekhar is talking about the last point in the draft liaison is already supported by “in force” G.872 ( which is described in Section 8.4.2 of this Rec.). On the other hand, Xihua is thinking about the second to the last point, where no reference to OCh-P at all.  So we do not have an issue here, I suppose.

  To Oscar,

     I looked at the latest version and only one comment.  What definitions are we expecting from ITU in the last point, i.e., “Clarification is needed on the definition and application of network media channel and its support of multiple OCh-Ps”?   Having Deborah’s question in mind, maybe we can re-phrase as: “what are the expected applications of media channel and its support of multiple OCh-Ps”?

Regards,
Xian

From: CCAMP [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 2014年3月18日 14:31
To: Iftekhar Hussain
Cc: CCAMP; CCAMP; [email-masked]
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Hi Iftekhar,

If you refer to current "in force" G.709 or G.872, you can't get any describtion on an OCh-P is supported by multiple network media channels. This is what I mean.

Xihua

2014-03-18 下午 12:46

收件人

"[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>

抄送

主题

Hi,

Thanks,
Iftekhar

Hi All,

Xihua

2014-03-18 上午 01:20

请答复 给

收件人

抄送

主题

Hola Oscar and Ramon.

Hasta pronto, Huub.

---

From: Ramon Casellas <[email-masked]>
Date: Tue, 18 Mar 2014 11:18:20 +0100

> it was almost impossible to insert in the plain text. 
We are preapring a new version (v6) trying (hard!) to accomodate all 
comments. It will be circulated today asap.
R.

---

From: Ramon Casellas <[email-masked]>
Date: Tue, 18 Mar 2014 11:42:28 +0100

Dear all,

Thanks for your comments. Below a revised text, still open for discussion.

Personally, I am afraid i still don't fully grasp the last bullet, so 
please elaborate a bit more or re-formulate (Iftekhar, Rajan?)

[Editor: In my limited understanding:
- A NMC as bound to 1 OCh-P by definition of the in-force G.872.
- a Media channel may carry more than 1 OCh-P, but MC != NMC
- With a Optical Tributary Signal (OTS) there is a 1:1 mapping between 
OTS:NMC.
- A particular case of OTS is an OCh-P
For my understanding, can a OTS group multiple OCh-P?]

Thanks
R.

--------------------------------------------------------

In order to progress our work on the draft "Framework and Requirements 
for GMPLS based control of Flexi-grid DWDM networks" [1] and subsequent 
solution documents within the IETF CCAMP working group, we would like to 
receive your comments/clarification as follows (addressing ITU-T experts 
within Q6, Q12 and Q14):

.    Please comment on future changes regarding the values of nominal 
central frequency (NCF) granularity [NCFG, currently 6.25 GHz] and slot 
width granularity [currently 12.5 GHz], as defined in G.694.1. Is ITU-T 
considering alternative values (e.g. 3.125 GHz) in the foreseeable 
future? If yes, is it correct to assume, that the following always 
holds, w.r.t. slot width granularity and NCF granularity?
SWG = 2 * NCFG [Note: changes in these values may require additional 
code-points within encodings at control plane protocols]

.    Clarification on the maximum values of the slot width (m parameter) 
and the expected use cases (e.g. to cover the whole C band).
Knowing these values is required since it has an impact on their encoding.

.    Opinion / Clarification on the data plane "hitless" and "hitless" 
capabilities. Is ITU-T considering any hitless procedure, such as 
resizing / restoration of a network media channel (in terms of its 
frequency slot)? Examples of cases where hitless capabilities may be 
considered are:
o    Case 1: Recovery where the new network media channel uses a diverse 
path
o    Case 2: shrink / enlarge frequency slot width, invariant NCF (n)
o    Case 3: shift the NCF (n), maintaining the frequency slot width (m)

.    Clarification on the case where an OTUCn is carried by a 
(co-routed) group of network media channels which must be managed as a 
single entity (including set up, recovery, and hardware 
cross-connection). If this is in scope, what is the estimated 
availability of ITU-T Recommendation covering this new requirement?
[Note: CCAMP has considered so far the following requirement: "The 
control plane architecture SHOULD allow multiple media channels to be 
logically associated.  The control plane SHOULD allow the co-routing of 
a set of media channels logically associated". If ITU-T covers this new 
requirement, it may have an impact on the control plane representation 
and related procedures]

.    Current in-force G.872 recommendation defines that a media channel 
may carry more than one OCh-P signal. It also defines that a network 
media channel is a specific use of media channel with a single OCh-P.  
May a network media channel be defined as associated with more than one 
OCh-P?

[1] http://tools.ietf.org/html/draft-ietf-ccamp-flexi-grid-fwk-01

---

From: Fatai Zhang <[email-masked]>
Date: Tue, 18 Mar 2014 11:45:49 +0000

Hi Ramon,
You mentioned NCFG and SWG before the question, but you did not specify alternative values for what (e.g, NCFG or SWG or both).
I assume that you meant "Is ITU-T considering alternative values (e.g. 3.125 GHz) of NCFG in the foreseeable future?".
=====================================================================================
Is ITU-T considering alternative values (e.g. 3.125 GHz) in the foreseeable future?

Best Regards

Fatai

From: CCAMP [mailto:[email-masked]] On Behalf Of Ramon Casellas
Sent: Tuesday, March 18, 2014 6:42 PM
To: [email-masked]
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Dear all,

Personally, I am afraid i still don't fully grasp the last bullet, so please elaborate a bit more or re-formulate (Iftekhar, Rajan?)

- With a Optical Tributary Signal (OTS) there is a 1:1 mapping between OTS:NMC.

Thanks
R.

In order to progress our work on the draft "Framework and Requirements for GMPLS based control of Flexi-grid DWDM networks" [1] and subsequent solution documents within the IETF CCAMP working group, we would like to receive your comments/clarification as follows (addressing ITU-T experts within Q6, Q12 and Q14):

*    Please comment on future changes regarding the values of nominal central frequency (NCF) granularity [NCFG, currently 6.25 GHz] and slot width granularity [currently 12.5 GHz], as defined in G.694.1. Is ITU-T considering alternative values (e.g. 3.125 GHz) in the foreseeable future? If yes, is it correct to assume, that the following always holds, w.r.t. slot width granularity and NCF granularity?
SWG = 2 * NCFG [Note: changes in these values may require additional code-points within encodings at control plane protocols]

*    Clarification on the maximum values of the slot width (m parameter) and the expected use cases (e.g. to cover the whole C band).
Knowing these values is required since it has an impact on their encoding.

*    Opinion / Clarification on the data plane "hitless" and "hitless" capabilities. Is ITU-T considering any hitless procedure, such as resizing / restoration of a network media channel (in terms of its frequency slot)? Examples of cases where hitless capabilities may be considered are:
o    Case 1: Recovery where the new network media channel uses a diverse path
o    Case 2: shrink / enlarge frequency slot width, invariant NCF (n)
o    Case 3: shift the NCF (n), maintaining the frequency slot width (m)

*    Clarification on the case where an OTUCn is carried by a (co-routed) group of network media channels which must be managed as a single entity (including set up, recovery, and hardware cross-connection). If this is in scope, what is the estimated availability of ITU-T Recommendation covering this new requirement?
[Note: CCAMP has considered so far the following requirement: "The control plane architecture SHOULD allow multiple media channels to be logically associated.  The control plane SHOULD allow the co-routing of a set of media channels logically associated". If ITU-T covers this new requirement, it may have an impact on the control plane representation and related procedures]

*    Current in-force G.872 recommendation defines that a media channel may carry more than one OCh-P signal. It also defines that a network media channel is a specific use of media channel with a single OCh-P.  May a network media channel be defined as associated with more than one OCh-P?

---

From: Iftekhar Hussain <[email-masked]>
Date: Tue, 18 Mar 2014 20:21:42 +0000

Hi Xihua,

The G.872 does talk about media channel supporting multiple OCH-Ps.

Thanks,
Iftekhar
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, March 17, 2014 11:31 PM
To: Iftekhar Hussain
Cc: CCAMP; CCAMP; [email-masked]
Subject: RE: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Hi Iftekhar,

Xihua

Iftekhar Hussain <[email-masked]<mailto:[email-masked]>>

2014-03-18 下午 12:46

收件人

"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

抄送

CCAMP <[email-masked]<mailto:[email-masked]>>, CCAMP <[email-masked]<mailto:[email-masked]>>

主题

Hi,

Thanks,
Iftekhar
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
Sent: Monday, March 17, 2014 6:48 PM
To: [email-masked]<mailto:[email-masked]>
Cc: CCAMP; CCAMP
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Hi All,

Xihua

2014-03-18 上午 01:20

请答复 给

收件人

抄送

主题

Hola Oscar and Ramon.

Hasta pronto, Huub.

---

From: Iftekhar Hussain <[email-masked]>
Date: Tue, 18 Mar 2014 21:52:19 +0000

Hi Ramon,
"- A NMC as bound to 1 OCh-P by definition of the in-force G.872.
- a Media channel may carry more than 1 OCh-P, but MC != NMC"

The above looks fine and we have the same understanding. What needs clarification is that (a) is NMC required? If so why?  Note that MC already is a superset of NMC. The bullet didn't have whole text we prefer the following full text in the liaison for clarity:
"G.872 defines that a media channel may carry more than one OCh-P signal. It also defines that a network media channel is a specific use of media channel with a single OCh-P.  Clarification is needed on the definition and application of network media channel. If intent is that there is always an end-to-end network media channel, then it should support multiple OCh-Ps. Alternatively, eliminate the network media channel definition altogether, in favor of always using the media channel term which already supports this capability. Requiring a one-to-one mapping between OCh-P and network media channels would be restrictive in cases where multiple OCh-P need to go between the same destinations. The most spectrally efficient packing of them may not allow each OCh-P to use its own network media channel within the defined flexible grid granularity"
Please let us know if any further clarification is required.
Thanks,
Iftekhar
From: Ramon Casellas [mailto:[email-masked]]
Sent: Tuesday, March 18, 2014 3:42 AM
To: [email-masked]
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Dear all,

Thanks
R.

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Wed, 19 Mar 2014 02:30:55 +0000

Hi,  Ramon, Iftekhar
   I am not sure either why we ask that question in the last point (i.e., May a network media channel be defined as associated with more than one OCh-P?)  and we can expect a “No” answer from current G.872 specification. But I am also concerned about directly using the text provided by Iftekhar since it implies “we are disagreeing with current G.872 and would suggest a change to this Rec.”. There is nothing with the text itself but this would not be appropriate in a liaison.   How about condensing it to the following?
“G.872 defines that a media channel may carry more than one OCh-P signal. It also defines that a network media channel is a specific use of media channel with a single OCh-P.  Clarification is needed on the application of network media channel.”
Regards,
Xian
From: CCAMP [mailto:[email-masked]] On Behalf Of Iftekhar Hussain
Sent: 2014年3月19日 5:52
To: Ramon Casellas; [email-masked]
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Hi Ramon,
“- A NMC as bound to 1 OCh-P by definition of the in-force G.872.
- a Media channel may carry more than 1 OCh-P, but MC != NMC”

The above looks fine and we have the same understanding. What needs clarification is that (a) is NMC required? If so why?  Note that MC already is a superset of NMC. The bullet didn’t have whole text we prefer the following full text in the liaison for clarity:
“G.872 defines that a media channel may carry more than one OCh-P signal. It also defines that a network media channel is a specific use of media channel with a single OCh-P.  Clarification is needed on the definition and application of network media channel. If intent is that there is always an end-to-end network media channel, then it should support multiple OCh-Ps. Alternatively, eliminate the network media channel definition altogether, in favor of always using the media channel term which already supports this capability. Requiring a one-to-one mapping between OCh-P and network media channels would be restrictive in cases where multiple OCh-P need to go between the same destinations. The most spectrally efficient packing of them may not allow each OCh-P to use its own network media channel within the defined flexible grid granularity”
Please let us know if any further clarification is required.
Thanks,
Iftekhar
From: Ramon Casellas [mailto:[email-masked]]
Sent: Tuesday, March 18, 2014 3:42 AM
To: [email-masked]
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Dear all,

Thanks
R.

In order to progress our work on the draft “Framework and Requirements for GMPLS based control of Flexi-grid DWDM networks” [1] and subsequent solution documents within the IETF CCAMP working group, we would like to receive your comments/clarification as follows (addressing ITU-T experts within Q6, Q12 and Q14):

*    Opinion / Clarification on the data plane “hitless” and “hitless” capabilities. Is ITU-T considering any hitless procedure, such as resizing / restoration of a network media channel (in terms of its frequency slot)? Examples of cases where hitless capabilities may be considered are:
o    Case 1: Recovery where the new network media channel uses a diverse path
o    Case 2: shrink / enlarge frequency slot width, invariant NCF (n)
o    Case 3: shift the NCF (n), maintaining the frequency slot width (m)

*    Clarification on the case where an OTUCn is carried by a (co-routed) group of network media channels which must be managed as a single entity (including set up, recovery, and hardware cross-connection). If this is in scope, what is the estimated availability of ITU-T Recommendation covering this new requirement?
[Note: CCAMP has considered so far the following requirement: “The control plane architecture SHOULD allow multiple media channels to be logically associated.  The control plane SHOULD allow the co-routing of a set of media channels logically associated”. If ITU-T covers this new requirement, it may have an impact on the control plane representation and related procedures]

---

From: Ramon Casellas <[email-masked]>
Date: Wed, 19 Mar 2014 07:50:01 +0100

El 18/03/2014 22:52, Iftekhar Hussain escribió:
> The above looks fine and we have the same understanding. What needs 
> clarification is that (a) is NMC required? If so why?  Note that MC 
> already is a superset of NMC. The bullet didn't have whole text we 
> prefer the following full text in the liaison for clarity:
>
> "G.872 defines that a media channel may carry more than one OCh-P 
> signal. It also defines that a network media channel is a specific use 
> of media channel with a single OCh-P. Clarification is needed on the 
> definition and application of network media channel. If intent is that 
> there is always an end-to-end network media channel, then it should 
> support multiple OCh-Ps. Alternatively, eliminate the network media 
> channel definition altogether, in favor of always using the media 
> channel term which already supports this capability. Requiring a 
> one-to-one mapping between OCh-P and network media channels would be 
> restrictive in cases where multiple OCh-P need to go between the same 
> destinations. The most spectrally efficient packing of them may not 
> allow each OCh-P to use its own network media channel within the 
> defined flexible grid granularity"
>
>

Iftekhar, all

Following several comments received, your text was edited in past 
versions of the liaison draft. I would be ok to leave the text as is in 
the liaison if the working group agrees or does not object. However, I 
still wonder what kind of clarification/question do we need from the 
ITU-T (in such text), related the control plane protocol requirements 
and extensions.

Like Xian, I am also slightly afraid that the last bullet may be 
basically challenging the definition of the network media channel, 
something that is, IMHO, ITU-T business. Im am also reluctant to use a 
wording that seems to be issuing direct recommendations to ITU-T whether 
this or that term is required or whether this or that entity should 
support this or that capability or whether it would be too restrictive. 
That said, I may be completely wrong, and I am just editing :-)

Thanks
R.

-- 
Ramon Casellas, Ph.D. -- Senior Research Associate -- Networks Division
Optical Networks and Systems Department -- http://networks.cttc.es/ons
CTTC - Centre Tecnològic de Telecomunicacions de Catalunya
Parc Mediterrani de la Tecnologia (PMT) - Edifici B4
Av. Carl Friedrich Gauss, 7 - 08860 Castelldefels (Barcelona) - Spain
Tel.: +34 93 645 29 00 ext 2168-- Fax. +34 93 645 29 01

---

From: Iftekhar Hussain <[email-masked]>
Date: Wed, 19 Mar 2014 17:58:42 +0000

Hi Xian and Ramon,
Personally I don’t see anything wrong in the text asking for a clarification on this ambiguity of a standard. However, if abbreviating the text will get the question across more clearly and get the required clarification, I am okay to use text suggested by Xian with small addition.
“G.872 defines that a media channel may carry more than one OCh-P signal. It also defines that a network media channel is a specific use of media channel with a single OCh-P.  Clarification is needed on the application of network media channel and media channel given that a media channel is a superset and can support the network media channel functionality. ”
Thanks,
Iftekhar
From: Zhangxian (Xian) [mailto:[email-masked]]
Sent: Tuesday, March 18, 2014 7:31 PM
To: Iftekhar Hussain; Ramon Casellas
Cc: [email-masked]
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Hi,  Ramon, Iftekhar

Hi Ramon,

Dear all,

Thanks
R.

•    Please comment on future changes regarding the values of nominal central frequency (NCF) granularity [NCFG, currently 6.25 GHz] and slot width granularity [currently 12.5 GHz], as defined in G.694.1. Is ITU-T considering alternative values (e.g. 3.125 GHz) in the foreseeable future? If yes, is it correct to assume, that the following always holds, w.r.t. slot width granularity and NCF granularity?
SWG = 2 * NCFG [Note: changes in these values may require additional code-points within encodings at control plane protocols]

•    Clarification on the maximum values of the slot width (m parameter) and the expected use cases (e.g. to cover the whole C band).
Knowing these values is required since it has an impact on their encoding.

•    Opinion / Clarification on the data plane “hitless” and “hitless” capabilities. Is ITU-T considering any hitless procedure, such as resizing / restoration of a network media channel (in terms of its frequency slot)? Examples of cases where hitless capabilities may be considered are:
o    Case 1: Recovery where the new network media channel uses a diverse path
o    Case 2: shrink / enlarge frequency slot width, invariant NCF (n)
o    Case 3: shift the NCF (n), maintaining the frequency slot width (m)

•    Clarification on the case where an OTUCn is carried by a (co-routed) group of network media channels which must be managed as a single entity (including set up, recovery, and hardware cross-connection). If this is in scope, what is the estimated availability of ITU-T Recommendation covering this new requirement?
[Note: CCAMP has considered so far the following requirement: “The control plane architecture SHOULD allow multiple media channels to be logically associated.  The control plane SHOULD allow the co-routing of a set of media channels logically associated”. If ITU-T covers this new requirement, it may have an impact on the control plane representation and related procedures]

•    Current in-force G.872 recommendation defines that a media channel may carry more than one OCh-P signal. It also defines that a network media channel is a specific use of media channel with a single OCh-P.  May a network media channel be defined as associated with more than one OCh-P?

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 19 Mar 2014 18:54:51 +0000

Hi,
We need to be careful to ask clarification about management/configuration of the technology, and not appear that we are questioning data plane definitions. Considering G872 says “Note that the apparent containment relationship of the media channels is actually an allocation dependency. No hierarchy is created in either the media channels or the signals carried”, I think we should refrain from saying the media channel is a superset and imply there is no need for the network media channel.

Iftekhar, if you have concerns with these data plane definitions and spectral efficiency, these concerns should be contributed directly to ITU-T.

We need to finish this liaison if we expect to get a response over the next two weeks. I’d suggest on this one to use Xian’s proposal with a slight tweak as the G.872 model is very clear the network media channel supports a single OCh-P network connection.

Propose to say:
“G.872 defines that a media channel may carry more than one OCh-P signal. It also defines that a network media channel is the end-to-end channel allocated to transport a single OCh-P.  We would appreciate clarification on the application of network media channel with respect to media channel with respect to management and configuration aspects.”

Ok?

Thanks,
Deborah

From: CCAMP [mailto:[email-masked]] On Behalf Of Iftekhar Hussain
Sent: Wednesday, March 19, 2014 1:59 PM
To: Zhangxian (Xian); Ramon Casellas
Cc: [email-masked]
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Hi Xian and Ramon,
Cc: [email-masked]<mailto:[email-masked]>

Hi,  Ramon, Iftekhar
To: Ramon Casellas; [email-masked]<mailto:[email-masked]>

Hi Ramon,

To: [email-masked]<mailto:[email-masked]>

Dear all,

Thanks
R.

---

From: Iftekhar Hussain <[email-masked]>
Date: Wed, 19 Mar 2014 21:02:22 +0000

Hi Deborah,
Yes, that would be fine. Fully agree with your suggested text below.
Thanks,
Iftekhar
From: BRUNGARD, DEBORAH A [mailto:[email-masked]]
Sent: Wednesday, March 19, 2014 11:55 AM
To: Iftekhar Hussain; Zhangxian (Xian); Ramon Casellas
Cc: [email-masked]
Subject: RE: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Hi,

Propose to say:

Ok?

Thanks,
Deborah

Hi Xian and Ramon,

Hi,  Ramon, Iftekhar

Hi Ramon,

Dear all,

Thanks
R.

---

From: [email-masked]
Date: Thu, 20 Mar 2014 08:28:30 +0800

Hi, all

By referring to section 12.1 of G.872, I found some texts that I post them 
below:

"The black link approach may be used to provide an OCh network connection 
between an OCh
source/sink pair. The OCh network connection is supported by a network 
media channel that is
terminated by an OCh-P source and an OCh-P sink where each of these 
components may be
provided by different vendors but must all be within the domain of a 
single network operator."

So, there may be some special scenario, like black link, that only an OCh 
network connection is carried in a media channel and ITU-T call this kind 
of media channel as "network media channel". This may be one application 
of network media channel.

It's my own understanding. I'm not sure if I have the right understanding, 
we can still send the liaison to get more clarification.

Thanks
Qilei Wang

"BRUNGARD, DEBORAH A" <[email-masked]> 
发件人:  "CCAMP" <[email-masked]>
2014-03-20 02:54

收件人
Iftekhar Hussain <[email-masked]>, "Zhangxian (Xian)" 
<[email-masked]>, Ramon Casellas <[email-masked]>, 
抄送
"[email-masked]" <[email-masked]>
主题
Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding Flexi-grid

Hi,
We need to be careful to ask clarification about management/configuration 
of the technology, and not appear that we are questioning data plane 
definitions. Considering G872 says “Note that the apparent containment 
relationship of the media channels is actually an allocation dependency. 
No hierarchy is created in either the media channels or the signals 
carried”, I think we should refrain from saying the media channel is a 
superset and imply there is no need for the network media channel.
 
Iftekhar, if you have concerns with these data plane definitions and 
spectral efficiency, these concerns should be contributed directly to 
ITU-T.
 
We need to finish this liaison if we expect to get a response over the 
next two weeks. I’d suggest on this one to use Xian’s proposal with a 
slight tweak as the G.872 model is very clear the network media channel 
supports a single OCh-P network connection.
 
Propose to say:
“G.872 defines that a media channel may carry more than one OCh-P signal. 
It also defines that a network media channel is the end-to-end channel 
allocated to transport a single OCh-P.  We would appreciate clarification 
on the application of network media channel with respect to media channel 
with respect to management and configuration aspects.”
 
Ok?
 
Thanks,
Deborah

Hi Xian and Ramon,
Personally I don’t see anything wrong in the text asking for a 
clarification on this ambiguity of a standard. However, if abbreviating 
the text will get the question across more clearly and get the required 
clarification, I am okay to use text suggested by Xian with small 
addition.
“G.872 defines that a media channel may carry more than one OCh-P signal. 
It also defines that a network media channel is a specific use of media 
channel with a single OCh-P.  Clarification is needed on the application 
of network media channel and media channel given that a media channel is a 
superset and can support the network media channel functionality. ”
Thanks,
Iftekhar
From: Zhangxian (Xian) [mailto:[email-masked]] 
Sent: Tuesday, March 18, 2014 7:31 PM
To: Iftekhar Hussain; Ramon Casellas
Cc: [email-masked]
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding 
Flexi-grid
 
Hi,  Ramon, Iftekhar
   I am not sure either why we ask that question in the last point (i.e., 
May a network media channel be defined as associated with more than one 
OCh-P?)  and we can expect a “No” answer from current G.872 
specification. But I am also concerned about directly using the text 
provided by Iftekhar since it implies “we are disagreeing with current 
G.872 and would suggest a change to this Rec.”. There is nothing with the 
text itself but this would not be appropriate in a liaison.   How about 
condensing it to the following? 
“G.872 defines that a media channel may carry more than one OCh-P signal. 
It also defines that a network media channel is a specific use of media 
channel with a single OCh-P.  Clarification is needed on the application 
of network media channel.”
Regards,
Xian
From: CCAMP [mailto:[email-masked]] On Behalf Of Iftekhar Hussain
Sent: 2014年3月19日 5:52
To: Ramon Casellas; [email-masked]
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding 
Flexi-grid
 
Hi Ramon,
 
The above looks fine and we have the same understanding. What needs 
clarification is that (a) is NMC required? If so why?  Note that MC 
already is a superset of NMC. The bullet didn’t have whole text we prefer 
the following full text in the liaison for clarity:
“G.872 defines that a media channel may carry more than one OCh-P signal. 
It also defines that a network media channel is a specific use of media 
channel with a single OCh-P.  Clarification is needed on the definition 
and application of network media channel. If intent is that there is 
always an end-to-end network media channel, then it should support 
multiple OCh-Ps. Alternatively, eliminate the network media channel 
definition altogether, in favor of always using the media channel term 
which already supports this capability. Requiring a one-to-one mapping 
between OCh-P and network media channels would be restrictive in cases 
where multiple OCh-P need to go between the same destinations. The most 
spectrally efficient packing of them may not allow each OCh-P to use its 
own network media channel within the defined flexible grid granularity”
Please let us know if any further clarification is required.
Thanks,
Iftekhar 
From: Ramon Casellas [mailto:[email-masked]] 
Sent: Tuesday, March 18, 2014 3:42 AM
To: [email-masked]
Subject: Re: [CCAMP] Draft Text for ITU-T - CCAMP Liason regarding 
Flexi-grid
 
Dear all,

Thanks
R.

In order to progress our work on the draft “Framework and Requirements 
for GMPLS based control of Flexi-grid DWDM networks” [1] and subsequent 
solution documents within the IETF CCAMP working group, we would like to 
receive your comments/clarification as follows (addressing ITU-T experts 
within Q6, Q12 and Q14):

•    Please comment on future changes regarding the values of nominal 
central frequency (NCF) granularity [NCFG, currently 6.25 GHz] and slot 
width granularity [currently 12.5 GHz], as defined in G.694.1. Is ITU-T 
considering alternative values (e.g. 3.125 GHz) in the foreseeable future? 
If yes, is it correct to assume, that the following always holds, w.r.t. 
slot width granularity and NCF granularity? 
SWG = 2 * NCFG [Note: changes in these values may require additional 
code-points within encodings at control plane protocols]

•    Clarification on the maximum values of the slot width (m parameter) 
and the expected use cases (e.g. to cover the whole C band). 
Knowing these values is required since it has an impact on their encoding. 

•    Opinion / Clarification on the data plane “hitless” and “hitless” 
capabilities. Is ITU-T considering any hitless procedure, such as resizing 
/ restoration of a network media channel (in terms of its frequency slot)? 
Examples of cases where hitless capabilities may be considered are:
o    Case 1: Recovery where the new network media channel uses a diverse 
path 
o    Case 2: shrink / enlarge frequency slot width, invariant NCF (n)
o    Case 3: shift the NCF (n), maintaining the frequency slot width (m) 

•    Clarification on the case where an OTUCn is carried by a (co-routed) 
group of network media channels which must be managed as a single entity 
(including set up, recovery, and hardware cross-connection). If this is in 
scope, what is the estimated availability of ITU-T Recommendation covering 
this new requirement? 
[Note: CCAMP has considered so far the following requirement: “The 
control plane architecture SHOULD allow multiple media channels to be 
logically associated.  The control plane SHOULD allow the co-routing of a 
set of media channels logically associated”. If ITU-T covers this new 
requirement, it may have an impact on the control plane representation and 
related procedures]

•    Current in-force G.872 recommendation defines that a media channel 
may carry more than one OCh-P signal. It also defines that a network media 
channel is a specific use of media channel with a single OCh-P.  May a 
network media channel be defined as associated with more than one OCh-P?

[1] http://tools.ietf.org/html/draft-ietf-ccamp-flexi-grid-fwk-01 
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Ramon Casellas <[email-masked]>
Date: Thu, 20 Mar 2014 08:21:07 +0100

All,

As Deborah mentioned, the text of the liaison should be ready by now. 
Accommodating most (all?) comments by now, I would say the following 
seems to be quite final.

Chairs, could you please proceed? many thanks in advance

Regards,
Ramon

-----8<----8<--------

In order to progress our work on the draft “Framework and Requirements 
for GMPLS based control of Flexi-grid DWDM networks” [1] and subsequent 
solution documents within the IETF CCAMP working group, we would like to 
receive your comments/clarification on the following items (addressing 
ITU-T experts within Q6, Q12 and Q14):

· Please comment on future changes regarding the values of nominal 
central frequency (NCF) granularity [NCFG, currently 6.25 GHz] and slot 
width granularity [currently 12.5 GHz], as defined in G.694.1. Is ITU-T 
considering alternative values (e.g. 3.125 GHz) for NCFG in the 
foreseeable future? If yes, is it correct to assume, that the following 
always holds, w.r.t. slot width granularity and NCF granularity?
SWG = 2 * NCFG [Note: changes in these values may require additional 
code-points within encodings at control plane protocols.]

· Clarification on the maximum values of the slot width (m parameter) 
and the expected use cases (e.g. to cover the whole C band).
[Note: Knowing these values is required since it has an impact on their 
encoding.]

· Opinion / Clarification on the data plane “hitless” and “hitless” 
capabilities. Is ITU-T considering any hitless procedure, such as 
resizing / restoration of a network media channel (in terms of its 
frequency slot)? Examples of cases where hitless capabilities may be 
considered are:

· Clarification on the case where an OTUCn is carried by a (co-routed) 
group of network media channels which must be managed as a single entity 
(including set up, recovery, and hardware cross-connection). If this is 
in scope, what is the estimated availability of ITU-T Recommendation 
covering this new requirement?
[Note: CCAMP has considered so far the following requirement: “The 
control plane architecture SHOULD allow multiple media channels to be 
logically associated.  The control plane SHOULD allow the co-routing of 
a set of media channels logically associated”. If ITU-T covers this new 
requirement, it may have an impact on the control plane representation 
and related procedures.]

· G.872 defines that a media channel may carry more than one OCh-P 
signal. It also defines that a network media channel is the end-to-end 
channel allocated to transport a single OCh-P.  We would appreciate 
clarification on the application of network media channel with respect 
to media channel related to management and configuration aspects.