Subject: Re: [CCAMP] Fwd: I-D Action: draft-malis-ccamp-fast-lsps-00.txt

From: Rajan Rao <[email-masked]>
Date: Fri, 7 Mar 2014 13:16:11 +0000

Andy,

My question during WG session was the following:

What does it mean to have control plane requirements of  N-LSP setups/sec if data plane is not able to carry traffic end to end in the same amount of time?

Thanks
Rajan

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Thursday, January 23, 2014 10:00 PM
To: [email-masked]
Subject: [CCAMP] Fwd: I-D Action: draft-malis-ccamp-fast-lsps-00.txt

This draft is intended to start the process of enhancing GMPLS LSP signaling for wavelengths and sub-wavelengths to carry lots of short-lived flows, orders of magnitude shorter and more frequent than applications like traffic engineering or router interconnection. Of course, there's a lot more detail in the draft, so please read it.
Once there's consensus on the requirements, the authors intend to continue the work on a solution draft or drafts to meet the requirements. Please review the draft and let us know if you have any comments or questions.

Thanks,
Andy

---------- Forwarded message ----------
From:  <[email-masked]>
Date: Thu, Jan 23, 2014 at 4:10 PM
Subject: I-D Action: draft-malis-ccamp-fast-lsps-00.txt
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Requirements for Very Fast Setup of GMPLS LSPs
        Authors         : Andrew G. Malis
                          Ronald A. Skoog
                          Haim Kobrinski
                          George Clapp
                          Vishnu Shukla
        Filename        : draft-malis-ccamp-fast-lsps-00.txt
        Pages           : 7
        Date            : 2014-01-23

Abstract:
   The Defense Advanced Research Projects Agency (DARPA) Core Optical
   Networks (CORONET) program has laid out a vision for the next
   evolution of IP and optical commercial and government networks, with
   a focus on highly dynamic and resilient multi-terabit core networks.
   It anticipates the need for rapid (sub-second) setup and SONET/SDH-
   like restoration times for high-churn (up to tens of requests per
   second network-wide and one second to one minute holding times) on-
   demand wavelength, sub-wavelength and packet services for a variety
   of applications (e.g., grid computing, cloud computing, data
   visualization, fast data transfer, etc.).  This must be done while
   meeting stringent call blocking requirements, and while minimizing
   the use of resources such as time slots, switch ports, wavelength
   conversion and wavelength-km.

   This document discusses the requirements for extensions to
   Generalized Multi-Protocol Label Switching (GMPLS) signaling for
   expediting the control of Label Switched Paths (LSPs), including sub-
   wavelengths (e.g., OTN ODUs) and full wavelengths, in order to
   satisfy application requirements laid out in this program.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-malis-ccamp-fast-lsps/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-malis-ccamp-fast-lsps-00

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 7 Mar 2014 14:00:31 -0000

Hi Rajan,

I think it means that the mechanisms of the control plane should not be the
gating factor.
Control plane implementations and data plane implementations being gates are a
matter between the network operator and the people who implement the equipment
that is deployed (i.e., bought).

A

> From: CCAMP [mailto:[email-masked]] On Behalf Of Rajan Rao
> Sent: 07 March 2014 13:16
> To: Andrew G. Malis; [email-masked]
> Subject: Re: [CCAMP] Fwd: I-D Action: draft-malis-ccamp-fast-lsps-00.txt
> 
> Andy,
> 
> What does it mean to have control plane requirements of  N-LSP setups/sec if
> data plane is not able to carry traffic end to end in the same amount of time?
> 
> Thanks
> Rajan
> 
> This draft is intended to start the process of enhancing GMPLS LSP signaling
for
> wavelengths and sub-wavelengths to carry lots of short-lived flows, orders of
> magnitude shorter and more frequent than applications like traffic engineering
or
> router interconnection. Of course, there's a lot more detail in the draft, so
please
> read it.
> Once there's consensus on the requirements, the authors intend to continue the
> work on a solution draft or drafts to meet the requirements. Please review the
> draft and let us know if you have any comments or questions.
> 
> Thanks,
> Andy
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 7 Mar 2014 14:47:48 +0000

Adrian,

Getting to this and your comment at the mike, the text at the end of
section 1 in the draft goes into some of the protocol-related problems
that have been seen in simulations and prototyping, and we can
certainly expand on that in subsequent revisions. Some things can be
fixed by higher capacity or better implementations, but other things
may need to be addressed from a protocol standpoint. As we progress
this work, the things that fall into each category should become more
clear.

Cheers,
Andy