Subject: [CCAMP] Question on LSP diversity

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 6 Mar 2014 11:35:55 +0000

Hi,

bringing this to the list due to time constraints.

We said we have 4 use cases for LSP diversity:

-          1. Single homing

-          2. Dual homing

-          3. LSPs with different edge and core nodes

-          4. Multi domain

In cases 3 and 4 there is the need for "coordination" between edge nodes. Is such coordination in CCAMP scope or we assume that "somehow" the two edge nodes exchange such piece of info (e.g. NMS, the triangle with the eye, or whatever)?

BR
Daniele

---

From: "Matt Hartley (mhartley)" <[email-masked]>
Date: Thu, 6 Mar 2014 13:50:28 +0000

Daniele,

ISTR Gert asked about this on Tuesday, and the reply was that this is outside the scope of CCAMP and therefore of the work being proposed here.

I'm sure someone will correct me if I'm wrong about that :)

Cheers

Matt

From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 06, 2014 6:36 AM
To: CCAMP ([email-masked])
Subject: [CCAMP] Question on LSP diversity

Hi,

-        1. Single homing

-        2. Dual homing

-        4. Multi domain

BR
Daniele

---

From: "Gabriele Maria Galimberti (ggalimbe)" <[email-masked]>
Date: Thu, 6 Mar 2014 14:00:48 +0000

Hi Daniele,

Also the case 2 in some conditions requires the Core nodes need to co-ordinate each other.
This is unless the edge node has the knowledge of the LSPs ERO

Regards,
Gabriele

[http://www.cisco.com/swa/i/logo.gif]

Gabriele Galimberti
Technical Leader
Cisco Photonics Srl

Via Philips, 12
20900 - Monza (MI)
Italy
www.cisco.com/global/IT/<http://www.cisco.com/global/IT/>

[email-masked]<mailto:[email-masked]>
Phone :+39 039 2091462
Mobile :+39 335 7481947
Fax :+39 039 2092049

From: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 6, 2014 12:35 PM
To: "CCAMP ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>
Subject: [CCAMP] Question on LSP diversity

Hi,

-          1. Single homing

-          2. Dual homing

-          4. Multi domain

In cases 3 and 4 there is the need for “coordination” between edge nodes. Is such coordination in CCAMP scope or we assume that “somehow” the two edge nodes exchange such piece of info (e.g. NMS, the triangle with the eye, or whatever)?

BR
Daniele

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 6 Mar 2014 14:12:53 -0000

We may learn something from the ingress/egress protection work in MPLS and from
the PW protection work in PWE3.
 
My personal view is that we continue to mix the concept of a service request and
an LSP set-up. I think this is hurting us.
 
A
 
From: CCAMP [mailto:[email-masked]] On Behalf Of Gabriele Maria
Galimberti (ggalimbe)
Sent: 06 March 2014 14:01
To: Daniele Ceccarelli; CCAMP ([email-masked])
Subject: Re: [CCAMP] Question on LSP diversity
 
Hi Daniele, 
 
Also the case 2 in some conditions requires the Core nodes need to co-ordinate
each other.
This is unless the edge node has the knowledge of the LSPs ERO
 
Regards,
Gabriele

http://www.cisco.com/swa/i/logo.gif

Gabriele Galimberti
Technical Leader
Cisco Photonics Srl
 
Via Philips, 12
20900 - Monza (MI)
Italy
 <http://www.cisco.com/global/IT/> www.cisco.com/global/IT/
 
[email-masked]
Phone :+39 039 2091462
Mobile :+39 335 7481947
Fax :+39 039 2092049 

 

 
From: Daniele Ceccarelli <[email-masked]>
Date: Thursday, March 6, 2014 12:35 PM
To: "CCAMP ([email-masked])" <[email-masked]>
Subject: [CCAMP] Question on LSP diversity
 
Hi,

 
In cases 3 and 4 there is the need for "coordination" between edge nodes. Is
such coordination in CCAMP scope or we assume that "somehow" the two edge nodes
exchange such piece of info (e.g. NMS, the triangle with the eye, or whatever)?
 
BR
Daniele

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 6 Mar 2014 14:42:51 +0000

Hi Matt,

I don't recall such decision, but I trust you if you say that it was made.
In that case I have to support Gert then :)

Cheers
Danieele

From: Matt Hartley (mhartley) [mailto:[email-masked]]
Sent: giovedì 6 marzo 2014 13:50
To: Daniele Ceccarelli; CCAMP ([email-masked])
Cc: Matt Hartley (mhartley)
Subject: RE: Question on LSP diversity

Daniele,

Cheers

Matt

From: CCAMP [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Thursday, March 06, 2014 6:36 AM
To: CCAMP ([email-masked]<mailto:[email-masked]>)
Subject: [CCAMP] Question on LSP diversity

Hi,

-          1. Single homing

-          2. Dual homing

-          4. Multi domain

BR
Daniele

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 6 Mar 2014 14:43:34 +0000

Sure Gabriele,

I was just limiting the discussion to the coordination between edge nodes, but it applies also to core nodes.

Cheers
Daniele

From: Gabriele Maria Galimberti (ggalimbe) [mailto:[email-masked]]
Sent: giovedì 6 marzo 2014 14:01
To: Daniele Ceccarelli; CCAMP ([email-masked])
Subject: Re: [CCAMP] Question on LSP diversity

Hi Daniele,

Regards,
Gabriele

Gabriele Galimberti
Technical Leader
Cisco Photonics Srl

Via Philips, 12
20900 - Monza (MI)
Italy

Hi,

-          1. Single homing

-          2. Dual homing

-          4. Multi domain

BR
Daniele

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 6 Mar 2014 14:47:12 +0000

Hi Adrian,

Correct. If we all say that RSVP-TE is just for LSP set-up and not for a service request that's fine. The discussion on LSP diversity and half dozen of CCAMP drafts would be closed immediately :)

Daniele

From: Adrian Farrel [mailto:[email-masked]]
Sent: giovedì 6 marzo 2014 14:13
To: 'Gabriele Maria Galimberti (ggalimbe)'; Daniele Ceccarelli; 'CCAMP'
Subject: RE: [CCAMP] Question on LSP diversity

We may learn something from the ingress/egress protection work in MPLS and from the PW protection work in PWE3.

My personal view is that we continue to mix the concept of a service request and an LSP set-up. I think this is hurting us.

A

From: CCAMP [mailto:[email-masked]] On Behalf Of Gabriele Maria Galimberti (ggalimbe)
Sent: 06 March 2014 14:01
To: Daniele Ceccarelli; CCAMP ([email-masked]<mailto:[email-masked]>)
Subject: Re: [CCAMP] Question on LSP diversity

Hi Daniele,

Regards,
Gabriele

Gabriele Galimberti
Technical Leader
Cisco Photonics Srl

Via Philips, 12
20900 - Monza (MI)
Italy

Hi,

-          1. Single homing

-          2. Dual homing

-          4. Multi domain

BR
Daniele

---

From: Lou Berger <[email-masked]>
Date: Thu, 06 Mar 2014 15:02:47 +0000

I believe Matt is referring to a comment that I made in response to a 
question.  The question was something like, if we need a protocol to 
coordinate information (call it a "cookie") between nodes, *must* it be 
specified as part of the solution.  My response was no, "it is out of 
scope of ccamp".  To be more precise, it is not required to be part of 
the solution and may use currently available mechanisms, e.g., something 
from PCE or network management.  "out of scope" is actually too extreme 
as it implies that if some wanted to propose a solution for such 
coordination in ccamp that we would not allow it to be discussed -- 
which is *not* the case.  We'd look at it just like any other 
contribution to the WG.

Lou

On 3/6/2014 2:42 PM, Daniele Ceccarelli wrote:
> Hi Matt,
>
> I don’t recall such decision, but I trust you if you say that it was made.
>
> In that case I have to support Gert then J
>
> Cheers
>
> Danieele
>
> *From:*Matt Hartley (mhartley) [mailto:[email-masked]]
> *Sent:* giovedì 6 marzo 2014 13:50
> *To:* Daniele Ceccarelli; CCAMP ([email-masked])
> *Cc:* Matt Hartley (mhartley)
> *Subject:* RE: Question on LSP diversity
>
> Daniele,
>
> ISTR Gert asked about this on Tuesday, and the reply was that this is
> outside the scope of CCAMP and therefore of the work being proposed here.
>
> I’m sure someone will correct me if I’m wrong about that :)
>
> Cheers
>
> Matt
>
> *From:*CCAMP [mailto:[email-masked]] *On Behalf Of *Daniele
> Ceccarelli
> *Sent:* Thursday, March 06, 2014 6:36 AM
> *To:* CCAMP ([email-masked] <mailto:[email-masked]>)
> *Subject:* [CCAMP] Question on LSP diversity
>
> Hi,
>
> -1. Single homing
> -2. Dual homing
> -3. LSPs with different edge and core nodes
>
> -4. Multi domain
>
> In cases 3 and 4 there is the need for “coordination” between edge
> nodes. Is such coordination in CCAMP scope or we assume that “somehow”
> the two edge nodes exchange such piece of info (e.g. NMS, the triangle
> with the eye, or whatever)?
>
> BR
> Daniele
>
>
>
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>

---

From: Gert Grammel <[email-masked]>
Date: Thu, 6 Mar 2014 15:45:29 +0000

Hi Matt,

I recall asking a different question, namely what kind of separation is represented by the domain boundary and where it is described. I understood that the definition of the boundary is not in the scope of ccamp but the draft(s) should describe which assumptions are made about the nature of the boundary.

About the cases themselves (using the terms "client" "server" in a control plane sense as described in Daniele's presentation) I try to point out some networking scenarios with the aim to spell out the scenarios:

-          1. Single homing --> it should be spelled out what is understood to be single homing

§  Would a client connected with two fibers into the server domain qualify for single homing?

§  Would a client connected with two fibers into the server domain, each attached to different server domain routers still qualify for single homing?

§  How do we account for a client LER which is connected to two client LSRs whereby one connection stays inside the client network and one connection is connected to the server network? The client LER is dual homed  from a client perspective but from a server perspective it appears single homed.

-          2. Dual homing --> it should be spelled out what is understood to be dual homing

§  Would a client connected with two fibers into the server domain, each attached to different server domain routers qualify for dual homing?

§  As we are talking about routers it is safe to assume that some are multi-homed where homing is >2. Unless there is a reason to limit the case to exactly dual homing we should name this 'Multi-homing' instead

§  Is a client which is connected to two distinct server domains considered dual homed or multi-domain?

-          3. LSPs with different edge and core nodes --> the content of this case probably depends a lot how single/multi homing is defined

§  Does this cover cases where one end is dual homed and the other end single homed? Or is this covered above?

§  Does this cover also cases where n clients are connected to m server nodes with n>m?

-          4. Multi domain

§  Does this mean multiple interconnected core domains, or does it refer to a client connected to several server domains?

§  Is it related to a stacked client-server-server case?

During his presentation George pointed out that he is considering "All networks under a single administration" when presenting http://tools.ietf.org/agenda/89/slides/slides-89-ccamp-4.pdf . This seems to suggest that there is also demand to work on single domain cases. Not sure how much merit is in that, but perhaps worth as a reference

Best

Gert

From: CCAMP [mailto:[email-masked]] On Behalf Of Matt Hartley (mhartley)
Sent: 06 March 2014 14:50
To: Daniele Ceccarelli; CCAMP ([email-masked])
Subject: Re: [CCAMP] Question on LSP diversity

Daniele,

Cheers

Matt

Hi,

-          1. Single homing

-          2. Dual homing

-          4. Multi domain

BR
Daniele

---

From: "Matt Hartley (mhartley)" <[email-masked]>
Date: Thu, 6 Mar 2014 15:50:16 +0000

Thanks, Gert. It may just have been someone else who asked the question I was thinking of (and that Lou replied to just now).

Good think I asked, wasn't it? :)

Cheers

Matt

From: Gert Grammel [mailto:[email-masked]]
Sent: Thursday, March 06, 2014 10:45 AM
To: Matt Hartley (mhartley); Daniele Ceccarelli; CCAMP ([email-masked])
Subject: RE: Question on LSP diversity

Hi Matt,

-        4. Multi domain

Best

Gert

From: CCAMP [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Matt Hartley (mhartley)
Sent: 06 March 2014 14:50
To: Daniele Ceccarelli; CCAMP ([email-masked]<mailto:[email-masked]>)
Subject: Re: [CCAMP] Question on LSP diversity

Daniele,

Cheers

Matt

Hi,

-        1. Single homing

-        2. Dual homing

-        4. Multi domain

BR
Daniele

---

From: Gert Grammel <[email-masked]>
Date: Thu, 6 Mar 2014 15:58:16 +0000

Hi Matt,

glad you brought the question up, it created a healthy email exchange.

Gert

From: Matt Hartley (mhartley) [mailto:[email-masked]]
Sent: 06 March 2014 16:50
To: Gert Grammel; Daniele Ceccarelli; CCAMP ([email-masked])
Cc: Matt Hartley (mhartley)
Subject: RE: Question on LSP diversity

Cheers

Matt

From: Gert Grammel [mailto:[email-masked]]
Sent: Thursday, March 06, 2014 10:45 AM
To: Matt Hartley (mhartley); Daniele Ceccarelli; CCAMP ([email-masked]<mailto:[email-masked]>)
Subject: RE: Question on LSP diversity

Hi Matt,

-          4. Multi domain

Best

Gert

Daniele,

Cheers

Matt

Hi,

-          1. Single homing

-          2. Dual homing

-          4. Multi domain

BR
Daniele