Subject: [CCAMP] Fwd: slides for draft-ietf-ccamp-flexi-grid-fwk-01

From: Oscar González de Dios <[email-masked]>
Date: Wed, 05 Mar 2014 13:53:23 +0000

FYI

Enviado desde mi iPhone

Inicio del mensaje reenviado:

De: Maarten vissers <[email-masked]<mailto:[email-masked]>>
Fecha: 5 de marzo de 2014 13:47:43 GMT
Para: Ramon Casellas <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Iftekhar Hussain <[email-masked]<mailto:[email-masked]>>
Cc: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Oscar González de Dios <[email-masked]<mailto:[email-masked]>>, "Zhangxian (Xian)" <[email-masked]<mailto:[email-masked]>>, Fatai Zhang <[email-masked]<mailto:[email-masked]>>
Asunto: RE: slides for draft-ietf-ccamp-flexi-grid-fwk-01

Hi Ramon,

A GMPLS LSP per network media channel is indeed **not** the right approach.

The GMPLS LSP has to represent the one optical channel layer connection that carries the complete OTUCn and thus encompasses all the associated network media channels; this GMPLS LSP is to be signaled with a list of frequency slots that are occupied by this optical channel layer connection. I.e. use an approach that is similar to the approach for signaling the set up of a multi-time slot ODUk connection.
See also Xihua’s email which was CC’ed to ccamp.

As you already know how to signal a multi-time slot ODUk connection, you essentially know how to signal a multi-frequency slot optical channel layer connection. The main difference is that a frequency slot is defined by a <nominal center frequency and slot width>-tuple and not by a simple <slot number> as in the ODUk case.

Regards,
Maarten

From: Ramon Casellas [mailto:[email-masked]]
Sent: woensdag 5 maart 2014 08:29
To: Maarten vissers; [email-masked]<mailto:[email-masked]>; Iftekhar Hussain
Cc: Daniele Ceccarelli; [email-masked]<mailto:[email-masked]>; Oscar González de Dios; Zhangxian (Xian); Fatai Zhang
Subject: Re: slides for draft-ietf-ccamp-flexi-grid-fwk-01

El 05/03/2014 0:33, Maarten vissers escribió:
Ramon,

My suggestion is to focus on the optical channel layer connection and not on the media channel as described in my response to Xihua about an hour ago. An optical channel layer connection encompasses one or more network media channels. You have to configure optical channel layer cross connects in each NE in the computed path. An optical channel layer cross connect connects one or more frequency slots <FS1,FS2,..,FSn> between two or more ports.

Awareness of network media channels is only required in the PCE, during optical channel layer path computation as described in my previous email.

Hi again,

In short, I want to understand whether, provided that the path computation function is able to compute a set of network media channels that are logically associated and that satisfy your constraints (i.e., compute the optical channel layer route), you think that having an LSP per network media channel where the label represents the frequency slot and associating them somehow (the method is still to be defined, channel sets, association, virtual concat, just to echo some terms) is *not* the right approach?

R.

Note: We should  CCccamp as requested in the past by AD & WG chairs to avoid parallel discussions.

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: Fatai Zhang <[email-masked]>
Date: Wed, 5 Mar 2014 23:43:31 +0000

Hi all,

I think this is what we(CCAMP) are doing, even though ITU-T and IETF people might use different terms like optical channel layer connection and network media channel.

Thanks

Fatai

发件人: CCAMP [mailto:[email-masked]] 代表 Oscar González de Dios
发送时间: 2014年3月5日 21:53
收件人: [email-masked]
主题: [CCAMP] Fwd: slides for draft-ietf-ccamp-flexi-grid-fwk-01

FYI

Enviado desde mi iPhone

Regards,
Maarten

Hi again,

R.

---

From: Cyril Margaria <[email-masked]>
Date: Thu, 6 Mar 2014 10:40:16 +0100

Hi,

The current framework document scope the LSP to the media channel, not any
OTU or OTUCn. The signal and adaptation part was out-of-scope in the
previous revisions. I did not see any change related to this configuration
in the document.
It is not immediately clear why the LSP should represent one optical
channel connection and not limit itself to the media channel.
This seems going into how the optical channel/termination is done.

I  do not see an immediate need to go in the termination part, the document
allows one LSP to carry several media-channel, encompassing all the media
channel needed to carry the optical channel.

I think that the current text address correctly the problem and
requirements for the current (public) data plane specs.

BR

On 5 March 2014 14:53, Oscar González de Dios <[email-masked]> wrote:

>  *De:* Maarten vissers <[email-masked]>
> *Fecha:* 5 de marzo de 2014 13:47:43 GMT
> *Para:* Ramon Casellas <[email-masked]>, "[email-masked]" <
> [email-masked]>, Iftekhar Hussain <[email-masked]>
> *Cc:* Daniele Ceccarelli <[email-masked]>, "
> [email-masked]" <[email-masked]>, Oscar González de
> Dios <[email-masked]>, "Zhangxian (Xian)" <[email-masked]>, Fatai
> Zhang <[email-masked]>
> *Asunto:* *RE: slides for draft-ietf-ccamp-flexi-grid-fwk-01*
>
>    Hi Ramon,
>
>
>
> The GMPLS LSP has to represent the one optical channel layer connection
> that carries the complete OTUCn and thus encompasses all the associated
> network media channels; this GMPLS LSP is to be signaled with a list of
> frequency slots that are occupied by this optical channel layer connection.
> I.e. use an approach that is similar to the approach for signaling the set
> up of a multi-time slot ODUk connection.
>
> See also Xihua's email which was CC'ed to ccamp.
>
>
>
> As you already know how to signal a multi-time slot ODUk connection, you
> essentially know how to signal a multi-frequency slot optical channel layer
> connection. The main difference is that a frequency slot is defined by a
> <nominal center frequency and slot width>-tuple and not by a simple <slot
> number> as in the ODUk case.
>
>
>
> Regards,
>
> Maarten
>
>
>
> *From:* Ramon Casellas [mailto:[email-masked]<[email-masked]>]
>
> *Sent:* woensdag 5 maart 2014 08:29
> *To:* Maarten vissers; [email-masked]; Iftekhar Hussain
> *Cc:* Daniele Ceccarelli; [email-masked]; Oscar González de
> Dios; Zhangxian (Xian); Fatai Zhang
> *Subject:* Re: slides for draft-ietf-ccamp-flexi-grid-fwk-01
>
>
>
> My suggestion is to focus on the optical channel layer connection and not
> on the media channel as described in my response to Xihua about an hour
> ago. An optical channel layer connection encompasses one or more network
> media channels. You have to configure optical channel layer cross connects
> in each NE in the computed path. An optical channel layer cross connect
> connects one or more frequency slots <FS1,FS2,..,FSn> between two or more
> ports.
>
>
>
> Awareness of network media channels is only required in the PCE, during
> optical channel layer path computation as described in my previous email.
>
>
> Hi again,
>
>
> In short, I want to understand whether, provided that the path computation
> function is able to compute a set of network media channels that are
> logically associated and that satisfy your constraints (i.e., compute the
> optical channel layer route), you think that having an LSP per network
> media channel where the label represents the frequency slot and associating
> them somehow (the method is still to be defined, channel sets, association,
> virtual concat, just to echo some terms) is *not* the right approach?
>
> R.
>
> ------------------------------
>
> Este mensaje se dirige exclusivamente a su destinatario. Puede consultar
> nuestra política de envío y recepción de correo electrónico en el enlace
> situado más abajo.
> This message is intended exclusively for its addressee. We only send and
> receive email on the basis of the terms set out at:
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>
>

---

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Thu, 6 Mar 2014 10:33:31 +0000

On 06 Mar 2014, at 10:40, Cyril Margaria <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

The current framework document scope the LSP to the media channel, not any OTU or OTUCn. The signal and adaptation part was out-of-scope in the previous revisions. I did not see any change related to this configuration in the document.
It is not immediately clear why the LSP should represent one optical channel connection and not limit itself to the media channel.
This seems going into how the optical channel/termination is done.

I  do not see an immediate need to go in the termination part, the document allows one LSP to carry several media-channel, encompassing all the media channel needed to carry the optical channel.

+1

G

I think that the current text address correctly the problem and requirements for the current (public) data plane specs.

BR

On 5 March 2014 14:53, Oscar González de Dios <[email-masked]<mailto:[email-masked]>> wrote:
FYI

Enviado desde mi iPhone

Hi Ramon,

Regards,
Maarten

Hi again,

R.

_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp

_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Ramon Casellas <[email-masked]>
Date: Thu, 06 Mar 2014 11:59:11 +0100

On 03/06/2014 11:33 AM, Giovanni Martinelli (giomarti) wrote:
>
> On 06 Mar 2014, at 10:40, Cyril Margaria <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>> Hi,
>>
>> The current framework document scope the LSP to the media channel, 
>> not any OTU or OTUCn. The signal and adaptation part was out-of-scope 
>> in the previous revisions. I did not see any change related to this 
>> configuration in the document.
>> I  do not see an immediate need to go in the termination part, the 
>> document allows one LSP to carry several media-channel, encompassing 
>> all the media channel needed to carry the optical channel.
>>
>

I guess my question, from a "high level perspective", is whether 
(regardless of OTUCn and signal layer) a LSP represents a single 
(effective) frequency slot, or, given the new requirement, a group of 
inter-dependent (co-routed) frequency slots, that need to be controlled 
together (setup, re-route, and cross-connect)

I think the question applies even in the current scope. Nothing preludes 
combining both: an LSP that corresponds to 1 frequency slot and an LSP 
that corresponds to N frequency slots.

That said, as agreed during the meeting, I will write a first draft of 
the liasion text. Please send your inputs.

Thanks,
R.