Subject: Re: [CCAMP] Solicit comments on availability WG drafts

From: "Yemin (Amy)" <[email-masked]>
Date: Mon, 4 May 2015 06:46:03 +0000

Hi Lou,

Thanks for your comments. Please see my reply below.

For OSPF draft, how about text like this:
"When the Switching Capability field is PSC-1/LSC (other Switching Capability could also be possible), the Switching Capability specific information field MAY include one or more ISCD Availability sub-TLV(s)."
The PSC-2/3/4 are removed to align with RFC7074.

For RSVP draft, the technology specific part in the section 1 will be moved to the appendix. The rest part is generic without the technology specific information, I think.  
And we need input on optical usage. Once we got it, it may goes to the appendix section. Or a separated draft including all the use case might be better?

BR,
Amy
-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Thursday, April 30, 2015 8:14 PM
To: Yemin (Amy); CCAMP ([email-masked])
Cc: Longhao; Giovanni Martinelli (giomarti)
Subject: Re: [CCAMP] Solicit comments on availability WG drafts

Hi Amy,
    If memory serves this dates back to IETF 90.  It would seem to me that the authors could take a pass at suggesting how to generalize or ask the person who proposed it make a proposal.  It doesn't look too hard:
For the OSPF draft:
    I think you just need to change the 1st line of 3.2 and drop restriction on types. (BTW I don't think you want to reference deprecated types in general, see RFC7074.)

For the RSVP draft:
    I think separating out the generic definition of the function and required information from the technology specifics and allowing form multiple technologies , will go a long (if not all the) way to making the solution generic.  Having a second use technology, e.g., optical, defined would be helpful to ensure that the split is right.

Lou

On 4/23/2015 2:54 AM, Yemin (Amy) wrote:
>
> Dear CCAMPers,
>
>  
>
> We would like to solicit comments on the two availability WG drafts:
>
> http://datatracker.ietf.org/doc/draft-ietf-ccamp-rsvp-te-bandwidth-ava
> ilability/
>
> http://datatracker.ietf.org/doc/draft-ietf-ccamp-ospf-availability-ext
> ension/
>
>  
>
> There were some comments to generalize the draft to optical area.
> However, how to generalize is still missing.
>
> We are looking forward to get more comments on the possible 
> generalization.
>
> Do you think it's worthy to apply the drafts to other area, e.g., 
> optical? If so, how to generalize?
>
>  
>
> BR,
>
> Amy (on behalf of the co-authors)
>
>  
>
> **********************************************************************
> ***************** This e-mail and its attachments contain confidential 
> information from HUAWEI, which is intended only for the person or 
> entity whose address is listed above. Any use of the information 
> contained herein in any way (including, but not limited to, total or 
> partial disclosure, reproduction, or dissemination) by persons other 
> than the intended
> recipient(s) is prohibited. If you receive this e-mail in error, 
> please notify the sender by phone or email immediately and delete it!
> **********************************************************************
> *****************
>
>  
>
>
>
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: Lou Berger <[email-masked]>
Date: Tue, 05 May 2015 14:57:50 -0400

Amy,

> The PSC-2/3/4 are removed to align with RFC7074.
Why not just start with "The Switching Capability specific information
field MAY ...
> And we need input on optical usage. Once we got it, it may goes to the appendix section. Or a separated draft including all the use case might be better?

I think separate generic and technology specific sections make sense. 
I'm not so sure about putting the latter part in appendices, but this
can be revisited once the text is there.

Thanks,
Lou

---

From: "Yemin (Amy)" <[email-masked]>
Date: Wed, 6 May 2015 02:58:37 +0000

Hi Lou,

Please see reply inline. 

BR,
Amy

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Wednesday, May 06, 2015 2:58 AM
To: Yemin (Amy); CCAMP ([email-masked])
Cc: Longhao; Giovanni Martinelli (giomarti)
Subject: Re: [CCAMP] Solicit comments on availability WG drafts

Amy,

> The PSC-2/3/4 are removed to align with RFC7074.
Why not just start with "The Switching Capability specific information field MAY ...
[Amy] Good idea. Will update the text.

I think separate generic and technology specific sections make sense. 
I'm not so sure about putting the latter part in appendices, but this can be revisited once the text is there.
[Amy]OK. We will wait the text and make the decision. 

Thanks,
Lou 
>     I think you just need to change the 1st line of 3.2 and drop 
> restriction on types. (BTW I don't think you want to reference 
> deprecated types in general, see RFC7074.)
>
> For the RSVP draft:
>> ***************** This e-mail and its attachments contain 
>> confidential information from HUAWEI, which is intended only for the 
>> person or entity whose address is listed above. Any use of the 
>> information contained herein in any way (including, but not limited 
>> to, total or partial disclosure, reproduction, or dissemination) by 
>> persons other than the intended