Subject: [CCAMP] I-D Action: draft-ietf-ccamp-optical-impairment-topology-yang-01.txt

From: [email-masked]
Date: Mon, 27 May 2019 21:44:24 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Common Control and Measurement Plane WG of the IETF.

        Title           : A Yang Data Model for Optical Impairment-aware Topology
        Authors         : Young Lee
                          Victor Lopez
                          G. Galimberti
                          AUGE Jean Luc
                          Dieter Beller
	Filename        : draft-ietf-ccamp-optical-impairment-topology-yang-01.txt
	Pages           : 39
	Date            : 2019-05-27

Abstract:
   In order to provision an optical connection through optical
   networks, a combination of path continuity, resource availability,
   and impairment constraints must be met to determine viable and
   optimal paths through the network. The determination of appropriate
   paths is known as Impairment-Aware Routing and Wavelength Assignment
   (IA-RWA) for WSON, while it is known as Impairment-Aware Routing and
   Spectrum Assigment (IA-RSA) for SSON.

   This document provides a YANG data model for the impairment-aware TE
   topology in optical networks.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-optical-impairment-topology-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ccamp-optical-impairment-topology-yang-01
https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-optical-impairment-topology-yang-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-optical-impairment-topology-yang-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Young Lee <[email-masked]>
Date: Tue, 28 May 2019 00:02:25 -0500

Hi.

This revision made some progress which deserves the WG to know.
1. Define Media Channel Group (MCG) and Media Channels.
2. Define OTSi-G and OTSi's
3. Clarify the relationship between MCG and OTSi-G.
4. Non-technical: keep five authors in the front.

Thanks.
Young (on behalf of other co-authors and contributors)

On Mon, May 27, 2019 at 11:44 PM <[email-masked]> wrote:

>         Filename        :
> draft-ietf-ccamp-optical-impairment-topology-yang-01.txt
>         Pages           : 39
>         Date            : 2019-05-27
>
> Abstract:
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp
>

---

From: Young Lee <[email-masked]>
Date: Tue, 28 May 2019 04:52:33 +0000

Hi,

This revision made some progress that deserves sharing with the WG:

1. Defined Media Channel Group (MCG) and media channels.
2. Defined OTSi-G and OTSi's. 
3. Clarify the relationship between MCG and OTSi-G. 
4. Non-technical: keep the five authors in the front page. 

Thanks.
Young on behalf of co-authors and contributors. 

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 27, 2019 11:44 PM
To: [email-masked]
Cc: [email-masked]
Subject: [CCAMP] I-D Action: draft-ietf-ccamp-optical-impairment-topology-yang-01.txt

Abstract:

The IETF datatracker status page for this draft is:
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-ccamp-optical-impairment-topology-yang%2F&amp;data=02%7C01%7Cleeyoung%40futurewei.com%7C445ae467b37744c3ff3e08d6e3274001%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C636946155055196464&amp;sdata=CTw0Sj%2FDXOsEUdYg%2FIQCfSIX6JRPcD7PRjsHqr2HKbU%3D&amp;reserved=0

There are also htmlized versions available at:
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-ccamp-optical-impairment-topology-yang-01&amp;data=02%7C01%7Cleeyoung%40futurewei.com%7C445ae467b37744c3ff3e08d6e3274001%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C636946155055206454&amp;sdata=SCHg7V5B8sKPcTyqWLX6%2FhYDUzxKivFUCpkaYBsLmD4%3D&amp;reserved=0
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-ccamp-optical-impairment-topology-yang-01&amp;data=02%7C01%7Cleeyoung%40futurewei.com%7C445ae467b37744c3ff3e08d6e3274001%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C636946155055206454&amp;sdata=N1CyoNgrWG1zpydeQPXuFPUS1sW3UsQX7bbeX6pFK1o%3D&amp;reserved=0

A diff from the previous version is available at:
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-ccamp-optical-impairment-topology-yang-01&amp;data=02%7C01%7Cleeyoung%40futurewei.com%7C445ae467b37744c3ff3e08d6e3274001%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C636946155055206454&amp;sdata=1QDDWey7jJvE2KgKundq5VMGwIdT1yqUcAFCvZ5BLqU%3D&amp;reserved=0

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
CCAMP mailing list
[email-masked]
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fccamp&amp;data=02%7C01%7Cleeyoung%40futurewei.com%7C445ae467b37744c3ff3e08d6e3274001%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C636946155055206454&amp;sdata=UqX6%2B4LJjEm1Iyx2PWYW4m3hJKg64NnSWTdY8fq3LLE%3D&amp;reserved=0

---

From: "Beller, Dieter (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Tue, 28 May 2019 12:40:51 +0000

Hi all,

the contributors contributing to ietf-layer0-types.yang and ietf-optical-impairment-topology.yang are using GitHub for developing the YANG modules - here is the link:
https://github.com/younglee-ietf/ietf-optical-impairment-yang
We agreed that it is mandatory to created an issue for proposed YANG file changes, see: https://github.com/younglee-ietf/ietf-optical-impairment-yang/issues
Changes have to be proposed on a temporary branch or a forked repository and a pull request has to be submitted with a review for merging the changes into the master branch.

@ Daniele/Fatai: is it possible to add the GitHub link to the list of Additional URLs on datatracker (see below )? I am assuming that chairs can edit the datatracker pages.
https://datatracker.ietf.org/doc/draft-ietf-ccamp-optical-impairment-topology-yang/

Thanks,
Dieter

On 28.05.2019 07:02, Young Lee wrote:
Hi.

Thanks.

On Mon, May 27, 2019 at 11:44 PM <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp

_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 29 May 2019 06:43:14 +0000

Hi Dieter, authors,

Done. I’ve added the ”document source repository” link.

BR

Daniele  

From: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]> 
Sent: den 28 maj 2019 14:41
To: [email-masked]; [email-masked]
Cc: Young Lee <[email-masked]>
Subject: Re: [CCAMP] I-D Action: draft-ietf-ccamp-optical-impairment-topology-yang-01.txt

Hi all,

https://github.com/younglee-ietf/ietf-optical-impairment-yang <https://protect2.fireeye.com/url?k=b345112c-ef911ddd-b34551b7-864685b2085c-ac26b7e9df899411&q=1&u=https%3A%2F%2Fgithub.com%2Fyounglee-ietf%2Fietf-optical-impairment-yang> 

We agreed that it is mandatory to created an issue for proposed YANG file changes, see: https://github.com/younglee-ietf/ietf-optical-impairment-yang/issues <https://protect2.fireeye.com/url?k=2cbcc25b-7068ceaa-2cbc82c0-864685b2085c-2d7a29b37703f6ac&q=1&u=https%3A%2F%2Fgithub.com%2Fyounglee-ietf%2Fietf-optical-impairment-yang%2Fissues> 
Changes have to be proposed on a temporary branch or a forked repository and a pull request has to be submitted with a review for merging the changes into the master branch.

Thanks,
Dieter

Hi. 

Thanks.

On Mon, May 27, 2019 at 11:44 PM <[email-masked] <mailto:[email-masked]> > wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org> .

_______________________________________________
CCAMP mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/ccamp

_______________________________________________
CCAMP mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/ccamp