Subject: [CCAMP] Fw: I-D Action: draft-ietf-ccamp-layer1-types-04.txt

From: Zhenghaomian <[email-masked]>
Date: Thu, 5 Dec 2019 09:38:37 +0000

Hi, WG, 

This document has been updated according to the discussion in Singapore, together with the comments from mailing list [1]. The authors believe it's now ready for YANG doctor review. 

Another problem we would raise is how to properly put the reference RFC7963 and ITU-T G.sup43. Usually all the reference in YANG should be normative, while RFC7963 (informational) is not allowed to be normative. Following options are possible: 
1. Remove the types in RFC7963/G.sup43, and remove the two references; 
2. Put RFC7963/G.sup43 as informative, and state the corresponding types in their description as current text, to emphasize they are 'informational'; 
3. Put RFC7963/G.sup43 as normative, but there would be nits;
Authors are slightly preferring #2, but open to suggestions from WG experts, chairs, AD and YANG doctor, thank you. 

[1] https://mailarchive.ietf.org/arch/msg/ccamp/yBT8ItiZn73bbskmjCUZpUJiw5c

Best wishes,
Haomian (on behalf of all authors & contributors)

-----邮件原件-----
发件人: CCAMP [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2019年12月5日 17:17
收件人: [email-masked]
抄送: [email-masked]
主题: [CCAMP] I-D Action: draft-ietf-ccamp-layer1-types-04.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Common Control and Measurement Plane WG of the IETF.

        Title           : A YANG Data Model for Layer 1 Types
        Authors         : Haomian Zheng
                          Italo Busi
	Filename        : draft-ietf-ccamp-layer1-types-04.txt
	Pages           : 25
	Date            : 2019-12-05

Abstract:
   This document defines a collection of common data types and groupings
   in YANG data modeling language for layer 1 networks.  These derived
   common types and groupings are intended to be imported by modules
   that specifies the OTN networks, including the topology, tunnel,
   client signal adaptation and service.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-layer1-types/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ccamp-layer1-types-04
https://datatracker.ietf.org/doc/html/draft-ietf-ccamp-layer1-types-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-layer1-types-04

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: tom petch <[email-masked]>
Date: Tue, 24 Dec 2019 10:34:39 +0000

________________________________________
From: CCAMP <[email-masked]> on behalf of Zhenghaomian <[email-masked]>
Sent: 05 December 2019 09:38
To: [email-masked]
Subject: [CCAMP] Fw:  I-D Action: draft-ietf-ccamp-layer1-types-04.txt

Hi, WG,

Another problem we would raise is how to properly put the reference RFC7963 and ITU-T G.sup43. Usually all the reference in YANG should be normative, while RFC7963 (informational) is not allowed to be normative. 

Wrong!
Informative documents ARE allowed to be Normative references.  There is a long list of those that have been approved for such usage and there is a procedure for getting  another one added to it.

A task that is familiar to most WG Chair and AD.

HTH

Tom Petch

Following options are possible:

Best wishes,

-----邮件原件-----
发件人: CCAMP [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2019年12月5日 17:17
收件人: [email-masked]
抄送: [email-masked]
主题: [CCAMP] I-D Action: draft-ietf-ccamp-layer1-types-04.txt

Abstract: