Subject: [CCAMP] Summary of the CCAMP meeting on Optical Impairment Topology YANG model

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Fri, 20 Mar 2020 18:06:56 +0000

During the meeting the major topic been discussed was related to the e-mail exchange regarding [CCAMP] WG last call on draft-ietf-ccamp-wson-yang-23 and in particular the issue raise by Dieter with the mail sent March 10 on , regarding the alignment among the different L0 YANG models with respect ietf-layer0-types.

These are the list of drafts we need to consider

  1.  ietf-ccamp-wson-yang;
  2.  ietf-ccamp-flexigrid-yang;
  3.  ietf-ccamp-wson-tunnel;
  4.  ietf-ccamp-flexigrid-media-channel-yang;
  5.  ietf-dwdm-if-param-yang;
  6.  ietf-ccamp-optical-impairment-topology-yang

There are practically two options on the table:

  1.  Go ahead to publish ietf-layer0-types as reference "types" module for the set of drafts addressing "only" specific use cases that basically is  "spectrum allocation" (a,b,c d drafts) , creating in parallel a new ietf-layer0-types-xxx that can be used for ietf-dwdm-if-param-yang and ietf-ccamp-optical-impairment-topology-yang.
In this solution there is the problem to understand if the use case claimed to be supported is possible without e.g. transpoder information like the ones contained in the e, f drafts.

  1.  Use "versioning" YANG paradigm, this solution permits to move ahead in parallel two version of the same files "types", and v2 will incorporate all the needed update for e and f drafts.

Before to take any choice, attendees of the call  decided that a careful review of the ietf-layer0-types is needed to understand possible gaps with respect all optical impairments and transponders description .
Moreover a new issue will be open in the ietf-layer0-types github to report optical impairments related comments/concerns.
Attached the e-mail exchange I mentioned at the beginning.

Feel free to amend and add what is missing.

Thanks
Sergio

Sergio Belotti
Senior System Engineer and Standardization Architect
IP/Optical Networks, Optics BU
Nokia
M: +39-335761776
Via Energy Park, 20871 Vimercate (MB) , Italy
[email-masked]<mailto:[email-masked]>

Subject: Re: [Teas] [CCAMP] WG last call on draft-ietf-ccamp-wson-yang-23
From: Zhenghaomian <[email-masked]>
To: Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>, "Beller, Dieter (Nokia - DE/Stuttgart)" <[email-masked]>, CCAMP <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Date: Wed, 18 Mar 2020 02:29:47 +0000
List-Id: Traffic Engineering Architecture and Signaling working group discussion list <teas.ietf.org>

Hi Dieter and Daniele,

Thanks for raising this point, I believe this is a right problem we should work on. To be more explicit, I listed all the document/modules which are expected to have dependency on ietf-layer0-types.

-          ietf-ccamp-wson-yang;

-          ietf-ccamp-flexigrid-yang;

-          ietf-ccamp-wson-tunnel;

-          ietf-ccamp-flexigrid-media-channel-yang;

-          ietf-dwdm-if-param-yang;

-          ietf-ccamp-optical-impairment-topology-yang;

The above order is based on WG adoption date, which is also my understanding the module maturity as well (other people may have different opinions but it’s okay…). Given the fact that there may be future modules that are dependent on ietf-layer0-types in future, the publication of ietf-layer0-types should not be expected on satisfying all the existing works. Instead, we need to agree on ‘what is the right subset of the above documents should the first publication of ietf-layer0-types support?’, and ‘how to deal with the gaps when we are working on the others which are not supported by the published ietf-layer0-types?’.

Regarding the first question, what is in my mind is the first two, i.e., ietf-ccamp-wson-yang and ietf-ccamp-flexigrid-yang, they can be considered as a cluster for publication, as suggested previously by the YANG doctor.

For the second question, as suggested by Daniele, it looks the impairment modules and the transponder modules are progressing in parallel. We don’t have perfect opinion yet. We may either create separate version for them, naming as something like ‘ietf-layer0-types-impairment’, and then publish in separation of ietf-layer0-types. Or alternatively we generally create an update version like ‘ietf-layer0-types-v2’ which inherits everything in ‘ietf-layer0-types’, and publish to obsolete ‘ietf-layer0-types-v2’ when it’s ready.

I am copying to teas WG as well, as they have same problem on ietf-te-types. Maybe their experience can be useful to us as well.

Thank you.

Best wishes,

Haomian

发件人: CCAMP [mailto:[email-masked]] 代表 Daniele Ceccarelli
发送时间: 2020年3月16日 23:19
收件人: Dieter Beller <[email-masked]>; CCAMP <ccamp@ietf..org>
主题: Re: [CCAMP] WG last call on draft-ietf-ccamp-wson-yang-23

Hi Dieter,

Good point.

What would your proposal be?

At an high level I would say something like:

Topology impairments free: https://datatracker.ietf.org/doc/draft-ietf-ccamp-wson-yang/
Transponders: https://datatracker.ietf.org/doc/draft-ietf-ccamp-dwdm-if-param-yang/
Impairments aware topology: https://datatracker.ietf.org/doc/draft-ietf-ccamp-optical-impairment-topology-yang/

Opinions?

Daniele

From: Dieter Beller <[email-masked]<mailto:[email-masked]>>
Sent: den 10 mars 2020 19:09
To: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; CCAMP <[email-masked]<mailto:[email-masked]>>
Subject: Re: [CCAMP] WG last call on draft-ietf-ccamp-wson-yang-23

Hi Daniele, Fatai, all,

there is a general issue the WG has to address: there are several WG drafts defining YANG data models for WDM networks including layer0-types:

https://datatracker.ietf.org/doc/draft-ietf-ccamp-layer0-types/

https://datatracker.ietf.org/doc/draft-ietf-ccamp-wson-yang/
https://datatracker.ietf.org/doc/draft-ietf-ccamp-dwdm-if-param-yang/
https://datatracker.ietf.org/doc/draft-ietf-ccamp-optical-impairment-topology-yang/

These YANG models are overlapping in a sense that they are defining containers that contain similar data. An example are transponder properties.
Different names and different type definitions are used in these drafts for the same transponder property.

My understanding was that layer0-types provides the foundation in terms of type definitions and groupings, on which the YANG models in the drafts
listed above are based in order to achieve alignment and consistency among them. If all these drafts listed above are progressed separately, I am
afraid that it will result in a mess making the applicability of the YANG data models doubtful.

To sort this out, the WG should take the time and align these drafts to the largest possible extent which should be beneficial for the applicability of
the YANG models.

Thanks,
Dieter

On 10.03.2020 16:40, Daniele Ceccarelli wrote:

   CCAMP,

   the IPR declaration collection has been successfully completed and we can move to the next step.

   This starts a 3 weeks working group last call on draft-ietf-ccamp-wson-yang-23.

   The last call ends on Tuesday March 31st. Please send you comments to the CCAMP mailing list.

   All the IPR declarations from authors and contributors have been collected and can be found in the history of the document.

   If interested, please volunteer to be the shepherd of the draft (authors excluded).

   Authors please note that the YANG validation reports 135 ERRORS and IDNITS 7 warnings.

   Thanks

   Daniele & Fatai

   _______________________________________________
   CCAMP mailing list
   [email-masked]<mailto:[email-masked]>
   https://www.ietf.org/mailman/listinfo/ccamp

---

From: Italo Busi <[email-masked]>
Date: Tue, 24 Mar 2020 09:45:41 +0000

Sergio, CCAMP WG,

The proposals are assuming that in the first phase a set of RFCs are published (drafts a, b, c and d, together with layer0-types), to cover the 'spectrum allocation' scenarios.

Do we all agree with the proposed phasing approach?

I think it makes a lot of sense since this model is quite mature (there as few WG LC comments that I guess can be easily and quickly addressed) and allows covering many, even if not all, the use cases that I have seen being requested and deployed

Regarding the versioning issue, I have uploaded on github few slides trying to clarifying the different options:

https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-layer0-types/files/4374340/versioning-00.pptx

I have added a third option where two versions of layer0-types modules are developed in parallel with different revision dates

A fourth option is to follow the guidelines under development by the Versioning DT in Netmod WG but I am not sure how mature they are as well as if they are supported by existing YANG tools

Italo

Italo Busi
Principal Optical Transport Network Research Engineer
Huawei Technologies Co., Ltd.
Tel : +39 345 4721946
Email : [email-masked]

This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

From: Belotti, Sergio (Nokia - IT/Vimercate) [mailto:[email-masked]]
Sent: venerdì 20 marzo 2020 19:07
To: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; [email-masked]; [email-masked]; Italo Busi <[email-masked]>; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked]>; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked]>; Gabriele Maria Galimberti (ggalimbe) <[email-masked]>; ([email-masked]) <[email-masked]>; Aihua Guo <[email-masked]>
Cc: Daniele Ceccarelli <[email-masked]>; Fatai Zhang <[email-masked]>; CCAMP <[email-masked]>; Zhenghaomian <[email-masked]>
Subject: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

These are the list of drafts we need to consider
a)       ietf-ccamp-wson-yang;
b)      ietf-ccamp-flexigrid-yang;
c)       ietf-ccamp-wson-tunnel;
d)      ietf-ccamp-flexigrid-media-channel-yang;
e)       ietf-dwdm-if-param-yang;
f)        ietf-ccamp-optical-impairment-topology-yang

There are practically two options on the table:
1)      Go ahead to publish ietf-layer0-types as reference "types" module for the set of drafts addressing "only" specific use cases that basically is  "spectrum allocation" (a,b,c d drafts) , creating in parallel a new ietf-layer0-types-xxx that can be used for ietf-dwdm-if-param-yang and ietf-ccamp-optical-impairment-topology-yang.
In this solution there is the problem to understand if the use case claimed to be supported is possible without e.g. transpoder information like the ones contained in the e, f drafts.
2)      Use "versioning" YANG paradigm, this solution permits to move ahead in parallel two version of the same files "types", and v2 will incorporate all the needed update for e and f drafts.

Thanks
Sergio

Sergio Belotti

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 24 Mar 2020 14:07:31 +0000

Hi,

I would agree with Italo.

We deliberately kept the layer0-types draft “on hold” (even if ready to be
progressed) just in case we discovered any last minute change required by
other ongoing work, but it makes sense to me to progress it along with
documents a,b,c,d as a first cluster.

One thing we need to further understand is to how to split the content among
them. I’m referring to e.g. the point raised by Dieter some days back on
where to define the transponders.

Opinions on this aspect?

BR

Daniele  

From: Italo Busi <[email-masked]> 
Sent: den 24 mars 2020 10:46
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>;
Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>;
[email-masked]; [email-masked]; Griseri, Enrico (Nokia
- IT/Vimercate) <[email-masked]>; Kelly, Colin (Nokia - CA/Ottawa)
<[email-masked]>; Gabriele Maria Galimberti (ggalimbe)
<[email-masked]>; ([email-masked]) <[email-masked]>; Aihua
Guo <[email-masked]>
Cc: Daniele Ceccarelli <[email-masked]>; Fatai Zhang
<[email-masked]>; CCAMP <[email-masked]>; Zhenghaomian
<[email-masked]>
Subject: RE: Summary of the CCAMP meeting on Optical Impairment Topology
YANG model

Sergio, CCAMP WG,

The proposals are assuming that in the first phase a set of RFCs are
published (drafts a, b, c and d, together with layer0-types), to cover the
'spectrum allocation' scenarios.

I think it makes a lot of sense since this model is quite mature (there as
few WG LC comments that I guess can be easily and quickly addressed) and
allows covering many, even if not all, the use cases that I have seen being
requested and deployed

Regarding the versioning issue, I have uploaded on github few slides trying
to clarifying the different options:

https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-layer0-types/files/4374340
/versioning-00.pptx

I have added a third option where two versions of layer0-types modules are
developed in parallel with different revision dates

A fourth option is to follow the guidelines under development by the
Versioning DT in Netmod WG but I am not sure how mature they are as well as
if they are supported by existing YANG tools

Italo

Italo Busi 

Tel : +39 345 4721946

Email : [email-masked] <mailto:[email-masked]>  

This e-mail and its attachments contain confidential information from
HUAWEI, which is intended only for the person or entity whose address is
listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure, reproduction,
or dissemination) by persons other than the intended recipient(s) is
prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

From: Belotti, Sergio (Nokia - IT/Vimercate)
[mailto:[email-masked]] 
Sent: venerdì 20 marzo 2020 19:07
To: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]
<mailto:[email-masked]> >; [email-masked]
<mailto:[email-masked]> ; [email-masked]
<mailto:[email-masked]> ; Italo Busi <[email-masked]
<mailto:[email-masked]> >; Griseri, Enrico (Nokia - IT/Vimercate)
<[email-masked] <mailto:[email-masked]> >; Kelly, Colin
(Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]> >;
Gabriele Maria Galimberti (ggalimbe) <[email-masked]
<mailto:[email-masked]> >; ([email-masked]
<mailto:[email-masked]> ) <[email-masked]
<mailto:[email-masked]> >; Aihua Guo <[email-masked]
<mailto:[email-masked]> >
Cc: Daniele Ceccarelli <[email-masked]
<mailto:[email-masked]> >; Fatai Zhang
<[email-masked] <mailto:[email-masked]> >; CCAMP
<[email-masked] <mailto:[email-masked]> >; Zhenghaomian
<[email-masked] <mailto:[email-masked]> >
Subject: Summary of the CCAMP meeting on Optical Impairment Topology YANG
model

During the meeting the major topic been discussed was related to the e-mail
exchange regarding [CCAMP] WG last call on draft-ietf-ccamp-wson-yang-23 and
in particular the issue raise by Dieter with the mail sent March 10 on ,
regarding the alignment among the different L0 YANG models with respect
ietf-layer0-types.

a.	ietf-ccamp-wson-yang;
b.	ietf-ccamp-flexigrid-yang;
c.	ietf-ccamp-wson-tunnel; 
d.	ietf-ccamp-flexigrid-media-channel-yang;
e.	ietf-dwdm-if-param-yang;
f.	ietf-ccamp-optical-impairment-topology-yang

1.	Go ahead to publish ietf-layer0-types as reference “types” module
for the set of drafts addressing “only” specific use cases that basically is
“spectrum allocation” (a,b,c d drafts) , creating in parallel a new
ietf-layer0-types-xxx that can be used for ietf-dwdm-if-param-yang and
ietf-ccamp-optical-impairment-topology-yang.

In this solution there is the problem to understand if the use case claimed
to be supported is possible without e.g. transpoder information like the
ones contained in the e, f drafts.

2.	Use “versioning” YANG paradigm, this solution permits to move ahead
in parallel two version of the same files “types”, and v2 will incorporate
all the needed update for e and f drafts.

Before to take any choice, attendees of the call  decided that a careful
review of the ietf-layer0-types is needed to understand possible gaps with
respect all optical impairments and transponders description .

Moreover a new issue will be open in the ietf-layer0-types github to report
optical impairments related comments/concerns.

Thanks

Sergio

Sergio Belotti

Nokia 

M: +39-335761776

[email-masked] <mailto:[email-masked]>

---

From: Italo Busi <[email-masked]>
Date: Thu, 26 Mar 2020 11:31:41 +0000

Hi Daniele,

The answer to your and Dieter's question "where to define the transponders" seems not trivial to me

At this moment, three different transponder models have been defined in different drafts (for further details see https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang/issues/29)

I guess that the transponder model should be defined at least in draft e) and in one of the other drafts. Therefore it would be better to have common set(s) of transponder attributes being defined in a common model (such as the layer0-types): which one depends on how we move forward with layer0-types.

My preference would be to define these attributes in a version 2 of layer0-types.

It is also not trivial to know which one or which ones of the other drafts need to model the transponder. I think we need to look at some use cases

When reporting an optical-impairment aware topology, should we also report the capability of the transponders at the MPI?

Is this the only case where it is required/useful to report the capability of the transponders at the MPI?

In case of an alien wavelength, should the OLS PNC be informed about the capabilities of the external OTs? Is this information sufficient or should the OLS PNC report the optical impairments at the MPI?

Just my initial 2 cents

Italo

Italo Busi

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: martedì 24 marzo 2020 15:08
To: Italo Busi <[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; [email-masked]; [email-masked]; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked]>; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked]>; Gabriele Maria Galimberti (ggalimbe) <[email-masked]>; ([email-masked]) <[email-masked]>; Aihua Guo <[email-masked]>
Cc: Fatai Zhang <[email-masked]>; CCAMP <[email-masked]>; Zhenghaomian <[email-masked]>
Subject: RE: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

Hi,

I would agree with Italo.
We deliberately kept the layer0-types draft "on hold" (even if ready to be progressed) just in case we discovered any last minute change required by other ongoing work, but it makes sense to me to progress it along with documents a,b,c,d as a first cluster.
One thing we need to further understand is to how to split the content among them. I'm referring to e.g. the point raised by Dieter some days back on where to define the transponders.
Opinions on this aspect?

BR
Daniele

From: Italo Busi <[email-masked]<mailto:[email-masked]>>
Sent: den 24 mars 2020 10:46
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; Gabriele Maria Galimberti (ggalimbe) <[email-masked]<mailto:[email-masked]>>; ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; Aihua Guo <[email-masked]<mailto:[email-masked]>>
Cc: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; Fatai Zhang <[email-masked]<mailto:[email-masked]>>; CCAMP <[email-masked]<mailto:[email-masked]>>; Zhenghaomian <[email-masked]<mailto:[email-masked]>>
Subject: RE: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

Sergio, CCAMP WG,

Italo

Italo Busi
Principal Optical Transport Network Research Engineer
Huawei Technologies Co., Ltd.
Tel : +39 345 4721946
Email : [email-masked]<mailto:[email-masked]>

From: Belotti, Sergio (Nokia - IT/Vimercate) [mailto:[email-masked]]
Sent: venerdì 20 marzo 2020 19:07
To: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Italo Busi <[email-masked]<mailto:[email-masked]>>; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; Gabriele Maria Galimberti (ggalimbe) <[email-masked]<mailto:[email-masked]>>; ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; Aihua Guo <[email-masked]<mailto:[email-masked]>>
Cc: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; Fatai Zhang <[email-masked]<mailto:[email-masked]>>; CCAMP <[email-masked]<mailto:[email-masked]>>; Zhenghaomian <[email-masked]<mailto:[email-masked]>>
Subject: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

Thanks
Sergio

Sergio Belotti

---

From: <[email-masked]>
Date: Thu, 26 Mar 2020 14:07:52 +0100

Ciao Italo,

Please see my input below as [JM].

Thanks,

Julien

On 26/03/2020 12:31, Italo Busi wrote:

Hi
Daniele,

The answer to
your and Dieter’s question “where to define the
transponders” seems not
trivial to me

At this moment,
three different transponder models have been defined in
different drafts (for further details see
https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-optical-impairment-topology-yang/issues/29)

I guess that
the transponder model should be defined at least in draft e)

[JM] Agreed

and in one of
the other drafts.

[JM] Not so sure. Consistency is mandatory, duplication should be
avoided. Do you foresee an issue with including
ietf-dwdm-if-param-yang on any device/software that has
transponder-related information to export?

Therefore it
would be better to have common set(s) of transponder
attributes being defined in a common model (such as the
layer0-types): which one depends on how we move forward with
layer0-types.

My preference
would be to define these attributes in a version 2 of
layer0-types.

It is also not
trivial to know which one or which ones of the other drafts
need to model the transponder. I think we need to look at
some use cases

[JM] The use cases can help identifying which information is
required, I'm not sure it will help us decide how we split our Yang
modules.

When reporting
an optical-impairment aware topology, should we also report
the capability of the transponders at the MPI?

Is this the
only case where it is required/useful to report the
capability of the transponders at the MPI?

In case of an
alien wavelength, should the OLS PNC be informed about the
capabilities of the external OTs? Is this information
sufficient or should the OLS PNC report the optical
impairments at the MPI?

[JM] These questions are valuable for deployment, but they don't
directly drive the answer to the questions above. We need a Yang
module to export transponder-related information in a standard way
that is fully consistent with the impairment-aware network modeling.
There are use cases where using both sets of information is required
at the PNC. I see two main options here:

- the PNC has NETCONF sessions to both the OLS and the transponders,
thus can combine them;

- the transponders and the OLS exchange information using the right
extensions to LMP [1] and RSVP-TE [2], and the OLS PNC makes use of
it.

[1] https://tools.ietf.org/html/draft-ietf-ccamp-dwdm-if-lmp

[2] https://tools.ietf.org/html/draft-meuric-ccamp-tsvmode-signaling

My complementary 2 cents,

Julien

Just my initial
2 cents

Italo

Italo
Busi

Tel : +39 345 4721946

This
e-mail and its attachments contain confidential
information from HUAWEI, which is intended only for the
person or entity whose address is listed above. Any use of
the information contained herein in any way (including,
but not limited to, total or partial disclosure,
reproduction, or dissemination) by persons other than the
intended recipient(s) is prohibited. If you receive this
e-mail in error, please notify the sender by phone or
email immediately and delete it!

From: Daniele Ceccarelli
[mailto:[email-masked]]

Hi,

I
would agree with Italo.

We deliberately kept
the layer0-types draft “on hold” (even if ready to be
progressed) just in case we discovered any last minute
change required by other ongoing work, but it makes
sense to me to progress it along with documents a,b,c,d
as a first cluster.

One thing we need to
further understand is to how to split the content among
them. I’m referring to e.g. the point raised by Dieter
some days back on where to define the transponders.

Opinions on this
aspect?

BR

Daniele

Sergio, CCAMP
WG,

The proposals
are assuming that in the first phase a set of RFCs are
published (drafts a, b, c and d, together with
layer0-types), to cover the 'spectrum allocation'
scenarios.

Do we all
agree with the proposed phasing approach?

I think it
makes a lot of sense since this model is quite mature
(there as few WG LC comments that I guess can be easily
and quickly addressed) and allows covering many, even if
not all, the use cases that I have seen being requested
and deployed

Regarding the
versioning issue, I have uploaded on github few slides
trying to clarifying the different options:

I have added
a third option where two versions of layer0-types modules
are developed in parallel with different revision dates

A fourth
option is to follow the guidelines under development by
the Versioning DT in Netmod WG but I am not sure how
mature they are as well as if they are supported by
existing YANG tools

Italo

Italo
Busi

Tel : +39 345 4721946

This
e-mail and its attachments contain confidential
information from HUAWEI, which is intended only for the
person or entity whose address is listed above. Any use
of the information contained herein in any way
(including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons
other than the intended recipient(s) is prohibited. If
you receive this e-mail in error, please notify the
sender by phone or email immediately and delete it!

From: Belotti, Sergio (Nokia
- IT/Vimercate) [mailto:[email-masked]]

During the
meeting the major topic been discussed was related to
the e-mail exchange regarding [CCAMP] WG last call on
draft-ietf-ccamp-wson-yang-23 and in particular the
issue raise by Dieter with the mail sent March 10 on ,
regarding the alignment among the different L0 YANG
models with respect ietf-layer0-types.

These are the
list of drafts we need to consider

a)
ietf-ccamp-wson-yang;

b)
ietf-ccamp-flexigrid-yang;

c)
ietf-ccamp-wson-tunnel;

d)
ietf-ccamp-flexigrid-media-channel-yang;

e)
ietf-dwdm-if-param-yang;

f)
ietf-ccamp-optical-impairment-topology-yang

There are
practically two options on the table:

1)
Go ahead to publish
ietf-layer0-types as reference “types” module for the
set of drafts addressing “only” specific use cases that
basically is  “spectrum allocation” (a,b,c d drafts) ,
creating in parallel a new ietf-layer0-types-xxx that
can be used for ietf-dwdm-if-param-yang and
ietf-ccamp-optical-impairment-topology-yang.

In this solution there is the
problem to understand if the use case claimed to be
supported is possible without e.g. transpoder
information like the ones contained in the e, f drafts.

2)
Use “versioning” YANG paradigm,
this solution permits to move ahead in parallel two
version of the same files “types”, and v2 will
incorporate all the needed update for e and f drafts.

Before to
take any choice, attendees of the call  decided that a
careful review of the ietf-layer0-types is needed to
understand possible gaps with respect all optical
impairments and transponders description .

Moreover a
new issue will be open in the ietf-layer0-types github
to report optical impairments related comments/concerns.

Attached
the e-mail exchange I mentioned at the beginning.

Feel free
to amend and add what is missing.

Thanks

Sergio

Sergio
Belotti

Senior
System Engineer and Standardization Architect

IP/Optical
Networks, Optics BU

Nokia

M:
+39-335761776

Via
Energy Park, 20871 Vimercate (MB) , Italy

[email-masked]

---

From: <[email-masked]>
Date: Thu, 26 Mar 2020 14:35:58 +0000

Hello

Sorry I have been disconnected and can not reconnect...

Have a nice evening!

Regards

esther

De : MEURIC Julien TGI/OLN
Envoyé : jeudi 26 mars 2020 14:08
À : Italo Busi
Cc : Daniele Ceccarelli; Belotti, Sergio (Nokia - IT/Vimercate); Beller, Dieter (Nokia - DE/Stuttgart); LE ROUZIC Esther TGI/OLN; Griseri, Enrico (Nokia - IT/Vimercate); Kelly, Colin (Nokia - CA/Ottawa); Gabriele Maria Galimberti (ggalimbe); ([email-masked]); Aihua Guo; Fatai Zhang; CCAMP; Zhenghaomian
Objet : Re: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

Ciao Italo,

Thanks,

Julien

   Hi Daniele,

   I guess that the transponder model should be defined at least in draft e)

   [JM] Agreed

   and in one of the other drafts.

   [JM] Not so sure. Consistency is mandatory, duplication should be avoided. Do you foresee an issue with including ietf-dwdm-if-param-yang on any device/software that has transponder-related information to export?

   Therefore it would be better to have common set(s) of transponder attributes being defined in a common model (such as the layer0-types): which one depends on how we move forward with layer0-types.

   [JM] The use cases can help identifying which information is required, I'm not sure it will help us decide how we split our Yang modules.

   [JM] These questions are valuable for deployment, but they don't directly drive the answer to the questions above. We need a Yang module to export transponder-related information in a standard way that is fully consistent with the impairment-aware network modeling. There are use cases where using both sets of information is required at the PNC. I see two main options here:
   - the PNC has NETCONF sessions to both the OLS and the transponders, thus can combine them;
   - the transponders and the OLS exchange information using the right extensions to LMP [1] and RSVP-TE [2], and the OLS PNC makes use of it.

   Julien

   Just my initial 2 cents

   Italo

   Italo Busi

   Tel : +39 345 4721946

   Hi,

   Opinions on this aspect?

   BR

   Daniele

   Sergio, CCAMP WG,

   Italo

   Italo Busi

   Tel : +39 345 4721946

   a)       ietf-ccamp-wson-yang;

   Thanks

   Sergio

   Sergio Belotti

   Nokia

   M: +39-335761776

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Italo Busi <[email-masked]>
Date: Thu, 26 Mar 2020 21:35:17 +0000

We have discussed the issue of phasing and versioning the layer0-types during the optical-impairments draft weekly call today

Based on the discussion, it seems that the preferred option is something in between the first and second option, where a new module/draft is started with the content of layer0-types which is not mature to be published in the first phase (named as something like 'ietf-layer0-types-ext') and, once the layer0-types is published as an RFC, to merge this module within an updated version of the layer0-types which could then be published as an RFC that updates the version 1 of layer0-types

This is described in the added slide 4 of: https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-layer0-types/files/4390041/versioning-01.pptx

We would like to get further comments/opinions from the WG about this proposal

Thanks

Italo (on behalf of the participants to today's call)

Italo Busi

From: Italo Busi [mailto:[email-masked]]
Sent: martedì 24 marzo 2020 10:46
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; [email-masked]; [email-masked]; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked]>; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked]>; Gabriele Maria Galimberti (ggalimbe) <[email-masked]>; ([email-masked]) <[email-masked]>; Aihua Guo <[email-masked]>
Cc: Daniele Ceccarelli <[email-masked]>; Fatai Zhang <[email-masked]>; CCAMP <[email-masked]>; Zhenghaomian <[email-masked]>
Subject: Re: [CCAMP] Summary of the CCAMP meeting on Optical Impairment Topology YANG model

Sergio, CCAMP WG,

Italo

Italo Busi

Thanks
Sergio

Sergio Belotti

---

From: Dieter Beller <[email-masked]>
Date: Sat, 28 Mar 2020 22:26:29 +0100

Hi all,

I completed m review of ietf-layer0-types.yang. Please find my comments 
here: 
https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-layer0-types/issues/9.

Thanks,
Dieter

On 20.03.2020 19:06, Belotti, Sergio (Nokia - IT/Vimercate) wrote:
>
> During the meeting the major topic been discussed was related to the 
> e-mail exchange regarding [CCAMP] WG last call on 
> draft-ietf-ccamp-wson-yang-23 and in particular the issue raise by 
> Dieter with the mail sent March 10 on , regarding the alignment among 
> the different L0 YANG models with respect ietf-layer0-types.
>
>     for the set of drafts addressing “only” specific use cases that
>     basically is  “spectrum allocation” (a,b,c d drafts) , creating in
>     parallel a new ietf-layer0-types-xxx that can be used for
>     ietf-dwdm-if-param-yang and
> In this solution there is the problem to understand if the use case 
> claimed to be supported is possible without e.g. transpoder 
>  2. Use “versioning” YANG paradigm, this solution permits to move
>     ahead in parallel two version of the same files “types”, and v2
>     will incorporate all the needed update for e and f drafts.
>
> Before to take any choice, attendees of the call  decided that a 
> careful review of the ietf-layer0-types is needed to understand 
> possible gaps with respect all optical impairments and transponders 
> description .
>
> Moreover a new issue will be open in the ietf-layer0-types github to 
> report optical impairments related comments/concerns.
>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 30 Mar 2020 12:29:13 +0000

Hi Dieter,

The L0 types has already concluded the last call, the draft in last call is
the WSON topology.but in any case it's always good to have further comments.

Looking at the comments it seems they are all applicable also to the
proposal to remove transponder properties from the L0 types draft, right?

BR

Daniele  

From: Dieter Beller <[email-masked]> 
Sent: den 28 mars 2020 22:26
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>;
[email-masked]; [email-masked]; Italo Busi
<[email-masked]>; Griseri, Enrico (Nokia - IT/Vimercate)
<[email-masked]>; Kelly, Colin (Nokia - CA/Ottawa)
<[email-masked]>; Gabriele Maria Galimberti (ggalimbe)
<[email-masked]>; ([email-masked]) <[email-masked]>; Aihua
Guo <[email-masked]>; Zhenghaomian <[email-masked]>
Cc: Daniele Ceccarelli <[email-masked]>; Fatai
<[email-masked]>; CCAMP <[email-masked]>
Subject: Re: Summary of the CCAMP meeting on Optical Impairment Topology
YANG model

Hi all,

I completed m review of ietf-layer0-types.yang. Please find my comments
here:
https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-layer0-types/issues/9
<https://protect2.fireeye.com/v1/url?k=44194f13-1890e0da-44190f88-0cc47ad93e
1c-9a756a5f63c40108&q=1&e=5547670a-4e75-42ee-aad0-9ab56d8dea6d&u=https%3A%2F
%2Fgithub.com%2Fietf-ccamp-wg%2Fdraft-ietf-ccamp-layer0-types%2Fissues%2F9>
.

Thanks,
Dieter

a.	ietf-ccamp-wson-yang;

1.	Go ahead to publish ietf-layer0-types as reference "types" module
for the set of drafts addressing "only" specific use cases that basically is
"spectrum allocation" (a,b,c d drafts) , creating in parallel a new
ietf-layer0-types-xxx that can be used for ietf-dwdm-if-param-yang and
ietf-ccamp-optical-impairment-topology-yang.

2.	Use "versioning" YANG paradigm, this solution permits to move ahead
in parallel two version of the same files "types", and v2 will incorporate
all the needed update for e and f drafts.

Thanks

Sergio

Sergio Belotti

Nokia 

M: +39-335761776