Subject: [CCAMP] Transponder Attributes Consideration//Re: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

From: Zhenghaomian <[email-masked]>
Date: Mon, 30 Mar 2020 09:43:30 +0000

Hi, All,

Thanks for raising the point on transponder modeling.

Yes there are some transponder-related properties in the current versions of ietf-layer0-types, which are not used in first-cluster modules a) b) c) d), and are used in impairment. It is quite challenging to perfectly ‘splitting’ the parameters among multiple modules, as they may be imported in multiple places in future, which is hard to predict.

Personally I am writing the following proposals, which looks feasible at the time being.

-          Remove the transponder properties from ietf-layer0-types, as they are not used in the first cluster;

-          Currently the transponder properties are used in ietf-optical-impairment-topology, so I suggest to create a separate module in the work to model the transponder. The module should be orthogonal to ietf-layer0-types, i.e., they are complementary of each other. Regarding the name of module, it can be something like ‘ietf-transponder-types’;

-          If we do the two steps above, there may be argument in future on a certain attribute saying ‘does it belong to ietf-layer0-types or ietf-transponder-types’? We should avoid duplicating the attributes in both modules, especially with different semantic meaning;

-          Again, the principle on judging parameters (to be or not to be in the above modules) should be alignment with ITU-T data plane specifications.

Hopefully these proposal can trigger some discussions:)

My 2 cents,
Haomian

发件人: Daniele Ceccarelli [mailto:[email-masked]]
发送时间: 2020年3月24日 22:08
收件人: Italo Busi <[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; [email-masked]; [email-masked]; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked]>; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked]>; Gabriele Maria Galimberti (ggalimbe) <[email-masked]>; ([email-masked]) <[email-masked]>; Aihua Guo <[email-masked]>
抄送: Fatai Zhang <[email-masked]>; CCAMP <[email-masked]>; Zhenghaomian <[email-masked]>
主题: RE: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

Hi,

I would agree with Italo.
We deliberately kept the layer0-types draft “on hold” (even if ready to be progressed) just in case we discovered any last minute change required by other ongoing work, but it makes sense to me to progress it along with documents a,b,c,d as a first cluster.
One thing we need to further understand is to how to split the content among them. I’m referring to e.g. the point raised by Dieter some days back on where to define the transponders.
Opinions on this aspect?

BR
Daniele

From: Italo Busi <[email-masked]<mailto:[email-masked]>>
Sent: den 24 mars 2020 10:46
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; Gabriele Maria Galimberti (ggalimbe) <[email-masked]<mailto:[email-masked]>>; ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; Aihua Guo <[email-masked]<mailto:[email-masked]>>
Cc: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; Fatai Zhang <[email-masked]<mailto:[email-masked]>>; CCAMP <[email-masked]<mailto:[email-masked]>>; Zhenghaomian <[email-masked]<mailto:[email-masked]>>
Subject: RE: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

Sergio, CCAMP WG,

The proposals are assuming that in the first phase a set of RFCs are published (drafts a, b, c and d, together with layer0-types), to cover the 'spectrum allocation' scenarios.

Do we all agree with the proposed phasing approach?

I think it makes a lot of sense since this model is quite mature (there as few WG LC comments that I guess can be easily and quickly addressed) and allows covering many, even if not all, the use cases that I have seen being requested and deployed

Regarding the versioning issue, I have uploaded on github few slides trying to clarifying the different options:

https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-layer0-types/files/4374340/versioning-00.pptx

I have added a third option where two versions of layer0-types modules are developed in parallel with different revision dates

A fourth option is to follow the guidelines under development by the Versioning DT in Netmod WG but I am not sure how mature they are as well as if they are supported by existing YANG tools

Italo

Italo Busi
Principal Optical Transport Network Research Engineer
Huawei Technologies Co., Ltd.
Tel : +39 345 4721946
Email : [email-masked]<mailto:[email-masked]>

This e-mail and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!

From: Belotti, Sergio (Nokia - IT/Vimercate) [mailto:[email-masked]]
Sent: venerdì 20 marzo 2020 19:07
To: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Italo Busi <[email-masked]<mailto:[email-masked]>>; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked]<mailto:[email-masked]>>; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked]<mailto:[email-masked]>>; Gabriele Maria Galimberti (ggalimbe) <[email-masked]<mailto:[email-masked]>>; ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; Aihua Guo <[email-masked]<mailto:[email-masked]>>
Cc: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; Fatai Zhang <[email-masked]<mailto:[email-masked]>>; CCAMP <[email-masked]<mailto:[email-masked]>>; Zhenghaomian <[email-masked]<mailto:[email-masked]>>
Subject: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

During the meeting the major topic been discussed was related to the e-mail exchange regarding [CCAMP] WG last call on draft-ietf-ccamp-wson-yang-23 and in particular the issue raise by Dieter with the mail sent March 10 on , regarding the alignment among the different L0 YANG models with respect ietf-layer0-types.

These are the list of drafts we need to consider
a)       ietf-ccamp-wson-yang;
b)       ietf-ccamp-flexigrid-yang;
c)       ietf-ccamp-wson-tunnel;
d)       ietf-ccamp-flexigrid-media-channel-yang;
e)       ietf-dwdm-if-param-yang;
f)        ietf-ccamp-optical-impairment-topology-yang

There are practically two options on the table:
1)      Go ahead to publish ietf-layer0-types as reference “types” module for the set of drafts addressing “only” specific use cases that basically is  “spectrum allocation” (a,b,c d drafts) , creating in parallel a new ietf-layer0-types-xxx that can be used for ietf-dwdm-if-param-yang and ietf-ccamp-optical-impairment-topology-yang.
In this solution there is the problem to understand if the use case claimed to be supported is possible without e.g. transpoder information like the ones contained in the e, f drafts.
2)      Use “versioning” YANG paradigm, this solution permits to move ahead in parallel two version of the same files “types”, and v2 will incorporate all the needed update for e and f drafts.

Before to take any choice, attendees of the call  decided that a careful review of the ietf-layer0-types is needed to understand possible gaps with respect all optical impairments and transponders description .
Moreover a new issue will be open in the ietf-layer0-types github to report optical impairments related comments/concerns.
Attached the e-mail exchange I mentioned at the beginning.

Feel free to amend and add what is missing.

Thanks
Sergio

Sergio Belotti
Senior System Engineer and Standardization Architect
IP/Optical Networks, Optics BU
Nokia
M: +39-335761776
Via Energy Park, 20871 Vimercate (MB) , Italy
[email-masked]<mailto:[email-masked]>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 30 Mar 2020 12:17:11 +0000

I like the proposal.

This would unlock both the L0 types and the cluster of 4 drafts.

Any other opinion?

Thanks,

Daniele  

From: Zhenghaomian <[email-masked]> 
Sent: den 30 mars 2020 11:44
To: Daniele Ceccarelli <[email-masked]>; Italo Busi <[email-masked]>; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked]>; [email-masked]; [email-masked]; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked]>; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked]>; Gabriele Maria Galimberti (ggalimbe) <[email-masked]>; ([email-masked]) <[email-masked]>; Aihua Guo <[email-masked]>
Cc: Fatai Zhang <[email-masked]>; CCAMP <[email-masked]>
Subject: Transponder Attributes Consideration//Re: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

Hi, All, 

My 2 cents,

Haomian

发件人: Daniele Ceccarelli [mailto:[email-masked]] 
发送时间: 2020年3月24日 22:08
收件人: Italo Busi <[email-masked] <mailto:[email-masked]> >; Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked] <mailto:[email-masked]> >; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked] <mailto:[email-masked]> >; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]> >; Gabriele Maria Galimberti (ggalimbe) <[email-masked] <mailto:[email-masked]> >; ([email-masked] <mailto:[email-masked]> ) <[email-masked] <mailto:[email-masked]> >; Aihua Guo <[email-masked] <mailto:[email-masked]> >
抄送: Fatai Zhang <[email-masked] <mailto:[email-masked]> >; CCAMP <[email-masked] <mailto:[email-masked]> >; Zhenghaomian <[email-masked] <mailto:[email-masked]> >
主题: RE: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

Hi,

Opinions on this aspect?

BR

Daniele  

From: Italo Busi <[email-masked] <mailto:[email-masked]> > 
Sent: den 24 mars 2020 10:46
To: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked] <mailto:[email-masked]> >; Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked] <mailto:[email-masked]> >; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]> >; Gabriele Maria Galimberti (ggalimbe) <[email-masked] <mailto:[email-masked]> >; ([email-masked] <mailto:[email-masked]> ) <[email-masked] <mailto:[email-masked]> >; Aihua Guo <[email-masked] <mailto:[email-masked]> >
Cc: Daniele Ceccarelli <[email-masked] <mailto:[email-masked]> >; Fatai Zhang <[email-masked] <mailto:[email-masked]> >; CCAMP <[email-masked] <mailto:[email-masked]> >; Zhenghaomian <[email-masked] <mailto:[email-masked]> >
Subject: RE: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

Sergio, CCAMP WG,

https://github.com/ietf-ccamp-wg/draft-ietf-ccamp-layer0-types/files/4374340/versioning-00.pptx <https://protect2.fireeye.com/v1/url?k=dd4b59f8-819f5509-dd4b1963-864685b2085c-912cadd45dff711b&q=1&e=00df1824-68ff-46a4-98f1-45cb236354ee&u=https%3A%2F%2Fgithub.com%2Fietf-ccamp-wg%2Fdraft-ietf-ccamp-layer0-types%2Ffiles%2F4374340%2Fversioning-00.pptx> 

Italo

Italo Busi 

Tel : +39 345 4721946

Email : [email-masked] <mailto:[email-masked]>  

From: Belotti, Sergio (Nokia - IT/Vimercate) [mailto:[email-masked]] 
Sent: venerdì 20 marzo 2020 19:07
To: Beller, Dieter (Nokia - DE/Stuttgart) <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> ; Italo Busi <[email-masked] <mailto:[email-masked]> >; Griseri, Enrico (Nokia - IT/Vimercate) <[email-masked] <mailto:[email-masked]> >; Kelly, Colin (Nokia - CA/Ottawa) <[email-masked] <mailto:[email-masked]> >; Gabriele Maria Galimberti (ggalimbe) <[email-masked] <mailto:[email-masked]> >; ([email-masked] <mailto:[email-masked]> ) <[email-masked] <mailto:[email-masked]> >; Aihua Guo <[email-masked] <mailto:[email-masked]> >
Cc: Daniele Ceccarelli <[email-masked] <mailto:[email-masked]> >; Fatai Zhang <[email-masked] <mailto:[email-masked]> >; CCAMP <[email-masked] <mailto:[email-masked]> >; Zhenghaomian <[email-masked] <mailto:[email-masked]> >
Subject: Summary of the CCAMP meeting on Optical Impairment Topology YANG model

a.	ietf-ccamp-wson-yang;
b.	ietf-ccamp-flexigrid-yang;
c.	ietf-ccamp-wson-tunnel; 
d.	ietf-ccamp-flexigrid-media-channel-yang;
e.	ietf-dwdm-if-param-yang;
f.	ietf-ccamp-optical-impairment-topology-yang

1.	Go ahead to publish ietf-layer0-types as reference “types” module for the set of drafts addressing “only” specific use cases that basically is  “spectrum allocation” (a,b,c d drafts) , creating in parallel a new ietf-layer0-types-xxx that can be used for ietf-dwdm-if-param-yang and ietf-ccamp-optical-impairment-topology-yang.

2.	Use “versioning” YANG paradigm, this solution permits to move ahead in parallel two version of the same files “types”, and v2 will incorporate all the needed update for e and f drafts.

Thanks

Sergio

Sergio Belotti

Nokia 

M: +39-335761776

[email-masked] <mailto:[email-masked]>