Subject: [CCAMP] POLLING on draft-ietf-ccamp-optical-impairment-topology-yang-05

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 20 Nov 2020 15:08:44 +0000

Hi WG,

This is a polling to follow up on the discussion we had during the IETF session.
The polling will be closed on Friday 27th November.

Please indicate which option (more than one allowed) do you support. You can motivate why an option and why not another or share if you are aware of existing implementations.

  *   Option 1: The draft is good as is today.
  *   Option 2: We need to add text specifying the use cases that we want to cover. More precisely identify the cases that are outside the scope of the solution proposed.
  *   Option 3: Contribute to ITU-T to have all the cases covered by application codes.
  *   Option 4: Remove explicit parameters in the organizational-mode because they are considered implicit parameters in the mode. This allows to cover cases where the same mode is used for transceivers that extend (but not limit) the operation range of a mode.

Thanks,
Daniele, Fatai.

---

From: <[email-masked]>
Date: Mon, 23 Nov 2020 18:18:59 +0100

Ciao Daniele, hi all,

I believe the way the draft is progressing is fine, which puts me on
option 1. If some holes are identified, I think option 2 is the typical
way to take care of them and I would be ready to support it.
Option 3 feels orthogonal: if it's progressed in parallel, the solution
from the I-D will be able to make use of the results, but I don't want
to bind the specification only to the output of that action.
I don't think what is proposed by the 1st sentence of option 4 is
necessary, and I don't understand how the 2nd sentence sustains the 1st
one...

Cheers,

Julien

On 20/11/2020 16:08, Daniele Ceccarelli wrote:
> *The polling will be closed on Friday 27^th November.*
>
>  
>
> Please indicate which option (more than one allowed) do you support.
> You can motivate why an option and why not another or share if you are
> aware of existing implementations.
>
>  
>
>   * Option 2: We need to add text specifying the use cases that we
>     want to cover. More precisely identify the cases that are outside
>     the scope of the solution proposed.
>   * Option 4: Remove explicit parameters in the organizational-mode
>     because they are considered implicit parameters in the mode. This
>     allows to cover cases where the same mode is used for transceivers
>     that extend (but not limit) the operation range of a mode.
>
>  
>
> Thanks,
>
> Daniele, Fatai.
>
>
> _______________________________________________
> CCAMP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ccamp

---

From: <[email-masked]>
Date: Tue, 24 Nov 2020 08:24:58 +0000

Dear Daniele, WG,

I am for option 1 or 2: for me the draft (model) is good as it is  but some
explanations (in the text) on the way it can be used could help
implementers. So far I have not identified cases that could not be covered.

I am not in favor to wait for option 3 to have our draft. Transponders not
covered by ITU are already deployed and implementers need a model that can
cover these cases already now. 

I am not in favor of option 4 : the first sentence is not reflecting what we
discussed in our meeting (not true in my understanding) and I do not
understand how removing parameters can help in any way to support modes with
extended range .

Regards

esther

 <http://www.orange.com/> 

Esther Le Rouzic 
Chargée d'études en réseaux optiques 
ORANGE/TGI/OLN/WNI/AOT/SOAN

+33 6 10 05 40 85
 <mailto:[email-masked]> [email-masked] 

 

De : CCAMP [mailto:[email-masked]] De la part de Daniele Ceccarelli
Envoyé : vendredi 20 novembre 2020 16:09
À : CCAMP <[email-masked]>
Objet : [CCAMP] POLLING on
draft-ietf-ccamp-optical-impairment-topology-yang-05

Hi WG,

This is a polling to follow up on the discussion we had during the IETF
session.

Please indicate which option (more than one allowed) do you support. You can
motivate why an option and why not another or share if you are aware of
existing implementations.

-          Option 1: The draft is good as is today.

-          Option 2: We need to add text specifying the use cases that we
want to cover. More precisely identify the cases that are outside the scope
of the solution proposed.

-          Option 3: Contribute to ITU-T to have all the cases covered by
application codes.

-          Option 4: Remove explicit parameters in the organizational-mode
because they are considered implicit parameters in the mode. This allows to
cover cases where the same mode is used for transceivers that extend (but
not limit) the operation range of a mode. 

Thanks,

Daniele, Fatai.

---

From: Young Lee <[email-masked]>
Date: Tue, 24 Nov 2020 21:36:38 +0900

Hi Daniele,

My preference is option 1. Option 2 is not too far from option 1 so I can
support option 2 if necessary.

Thanks
Young

2020년 11월 21일 (토) 오전 12:08, Daniele Ceccarelli <daniele.ceccarelli=
[email-masked]>님이 작성:

> *The polling will be closed on Friday 27th November.*
>
>
>
> Please indicate which option (more than one allowed) do you support. You
> can motivate why an option and why not another or share if you are aware of
>    - Option 2: We need to add text specifying the use cases that we want
>    to cover. More precisely identify the cases that are outside the scope of
>    the solution proposed.

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Tue, 24 Nov 2020 16:15:14 +0000

Hi Daniele,

-My preference is Option 1  and we (as Nokia) have an implementation close to
Option 1 (organizational-mode).
-As second priority I can also survive with Option 2 : adding or clarifying text how the model can be applied to some real use cases can be helpful.

Thanks
Sergio

From: CCAMP <[email-masked]> On Behalf Of Daniele Ceccarelli
Sent: Friday, November 20, 2020 4:09 PM
To: CCAMP <[email-masked]>
Subject: [CCAMP] POLLING on draft-ietf-ccamp-optical-impairment-topology-yang-05

Hi WG,

Thanks,
Daniele, Fatai.

---

From: "Kelly, Colin (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 24 Nov 2020 16:53:26 +0000

Hi Daniele,  I am also aligned with Sergio's position here.

Regards,
Colin

From: Belotti, Sergio (Nokia - IT/Vimercate) <[email-masked]>
Sent: Tuesday, November 24, 2020 12:15 PM
To: Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>; CCAMP <[email-masked]>
Subject: RE: POLLING on draft-ietf-ccamp-optical-impairment-topology-yang-05

Hi Daniele,

Thanks
Sergio

From: CCAMP <[email-masked]<mailto:[email-masked]>> On Behalf Of Daniele Ceccarelli
Sent: Friday, November 20, 2020 4:09 PM
To: CCAMP <[email-masked]<mailto:[email-masked]>>
Subject: [CCAMP] POLLING on draft-ietf-ccamp-optical-impairment-topology-yang-05

Hi WG,

Thanks,
Daniele, Fatai.

---

From: Dieter Beller <[email-masked]>
Date: Wed, 25 Nov 2020 09:19:02 +0100

Hi Daniele,

my preference is clearly Option 1.
Option 2 is my second preferred option - adding text to the draft 
describing how the model can be applied to some use cases is always helpful.

As pointed out by Sergio, we do have an implementation very close to the 
organizational-mode approach.

Thanks,
Dieter

---

From: "Griseri, Enrico (Nokia - IT/Vimercate)" <[email-masked]>
Date: Wed, 25 Nov 2020 13:00:52 +0000

Hi Daniele,
                My preference is for Option 1.
I may consider Option 2 as a second choice as it is essentially Option 1 plus some explanatory text.
I'm not in favor of Option 3 nor Option 4. The former prevents the IETF model from supporting transceivers already deployed and the latter introduces unwanted rigidity in the model.

Thanks and regards,
                Enrico

Hi WG,

Thanks,
Daniele, Fatai.

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 26 Nov 2020 09:31:48 +0000

Hi Daniele,

I would like to support option 1. Option 2 is second.

Thanks,
Yuji

From: CCAMP <[email-masked]> On Behalf Of Daniele Ceccarelli
Sent: Saturday, November 21, 2020 12:09 AM
To: CCAMP <[email-masked]>
Subject: [CCAMP] POLLING on draft-ietf-ccamp-optical-impairment-topology-yang-05

Hi WG,

Thanks,
Daniele, Fatai.

---

From: Italo Busi <[email-masked]>
Date: Fri, 27 Nov 2020 09:22:33 +0000

Hi Daniele, Fatai,

My preference is for option 3. This would simplify the work in IETF since it would be based on ITU-T standard data plane specifications, as we usually do.

I understand that the there is some desire to support also organizational and explicit modes, mainly to allow some proprietary deployments during the transition phase between when the technology evolves and when new standard application codes are defined by ITU-T.

In this case, option 2 seems also a viable option since it is quite important that the draft clarifies how and to what extent these modes can be actually used, in particular when going beyond what it is currently defined by ITU-T Recommendations.

Since we are not in WG LC phase, I think that the WG should remain open also to consider changes to the current YANG model, if there are valid technical reasons. In other words, the YANG model in the current draft is a good starting point for further updates based on further technical input.

Italo

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: venerdì 20 novembre 2020 16:09
To: CCAMP <[email-masked]>
Subject: [CCAMP] POLLING on draft-ietf-ccamp-optical-impairment-topology-yang-05

Hi WG,

-          Option 1: The draft is good as is today.
-          Option 2: We need to add text specifying the use cases that we want to cover. More precisely identify the cases that are outside the scope of the solution proposed.
-          Option 3: Contribute to ITU-T to have all the cases covered by application codes.
-          Option 4: Remove explicit parameters in the organizational-mode because they are considered implicit parameters in the mode. This allows to cover cases where the same mode is used for transceivers that extend (but not limit) the operation range of a mode.

Thanks,
Daniele, Fatai.

---

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 27 Nov 2020 14:41:26 +0000

Hi WG,

Thanks for your replies.

Fatai and I will discuss about the output of the polling and be back to you ASAP.

Have a nice weekend.
Daniele

From: CCAMP <[email-masked]> On Behalf Of Daniele Ceccarelli
Sent: den 20 november 2020 16:09
To: CCAMP <[email-masked]>
Subject: [CCAMP] POLLING on draft-ietf-ccamp-optical-impairment-topology-yang-05

Hi WG,

Thanks,
Daniele, Fatai.