Subject: [CCAMP] Proposal for YANG model prefix naming

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 2 Feb 2021 18:26:07 -0000

Proposal for YANG model prefix naming.

Radek and then Tom raised the issue of consistency in prefix naming based on
the fact that the TE topology model uses 'tet' and the TE topology state
model uses 'tet-s'

CCAMP is currently working on plenty of YANG models, so it might be worth
stepping back and getting the prefixes consistent across all of our work.
I'm not sure this is the most important thing on our list, and perhaps it
would be better to discuss the colour of the bike shed, but to make sure
that we do this just once, here is my attempt.

My conclusion is that, although it would be nice to be consistent with using
just a suffix of 't' to indicate 'topology', this becomes messy with some of
the longer names, and it is clearer to always use 'topo' (leaving the TE
topology model as the odd one out).

This proposal only extends to CCAMP YANG models, and I don't think this list
can debate the wider scoping of prefixes, but I think it would extend well
enough.

The list shows...
Draftname
Modelname (currentprefix)--->(proposedprefix)

draft-ietf-client-signal-yang
ietf-eth-tran-service (ethtsvc)--->(etht-svc)
ietf-eth-tran-types (etht-types) --->(etht-types)
ietf-trans-client-service (clntsvc) --->(tclnt-svc)
ietf-trans-client-svc-types (clntsvc-types) --->(tclnt-svc-types)

draft-ietf-ccamp-dwdm-if-param-yang
ietf-ext-xponder-wdm-if (ietf-ext-xponder-wdm-if)--->(ext-xponder-wdm-if)

draft-ietf-ccamp-flexigrid-yang
ietf-flexi-grid-topology (flexi-grid-topology) --->(flexi-grid-topo)

draft-ietf-ccamp-l1csm-yang
ietf-l1csm (l1csm) --->(l1csm)

draft-ietf-ccamp-layer0-types
ietf-layer0-types (l0-types) --->(l0-types)

draft-ietf-ccamp-layer1-types
ietf-layer1-types (l1-types) --->(l1types)

draft-ietf-ccamp-optical-impairment-topology-yang
ietf-optical-impairment-topology (optical-imp-topo) --->(optical-imp-topo)

draft-ietf-ccamp-otn-topo-yang
ietf-otn-topology (otntopo) --->(otn-topo)

draft-ietf-ccamp-otn-tunnel-model
ietf-otn-tunnel (otn-tunnel) --->(otn-tunnel)

draft-ietf-ccamp-wson-yang
ietf-wson-topology  (wson) --->(wson-topo)

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 3 Feb 2021 09:12:07 +0000

Hi Adrian,

Thanks for reviving this discussion.

Together with Italo we tried to propose a sync up with TEAS before Christmas but we didn't have a big success.

Italo tried again to bring this up a couple of weeks ago: https://mailarchive.ietf.org/arch/msg/ccamp/4R6Bh4Pxo-DZJ6I4R918c1PwrMw/

I agree with you that we should limit the scope to CCAMP. What would be your proposal to fill Italo's table?

Cheers,
Daniele  

-----Original Message-----
From: CCAMP <[email-masked]> On Behalf Of Adrian Farrel
Sent: den 2 februari 2021 19:26
To: 'CCAMP' <[email-masked]>
Cc: [email-masked]; 'tom petch' <[email-masked]>
Subject: [CCAMP] Proposal for YANG model prefix naming

Radek and then Tom raised the issue of consistency in prefix naming based on the fact that the TE topology model uses 'tet' and the TE topology state model uses 'tet-s'

CCAMP is currently working on plenty of YANG models, so it might be worth stepping back and getting the prefixes consistent across all of our work.
I'm not sure this is the most important thing on our list, and perhaps it would be better to discuss the colour of the bike shed, but to make sure that we do this just once, here is my attempt.

My conclusion is that, although it would be nice to be consistent with using just a suffix of 't' to indicate 'topology', this becomes messy with some of the longer names, and it is clearer to always use 'topo' (leaving the TE topology model as the odd one out).

This proposal only extends to CCAMP YANG models, and I don't think this list can debate the wider scoping of prefixes, but I think it would extend well enough.

The list shows...
Draftname

draft-ietf-client-signal-yang
ietf-eth-tran-service (ethtsvc)--->(etht-svc) ietf-eth-tran-types (etht-types) --->(etht-types) ietf-trans-client-service (clntsvc) --->(tclnt-svc) ietf-trans-client-svc-types (clntsvc-types) --->(tclnt-svc-types)

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: tom petch <[email-masked]>
Date: Wed, 3 Feb 2021 09:51:18 +0000

From: CCAMP <[email-masked]> on behalf of Adrian Farrel <[email-masked]>
Sent: 02 February 2021 18:26

<tp>
Adrian

I think that the starting point is a list of I-D/RFC and I see some glitches in your list.

draft-ietf-client-signal-yang probably should be draft-ietf-ccamp-client-signal-yang

I see two flexigrid I-D but you only list one

wson-yang and l1types have been approved by the IESG so I regard those as fixed points that it is now too late to change and which we should build around

I have seen more than one wson model

microwave seems to be missing

Tom Petch

The list shows...
Draftname

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 3 Feb 2021 13:53:54 +0000

Hi Adrian,

The drafts are in the editor queue, I think there is still some time to have minor changes. I'll check with the RFC-editor.

Cheers,
Daniele  

-----Original Message-----
From: Adrian Farrel <[email-masked]> 
Sent: den 3 februari 2021 13:12
To: Daniele Ceccarelli <[email-masked]>; 'CCAMP' <[email-masked]>
Cc: [email-masked]; 'tom petch' <[email-masked]>
Subject: RE: [CCAMP] Proposal for YANG model prefix naming

Hi Daniele,

Per the recent exchange with Tom, this whole debate may have elapsed. If the WSON model is now considered to be "beyond edit" then it will go ahead using 'wson' and any battle to achieve consistency among prefixes used in CCAMP models is already lost.

So we should just find a better use of our time (like actually completing the model :-)

I tried to look at Italo's table, but I'm afraid that I go quite confused about which models the prefixes applied to. Possibly this is because I didn't open up any of the expired drafts.

Best,
Adrian

-----Original Message-----
From: Daniele Ceccarelli <[email-masked]>
Sent: 03 February 2021 09:12
To: [email-masked]; 'CCAMP' <[email-masked]>
Cc: [email-masked]; 'tom petch' <[email-masked]>
Subject: RE: [CCAMP] Proposal for YANG model prefix naming

Hi Adrian,

Italo tried again to bring this up a couple of weeks ago:
https://mailarchive.ietf.org/arch/msg/ccamp/4R6Bh4Pxo-DZJ6I4R918c1PwrMw/

Cheers,
Daniele  

-----Original Message-----
From: CCAMP <[email-masked]> On Behalf Of Adrian Farrel
Sent: den 2 februari 2021 19:26
To: 'CCAMP' <[email-masked]>
Cc: [email-masked]; 'tom petch' <[email-masked]>
Subject: [CCAMP] Proposal for YANG model prefix naming

The list shows...
Draftname

draft-ietf-ccamp-client-signal-yang
ietf-eth-tran-service (ethtsvc)--->(etht-svc) ietf-eth-tran-types
(etht-types) --->(etht-types) ietf-trans-client-service (clntsvc)
--->(tclnt-svc) ietf-trans-client-svc-types (clntsvc-types)
--->(tclnt-svc-types)

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 3 Feb 2021 12:12:09 -0000

Hi Tom,

> draft-ietf-client-signal-yang probably should be
draft-ietf-ccamp-client-signal-yang

Yes, typo.

> I see two flexigrid I-D but you only list one

I'm at https://datatracker.ietf.org/wg/ccamp/documents/ looking at extant WG
documents. 
Looks like draft-ietf-ccamp-flexigrid-media-channel-yang expired almost 6
months ago.

> wson-yang and l1types have been approved by the IESG so I regard those as
fixed
> points that it is now too late to change and which we should build around

Well, colour me confused.
I thought this whole thing came up in debate of the WSON YANG model.
If that debate is now closed, let's all move on and not worry about any of
this any more.

> I have seen more than one wson model

There's an information model in draft-ietf-ccamp-wson-iv-info, but no data
model.
draft-ietf-ccamp-wson-tunnel-model expired almost 6 months ago

> microwave seems to be missing

draft-ietf-ccamp-mw-topo-yang expired almost 18 months ago

The list shows...
Draftname

=

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 3 Feb 2021 12:12:09 -0000

Hi Daniele,

Per the recent exchange with Tom, this whole debate may have elapsed. If the
WSON model is now considered to be "beyond edit" then it will go ahead using
'wson' and any battle to achieve consistency among prefixes used in CCAMP
models is already lost.

So we should just find a better use of our time (like actually completing
the model :-)

I tried to look at Italo's table, but I'm afraid that I go quite confused
about which models the prefixes applied to. Possibly this is because I
didn't open up any of the expired drafts.

Best,
Adrian

-----Original Message-----
From: Daniele Ceccarelli <[email-masked]> 
Sent: 03 February 2021 09:12
To: [email-masked]; 'CCAMP' <[email-masked]>
Cc: [email-masked]; 'tom petch' <[email-masked]>
Subject: RE: [CCAMP] Proposal for YANG model prefix naming

Hi Adrian,

Together with Italo we tried to propose a sync up with TEAS before Christmas
but we didn't have a big success.

I agree with you that we should limit the scope to CCAMP. What would be your
proposal to fill Italo's table?

Cheers,
Daniele  

-----Original Message-----
From: CCAMP <[email-masked]> On Behalf Of Adrian Farrel
Sent: den 2 februari 2021 19:26
To: 'CCAMP' <[email-masked]>
Cc: [email-masked]; 'tom petch' <[email-masked]>
Subject: [CCAMP] Proposal for YANG model prefix naming

The list shows...
Draftname

---

From: tom petch <[email-masked]>
Date: Wed, 3 Feb 2021 16:43:39 +0000

From: Adrian Farrel <[email-masked]>
Sent: 03 February 2021 12:12

Hi Tom,

Yes, typo.

fixed

<tp>

Adrian,

The progress of I-D in the routing area can be erratic.  The fact that the IETF has expired the I-D does not mean that it will not come back to life - a whole raft of I-D that were produced in a rush just before the IETF meeting have just expired 6 months later and some are now being resuscitated, others will be in future, others will not.  Some re-appear years later when their time has come.

To me, an expired draft says that someone was interested enough to put in a lot of work and even if that work is not current, then it would be a short-sighted naming convention, although well in keeping with the traditions of the IETF, not to cater for such work in future.

For myself, I like names that start with the most important property and for me, that is WSON. OTN, RSVP and so on, and that is the basis on which I reviewed them, and not the fact that they are te - the rival proposal is for te to be the centre of the universe around which everything revolves, regardless of which WG  - TEAS, CCAMP, ... -it may be in.  I am not a fan of this approach.

Tom Petch

The list shows...
Draftname

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 4 Feb 2021 08:14:28 +0000

Tom, Adrian, all,

The L0 types and the WSON topology drafts are now on hold. We can include them in the updated prefix naming.
The RFC editor will delay processing these documents until the updated versions are available. The AD (John or Deborah) will need to approve the changes.

This will also affect the IANA registries, they have been informed as well.  

BR
Daniele   

-----Original Message-----
From: CCAMP <[email-masked]> On Behalf Of tom petch
Sent: den 3 februari 2021 17:44
To: 'CCAMP' <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [CCAMP] Proposal for YANG model prefix naming

Hi Tom,

>> Radek and then Tom raised the issue of consistency in prefix naming 
>> based
on
>> the fact that the TE topology model uses 'tet' and the TE topology 
>> state model uses 'tet-s'
>

Yes, typo.

> I see two flexigrid I-D but you only list one

I'm at https://datatracker.ietf.org/wg/ccamp/documents/ looking at extant WG documents.
Looks like draft-ietf-ccamp-flexigrid-media-channel-yang expired almost 6 months ago.

fixed

Well, colour me confused.
I thought this whole thing came up in debate of the WSON YANG model.
If that debate is now closed, let's all move on and not worry about any of this any more.

> I have seen more than one wson model

There's an information model in draft-ietf-ccamp-wson-iv-info, but no data model.
draft-ietf-ccamp-wson-tunnel-model expired almost 6 months ago

<tp>

Adrian,

Tom Petch

The list shows...
Draftname

---

From: Italo Busi <[email-masked]>
Date: Fri, 12 Feb 2021 09:02:58 +0000

Thanks Daniele

FYI: we are discussing these options also with TEAS experts:

https://github.com/tsaad-dev/te/issues/125

> ietf-layer0-types (l0-types) --->(l0-types)

I think we can agree with this prefix since all the proposals are aligned.

> ietf-wson-topology  (wson) --->(wson-topo)

Here, I think we have two candidates: wson-topo and wsont

I have a slight preference for wsont since it is aligned with tet and nt prefix conventions used in RFC8795 and RFC8345 but I can accept wson-topo (it could be seen as aligned with wson-tunnel or wson-tnl prefix conventions).

What do you think?

Italo

> From: Daniele Ceccarelli [mailto:[email-masked]]
> Sent: giovedì 4 febbraio 2021 09:14
> To: tom petch <[email-masked]>; 'CCAMP' <[email-masked]>;
> [email-masked]
> Cc: [email-masked]
> The RFC editor will delay processing these documents until the updated
> versions are available. The AD (John or Deborah) will need to approve the
> changes.
> 
> The progress of I-D in the routing area can be erratic.  The fact that the IETF
> has expired the I-D does not mean that it will not come back to life - a whole
> raft of I-D that were produced in a rush just before the IETF meeting have just
> expired 6 months later and some are now being resuscitated, others will be in
> future, others will not.  Some re-appear years later when their time has come.
> 
> To me, an expired draft says that someone was interested enough to put in a
> lot of work and even if that work is not current, then it would be a short-
> sighted naming convention, although well in keeping with the traditions of the
> IETF, not to cater for such work in future.
> 
> For myself, I like names that start with the most important property and for
> me, that is WSON. OTN, RSVP and so on, and that is the basis on which I
> reviewed them, and not the fact that they are te - the rival proposal is for te to
> be the centre of the universe around which everything revolves, regardless of
> which WG  - TEAS, CCAMP, ... -it may be in.  I am not a fan of this approach.
> 
> Tom Petch
> 
> I'm not sure this is the most important thing on our list, and perhaps it would
> be better to discuss the colour of the bike shed, but to make sure that we do
> this just once, here is my attempt.
> 
> just a suffix of 't' to indicate 'topology', this becomes messy with some of the
> longer names, and it is clearer to always use 'topo' (leaving the TE topology
> model as the odd one out).
> 
> ietf-eth-tran-service (ethtsvc)--->(etht-svc) ietf-eth-tran-types (etht-types) ---
> >(etht-types) ietf-trans-client-service (clntsvc) --->(tclnt-svc) ietf-trans-client-
> svc-types (clntsvc-types) --->(tclnt-svc-types)
>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 12 Feb 2021 10:28:34 +0000

Hi Italo,

Thanks for bringing this forward. 

I agree with the L0 types. Regarding the WSON topology I would prefer to be as much aligned as possible with the TE topology , but can live with both options if the WG has a strong preference.

Thanks,
Daniele  

-----Original Message-----
From: Italo Busi <[email-masked]> 
Sent: den 12 februari 2021 10:03
To: Daniele Ceccarelli <[email-masked]>; tom petch <[email-masked]>; 'CCAMP' <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: RE: [CCAMP] Proposal for YANG model prefix naming

Thanks Daniele

https://protect2.fireeye.com/v1/url?k=9a8a1fdc-c51126bd-9a8a5f47-86d8a30ca42b-e243c3b8875e5f84&q=1&e=1115c25e-b420-49d3-8f20-10e691d487cb&u=https%3A%2F%2Fgithub.com%2Ftsaad-dev%2Fte%2Fissues%2F125

What do you think?

Italo

> The L0 types and the WSON topology drafts are now on hold. We can 
> include them in the updated prefix naming.
> versions are available. The AD (John or Deborah) will need to approve 
> the changes.
> 
> The progress of I-D in the routing area can be erratic.  The fact that 
> the IETF has expired the I-D does not mean that it will not come back 
> to life - a whole raft of I-D that were produced in a rush just before 
> the IETF meeting have just expired 6 months later and some are now 
> being resuscitated, others will be in future, others will not.  Some re-appear years later when their time has come.
> 
> To me, an expired draft says that someone was interested enough to put 
> in a lot of work and even if that work is not current, then it would 
> be a short- sighted naming convention, although well in keeping with 
> the traditions of the IETF, not to cater for such work in future.
> 
> For myself, I like names that start with the most important property 
> and for me, that is WSON. OTN, RSVP and so on, and that is the basis 
> on which I reviewed them, and not the fact that they are te - the 
> rival proposal is for te to be the centre of the universe around which 
> everything revolves, regardless of which WG  - TEAS, CCAMP, ... -it may be in.  I am not a fan of this approach.
> 
> Tom Petch
> 
> CCAMP is currently working on plenty of YANG models, so it might be 
> worth stepping back and getting the prefixes consistent across all of our work.
> I'm not sure this is the most important thing on our list, and perhaps 
> it would be better to discuss the colour of the bike shed, but to make 
> sure that we do this just once, here is my attempt.
> 
> My conclusion is that, although it would be nice to be consistent with 
> using just a suffix of 't' to indicate 'topology', this becomes messy 
> with some of the longer names, and it is clearer to always use 'topo' 
> (leaving the TE topology model as the odd one out).
> 
> This proposal only extends to CCAMP YANG models, and I don't think 
> this list can debate the wider scoping of prefixes, but I think it 
> would extend well enough.
> 
> The list shows...
> Draftname
> (etht-types) ---
> ietf-ext-xponder-wdm-if 
> (ietf-ext-xponder-wdm-if)--->(ext-xponder-wdm-if)
>

---

From: tom petch <[email-masked]>
Date: Fri, 12 Feb 2021 12:28:55 +0000

From: Italo Busi <[email-masked]>
Sent: 12 February 2021 09:02

Thanks Daniele

What do you think?

<tp>
Since TEAS already has its tanks on the lawn, I would go for wsont.

Adrian expressed a preference for ...topo but I think that wrong as it gets too long IMHO as with
ethtetopo
or else
eth-te-topo

Tom Petch
Italo

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 15 Feb 2021 15:16:41 +0000

Thanks for your feedback Tom.

Working group, other opinions? 

Thanks,
Daniele  

-----Original Message-----
From: tom petch <[email-masked]> 
Sent: den 12 februari 2021 13:29
To: Italo Busi <[email-masked]>; Daniele Ceccarelli <[email-masked]>; 'CCAMP' <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: Re: [CCAMP] Proposal for YANG model prefix naming

Thanks Daniele

https://protect2.fireeye.com/v1/url?k=d3d01972-8c4b2077-d3d059e9-86959e472243-ddf7de26918206cd&q=1&e=586b5fcf-a971-4d25-81f3-4c64316f0395&u=https%3A%2F%2Fgithub.com%2Ftsaad-dev%2Fte%2Fissues%2F125

What do you think?

<tp>

Adrian expressed a preference for ...topo but I think that wrong as it gets too long IMHO as with ethtetopo or else eth-te-topo

Tom Petch
Italo

---

From: Young Lee <[email-masked]>
Date: Tue, 16 Feb 2021 07:29:30 +0900

Hi Daniele,

I perfer wson-topo. This is more descriptive than wson-t although it is a
bit long.

Thanks.
Young

2021년 2월 16일 (화) 오전 12:16, Daniele Ceccarelli <daniele.ceccarelli=
[email-masked]>님이 작성:

> To: Italo Busi <[email-masked]>; Daniele Ceccarelli <
> [email-masked]>; 'CCAMP' <[email-masked]>;
> [email-masked]
> Cc: [email-masked]
> I have a slight preference for wsont since it is aligned with tet and nt
> prefix conventions used in RFC8795 and RFC8345 but I can accept wson-topo
> (it could be seen as aligned with wson-tunnel or wson-tnl prefix
> conventions).
>
> What do you think?
>
> <tp>
> Adrian expressed a preference for ...topo but I think that wrong as it
> gets too long IMHO as with ethtetopo or else eth-te-topo
>
> Tom Petch
> Italo
>
> > being resuscitated, others will be in future, others will not.  Some
> re-appear years later when their time has come.
> >

---

From: "Belotti, Sergio (Nokia - IT/Vimercate)" <[email-masked]>
Date: Tue, 16 Feb 2021 14:56:40 +0000

Dear Daniele,
This time I’m not aligned with my friend, Young :
I would rather take shorter  the prefix and more aligned with RFC 8345 and 8795 (nt and tet prefixes) so “wsont” it is my preference.

Thanks
Sergio

From: CCAMP <[email-masked]> On Behalf Of Young Lee
Sent: Monday, February 15, 2021 11:30 PM
To: Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>
Cc: CCAMP <[email-masked]>; [email-masked]; Italo Busi <[email-masked]>
Subject: Re: [CCAMP] Proposal for YANG model prefix naming

Hi Daniele,

I perfer wson-topo. This is more descriptive than wson-t although it is a bit long.

Thanks.
Young

2021년 2월 16일 (화) 오전 12:16, Daniele Ceccarelli <daniele.ceccarelli=[email-masked]<mailto:[email-masked]>>님이 작성:
Thanks for your feedback Tom.

Thanks,
Daniele

-----Original Message-----
From: tom petch <[email-masked]<mailto:[email-masked]>>
Sent: den 12 februari 2021 13:29
To: Italo Busi <[email-masked]<mailto:[email-masked]>>; Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; 'CCAMP' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [CCAMP] Proposal for YANG model prefix naming

From: Italo Busi <[email-masked]<mailto:[email-masked]>>
Sent: 12 February 2021 09:02

Thanks Daniele

What do you think?

<tp>

Tom Petch
Italo

> From: Daniele Ceccarelli [mailto:[email-masked]<mailto:[email-masked]>]
> To: tom petch <[email-masked]<mailto:[email-masked]>>; 'CCAMP' <[email-masked]<mailto:[email-masked]>>;
> [email-masked]<mailto:[email-masked]>
> Cc: [email-masked]<mailto:[email-masked]>
> From: CCAMP <[email-masked]<mailto:[email-masked]>> On Behalf Of tom petch
> To: 'CCAMP' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> Cc: [email-masked]<mailto:[email-masked]>
> From: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
CCAMP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ccamp