Subject: [CCAMP] Notes: CCAMP - Microwave 2021-10-06

From: Jonas Ahlberg <[email-masked]>
Date: Wed, 6 Oct 2021 10:58:13 +0000

Hi all,

Short notes from the CCAMP microwave working group meeting 6 October.

Latest version of the draft is attached.

  *   A github for this work
     *   Scott presented the concept at the meeting – OK
     *   Local environments to be set up for those who would like to run the translations & validations
     *   https://www.rfc-editor.org/styleguide/<https://protect2.fireeye.com/v1/url?k=4e84d345-111fea74-4e8493de-86e2237f51fb-baf7a4ef203884ed&q=1&e=f7899998-d339-4286-a921-9706a55342de&u=https%3A%2F%2Fwww.rfc-editor.org%2Fstyleguide%2F>
     *   https://www.rfc-editor.org/rfc/rfc7322.html#page-20<https://protect2.fireeye.com/v1/url?k=99061782-c69d2eb3-99065719-86e2237f51fb-588aaf9f3064e43a&q=1&e=f7899998-d339-4286-a921-9706a55342de&u=https%3A%2F%2Fwww.rfc-editor.org%2Frfc%2Frfc7322.html%23page-20>
  *   The draft has been updated to become the next version of the CCAMP draft
     *   Check the version number – 02 – Done!
  *   Need to review the draft in more detail and relate it to the use cases it is supposed to support
     *   Use the notes from earlier this year – 2021-02-03 as a reminder of topics discussed
     *   Check that text in draft reflects the fact that it contains three YANG modules - Done
     *   To what extent should the topology model show current values?
Changed very frequently – short time span – milliseconds
Will this info be used as a basis for the operations related to a topology, e.g. path selection?
Any input based on what other technologies have done? (Italo)
        *   Current coding & modulation? - Understand how it will be used?
        *   Current signal condition? - Understand how it will be used?
        *   Current bandwidth (=speed)?
     *   Tx-enabled – Understand/describe if that can be supported by admin-status or not (Jonas)
        *   Tx-enabled is related only to transmission side, instead admin-status is the enabling/disabling of the complete carrier (including both rx and tx)
        *   Look at this in the overall context of how to make use of admin-status & oper-status for tps and links in te-topology.
        *   Bear in mind that links are uni-directional
        *   Link status = oper-status (relationship with carriers possibly in protected mode)
        *   Check the general relationship between status on tps and links (Italo)
     *   Bandwidth utilization (Daniela)
        *   Do nodes provide this info on a link/carrier level?
        *   How often do they change?
        *   Retrieve from node?
     *    Tx Power
        *   Use case for a topology model?

Next meeting October 13

Last day for submitting drafts in time for the next IETF meeting – October 25

Regards,
JonasA

---

From: Italo Busi <[email-masked]>
Date: Tue, 12 Oct 2021 21:06:01 +0000

Jonas,

Aihua and I have discussed the two actions assigned to me

See our feedbacks in line

Thanks

Aihua and Italo

From: Jonas Ahlberg [mailto:[email-masked]]
Sent: mercoledì 6 ottobre 2021 12:58
To: [email-masked]
Subject: [CCAMP] Notes: CCAMP - Microwave 2021-10-06

Hi all,

-          A github for this work
o   Scott presented the concept at the meeting – OK
o   Local environments to be set up for those who would like to run the translations & validations
o   https://www.rfc-editor.org/styleguide/<https://protect2.fireeye.com/v1/url?k=4e84d345-111fea74-4e8493de-86e2237f51fb-baf7a4ef203884ed&q=1&e=f7899998-d339-4286-a921-9706a55342de&u=https%3A%2F%2Fwww.rfc-editor.org%2Fstyleguide%2F>
o   https://www.rfc-editor.org/rfc/rfc7322.html#page-20<https://protect2.fireeye.com/v1/url?k=99061782-c69d2eb3-99065719-86e2237f51fb-588aaf9f3064e43a&q=1&e=f7899998-d339-4286-a921-9706a55342de&u=https%3A%2F%2Fwww.rfc-editor.org%2Frfc%2Frfc7322.html%23page-20>
-          The draft has been updated to become the next version of the CCAMP draft
o   Check the version number – 02 – Done!
-          Need to review the draft in more detail and relate it to the use cases it is supposed to support
o   Use the notes from earlier this year – 2021-02-03 as a reminder of topics discussed
o   Check that text in draft reflects the fact that it contains three YANG modules - Done
o   To what extent should the topology model show current values?
Changed very frequently – short time span – milliseconds
Will this info be used as a basis for the operations related to a topology, e.g. path selection?
Any input based on what other technologies have done? (Italo)

[[Aihua/Italo] ] We think that path selection should be based on the nominal bandwidth (speed) values (which may be different for different levels of availability). However, if needed, the actual bandwidth (speed) can be reported in the MW topology model if needed for other purposes (e.g., troubleshooting, network monitoring). If the value changes too frequently it might be better to use mechanisms like streaming telemetry instead of plain notifications to keep the YANG client updated with optimal control traffic load.

§  Current coding & modulation? - Understand how it will be used?
§  Current signal condition? - Understand how it will be used?
§  Current bandwidth (=speed)?
o   Tx-enabled – Understand/describe if that can be supported by admin-status or not (Jonas)
§  Tx-enabled is related only to transmission side, instead admin-status is the enabling/disabling of the complete carrier (including both rx and tx)
§  Look at this in the overall context of how to make use of admin-status & oper-status for tps and links in te-topology.
§  Bear in mind that links are uni-directional
§  Link status = oper-status (relationship with carriers possibly in protected mode)
§  Check the general relationship between status on tps and links (Italo)

[[Aihua/Italo] ] Unless there is a technology-specific reason to differentiate between LTP and link states, our suggestion is to use only the link state when the link is available in the topology model (e.g., for intra-domain links) and the LTP state only when the LTP exists in the topology model without an associated link (e.g., the LTP of an external link).

o   Bandwidth utilization (Daniela)
§  Do nodes provide this info on a link/carrier level?
§  How often do they change?
§  Retrieve from node?
o    Tx Power
§  Use case for a topology model?

Next meeting October 13

Regards,
JonasA

---

From: "Yemin (Amy)" <[email-masked]>
Date: Wed, 13 Oct 2021 14:35:44 +0000

Dear all,

Sorry that I didn't join the call due to some conflict. Please find my comments as below.

  1.  mw-bandwidth: the definition is not clear whether the mw-bandwidth is refered to the nominal-bandwidth, or the current-bandwidth as the two might be different. I assume it's nominal-bandwidth. This should be clarified.
  2.  some thought on the use case of tx-power. mw is running as radio technology, a mw link might be suffer from the interference from another radio link, it can also cause interference to other radio link. In case of interference is detected, decreasing the tx-power to a allowed power level should ease the interference.

BR,
Amy

________________________________
发件人: CCAMP <[email-masked]> 代表 Italo Busi <[email-masked]>
发送时间: 2021年10月13日 5:06
收件人: 'Jonas Ahlberg'; [email-masked]
抄送: Aihua Guo
主题: Re: [CCAMP] Notes: CCAMP - Microwave 2021-10-06

Jonas,

Thanks

Aihua and Italo

Hi all,

-          A github for this work

§  Retrieve from node?

o    Tx Power

Next meeting October 13

Regards,

JonasA

---

From: "Spreafico, Daniela (Nokia - IT/Vimercate)" <[email-masked]>
Date: Tue, 19 Oct 2021 15:41:08 +0000

Hi all,
here my considerations about Bandwidth utilization (action for me).

The Bandwidth utilization could provide a way to understand whether the nominal (maximum) radio capacity is coherent with the traffic passing through it.
The formula to calculate it has to use the throughput (transmitted data in specific period time ) and the nominal capacity (or nominal maximum bandwidth)
Bandwidth-utilization = [throughput (Mb/s) / nominal-maximum-bandwidth (Mb/s)]  * 100

This information is on link level, taking into account the single carriers and the mode they are combined for the link (1+1, 2+0, etc).
Due to the frequent change of throughput then also the Bandwidth utilization could change frequently.
It is mainly a performance counter (both as statistic/timely data value or on period-time basis data value).

Could it be recovered from the node? It is not a standard counter, so not all devices are able to provide it.
Or based on other data from the node (tx bytes sent) ? In this case it is needed a reference time to calculated delta-time and delta-tx-bytes-sent).
Let’s share your view on these considerations.

BR, Daniela

From: CCAMP <[email-masked]> On Behalf Of Yemin (Amy)
Sent: Wednesday, October 13, 2021 4:36 PM
To: Italo Busi <[email-masked]>; 'Jonas Ahlberg' <[email-masked]>; [email-masked]
Cc: Aihua Guo <[email-masked]>
Subject: Re: [CCAMP] Notes: CCAMP - Microwave 2021-10-06

Dear all,

BR,
Amy
________________________________
发件人: CCAMP <[email-masked]<mailto:[email-masked]>> 代表 Italo Busi <[email-masked]<mailto:[email-masked]>>
发送时间: 2021年10月13日 5:06
收件人: 'Jonas Ahlberg'; [email-masked]<mailto:[email-masked]>
抄送: Aihua Guo
主题: Re: [CCAMP] Notes: CCAMP - Microwave 2021-10-06

Jonas,

Thanks

Aihua and Italo

From: Jonas Ahlberg [mailto:[email-masked]]
Sent: mercoledì 6 ottobre 2021 12:58
To: [email-masked]<mailto:[email-masked]>
Subject: [CCAMP] Notes: CCAMP - Microwave 2021-10-06

Hi all,

-          A github for this work

•  Current coding & modulation? - Understand how it will be used?

•  Current signal condition? - Understand how it will be used?

•  Current bandwidth (=speed)?

•  Tx-enabled is related only to transmission side, instead admin-status is the enabling/disabling of the complete carrier (including both rx and tx)

•  Look at this in the overall context of how to make use of admin-status & oper-status for tps and links in te-topology.

•  Bear in mind that links are uni-directional

•  Link status = oper-status (relationship with carriers possibly in protected mode)

•  Check the general relationship between status on tps and links (Italo)

•  Do nodes provide this info on a link/carrier level?

•  How often do they change?

•  Retrieve from node?

o    Tx Power

•  Use case for a topology model?

Next meeting October 13

Regards,

JonasA