Subject: [CCAMP] I-D Action: draft-ietf-ccamp-mw-topo-yang-02.txt

From: [email-masked]
Date: Fri, 22 Oct 2021 06:31:58 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Common Control and Measurement Plane WG of the IETF.

        Title           : A YANG Data Model for Microwave Topology
        Authors         : Jonas Ahlberg
                          Scott Mansfield
                          Min Ye
                          Italo Busi
                          Xi Li
                          Daniela Spreafico
	Filename        : draft-ietf-ccamp-mw-topo-yang-02.txt
	Pages           : 36
	Date            : 2021-10-22

Abstract:
   This document defines three YANG data models to describe topologies
   of microwave/millimeter radio links and bandwidth availability for a
   link in general, as well as to reference interface management
   information from a termination point.

RFC Ed.  Note

   // RFC Ed.: replace all XXXX throughout the document with actual RFC
   numbers and remove this note

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ccamp-mw-topo-yang/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-ccamp-mw-topo-yang-02.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ccamp-mw-topo-yang-02

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Jonas Ahlberg <[email-masked]>
Date: Fri, 22 Oct 2021 14:17:57 +0000

Hi all,

A new draft for "A YANG Data Model for Microwave Topology" is now available.
It is an evolution of the draft "draft-ietf-ccamp-mw-topo-yang-01" submitted in March 2019.

The main changes are:
- Modeling of both radio-links and carriers as separate link entities
- Introduction of two additional modules, usable/applicable also for other technologies
      - Bandwidth availability for links with variable/adaptive link bandwidth
      - A way to reference the information in a YANG data model for interface management [RFC8343] from a termination point
- A recommendation, in terms of a tree of supported leafs, on a more limited usage of the "YANG Data Model for Traffic Engineering (TE) Topologies" for a microwave topology
- A json example of a simple microwave link

Regards
JonasA (on behalf of the authors) 

-----Original Message-----
From: CCAMP <[email-masked]> On Behalf Of [email-masked]
Sent: den 22 oktober 2021 15:32
To: [email-masked]
Cc: [email-masked]
Subject: [CCAMP] I-D Action: draft-ietf-ccamp-mw-topo-yang-02.txt

Abstract:

RFC Ed.  Note

_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp