Subject: [CDNi] Requirements from the Content Service Provider

From: Songhaibin <[email-masked]>
Date: Mon, 14 Mar 2011 13:04:18 +0000

Hi Folks,

This is another topic I would like to put into this list for discussion.

Content Service Providers may have various requirements for the CDN. For example, specific encryption algorithms, or to support iPAD. The CDN may need to do some optimization engineering work for those requirements. Some CDNs are preferred because they do a lot of work to make it more efficient with low lost to meet these specific requirements.  I want to know how to solve this in the interconnected CDN scenarios because the CSP's requirements are changing all the time. 

By the way, there will be no such a problem if the CSP only requires the CDN to provide download service.

BR,
Haibin

---

From: "Lee, Yiu" <[email-masked]>
Date: Mon, 14 Mar 2011 14:30:36 +0000

Hi Haibin,

IMHO, DRM should not happen in the downstream CDN.? The CSP/A-CDN should
have encrypted the content before caching it in the downstream cdn. The
key and algorithm should be only exchanged between the CSP/A-CDN and the
client. The downstream CDN should not know the key or DRM of the content.

/Yiu

On 3/14/11 9:04 AM, "Songhaibin" <[email-masked]> wrote:

>Content Service Providers may have various requirements for the CDN. For
>example, specific encryption algorithms, or to support iPAD. The CDN may
>need to do some optimization engineering work for those requirements.
>Some CDNs are preferred because they do a lot of work to make it more
>efficient with low lost to meet these specific requirements.  I want to
>know how to solve this in the interconnected CDN scenarios because the
>CSP's requirements are changing all the time.
>
>_______________________________________________
>CDNi mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/cdni

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 15 Mar 2011 04:19:58 +0000

Haibin,

> Content Service Providers may have various requirements for the CDN. For example, specific encryption algorithms, or to support iPAD. The CDN may need to do some optimization engineering work for t…

The delivery requirements for the content are encapsulated in the content distribution metadata exactly as they would be for a single CDN scenario.

It is always possible that a single CDN may be able to react to changing market requirements faster than interconnected CDNs and therefore a CSP that has brand new requirements may be limited in the CDNs that they can use until the market (and the standards) catch up.

That is a common issue for many technologies and standardised protocols and is not unique to CDNI.

Ben