Subject: [CDNi] A business issues on CDNI

From: Songhaibin <[email-masked]>
Date: Mon, 14 Mar 2011 13:28:57 +0000

Hi Folks,

I definitely know that IETF is not a place to discuss business issues. But I still would like to hear thoughts from some guys as I think this might be interesting.

CDN may give different price to different CSPs because their requirements are different. Then let's compare these two scenarios:

(1) in CDN interconnection scenario, a CDN operator may need to talk with its downstream CDN about delivery price for this specific CSP, and then can delegate the delivery to that CDN; the CSP only needs to select one CDN;

(2) A CSP talk with two CDNs, and then delegate the delivery to them without CDN interconnection;

I am not sure which one is better than another.

I would like to add that I did not want to give an impression that CDN interconnection is useless. It is still useful in some cases, such as those listed in the usecase draft. 

BR,
Haibin

---

From: Ping Pan <[email-masked]>
Date: Mon, 14 Mar 2011 06:59:10 -0700

Isn't much of this being included in draft-ma-cdni-publisher-use-cases-00?

It seems to be using a workflow management agent for this type of
negotiation...

Ping

On Mon, Mar 14, 2011 at 6:28 AM, Songhaibin <[email-masked]> wrote:

> Hi Folks,
>
> I definitely know that IETF is not a place to discuss business issues. But
> I still would like to hear thoughts from some guys as I think this might be
> interesting.
>
> CDN may give different price to different CSPs because their requirements
> are different. Then let's compare these two scenarios:
>
> (1) in CDN interconnection scenario, a CDN operator may need to talk with
> its downstream CDN about delivery price for this specific CSP, and then can
> delegate the delivery to that CDN; the CSP only needs to select one CDN;
>
> I would like to add that I did not want to give an impression that CDN
> interconnection is useless. It is still useful in some cases, such as those
> listed in the usecase draft.
>
> BR,
> Haibin
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni
>

---

From: <[email-masked]>
Date: Mon, 14 Mar 2011 15:51:53 +0100

Hi Haibin

IMO there is no business issue for the CSP because these use cases are complementary: one of the CDN of (2) may correspond to the CDN interconnection given in (1).

Regards
Emile

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Songhaibin
> Envoyé : lundi 14 mars 2011 14:29
> À : [email-masked]
> Objet : [CDNi] A business issues on CDNI
> 
> Hi Folks,
> 
> I still would like to hear thoughts from some guys as I think this might
> be interesting.
> 
> its downstream CDN about delivery price for this specific CSP, and then
> can delegate the delivery to that CDN; the CSP only needs to select one
> CDN;
> 
> interconnection is useless. It is still useful in some cases, such as
> those listed in the usecase draft.
> 
> BR,
> Haibin

---

From: Songhaibin <[email-masked]>
Date: Tue, 15 Mar 2011 01:47:50 +0000

Hi Emile,

Thanks for your response. I mean if it is still complex for two CDNs to interconnect, a CSP may choose the direct way to delegate the delivery to different CDNs.

BR,
Haibin

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Monday, March 14, 2011 10:52 PM
> To: Songhaibin; [email-masked]
> Subject: RE: [CDNi] A business issues on CDNI
> 
> 
> Hi Haibin
> 
> IMO there is no business issue for the CSP because these use cases are
> complementary: one of the CDN of (2) may correspond to the CDN
> interconnection given in (1).
> 
> Regards
> Emile
>

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 15 Mar 2011 04:30:14 +0000

Haibin,

> I definitely know that IETF is not a place to discuss business issues. But I still would like to hear thoughts from some guys as I think this might be interesting.

You are right, IETF is not the right place to discuss this.

> I am not sure which one is better than another.

You vastly oversimplify the business context. Regardless, it is not a matter of which one is better. The real questions are whether there is a market demand for a standardised way to interconnect CDNs and whether IETF is the right place to do that standardisation?

Part of the objective of the upcoming BoF is to judge whether there is consensus that there is a market demand, whether the current drafts and proposed charter appropriately document that demand and whether IETF is the place to progress the CDNI work.

Ben