Subject: [CDNi] Updated version of the CDNI charter

From: "Woundy, Richard" <[email-masked]>
Date: Thu, 31 Mar 2011 14:43:43 +0000

Folks,

I wanted everyone to have an updated version of the CDNI draft charter below, for discussion at the BOF shortly. This is based on input from many people this week, including people that attended the informal CDNI gathering last night. It is available online at <http://www.ietf.org/proceedings/80/slides/cdni-9.txt>, and has been updated on the BOF wiki <http://trac.tools.ietf.org/bof/trac/wiki/WikiStart>.

The meeting materials for the BOF are available here: <https://datatracker.ietf.org/meeting/80/materials.html#wg-cdni>.

-- Rich and Francois

Content Delivery Networks Interconnection (CDNI) - Draft Charter
----------------------------------------------------------------

Description of Working Group
============================

A Content Delivery Network (CDN) is an infrastructure of network elements operating at layer 4 through layer 7, arranged for the efficient distribution and delivery of digital content. Such content includes, but is not limited to, web pages and images delivered via HTTP, and streaming of continuous media delivered via HTTP, RTSP, RTMP, etc. CDNs typically provide services to multiple Content Service Providers (CSPs).

CDNs provide numerous benefits: a shared platform for multi-service content delivery, reduced transmission costs for cacheable content, improved quality of experience for end users and increased robustness of delivery. For these reasons they are frequently used for large-scale content delivery.

As a result of the significant growth in content delivered over IP networks, existing CDN providers are scaling up their infrastructure and many Network Service Providers and Enterprise Service Providers are deploying their own CDNs. Subject to the policy of the CSP, it is generally desirable that a given item of content can be delivered to an end user regardless of that end user's location or attachment network. This creates a need for interconnecting (previously) standalone CDNs so they can interoperate and collectively behave as a single delivery infrastructure.

The goal of the CDNI Working Group is to allow the interconnection of separately administered CDNs in support of the end-to-end delivery of content from CSPs through multiple CDNs and ultimately to end users (via their respective User Agents). The CDNI WG aims at delivering a targeted, deployable solution in a short timeframe (18-24 months) as needed by the industry. It is expected that the CDNI interfaces will be realized using existing IETF protocols for transport and message exchange, and using existing object notation grammars/languages for the definition of CDNI objects and semantics. In the event that protocol extensions or new protocols are deemed necessary by the WG, the WG will recharter.

The working group will focus on the following items:

- A "problem statement" document providing a description of the problem and a common terminology.

- A "use case" document describing scenarios for usage and applications of the CDNI solution and protocols

- A "framework" document providing a description of the different components of the CDNI solution and how they interact with and relate to one another.

- A "requirements" document. This document lists the requirements for CDNI architecture and the protocols to support it. In particular, this document will focus on identifying a reasonable set of more urgent and important requirements that will be addressed in the initial set of CDNI protocols and solutions produced by the working group.

- A detailed specification of the interfaces for the interconnection & interoperation of:

        o CDNI request-routing systems. In particular, this interface will allow an upstream CDN request routing system to obtain from the downstream CDN the information necessary to perform request redirection.

        o CDNI metadata distribution systems. This interface will allow the CDNs to exchange distribution metadata of inter-CDN scope. Distribution metadata refers to the subset of content metadata that is relevant to the distribution of the content and therefore is to be processed by CDNs (for example, this may include information enabling: content acquisition, geo-blocking, enforcement of availability windows or access control).

        o CDNI logging systems. This interface will allow CDN logging systems to exchange logging information associated with actions that are relevant across CDNs (such as content distribution, content delivery and content routing actions) for purposes of accounting, analytics, monitoring, etc.

        o CDN control systems. In particular, this interface will allow an upstream CDN to remove or invalidate content in a downstream CDN.

The WG will discuss and address the security (including threat model), management and operational issues specific to CDNI, inside the above documents and specifications.

The working group will only define solutions for aspects of the CDN Interconnection problem space that require direct communication or interoperation between CDNs.

In particular, the WG will not define:
- New session, transport or network protocols.
- New protocols for delivering content from a CDN to an End User/User Agent.
- New protocols for ingestion of content or metadata between a CSP and a CDN.
- New protocols for acquiring content across CDNs.
- Protocols and algorithms for intra-CDN operations.
- Support for Transparent Caching across CDNs.
- New applications consuming CDNI logs.

The WG will work with other WGs to assess, and where appropriate, leverage protocols developed by those WGs, in order to realize the CDNI requirements and CDNI interfaces. For example, the WG may assess the suitability of the ALTO protocol as a protocol to enable downstream CDNs to exchange information which may aid an upstream CDN with making CDNI request routing decisions.

Goals & Milestones
==================

WG Creation + 6 months:        Submit CDNI problem statement to IESG as Informational
WG Creation + 9 months:        Submit CDNI use cases to IESG as Informational
WG Creation + 12 months:       Submit CDNI framework to IESG as Informational
WG Creation + 12 months:       Submit CDNI requirements to IESG as Informational
WG Creation + 18 months:       Submit specification of the CDNI Request Routing interface to IESG as Proposed Standard
WG Creation + 18 months:       Submit specification of the CDNI Logging interface to IESG as Proposed Standard
WG Creation + 18 months:       Submit specification of the CDNI Control interface to IESG as proposed Standard
WG Creation + 24 months:       Submit specification of the CDNI Metadata Distribution interface to IESG as Proposed Standard
WG Creation + 24 months:       Recharter or dissolve

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 31 Mar 2011 17:14:35 +0200

I'm sorry that I won't be able to attend the BoF, since I will be in the
PRECIS WG session at that time.

Overall I think this proposed charter looks quite good. I have one
question at this time, about the phrase "through multiple CDNs". Which
of the following is true?

(1) a CDN will deliver content to end users by communicating
individually with a set of other CDNs, each of which directly delivers
the content to end users

(2) a CDN will deliver content to end users by communicating with a set
of CDNs, each of which might send that content to other CDNs (etc.),
eventually resulting in the content being delivered to end users

On 3/31/11 4:43 PM, Woundy, Richard wrote:
> Folks,
> 
>  
> 
> I wanted everyone to have an updated version of the CDNI draft charter
> below, for discussion at the BOF shortly. This is based on input from
> many people this week, including people that attended the informal CDNI
> gathering last night. It is available online at
> <http://www.ietf.org/proceedings/80/slides/cdni-9.txt>, and has been
> updated on the BOF wiki
> <http://trac.tools.ietf.org/bof/trac/wiki/WikiStart>.
> 
>  
> 
> The meeting materials for the BOF are available here:
> <https://datatracker.ietf.org/meeting/80/materials.html#wg-cdni>.
> 
>  
> 
> -- Rich and Francois
> 
>  
> 
> A Content Delivery Network (CDN) is an infrastructure of network
> elements operating at layer 4 through layer 7, arranged for the
> efficient distribution and delivery of digital content. Such content
> includes, but is not limited to, web pages and images delivered via
> HTTP, and streaming of continuous media delivered via HTTP, RTSP, RTMP,
> etc. CDNs typically provide services to multiple Content Service
> Providers (CSPs).
> 
>  
> 
> CDNs provide numerous benefits: a shared platform for multi-service
> content delivery, reduced transmission costs for cacheable content,
> improved quality of experience for end users and increased robustness of
> delivery. For these reasons they are frequently used for large-scale
> content delivery.
> 
>  
> 
> As a result of the significant growth in content delivered over IP
> networks, existing CDN providers are scaling up their infrastructure and
> many Network Service Providers and Enterprise Service Providers are
> deploying their own CDNs. Subject to the policy of the CSP, it is
> generally desirable that a given item of content can be delivered to an
> end user regardless of that end user's location or attachment network.
> This creates a need for interconnecting (previously) standalone CDNs so
> they can interoperate and collectively behave as a single delivery
> infrastructure.
> 
>  
> 
> The goal of the CDNI Working Group is to allow the interconnection of
> separately administered CDNs in support of the end-to-end delivery of
> content from CSPs through multiple CDNs and ultimately to end users (via
> their respective User Agents). The CDNI WG aims at delivering a
> targeted, deployable solution in a short timeframe (18-24 months) as
> needed by the industry. It is expected that the CDNI interfaces will be
> realized using existing IETF protocols for transport and message
> exchange, and using existing object notation grammars/languages for the
> definition of CDNI objects and semantics. In the event that protocol
> extensions or new protocols are deemed necessary by the WG, the WG will
> recharter.
> 
>  
> 
> - A "framework" document providing a description of the different
> components of the CDNI solution and how they interact with and relate to
> one another.
> 
>  
> 
> - A "requirements" document. This document lists the requirements for
> CDNI architecture and the protocols to support it. In particular, this
> document will focus on identifying a reasonable set of more urgent and
> important requirements that will be addressed in the initial set of CDNI
> protocols and solutions produced by the working group.
> 
>  
> 
>         o CDNI request-routing systems. In particular, this interface
> will allow an upstream CDN request routing system to obtain from the
> downstream CDN the information necessary to perform request redirection.
> 
>  
> 
>         o CDNI metadata distribution systems. This interface will allow
> the CDNs to exchange distribution metadata of inter-CDN scope.
> Distribution metadata refers to the subset of content metadata that is
> relevant to the distribution of the content and therefore is to be
> processed by CDNs (for example, this may include information enabling:
> content acquisition, geo-blocking, enforcement of availability windows
> or access control).
> 
>  
> 
>         o CDNI logging systems. This interface will allow CDN logging
> systems to exchange logging information associated with actions that are
> relevant across CDNs (such as content distribution, content delivery and
> content routing actions) for purposes of accounting, analytics,
> monitoring, etc.
> 
>  
> 
>         o CDN control systems. In particular, this interface will allow
> an upstream CDN to remove or invalidate content in a downstream CDN.
> 
>  
> 
> The WG will discuss and address the security (including threat model),
> management and operational issues specific to CDNI, inside the above
> documents and specifications.
> 
>  
> 
> The working group will only define solutions for aspects of the CDN
> Interconnection problem space that require direct communication or
> interoperation between CDNs.
> 
>  
> 
> The WG will work with other WGs to assess, and where appropriate,
> leverage protocols developed by those WGs, in order to realize the CDNI
> requirements and CDNI interfaces. For example, the WG may assess the
> suitability of the ALTO protocol as a protocol to enable downstream CDNs
> to exchange information which may aid an upstream CDN with making CDNI
> request routing decisions.
> 
>  
> 
>  
> 
> Goals & Milestones
> 
> ==================
> 
>  
> 
> WG Creation + 18 months:       Submit specification of the CDNI Request
> Routing interface to IESG as Proposed Standard
> 
> WG Creation + 24 months:       Submit specification of the CDNI Metadata
> Distribution interface to IESG as Proposed Standard
>

---

From: Francois Le Faucheur <[email-masked]>
Date: Thu, 31 Mar 2011 17:24:27 +0200

> eventually resulting in the content being delivered to end users

This has been discussed and the general feeling was that (2) is highly desirable but we need to make some progress on solutions before we can make a determination as to whether it can be chewed in the targeted timeframe and therefore included in the initial charter.

So for now, in the Requirements I-D, (1) is a MUST and (2) is a SHOULD.

Francois

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: "Woundy, Richard" <[email-masked]>
Date: Thu, 31 Mar 2011 15:26:56 +0000

I just want to highlight that the current text is the PROPOSED charter.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Woundy, Richard
Sent: Thursday, March 31, 2011 4:44 PM
To: [email-masked]
Subject: [CDNi] Updated version of the CDNI charter

Folks,

-- Rich and Francois

Goals & Milestones
==================