Subject: [CDNi] CDNI BOF - draft minutes posted for comments

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 6 Apr 2011 17:53:32 +0200

Hello,

Draft CDNI BOF minutes are available from the IETF meeting materials website:
http://www.ietf.org/proceedings/80/minutes/cdni.txt

Please provide corrections & comments as needed.

Thanks

Francois & Richard

PS: thanks to Emile for providing his notes as the basis for these minutes.

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Wed, 6 Apr 2011 21:02:29 +0100

Francois,

Thanks for the minutes, they seem a fair reflection of the BoF (at least my recollection of it).

One minor editorial nit, regarding Bruce's presentation on ATIS the minutes state "He recalls ATIS rule and importance" I guess you mean "ATIS role" :-)

Ben

On 6 Apr 2011, at 16:53, Francois Le Faucheur wrote:

> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Francois Le Faucheur <[email-masked]>
Date: Thu, 7 Apr 2011 10:47:14 +0200

> One minor editorial nit, regarding Bruce's presentation on ATIS the minutes state "He recalls ATIS rule and importance" I guess you mean "ATIS role" :-)

Fixed.
Tx.

---

From: Ping Pan <[email-masked]>
Date: Thu, 7 Apr 2011 05:49:54 -0700

Hi, Francois,

Thanks for the notes.

I take the following is an accurate description of the work to be done here,
correct?

+ Francois: we say that we need only to define several schema. If we
need ALTO extensions this still only requires work on schema and not
definition of new protocol or protocol extensions per say (whether
done in CDNI WG or in ALTO WG).
+ Bruce Davie: it is pretty clear that CDNI does not require protocol
work (ie only schema definition).

Regards,

- Ping

---

From: Francois Le Faucheur <[email-masked]>
Date: Thu, 7 Apr 2011 17:19:28 +0200

Hi Ping,

On 7 Apr 2011, at 14:49, Ping Pan wrote:

> Hi, Francois,
> 
> Thanks for the notes.
> 
> I take the following is an accurate description of the work to be done here, correct?

Let's say that:
	* this is an accurate description of what a lot of the people involved in the CDNI effort believe
	* the proposed charter is drafted in line with that assumption

In particular, the proposed draft charter (http://www.ietf.org/proceedings/80/slides/cdni-9.txt) currently says:
"
It is expected that the CDNI interfaces will be realized using existing IETF protocols for transport and message exchange, and using existing object notation grammars/languages for the definition of CDNI objects and semantics. In the event that protocol extensions or new protocols are deemed necessary by the WG, the WG will recharter.
"

Cheers

Francois

> 
> + Francois: we say that we need only to define several schema. If we need ALTO extensions this still only requires work on schema and not definition of new protocol or protocol extensions per say (whether done in CDNI WG or in ALTO WG). 
> + Bruce Davie: it is pretty clear that CDNI does not require protocol work (ie only schema definition).
> 
> 
> Regards,
> 
> - Ping
> 
> 
> On Wed, Apr 6, 2011 at 8:53 AM, Francois Le Faucheur <[email-masked]> wrote:
> Hello,
>

---

From: Ping Pan <[email-masked]>
Date: Thu, 7 Apr 2011 08:27:03 -0700

Here is the IETF WG info:

https://datatracker.ietf.org/wg/alto/charter/

Started as a way to control P2P traffic:

http://cs-www.cs.yale.edu/homes/yong/p4p.html

It has evolved to control CDN as well

http://www.ietf.org/id/draft-penno-alto-cdn-03.txt

Hope it helps!

- Ping

On Thu, Apr 7, 2011 at 8:22 AM, SAYKO, ROBERT J (ATTSI) <[email-masked]>wrote:

> Francois, Ping,
>
> Can either of  you point me to a resource to learn about ALTO?  No one
> here at AT&T (that I have spoken with) has any clue as to what that is.
>
> Regards,
> Bob
>
>
> Robert Sayko
> AT&T Labs
> 732-420-3292
> [email-masked]
>
>
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Francois Le Faucheur
> Sent: Thursday, April 07, 2011 11:19 AM
> To: Ping Pan
> Cc: [email-masked]
> Subject: Re: [CDNi] CDNI BOF - draft minutes posted for comments
>
> Hi Ping,
>
> In particular, the proposed draft charter
> (http://www.ietf.org/proceedings/80/slides/cdni-9.txt) currently says:
> "
> It is expected that the CDNI interfaces will be realized using existing
> IETF protocols for transport and message exchange, and using existing
> object notation grammars/languages for the definition of CDNI objects
> and semantics. In the event that protocol extensions or new protocols
> are deemed necessary by the WG, the WG will recharter.
> "
>
> Cheers
>
> Francois
>
> >
> definition of new protocol or protocol extensions per say (whether done
> in CDNI WG or in ALTO WG).

---

From: Francois Le Faucheur <[email-masked]>
Date: Tue, 12 Apr 2011 14:51:45 +0200

Hello,

The comments received on the draft minutes have been incorporated in updated CDNI BOF Minutes available at:
http://www.ietf.org/proceedings/80/minutes/cdni.htm

Cheers

Francois & Rich

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 12 Apr 2011 14:58:30 -0500

My apologies for late comments, of course.

And thanks for a really well-executed BOF.

Spencer

+ Rich: the WG will have to consider and address this privacy issue.
+ Jason: every IETF document has a security section and it could be covered 
there.
+ Spencer Dawkins (?): this has to be handled when the WG is set up

- Not sure what the (?) was meant to be - but I also noticed there are a 
couple of "Spencer Dawkins (IAB)"s further down, but I was actually 
attending this BOF as an individual. Could the (?) and (IAB)s go away?

- What I intended to say was, "this can be handled by the work group, and 
shouldn't gate chartering".

...

+ Eric Burger: We should identify the requirements that UltraViolet may 
place on CDNI.
+ Jon Peterson (IAB and UltraViolet hat also) : UltraViolet may be relevant 
(eg they also define metadata). UltraViolet folks are aware of this new CDNI 
activity.
+ Spencer Dawkins (IAB): it would be smart to have discussions with these 
people (for the final charter)

- What I meant to say was "It would be smart to have discussions with these 
people, but that can be added to the charter as one of the groups that the 
CDNI working group would coordinate with."

...

** Discussion before the hum test

+ Spencer: did you mention a couple of protocols that may need to be 
extended?
+ Francois: only need to define a schema, but no new schema languages and no 
new protocol or protocol extensions;
+ Ben: no new schema languages and no new protocol or protocol extensions 
needed.
+ ?: but there was mention of potential ALTO extensions? Does this need to 
be brought up in the charter?
+ Spencer: no need to do that in the charter

- What I meant to say was, "no need to delay chartering to discuss potential 
ALTO extensions, since you can do CDNI without relying on those extensions".

...

+ Eric & Spencer: charter to do this without extending existing protocols
+ Francois: we say that we need only to define several schema. If we need 
ALTO extensions this still only requires work on schema and not definition 
of new protocol or protocol extensions per say (whether done in CDNI WG or 
in ALTO WG).
+ Bruce Davie: it is pretty clear that CDNI does not require protocol work 
(ie only schema definition).
+ Spencer: ok to define a protocol at schema level: are you going to need 
the extension of protocol that another WG is in charge of?

- What I meant to ask here was whether CDNI would rely on any extensions of 
protocols that another WG is in charge of, so that we would need to discuss 
those extensions with another WG as part of chartering CDNI. I thought the 
answer was "no" :D

+ ? : potential extra work for ALTO need not be decided/spelled out in the 
charter.

---

From: Francois Le Faucheur <[email-masked]>
Date: Tue, 12 Apr 2011 22:55:43 +0200

Hello Spencer,

> My apologies for late comments, of course.

no problems.

> + Jason: every IETF document has a security section and it could be covered there.
> - Not sure what the (?) was meant to be - but I also noticed there are a couple of "Spencer Dawkins (IAB)"s further down, but I was actually attending this BOF as an individual. Could the (?) and (IAB)s go away?

fixed.

> 
> - What I intended to say was, "this can be handled by the work group, and shouldn't gate chartering".
> 

fixed.

> ...
> 
> + Eric Burger: We should identify the requirements that UltraViolet may place on CDNI.
> + Jon Peterson (IAB and UltraViolet hat also) : UltraViolet may be relevant (eg they also define metadata). UltraViolet folks are aware of this new CDNI activity.
> + Spencer Dawkins (IAB): it would be smart to have discussions with these people (for the final charter)
> 
> - What I meant to say was "It would be smart to have discussions with these people, but that can be added to the charter as one of the groups that the CDNI working group would coordinate with."

fixed.
Sorry for missing that. We 'll also reflect that in the draft charter, unless we hear dissent. 

> + Spencer: did you mention a couple of protocols that may need to be extended?
> + Francois: only need to define a schema, but no new schema languages and no new protocol or protocol extensions;
> + Ben: no new schema languages and no new protocol or protocol extensions needed.
> + ?: but there was mention of potential ALTO extensions? Does this need to be brought up in the charter?
> - What I meant to say was, "no need to delay chartering to discuss potential ALTO extensions, since you can do CDNI without relying on those extensions".
> 

Please see below.

> + Spencer: ok to define a protocol at schema level: are you going to need the extension of protocol that another WG is in charge of?
> 
> - What I meant to ask here was whether CDNI would rely on any extensions of protocols that another WG is in charge of, so that we would need to discuss those extensions with another WG as part of chartering CDNI. I thought the answer was "no" :D

> + ? : potential extra work for ALTO need not be decided/spelled out in the charter. 

Here is how I see the situation.

Among other things, the CDNI solution:
	* _must_ define a base exchange of request-routing information across CDNs. This would be specified as the "CDNI Request Routing interface" that is a deliverable of the CDNI WG.
	* _may_ also define expanded exchange of request-routing related information across CDNs (eg to allow dynamic discovery of downstream CDN footprint/capabilities/...). This may or may not be part of the initial CDNI solution. If it is part of it, how much "expanded" exchange to support is to be decided by the WG. If is part of it, the WG would consider several candidate "protocol stacks" to support it which include (i) incorporate this into the "CDNI Request Routing interface", (ii) get it incorporated in ALTO and (iii) get it advertised using BGP.

I believe the general sense was that the above determinations (i.e. do we want to do expanded exchange of request-routing info? if yes, how much? if yes, using which base protocol stack?) would be best done if/once there is a WG since they require better understanding/convergence on the trade-offs. So this was intended to be left open in the draft charter. 

So, in summary, I would say that the answer to your question was :
"CDNI does not rely on extensions that another WG is in charge of, but may potentially, at a later stage, propose requirements to be taken on by another WG (ie ALTO).
Noting that this is just one of many potential outcomes (eg a CDNI WG may decide to not cover this functionality in initial scope, or may conclude that it be better realized in other ways than using ALTO)."

Not quite as short answer as "no",  8^). 

Thanks

Francois

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 12 Apr 2011 17:37:32 -0500

Francois,

Ack, and thanks for your note on my last item. I'm fine with where you are.

Spencer

----- Original Message ----- 
  From: Francois Le Faucheur 
  To: Spencer Dawkins 
  Cc: Francois Le Faucheur ; [email-masked] 
  Sent: Tuesday, April 12, 2011 3:55 PM
  Subject: Re: [CDNi] CDNI BOF - final minutes posted

  Hello Spencer,

  no problems.

    Spencer

  fixed.

  fixed.

    ...

  fixed.

    ...

  Please see below.

    ...

  Thanks

  Francois