Subject: [CDNi] Recursive & Iterative definitions

From: <[email-masked]>
Date: Thu, 11 Aug 2011 15:40:36 +0100

Hi,
Currently the definitions for Recursive & Iterative CDNI Request Routing appear in the use-cases document. The authors had some discussion that the definitions could be clearer. Below is a possible variant.

I think that all the definitions are being moved into one document? - so this is just a suggestion for the editor of the Definitions document

Recursive & Iterative CDNI Request Routing
CDNI request routing involves the Upstream CDN electing to redirect a route request towards a Downstream CDN.
There are two possibilities for what happens next

1.       (recursive) the Downstream CDN advises the Upstream CDN how to handle the route request. For example, it might (1) indicate one of its own surrogates or (2) a third CDN to try. The Upstream CDN then sends a new route request (1) to the second CDN's surrogate or (2) towards the third CDN.

2.       (iterative) the Downstream CDN decides how to handle the route request without referring back to the Upstream CDN. It could forward the route request, for example, (1) to one of its own surrogates or (2) towards a third CDN. In the latter case, it now plays the role of the Upstream CDN and the third CDN acts as a Downstream CDN.
A picture would help as well

Best wishes
Phil/

Philip Eardley
Research and Technology Strategy

This email contains BT information, which may be privileged or confidential. It's meant only for the individual(s) or entity named above. If you're not the intended recipient, note that disclosing, copying, distributing or using this information is prohibited. If you've received this email in error, please let me know immediately on the email address above. Thank you. We monitor our email system, and may record your emails.
British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000

---

From: ZhouZhipeng <[email-masked]>
Date: Fri, 12 Aug 2011 01:27:02 +0000

Hi Philip,
A comment: if the Downstream CDN may not fulfill the task, it may just feedback “unavailable”.
Whether or not to advise the Upstream CDN of the next route is not necessary.
Thanks.
Zhipeng

发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2011年8月11日 22:41
收件人: [email-masked]
主题: [CDNi] Recursive & Iterative definitions

Hi,

1.      (recursive) the Downstream CDN advises the Upstream CDN how to handle the route request. For example, it might (1) indicate one of its own surrogates or (2) a third CDN to try. The Upstream CDN then sends a new route request (1) to the second CDN’s surrogate or (2) towards the third CDN.

Best wishes
Phil/

Philip Eardley