Subject: Re: [CDNi] Fwd: comments on draft-bertrand-cdni-use-cases-02

From: Bhumip Khasnabish <[email-masked]>
Date: Thu, 4 Aug 2011 11:01:01 -0400

Hello,

Please note that "well-accepted" and "opaque" elements may be different in
different environment (region, provider, context, etc.).
May be some *specific* examples are needed on what one means
by  "well-accepted" and "opaque" metadata elements in
region/provider/context/... ... ... . Thanks.

Best.

Bhumip

On Fri, Jul 29, 2011 at 10:03 AM, Francois Le Faucheur
<[email-masked]>wrote:

> Ken, Yiu,
>
> Can you add into your list of tracked candidate items something reflecting
> this thread? ie ensuring cdni-requirements incorporates requirements on the
> CDNI Metadata interface covering:
> *A* ability to exchange a set of well-accepted metadata elements with
> specified semantics (eg start of time window, end of time window,...), AND
> *B* ability to allow exchange of opaque metadata element, whose semantic is
> not defined in CDNI but left up to private CDN agreement.
>
> Dave Oran also privately suggested that we expand on *B* to cover the usual
> distribution options for treatment of opaque element (eg
> ignore-and-pass-on-when-not-understood, etc). Which makes sense to me.
>
> Thanks
>
> Francois
>
> Begin forwarded message:
>
>  *From: *Kevin J Ma <[email-masked]>
> *Date: *28 July 2011 17:35:22 EDT
> *To: *Francois Le Faucheur <[email-masked]>
> *Cc: *Francois Le Faucheur <[email-masked]>, "Kent Leung (kleung)" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <
> [email-masked]>
>   *Subject: **Re: [CDNi] comments on draft-bertrand-cdni-use-cases-02*
>
>  i think there could be alot of debate about what qualifies as A.
>
> one solution would be to go with just B, for requirements, but
> either way is ok with me.
>
> Sent from my iPhone
>
> On Jul 28, 2011, at 5:22 PM, "Francois Le Faucheur" <[email-masked]>
> wrote:
>
>
>  On 28 Jul 2011, at 16:54, Kevin J Ma wrote:
>
>   Just one quick comment: it was not necessarily the intent of the use
> cases to imply****
> that CDNI requirements be generated for each piece of metadata; the
> metadata may be****
> useful for certain deployments, but opaque metadata distribution may be
> sufficient?****
> ** **
> There was discussion early on about metadata with implied actions like:
> expiration,****
> or sunset/sunrise, or ssl only, or url hashing required, or content
> transformation,****
> or do accounting, or other proprietary optimization or policy enforcement
> features,****
> etc., but its not clear that we would want CDNI requirements for each of
> these?****
> ** **
> It seems like a more generic notion of defining metadata (and their
> actions), and****
> allowing CDNs to advertise or decline metadata (action) support would
> useful, as****
> opposed to adding a requirement for each piece of metadata?
>
>
> I have been assuming that we'd want to specify:
> *A* a set of well-accepted metadata elements with their semantics (eg start
> of time window, end of time window,...), AND
> *B* probably, also a mechanism to allow exchange of opaque metadata
> element, whose semantic is not defined in CDNI but up to private CDN
> agreement.
>
> I believe *A* is needed to facilitate actual base interoperation across
> CDNs.
> I believe *B* is useful to allow CDNs to do extra thing on top of what has
> been specified in CDNI.
> Are you saying that you feel only *B* is needed?
>
> Cheers
>
> Francois
>
>   ****
> ** **
> ** **
>   *From:* Francois Le Faucheur [mailto:[email-masked]]
> *Sent:* Thursday, July 28, 2011 4:17 PM
> *To:* Kent Leung (kleung)
> *Cc:* Francois Le Faucheur; <[email-masked]>
> [email-masked];  <[email-masked]>
> [email-masked]
> *Subject:* Re: [CDNi] comments on draft-bertrand-cdni-use-cases-02****
> ** **
> Kent and all,****
>  ** **
>  On 28 Jul 2011, at 16:10, Kent Leung (kleung) wrote:****
>
>
> ****
>  Hi Francois.  Responding to comments related to the requirements draft
> below.
>
>
>   o  an expiration time (i.e., the time at which the content files
>      should be expunged from all CDN storage).
> "
> I understand this is saying that CDNI metadata need to include this
> expiration time (triggering cache removal) , in addition to deactivation
> time.
> I don't think this is discussed in cdni-requirements yet. Can you bring
> that up on the list with the cdni-reqts authors?
>
> KL> I've seen references to content expiration time (i.e. removal) in
> some drafts.  So it seems to be needed in the CDNI Metadata.  Noted as
> requirement (possibly part of availability window) unless others object.**
> **
>  ** **
>  FLF as an Individual: that works for me.****
>  ** **
>
>
>
> "
>   The delivery of content may be further influenced by policies which
>   may include quality of service rules that specify:
>   o  the maximum resolution deliverable to specific devices,
>   o  the maximum resolution deliverable though a specific NSP, or
>   o  the maximum resolution deliverable to users based on their
>      subscription levels.
> "
> I don't think this is covered in the cdni-requirements doc.
> It is not obvious to me that absolutely all of those ought to be in
> phase 1. The first bullet only makes sense if the solution supports
> transcoding/transrating, which I don't know if it will be supported in
> Initial scope.
> The last bullet does not make sense to me as we don;t want the CDNs to
> be aware of any user subscription levels (ie only CSP is aware of user
> subscription level).
>
>
> KL> I'm not yet convinced that this should be part of the CDNI Metadata.
> Based on the discussion conclusion, we can track this as possible
> requirement for now.****
>
>  ** **
>  FLF as a chair: I will raise a discussion in the "Open Items" slot
> towards the end of the WG meeting on "Content Adaptation" and what shoudl be
> in scope of CDNI. This will give us some sense on the WG views on that.***
> *
>  ** **
>  Francois****
>  ** **
>
>
> ****
>
>
> Kent
>
> ****
> ** **
>    ****
>
>   *
> Francois Le Faucheur*
> *Distinguished Engineer*
> *Corporate Development*
> [email-masked]
> Phone: *+33 49 723 2619*
> Mobile: *+33 6 19 98 50 90*
>
> ****
>
> *Cisco Systems France*
> Greenside
> 400 Ave de Roumanille
> 06410 Sophia Antipolis
> France
> Cisco.com <http://www.cisco.com/>****
>   ****
>
> ****
>     Think before you print.****
>
>
> This email may contain confidential and privileged material for the sole
> use of the intended recipient. Any review, use, distribution or disclosure
> by others is strictly prohibited. If you are not the intended recipient (or
> authorized to receive for the recipient), please contact the sender by reply
> email and delete all copies of this message.
>
> Cisco Systems France, Société à responsabiité limitée, Rue Camille
> Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux,
> Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la
> publication: Jean-Luc Michel Givone.
>
> For corporate legal information go to:
> <http://www.cisco.com/web/about/doing_business/legal/cri/index.html>
> http://www.cisco.com/web/about/doing_business/legal/cri/index.html****
> ** **
>
>
>
> *
> Francois Le Faucheur*
> *Distinguished Engineer*
> *Corporate Development*
> <[email-masked]>[email-masked]
> Phone: *+33 49 723 2619*
> Mobile: *+33 6 19 98 50 90*
>
>
>  *Cisco Systems France*
> Greenside
> 400 Ave de Roumanille
> 06410 Sophia Antipolis
> France
> <http://www.cisco.com/>Cisco.com <http://cisco.com/>
>
>
>    Think before you print.
> This email may contain confidential and privileged material for the sole
> use of the intended recipient. Any review, use, distribution or disclosure
> by others is strictly prohibited. If you are not the intended recipient (or
> authorized to receive for the recipient), please contact the sender by reply
> email and delete all copies of this message.
>
> Cisco Systems France, Société à responsabiité limitée, Rue Camille
> Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux,
> Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la
> publication: Jean-Luc Michel Givone.
>
> For corporate legal information go to:
> <http://www.cisco.com/web/about/doing_business/legal/cri/index.html>
> http://www.cisco.com/web/about/doing_business/legal/cri/index.html
>
>
>
>
>     *
> Francois Le Faucheur*
> *Distinguished Engineer*
> *Corporate Development*
> [email-masked]
> Phone: *+33 49 723 2619*
> Mobile: *+33 6 19 98 50 90*
>
>
>  *Cisco Systems France*
> Greenside
> 400 Ave de Roumanille
> 06410 Sophia Antipolis
> France
> Cisco.com <http://www.cisco.com/>
>
>
>
>    Think before you print.
> This email may contain confidential and privileged material for the sole
> use of the intended recipient. Any review, use, distribution or disclosure
> by others is strictly prohibited. If you are not the intended recipient (or
> authorized to receive for the recipient), please contact the sender by reply
> email and delete all copies of this message.
>
> Cisco Systems France, Société à responsabiité limitée, Rue Camille
> Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux,
> Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la
> publication: Jean-Luc Michel Givone.
>
> For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/index.html
>
>
>
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni
>
>

--

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Thu, 4 Aug 2011 11:51:35 -0700

My interpretation of “well-accepted” is that these metadata elements are common for CDNI regardless of region, provider, environment, etc.  The specific elements are determined in the solutions draft.  I expect these are the information needed for basic CDNI operation (i.e. necessary for interoperability).  So these information elements are defined in the standardized types.  Note, a specific  environment may only use a subset of the standardized elements.

For “opaque”, I expect that there will be a standards type that specifies the information is opaque (i.e. not defined by standards) and can be used by private CDN agreement.  So, in this case, it may be CDN provider-specific information elements.   In many protocols, this is defined as Vendor Specific Option/Attribute.

Kent

From: Bhumip Khasnabish [mailto:[email-masked]] 
Sent: Thursday, August 04, 2011 8:01 AM
To: Francois Le Faucheur (flefauch)
Cc: Kent Leung (kleung); Yiu Lee; [email-masked]
Subject: Re: [CDNi] Fwd: comments on draft-bertrand-cdni-use-cases-02

Hello,

Please note that "well-accepted" and "opaque" elements may be different in different environment (region, provider, context, etc.). 

May be some specific examples are needed on what one means by  "well-accepted" and "opaque" metadata elements in region/provider/context/... ... ... . Thanks.

Best.

Bhumip

On Fri, Jul 29, 2011 at 10:03 AM, Francois Le Faucheur <[email-masked]> wrote:

Ken, Yiu, 

Can you add into your list of tracked candidate items something reflecting this thread? ie ensuring cdni-requirements incorporates requirements on the CDNI Metadata interface covering:

*A* ability to exchange a set of well-accepted metadata elements with specified semantics (eg start of time window, end of time window,...), AND

*B* ability to allow exchange of opaque metadata element, whose semantic is not defined in CDNI but left up to private CDN agreement.

Dave Oran also privately suggested that we expand on *B* to cover the usual distribution options for treatment of opaque element (eg ignore-and-pass-on-when-not-understood, etc). Which makes sense to me.

Thanks

Francois

Begin forwarded message:

From: Kevin J Ma <[email-masked]>

Date: 28 July 2011 17:35:22 EDT

To: Francois Le Faucheur <[email-masked]>

Cc: Francois Le Faucheur <[email-masked]>, "Kent Leung (kleung)" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>

Subject: Re: [CDNi] comments on draft-bertrand-cdni-use-cases-02

Sent from my iPhone

On Jul 28, 2011, at 5:22 PM, "Francois Le Faucheur" <[email-masked]> wrote:

	

	Just one quick comment: it was not necessarily the intent of the use cases to imply

	that CDNI requirements be generated for each piece of metadata; the metadata may be

	useful for certain deployments, but opaque metadata distribution may be sufficient?

	There was discussion early on about metadata with implied actions like: expiration,

	or sunset/sunrise, or ssl only, or url hashing required, or content transformation,

	or do accounting, or other proprietary optimization or policy enforcement features,

	etc., but its not clear that we would want CDNI requirements for each of these?

	It seems like a more generic notion of defining metadata (and their actions), and

	allowing CDNs to advertise or decline metadata (action) support would useful, as

	*A* a set of well-accepted metadata elements with their semantics (eg start of time window, end of time window,...), AND

	*B* probably, also a mechanism to allow exchange of opaque metadata element, whose semantic is not defined in CDNI but up to private CDN agreement.

	I believe *A* is needed to facilitate actual base interoperation across CDNs.

	I believe *B* is useful to allow CDNs to do extra thing on top of what has been specified in CDNI.

	Cheers

	Francois

	 

	From: Francois Le Faucheur [mailto:[email-masked]] 
	Sent: Thursday, July 28, 2011 4:17 PM
	To: Kent Leung (kleung)
	Cc: Francois Le Faucheur; [email-masked]; [email-masked]
	Subject: Re: [CDNi] comments on draft-bertrand-cdni-use-cases-02

	Kent and all,

	On 28 Jul 2011, at 16:10, Kent Leung (kleung) wrote:

	
	KL> I've seen references to content expiration time (i.e. removal) in
	some drafts.  So it seems to be needed in the CDNI Metadata.  Noted as
	requirement (possibly part of availability window) unless others object.

	FLF as an Individual: that works for me.

		
		"

		requirement for now.

	FLF as a chair: I will raise a discussion in the "Open Items" slot towards the end of the WG meeting on "Content Adaptation" and what shoudl be in scope of CDNI. This will give us some sense on the WG views on that.

	Francois

	Kent

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked] <mailto:[email-masked]> 
Phone: +33 49 723 2619 <tel:%2B33%2049%20723%202619> 
Mobile: +33 6 19 98 50 90 <tel:%2B33%206%2019%2098%2050%2090> 

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

	 

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619 <tel:%2B33%2049%20723%202619> 
Mobile: +33 6 19 98 50 90 <tel:%2B33%206%2019%2098%2050%2090> 

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com <http://cisco.com/> 

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

 

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked] <mailto:[email-masked]> 
Phone: +33 49 723 2619 <tel:%2B33%2049%20723%202619> 
Mobile: +33 6 19 98 50 90 <tel:%2B33%206%2019%2098%2050%2090> 

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

--