Subject: Re: [CDNi] CDNI minutes from IETF 81

From: Francois Le Faucheur <[email-masked]>
Date: Mon, 12 Sep 2011 23:23:10 +0200

Hi Ben,

On 22 Aug 2011, at 14:31, Ben Niven-Jenkins wrote:

> Rich,
> 
> One correction related to something I said during the meeting
> 
> Towards the bottom of the minutes:
>> Ben Niven-Jenkins: Layer 4 VPNs are a multi-billion dollar market. And they do 
>> everything out of band. 
> 
> Can you s/Layer 4/Layer 3/

Done.

> 
> Also as a clarification I didn't actually say that Layer 3 VPNs do *everything* out of band, what I said was that the negotiation for what treatment to apply for a particular CoS/DSCP value (or how to map a particular DSCP value in one network to a different DSCP value in another network) is performed out of band between Layer 3 VPNs running over interconnected network.

I checked back the audio recording and aligned the minutes to what was said. It now reads:

"
Ben Niven-Jenkins: We have an existence proof: Layer 3 VPNs are a multi-billion dollar market today and they do all of this out of band. 

Francois Le Faucheur: I challenge that assertion. They do most of it out of band, but they still use an in-band signaling mechanism (DSCP) to invoke the differentiated services. 

Ben: OK, but the mapping of DSCP across operators and its meaning is out of band.

Francois Le Faucheur: yes, but that part I am hoping we all agree is out of scope.
"

Francois

PS: The new minutes are not yet accessible on line as the meeting material page is not letting me upload them (working on it with datatracker folks).

> The rest of the minutes look OK to me.
> 
> Thanks
> Ben
> 
> On 15 Aug 2011, at 22:08, Woundy, Richard wrote:
> 
>> Folks,
>> 
>> We have uploaded the CDNI minutes from our last WG session in Quebec City. Please review the minutes for accuracy. Please send any corrections to us by Monday August 29.
>> 
>> Many thanks to Daryl Malas and Ray van Brandenburg who composed these notes!
>> 
>> <http://www.ietf.org/proceedings/81/minutes/cdni.txt>
>> 
>> -- Rich & Francois
>> _______________________________________________
>> CDNi mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/cdni
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: ZhouZhipeng <[email-masked]>
Date: Tue, 13 Sep 2011 07:24:32 +0000

Hello Ben,
Via reading the web of your company, http://www.velocix.com/delivery.php

I find an interesting feature: “Delivery speed control”.
In my understanding, that is a kind of service with Quality Priority.

Meanwhile, in the whitepaper http://www.velocix.com/next_gen_video_distr_velocix.pdf

The section 3.3 “Flexible and Multi-level Quality Control” also has some description such as “intelligent traffic management”.

So, I feel such technology has already been implemented in your company’s product.

Then, if to support such capability in the CDN-CDN scenario, perhaps some simple negotiation would be needed based on the existing CDN capability.

So, I feel my use cases looks appropriate and I am wondering whether you may help me with some more  explanations.

Thanks very much.

Zhipeng

发件人: Francois Le Faucheur [mailto:[email-masked]]
发送时间: 2011年9月13日 5:23
收件人: Ben Niven-Jenkins
抄送: [email-masked]
主题: Re: [CDNi] CDNI minutes from IETF 81

Hi Ben,

Rich,

Done.

"

Francois

Thanks
Ben

Folks,

-- Rich & Francois
_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni

_______________________________________________
CDNi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/cdni

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]<mailto:[email-masked]>
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com<http://www.cisco.com>

 Think before you print.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 �, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 14 Sep 2011 21:21:53 +0200

> PS: The new minutes are not yet accessible on line as the meeting material page is not letting me upload them (working on it with datatracker folks).

Updated minutes are now accessible from the Meeting Material page:
http://www.ietf.org/proceedings/81/minutes/cdni.txt

Cheers

Francois & Rich

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Sun, 18 Sep 2011 11:35:19 +0100

Zhipeng,

Please see below.

> So, I feel my use cases looks appropriate and I am wondering whether you may help me with some more  explanations.

I'll expand on the analogy I drew in the meeting. Many router products support the configuration of different packet classification, marking, shaping and queuing strategies but in Layer 3 VPNs the treatment of different classes of traffic is not signalled through the control plane but rather the mapping between how certain traffic is classified by different VPN providers that have interconnected their networks is 'signalled' out of band via business agreements between the VPN providers.

One of the reasons for that is that the appropriate classification and treatment within a network is dependent on how that network has been built/designed and trying to have some generic language for describing it and mapping between different variants rapidly gets very complicated and is not something that can necessarily be done automatically.

Let's not forget that CDNs won't interconnect without some business agreement occurring between the two interconnected CDNs and as part of that business agreement certain classifications/mappings can be made without trying to build complexity into the CDNI interfaces themselves, especially for properties such as "Quality Control" where the actual meaning/treatment is likely to be dependent on the specific network design/deployment and any kind of automatic negotiation is likely to be anything but simple due to the differences in the CDN products used and the way the networks have been designed/deployed.

IMO the CDNI interfaces (for example the CDNI Metadata interface) need the ability to carry properties that indicate that some content should be treated differently to other content but how that property is mapped to how that content is treated by the individual CDNs is something that does not need to be negotiated at "run time" and that it is probably not possible to do an automatic negotiation/mapping anyway without the mapping being done out of band via some business agreement.

Instead it is probably sufficient for two interconnected CDNs to have a common understanding (that is acceptable to both parties and their customers) via a business agreement about how to map such properties onto their own CDNs/networks according to how they have designed/deployed those CDNs/networks. Such an approach works for Layer 3 VPNs todays which are a multi-billion dollar market without requiring complex (and ultimately IMO futile) automatic negotiation protocol machinery.

HTH
Ben

---

From: ZhouZhipeng <[email-masked]>
Date: Mon, 19 Sep 2011 07:23:41 +0000

Hello Ben,
First of all, I should say CDN has nothing to do with VPN but I understand that your case is to explain how the "diff-service" works: to set multiple channels (e.g VPN) and assign each VPN for the data with different priority.
I think generally the basic concept of diff-service is similar while measures may be different and may be implemented in different layers, for different applications.
For example, the routers may implement some technologies that are originally implemented in service layer. For instance, I know the DPI technology has been widely supported on routers right now.  
Here is an import point I like to repeat: my use case is taking the "content copy" as a unit while router is taking the packet as a unit.

Secondly, I like to clarify that my use case does not intend to define the detail classifications here since as you explained different CDNs may have different measures.
For example, both CDN-A and CDN-B may provide two classes of service: high class and normal class. Perhaps the meaning of high class service in these two CDNs may differ a little.
But, "the service date in high class service of CDN-A would be forwarded via the high class service of CDN-B" is reasonable, right.
I guess this is what you implied "common understanding".

Hope this email can answer your concern and some improvement may be taken if you agree to accept the use case.

Thanks.
Zhipeng

-----邮件原件-----
发件人: Ben Niven-Jenkins [mailto:[email-masked]] 
发送时间: 2011年9月18日 18:35
收件人: ZhouZhipeng
抄送: [email-masked]
主题: Re: 答复: [CDNi] CDNI minutes from IETF 81

Zhipeng,

Please see below.

HTH
Ben