Subject: [CDNi] Is it feasible to extend the CDNi mechanisms to manage virtual network functions in multiple DCs?

From: Linda Dunbar <[email-masked]>
Date: Tue, 2 Sep 2014 02:53:04 +0000

Very often resources from one single Data Center can't meet the service requirement. So it is desirable for operators to utilize resources from multiple data centers for those services.

The "Media Cloud Federation" shown in draft-aazam-cdni-inter-cloud-architecture-00 is one example.

Many features specified by CDNi, such as "footprint & Capability advertisement interface", "logging", etc., can be very useful. Is it feasible to extend those CDNi protocols for those services?

Thanks, Linda Dunbar

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Fri, 5 Sep 2014 15:41:19 +0100

Hi Linda,

I haven't read the draft you mention below. The CDNI interfaces defined to date are basically HTTP APIs carrying CDNI specific data.

There may be some reuse possible, e.g. footprint/capability but it probably depends on how much overlap there is between the Media Cloud Federation's view of footprint/capability and CDNI's definition/use of that data.

Likewise with logging, the logging format defined is similar to a web server access log so it depends how well that maps to the sorts of logs you'll be generating. The logging "API" is just an Atom feed.

Without reading the draft you mention my gut says you'll probably end up defining so much of your own cloud-specific data to exchange that even if you start with the CDNI specifications, you'll end up with something that looks completely different so you may be better defining your own cloud-specific APIs but YMMV.

Ben

On 2 Sep 2014, at 03:53, Linda Dunbar <[email-masked]> wrote:

> Very often resources from one single Data Center can’t meet the service requirement. So it is desirable for operators to utilize resources from multiple data centers for those services.
> The “Media Cloud Federation” shown in draft-aazam-cdni-inter-cloud-architecture-00 is one example.
>  
> Many features specified by CDNi, such as “footprint & Capability advertisement interface”, “logging”, etc., can be very useful. Is it feasible to extend those CDNi protocols for those services?
>  
> Thanks, Linda Dunbar
>  
>  
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni