Subject: [CDNi] Key ID options for URI Signing draft

From: "Kent Leung (kleung)" <[email-masked]>
Date: Wed, 7 Jan 2015 23:51:19 +0000

Hi folks. For implementation simplicity, there's value to have Key ID using a number to reference the key. The current KID IE is specified to be generic using a string format. Perhaps we should specify two IEs to provide the flexibility vs. simplicity options? For example, Key ID Number (KIDNUM) IE and Key ID reference (KIDREF) provides the number and string formats, respectively. Only one of the IE can be used as the key identifier in the signed URI. The current KID IE will be replaced by the two IEs.

Let me know if there are any objections. This change will be incorporated in the next version.

Kent

---

From: Leif Hedstrom <[email-masked]>
Date: Thu, 8 Jan 2015 19:59:11 -0700

> On Jan 7, 2015, at 4:51 PM, Kent Leung (kleung) <[email-masked]> wrote:
> 
> Hi folks. For implementation simplicity, there’s value to have Key ID using a number to reference the key. The current KID IE is specified to be generic using a string format. Perhaps we should specify two IEs to provide the flexibility vs. simplicity options? For example, Key ID Number (KIDNUM) IE and Key ID reference (KIDREF) provides the number and string formats, respectively. Only one of the IE can be used as the key identifier in the signed URI. The current KID IE will be replaced by the two IEs.

I would very much like to see some constraints on the KID. A numeric value seems fine, as long as you put some well defined limits on it (e.g. 64-bit unsigned).

Cheers,

— leif

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Tue, 20 Jan 2015 09:19:51 +0000

Hi Kent,

I'm not a big fan of having two IEs for effectively the same purpose. I understand the arguments in favor of allowing both options, but since we don't describe the semantics of the KID field anyway, wouldn't it be possible for a uCDN-dCDN pair that would prefer using numeric values to just parse the KID strings as an integer?

Alternatively, if there are arguments agains that, maybe it would be possible to have some sort of sub-options (e.g. KID=NUM:<num> and KID=STR:<string>)

Thanks,

Ray

From: CDNi [mailto:[email-masked]] On Behalf Of Kent Leung (kleung)
Sent: donderdag 8 januari 2015 0:51
To: [email-masked]
Subject: [CDNi] Key ID options for URI Signing draft

Kent
This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: Leif Hedstrom <[email-masked]>
Date: Tue, 20 Jan 2015 09:48:16 -0700

> On Jan 20, 2015, at 2:19 AM, Brandenburg, R. (Ray) van <[email-masked]> wrote:
> 
> Hi Kent,
>  
> I’m not a big fan of having two IEs for effectively the same purpose. I understand the arguments in favor of allowing both options, but since we don’t describe the semantics of the KID field anyway, wouldn’t it be possible for a uCDN-dCDN pair that would prefer using numeric values to just parse the KID strings as an integer?
>  

I’m ok either way. My primary motivation is that I think KID should have a max length defined in the standards. I don’t care if its 64-bytes, or 256-bytes, or something otherwise reasonable. Allowing it for arbitrary length makes implementations less efficient and likely, error prone. Yes, I’m painfully aware that the RFCs for HTTP and URLs do not impose a max-URL length, but that’s not an excuse for us making things worse :).

I understand that the CDNs at play can put whatever restrictions in as they like, but that also makes for iffy interops IMO.

Cheers,

— leif

---

From: "Brandenburg, R. (Ray) van" <[email-masked]>
Date: Wed, 21 Jan 2015 08:36:38 +0000

Hi Leif,

I think that’s a valid point. I will work with Kent on adding max length values for all IEs that end up in the URL.

Thanks,

Ray

From: Leif Hedstrom [mailto:[email-masked]]
Sent: dinsdag 20 januari 2015 17:48
To: Brandenburg, R. (Ray) van
Cc: Kent Leung (kleung); [email-masked]
Subject: Re: [CDNi] Key ID options for URI Signing draft

On Jan 20, 2015, at 2:19 AM, Brandenburg, R. (Ray) van <[email-masked]<mailto:[email-masked]>> wrote:

Hi Kent,

Cheers,

— leif