Subject: Re: [CDNi] Alexey Melnikov's No Objection on draft-ietf-cdni-logging-26: (with COMMENT)

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 1 Jun 2016 18:17:48 +0200

Hi Alexey,

Thanks for following up. See below:

> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> Thank you for addressing my DISCUSS points.
> 
> Ok, you now clarified that version names are case-insensitive. However I
> didn't get this impression while reading 3.3, as there is no version ABNF
> there. So you might want to say that earlier in the document as well.

Fair enough. I added a statement about case -insensitive for each of the directives, version, value, field names where there are respectively defined (under 3.3 and 3.4)

> 
> In 7.1, last sentence: TLS only provides for protection from tampering
> when in transit, not when a log file being stored.

I already responded to that point and corrected the sentence so it now reads:
“
Protection against third party tampering, when the CDNI Logging File is communicated over the CDN Logging Interface, can be achieved as discussed above through the use of TLS.
“

Is it not acceptable ?

Cheers

Francois

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 1 Jun 2016 19:47:59 +0100

Hi Francois,

> Protection against third party tampering, when the CDNI Logging File is communicated over the CDN Logging Interface, can be achieved as discussed above through the use of TLS.

Sorry, missed that. Yes, this is an improvement.

Can anything be said about data at rest?

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 8 Jun 2016 10:22:26 +0200

Hi Alexey,

> On 1 Jun 2016, at 20:47, Alexey Melnikov <[email-masked]> wrote:
> 
> Hi Francois,
> 

The document already has a specific statement wrt data at rest regarding privacy protection :

“
The algorithmic mapping and variation over time MAY allow the uCDN … to reconstruct the actual client IPv4 or IPv6 address and/or other network-level identifying information when required … .  However, these enduser addresses SHOULD only be reconstructed on-demand and the CDNI Logging File SHOULD only be stored with the anonymised c-groupid value.
"

The paragraph we were discussing, in the context of your COMMENT, relates to integrity protection. We clarified that the statement about integrity protection applies when the data is in flight. When the data is at rest, I don’t think we need to discuss integrity protection since the data exchanged via CDNI LI interface can be processed by the uCDN as it sees fit (e.g. aggregate CDNI Logging Files with its own local logging records, e.g. filter/sanitise/summarize in order to export to the Content Service Provider, etc.) so it is legitimate that the uCDN can modify the data, once properly communicated via the CDNI LI interface.

So to me, we are already covered.

Cheers

Francois