Subject: [CDNi] I-D Action: draft-ietf-cdni-metadata-20.txt

From: [email-masked]
Date: Tue, 02 Aug 2016 11:33:04 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Content Delivery Networks Interconnection of the IETF.

        Title           : CDN Interconnection Metadata
        Authors         : Ben Niven-Jenkins
                          Rob Murray
                          Matt Caulfield
                          Kevin J. Ma
	Filename        : draft-ietf-cdni-metadata-20.txt
	Pages           : 64
	Date            : 2016-08-02

Abstract:
   The Content Delivery Networks Interconnection (CDNI) metadata
   interface enables interconnected Content Delivery Networks (CDNs) to
   exchange content distribution metadata in order to enable content
   acquisition and delivery.  The CDNI metadata associated with a piece
   of content provides a downstream CDN with sufficient information for
   the downstream CDN to service content requests on behalf of an
   upstream CDN.  This document describes both a base set of CDNI
   metadata and the protocol for exchanging that metadata.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-cdni-metadata/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-cdni-metadata-20

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-cdni-metadata-20

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Kevin Ma J <[email-masked]>
Date: Tue, 2 Aug 2016 18:33:57 +0000

Hi All,

  (As an author) This update should take care of all the outstanding comments, as well as address Ori's comments (see other email).

  Changes:
  - updated IDNA reference
  - added link loop prevention text
  - removed text about methods other than GET/HEAD
  - updated versioning text to clarify that structural metadata and generic metadata must be updated atomically
  - updated PatternMatch and Cache objects

  Once we have confirmation from the WG on the PatternMatch and Cache changes, the authors believe this version is ready for publication.

thanx!

--  Kevin J. Ma

> -----Original Message-----
> From: CDNi [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Tuesday, August 02, 2016 2:33 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [CDNi] I-D Action: draft-ietf-cdni-metadata-20.txt
> 
> 
> _______________________________________________
> CDNi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cdni

---

From: Kevin Ma J <[email-masked]>
Date: Wed, 17 Aug 2016 16:05:33 +0000

Hi All,

  Having heard no objections to the changes, the authors will move forward with -20, unless Alexey has any additional comments on this revision.

thanx!

--  Kevin J. Ma

> From: Kevin Ma J
> Sent: Tuesday, August 02, 2016 2:34 PM
> To: [email-masked]
> Subject: RE: [CDNi] I-D Action: draft-ietf-cdni-metadata-20.txt
> 
> Hi All,
> 
>   (As an author) This update should take care of all the outstanding
> comments, as well as address Ori's comments (see other email).
> 
>   Changes:
>   - updated IDNA reference
>   - updated versioning text to clarify that structural metadata and
> generic metadata must be updated atomically
>   Once we have confirmation from the WG on the PatternMatch and Cache
> changes, the authors believe this version is ready for publication.
> 
> thanx!
> 
> --  Kevin J. Ma
> 
> 
> > This draft is a work item of the Content Delivery Networks
> Interconnection
> > of the IETF.
> >

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 17 Aug 2016 17:43:12 +0100

On Wed, Aug 17, 2016, at 05:05 PM, Kevin Ma J wrote:
> Hi All,
> 
>   Having heard no objections to the changes, the authors will move
>   forward with -20, unless Alexey has any additional comments on this
>   revision.

I have a few more small comments, but these can wait. So feel free to
post a new version.

---

From: Kevin Ma J <[email-masked]>
Date: Wed, 17 Aug 2016 16:58:36 +0000

Hi Alexey,

  The posted version (-20) is our current version.  Just let us know, and we will address any final comments you may have and happily hand it off to the RFC Editor.  :)

thanx!

--  Kevin J. ma 

> From: Alexey Melnikov [mailto:[email-masked]]
> Sent: Wednesday, August 17, 2016 12:43 PM
> To: Kevin Ma J <[email-masked]>; [email-masked]
> Subject: Re: [CDNi] I-D Action: draft-ietf-cdni-metadata-20.txt
>