Subject: [Cellar] I-D Action: draft-ietf-cellar-ffv1-03.txt

From: [email-masked]
Date: Fri, 01 Jun 2018 05:59:41 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Codec Encoding for LossLess Archiving and Realtime transmission WG of the IETF.

        Title           : FFV1 Video Coding Format Version 0, 1, and 3
        Authors         : Michael Niedermayer
                          Dave Rice
                          Jerome Martinez
	Filename        : draft-ietf-cellar-ffv1-03.txt
	Pages           : 41
	Date            : 2018-06-01

Abstract:
   This document defines FFV1, a lossless intra-frame video encoding
   format.  FFV1 is designed to efficiently compress video data in a
   variety of pixel formats.  Compared to uncompressed video, FFV1
   offers storage compression, frame fixity, and self-description, which
   makes FFV1 useful as a preservation or intermediate video format.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-cellar-ffv1/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-cellar-ffv1-03
https://datatracker.ietf.org/doc/html/draft-ietf-cellar-ffv1-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-cellar-ffv1-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Michael Richardson <[email-masked]>
Date: Fri, 01 Jun 2018 13:21:28 -0400

> https://www.ietf.org/rfcdiff?url2=draft-ietf-cellar-ffv1-03

Hi Authors, thanks for fixing the Intended Status.
It appears that this document has itself as a (circular) Normative Reference :-)
I'm guessing this is intended for ffv1-v4 only.
Please fix it in the source, but you don't need to repost it until there
is something else more substantial.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Dave Rice <[email-masked]>
Date: Fri, 1 Jun 2018 13:28:19 -0400

> On Jun 1, 2018, at 1:21 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

Could you suggest what should be said under “Published specification” in the Media Type Definition. I see other RFC documents, such as https://tools.ietf.org/html/rfc7587#section-6.1 <https://tools.ietf.org/html/rfc7587#section-6.1>, which do include circular self-references.

Should the current “Published specification” section be changed to:

Version 0,1,3
Published specification: none

Version 4:
Published specification: [@!I-D.ietf-cellar-ffv1]

> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

---

From: Michael Richardson <[email-masked]>
Date: Fri, 01 Jun 2018 13:59:23 -0400

> Could you suggest what should be said under “Published specification”
    > in the Media Type Definition. I see other RFC documents, such as
    > https://tools.ietf.org/html/rfc7587#section-6.1
    > <https://tools.ietf.org/html/rfc7587#section-6.1>, which do include
    > circular self-references.

That's not the kind of reference I mean.
In the media type definition, referring to document-self is fine.

>> https://www.ietf.org/rfcdiff?url2=draft-ietf-cellar-ffv1-03

You'll see:

12.1.  Normative References		12.1.  Normative References

   [I-D.ietf-cellar-ffv1]		          [I-D.ietf-cellar-ffv1]

And the diff is about how the version changed.

That is, I-D.ietf-cellar-ffv1 is referenced by I-D.ietf-cellar-ffv1...

It would make sense for I-D.ietf-cellar-ffv1-v4 to reference I-D.ietf-cellar-ffv1.