Subject: [Cellar] github org name

From: Michael Richardson <[email-masked]>
Date: Sun, 22 Nov 2020 20:07:17 -0500

RFC8875 suggests github organizations be named "ietf-wg-XXXX".
Our is named cellar-wg.

Renaming is not required, but it seems like a good idea to me.
All of RFC8874/8875 are essentially guidelines, best current practices, btw.

Github says that almost everything will be redirected (repository access in
particular), but not https://github.com/cellar-wg itself.
They list that the biggest threat is that old name could get squatted on!

In looking at the settings, I noticed that we could upload a logo.
Does EBML/FFV1/Matroska have a logo?  Some IETF WGs have created a logo.
  6tisch has:
https://duckduckgo.com/?q=6tisch+logo&atb=v147-3__&iax=images&ia=images&iai=https%3A%2F%2Ftwatteyne.files.wordpress.com%2F2013%2F10%2Flogo_6tisch.png

Unless there are objections, I'll hit the rename button Tuesday.
Our next meeting: 2020-12-01, in ten days.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Jerome Martinez <[email-masked]>
Date: Mon, 23 Nov 2020 07:46:23 +0100

> All of RFC8874/8875 are essentially guidelines, best current practices, btw.

I am in favor of the renaming.

> They list that the biggest threat is that old name could get squatted on!

Sad but we mostly link on repositories so better to do it now than later.

> Does EBML/FFV1/Matroska have a logo?  Some IETF WGs have created a logo.

We could use the Matroska one while waiting for finding a more generic one.

Jérôme

---

From: Reto Kromer <[email-masked]>
Date: Mon, 23 Nov 2020 08:35:10 +0100

>I am in favor of the renaming.

I second this.

I don't have a strong opinion about logos.

Best regards, Reto

---

From: Dave Rice <[email-masked]>
Date: Mon, 23 Nov 2020 10:56:35 -0500

Hi,

> On Nov 23, 2020, at 1:46 AM, Jerome Martinez <[email-masked]> wrote:
> 

+1

> We could use the Matroska one while waiting for finding a more generic one.

Do logos play any role for documents in the IETF beyond using it in the GitHub repository?
Dave

---

From: Michael Richardson <[email-masked]>
Date: Mon, 23 Nov 2020 15:16:09 -0500

Dave Rice <[email-masked]> wrote:
    >>> RFC8875 suggests github organizations be named "ietf-wg-XXXX".  Our
    >>> is named cellar-wg.
    >>>
    >>> Renaming is not required, but it seems like a good idea to me.  All
    >>> of RFC8874/8875 are essentially guidelines, best current practices,
    >>> btw.
    >>

it is done: https://github.com/ietf-wg-cellar/
I may re-register the old name with redirects.  Maybe.

    >>> Github says that almost everything will be redirected (repository
    >>> access in particular), but not https://github.com/cellar-wg itself.

    > Do logos play any role for documents in the IETF beyond using it in the

None :-)

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 24 Nov 2020 14:22:55 -0600

> I may re-register the old name with redirects.  Maybe.

It will surprise no one that the summaries for our repo to the mailing list
don't automagically follow the renaming. I've updated our entry in
https://github.com/ietf-github-services/activity-summary to point to the
new name.

Best,

Spencer

---

From: Steve Lhomme <[email-masked]>
Date: Wed, 25 Nov 2020 07:04:37 +0100

Fine with the renaming. If the logo is used for the whole CELLAR group, the Matroska one may not be suitable. We might as well use an IETF logo.

> On 23 Nov 2020, at 21:16, Michael Richardson <[email-masked]> wrote:
> 
> _______________________________________________
> Cellar mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/cellar

---

From: Michael Richardson <[email-masked]>
Date: Wed, 25 Nov 2020 13:18:50 -0500

> https://github.com/ietf-github-services/activity-summary to point to the

Hi, thank you!
I had been wondering if there was a setup to run the summaries, and now I
know.

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 25 Nov 2020 13:53:49 -0600

Hi, Michael,

On Wed, Nov 25, 2020 at 12:18 PM Michael Richardson <[email-masked]>
wrote:

>     >> >> On Nov 23, 2020, at 1:46 AM, Jerome Martinez <
> [email-masked]>
>     >> >> wrote:
>     >> >>
> Our
> All

I wish this was automagic - I set it up fairly soon after joining Cellar,
and managed to miss FFmpeg/FFV1, because it wasn't in the same directory as
the rest of the Cellar repos. I added it after the first meeting where we
worked on FFV1, and realized I wasn't seeing that activity.

What we're reporting on now, is

    "[email-masked]": {
        "digest:sunday": {
            "eventFilter": {
                "notlabel": [
                    "editorial"
                ]
            },
            "repos": [
                "ietf-cellar-wg/ebml-specification",
                "ietf-cellar-wg/matroska-specification",
                "FFmpeg/FFV1",
                "ietf-cellar-wg/Cellar-FLAC",
                "ietf-cellar-wg/chair-notes"
            ],
            "topic": "CELLAR Activity Summary"
        }
    },

Is there anything else I'm missing? Note that I'm not including anything
labeled "editorial".

Best,

Spencer