Subject: RES: [Cfrg] Possible RFC: Data integrity combined with encryption

From: "Mads Rasmussen" <[email-masked]>
Date: Fri, 20 Sep 2002 17:19:34 -0300

> -----Mensagem original-----
> De: Mok-Kong Shen [mailto:[email-masked]]
> Enviada em: sexta-feira, 20 de setembro de 2002 17:00
> Para: csjutla; [email-masked]
> Assunto: Re: [Cfrg] Possible RFC: Data integrity combined with
encryption
> 
> 
> 
> csjutla wrote:
> >
> > Sure, non-linear schemes work.
> > But, if you want to use non-linearity,
> > some really simple schemes work.
> > See my old paper : (which describes two schemes IAPM and IACBC).
> >
> > http://eprint.iacr.org/2000/039/
> >
> > Also see
> > www.nist.gov/aes/modes/proposedmodes (and look under my name).
> >
> 
> Many thanks for the references.
> 
> Anton Stiglic mentioned that possibly all good schemes
> known are patented. Is that true or could you name
> one that is free? Thanks.

I think CCM is only "patent pending", but I guess it's only a question
of time.

I find this whole patent issue of operation modes a very unfortunate
turn and I'm afraid it will cause more harm and more home brew
solutions.

A guy creating a protocol will have to pay for a license in order to
make him protocol secure, what would motivate him to do that? Just the
fact that it's more secure? Highly unlikely!

He is more likely to invent his own solution (maybe based on a patented
mode) which is very unfortunate.

Just a comment :o)

Regards,

Mads Rasmussen
Open Communications Security
+55(11)3345-2525

_______________________________________________
Cfrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/cfrg

---

From: "Housley, Russ" <[email-masked]>
Date: Fri, 20 Sep 2002 17:10:23 -0400

>turn and I'm afraid it will cause more harm and more home brew

Nonsense!  I provide an extract from the CCM document:

    9. Intellectual Property Statements

    The authors hereby explicitly release any intellectual property
    rights to CCM to the public domain.  Further, the authors are not
    aware of any patent or patent application anywhere in the world that
    covers CCM mode.  It is our belief that CCM is a simple combination
    of well-established techniques, and we believe that CCM is obvious to
    a person of ordinary skill in the arts.

Russ