Subject: [Cfrg] Re: Hmac strength

From: Anonymous User <[email-masked]>
Date: Fri, 4 Oct 2002 04:10:28 +0000 (UTC)

In a recent thread on sci.crypt ("Re: Hmac strength")
John Hadstate and Nicol So were curious about the rationales
in RFC-2104 for hashing only overly long HMAC keys before use,
and for recommending certain keysize limits.
Can anyone shed further light on the subject?

So> The purpose of hashing long keys before use is to
So> reduce the number of block operations ...

Sierchio> There are performance reasons for hashing long keys..

Sierchio> No theoretical explanation is offered for the
Sierchio> choice of key length in the FIPS guidlelines.

DJohn> The key only needs to be half the block size.

_______________________________________________
Cfrg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/cfrg

---

From: David Hopwood <[email-masked]>
Date: Tue, 08 Oct 2002 06:42:30 +0000

-----BEGIN PGP SIGNED MESSAGE-----

> and for recommending certain keysize limits.
[...]
> DJohn> The key only needs to be half the block size.

Note that this statement is not correct, and after much criticism
Don Johnson effectively retracted it. See
<http://groups.google.com/groups?threadm=3D9FD8B5.858B74B4%40zetnet.co.uk>.

- -- 
David Hopwood <[email-masked]>

Home page & PGP public key: http://www.users.zetnet.co.uk/hopwood/
RSA 2048-bit; fingerprint 71 8E A6 23 0E D3 4C E5  0F 69 8C D4 FA 66 15 01
Nothing in this message is intended to be legally binding. If I revoke a
public key but refuse to specify why, it is because the private key has been
seized under the Regulation of Investigatory Powers Act; see www.fipr.org/rip