Subject: [Cfrg] Is Cryptographic Theory Practically Relevant? (Was: Re: cfrg co-chair)

From: David McGrew <[email-masked]>
Date: Wed, 7 Dec 2011 10:00:21 -0800

Hi Kenny,

On Nov 22, 2011, at 8:39 AM, Paterson, Kenny wrote:

> Hi All,
>
> There are indeed ECRYPT members on the list and paying attention!  
> One of our objectives as a network of excellence is to find ways to  
> engage with people developing standards, implementing cryptography,  
> etc. So there is certainly interest and appetite from individuals  
> within ECRYPT for providing input to CFRG.
>
> One immediate item that may be of interest to CFRG is the annual  
> ECRYPT report on key lengths and algorithms, which is available here:
>
> http://www.ecrypt.eu.org/documents.html
>
> Another item of possible interest is the following ECRYPT co- 
> sponsored workshop happening in Cambridge (UK) in Jan/Feb 2012:
>
> Is Cryptographic Theory Practically Relevant?
> http://www.newton.ac.uk/programmes/SAS/sasw07.html

thanks for pointing this workshop out to the list.  I had noticed it  
and was thinking that I should aim to get some engagement with CFRG,  
considering that the agenda of "theory -> practice" lines up well with  
the RG charter.

>
> I am co-organizer of this workshop - so if someone from CFRG is  
> available to present, s/he would be more than welcome to have a slot!
>

This is a kind offer, and if no one else from CFRG is able to attend,  
I think that I could put together a worthwhile contribution.  If the  
offer still holds, how about we discuss offline what sort of  
contribution would be most valuable?

David

> Regards,
>
> Kenny
>
>> Hi Simon,
>>
>> On Nov 22, 2011, at 4:56 AM, Simon Josefsson wrote:
>>
>>>
>>> David,
>>>
>>> I have no concerns other than a general preference for attempting to
>>> enlarge the pond a bit and find someone with experience from the
>>> ECRYPT
>>> or CRYPTREC efforts, for example.  I do realize that there may not  
>>> be
>>> huge pool of volunteers with free time to chose from, however, so we
>>> should be grateful for Kevin's offer.
>>
>> agreed, global engagement is the right goal, and we should figure out
>> ways to get more engagement and involvement from ECRYPT and
>> CRYPTREC.   One thought is: we can solict input to the RG from those
>> groups and other similar groups.  Having a presentation at physical
>> meeting might be the best way to get interaction going.  I bet that
>> there are people on the list who participate in some of those groups,
>> and it would be great to hear from them.
>>
>> David
>>
>>>
>
> ------
> Kenneth G. Paterson,
> Information Security Group,
> Royal Holloway, University of London,
> Egham, Surrey TW20 0EX, U.K.
> e-mail: [email-masked]
> web:    www.isg.rhul.ac.uk/~kp
> phone:  01784 414393
> fax:    01784 430766
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg

---

From: David McGrew <[email-masked]>
Date: Tue, 13 Dec 2011 06:32:30 -0800

Thanks to everyone for their input, both on-list and off-list.  I'm  
calling consensus on having Kevin as co-chair for the Crypto Forum RG.

I also note the good suggestions for the RG to make an effort to  
engage with crypto programs like ECRYPT and CRYPTREC.  Ideas on how to  
do this are welcome.  One thought: we can have an in-person meeting  
during the March 2012 IETF meeting in Paris.

David

On Nov 22, 2011, at 8:38 AM, Dan Harkins wrote:

>
>  Ditto.
>
>  Dan.
>
> On Tue, November 22, 2011 5:10 am, Stephen Farrell wrote:
>>
>> same here
>> S
>>
>> On 11/22/2011 10:57 AM, Sean Turner wrote:
>>> +1
>>>
>>> spt
>>>
>>> On 11/22/11 12:17 AM, Sean Shen 沈烁 wrote:
>>>> +1
>>>>
>>>> Sean Shen
>>>>
>>>> -----Original Message-----
>>>> From: [email-masked] [mailto:[email-masked]] On  
>>>> Behalf
>>>> Of Richard Graveman
>>>> Sent: Tuesday, November 22, 2011 12:43 PM
>>>> To: David McGrew
>>>> Cc: [email-masked]; Lars Eggert
>>>> Subject: Re: [Cfrg] cfrg co-chair
>>>>
>>>> I support Kevin without reservations.
>>>>
>>>> Rich Graveman
>>>>
>>>> On Mon, Nov 21, 2011 at 4:41 PM, David McGrew<[email-masked]>  
>>>> wrote:
>>>>> Hi,
>>>>>
>>>>> the IRTF process on selecting new chairs or co-chairs for RGs is
>>>>> somewhat
>>>>> underspecified. To make sure that we are following a transparent
>>>>> process,
>>>>> I should have said that, while I support and appreciate Kevin's  
>>>>> offer
>>>>> to
>>>>> chair, that position ought to be affirmed by the research group  
>>>>> itself
>>>>> -
>>>>> that is, by you. Can you please chime in with an acceptance of  
>>>>> Kevin
>>>>> in
>>>>> this role (or alternatively, share your concerns if you have  
>>>>> them)?
>>>>>
>>>>> Recall that the research group membership is unrestricted, and  
>>>>> anyone
>>>>> can
>>>>> join by joinging the mail list. The IRTF processes are outlined  
>>>>> in RFC
>>>>> 2014, and the IRTF document publication process is described in  
>>>>> RFC
>>>>> 5743.
>>>>>
>>>>> thanks!
>>>>>
>>>>> David
>>>>>
>>>>> On Nov 11, 2011, at 3:30 PM, David McGrew wrote:
>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> I would like to thank Ran Canetti for serving as Crypto Forum
>>>>>> Research
>>>>>> Group co-chair, starting at the inception of the RG almost ten  
>>>>>> years
>>>>>> ago.
>>>>>> Ran has decided to step down from this role.
>>>>>>
>>>>>> Fortunately, Kevin Igoe has offered to fill this role. Kevin is a
>>>>>> senior
>>>>>> cryptographer with the Commercial Solutions Center of the U.S.
>>>>>> National
>>>>>> Security Agency. Kevin has a great depth of technical knowledge  
>>>>>> in
>>>>>> this
>>>>>> area, as
>>>>>> well as a pragmatic focus that fits well with the IETF. He has
>>>>>> authored/coauthored four RFCs and several current drafts on
>>>>>> cryptography,
>>>>>> and he led the design of the SHA-1 hash algorithm.
>>>>>>
>>>>>> Thanks Kevin and Ran!
>>>>>>
>>>>>> David
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>