Subject: Re: [Cfrg] FW: Request for review of ChaCha/Poly1305

From: Gordon Procter <[email-masked]>
Date: Thu, 14 Aug 2014 10:01:40 +0100

On 29 July 2014 11:05, Gordon Procter <[email-masked]> wrote:
>
> On 25/07/2014 12:04, "Paterson, Kenny" <[email-masked]> wrote:
>
> >Dear CFRG,
> >
> >We have been formally requested by the TLS WG to provide review on this
> >document:
> >
> >https://datatracker.ietf.org/doc/draft-irtf-cfrg-chacha20-poly1305/
> >
> >defining an AEAD construction using the ChaCha and Poly1305 algorithms.
> >This scheme is being considered by the TLS WG for adoption in TLS.
> >
> >There are two aspects to the request:
> >
> >A) analysis of the individual algorithms;
> >B) analysis of the composition (in Section 2.8 of the document).
> >
> > ........
> >
> >Comments, please.
> >
> >Best wishes
> >
> >Kenny (for the chairs)
> >
>
> Hi Kenny,
>
> I can spend some time looking at this (specifically the composition).
>
>
> Gordon

I've put a short note describing a reduction from the proposed composition
to the PRF security of the ChaCha20 block function at
eprint.iacr.org/2014/613.

Gordon

---

From: Yoav Nir <[email-masked]>
Date: Thu, 14 Aug 2014 12:59:32 +0300

Thank you, Gordon.

I'll add this as a reference to the draft.

Cheers,

Yoav 

-----Original Message-----
From: "Gordon Procter" <[email-masked]>
Sent: ‎8/‎14/‎2014 12:02 PM
To: "[email-masked]" <[email-masked]>
Subject: Re: [Cfrg] FW: Request for review of ChaCha/Poly1305

> I can spend some time looking at this (specifically the composition).

I've put a short note describing a reduction from the proposed composition to the PRF security of the ChaCha20 block function at eprint.iacr.org/2014/613.

Gordon