Subject: Re: [Cfrg] I-D Action: draft-irtf-cfrg-chacha20-poly1305-00.txt

From: Tim Whittington <[email-masked]>
Date: Tue, 5 Aug 2014 14:27:44 +1200

I note that there is a repeated error in the HEX <-> ASCII conversion for the test vectors that use the phrase "'Twas brillig, and the slithy roves…”:
 - A.2, Test Vector #3
 - A.3, Test Vector #4

I can verify the test vectors using the hex plaintext, but this is not representative of the actual text.
Specifically all but the last period (ASCII 0x2e) in the text are 0x0A in the hex representation.

The error is also in draft-nir-cfrg-chacha20-poly1305.

cheers
tim

On 24/07/2014, at 9:34 am, [email-masked] wrote:

> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Crypto Forum Research Group Working Group of the IETF.
> 
>        Title           : ChaCha20 and Poly1305 for IETF protocols
>        Authors         : Yoav Nir
>                          Adam Langley
> 	Filename        : draft-irtf-cfrg-chacha20-poly1305-00.txt
> 	Pages           : 38
> 	Date            : 2014-07-23
> 
> Abstract:
>   This document defines the ChaCha20 stream cipher, as well as the use
>   of the Poly1305 authenticator, both as stand-alone algorithms, and as
>   a "combined mode", or Authenticated Encryption with Additional Data
>   (AEAD) algorithm.
> 
>   This document does not introduce any new crypto, but is meant to
>   serve as a stable reference and an implementation guide.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-irtf-cfrg-chacha20-poly1305/
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-irtf-cfrg-chacha20-poly1305-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg

---

From: Yoav Nir <[email-masked]>
Date: Tue, 5 Aug 2014 09:06:36 +0300

Hi, Tim.

The original text (copied from some page Google turned up by searching for “Jabberwocky” is as follows:

'Twas brillig, and the slithy toves
Did gyre and gimble in the wabe:
All mimsy were the borogoves,
And the mome raths outgrabe.

The hex representation shows any non-printable character (code<32 or code>=127) as a period.
So only the last character in the test vector is an actual period.

Hope this helps

Yoav