Subject: [Cfrg] two curvy drafts...

From: Stephen Farrell <[email-masked]>
Date: Tue, 30 Jun 2015 16:13:52 +0100

Hiya,

I've just noticed we have both of these drafts [1,2] in work
at the same time.

What is the proper relationship between them? E.g. should they
mention one another somehow or should there be some text in
one that helps a reader of the other, or are there changes to
one that'd be worth making given the other?

For example, the title of [2] might be considered no longer
quite accurate if [2] doesn't cover the kinds of curve
described in [1]? Or maybe [1] should adopt notation from
[2] and say where/how it differs from what's in [2]?

I don't really care much how we resolve any potential issues
with these, but it'd be a shame if we ended up confusing
readers (more than necessary:-)

Thanks,
S.

[1] https://tools.ietf.org/html/draft-irtf-cfrg-curves-02
[2] https://tools.ietf.org/html/draft-hoffman-rfc6090bis-02

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 30 Jun 2015 16:27:21 +0100

Hi Stephen,

> readers (more than necessary:-)

(I haven't looked at draft-hoffman-rfc6090bis recently.)
If there are any inconsistencies, it is worth updating draft-hoffman-rfc6090bis-02 after draft-irtf-cfrg-curves is done.

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 30 Jun 2015 08:30:48 -0700

The RG has not yet adopted draft-hoffman-rfc6090bis, although that would be great. 

RFC 6090 was about the early foundations of the EC used in ECDSA, showing that it all was quite some time ago. Someone reading RFC 6090 who cared about possible patent claims could get a historical perspective on how old the fundamental parts of EC were invented.

It has been said that some of the cryptography in draft-irtf-cfrg-curves is more recent than that of ECDSA. If we added that into 6090bis, it would make it harder for the reader to make the historical distinctions.

Maybe we can progress 6090bis for its value of fixing bugs in 6090, and start a different document that only talks about the crypto that is different from 6090bis.

--Paul Hoffman

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 30 Jun 2015 16:38:26 +0100

> The RG has not yet adopted draft-hoffman-rfc6090bis, although that

Ah, ok - I forgot or didn't know you wanted to do it via cfrg.
(6090 is an IETF stream RFC but we can figure out whatever's
needed if cfrg want to process it.)

> 
> RFC 6090 was about the early foundations of the EC used in ECDSA,
> showing that it all was quite some time ago. Someone reading RFC 6090
> who cared about possible patent claims could get a historical
> perspective on how old the fundamental parts of EC were invented.
> 
> It has been said that some of the cryptography in
> draft-irtf-cfrg-curves is more recent than that of ECDSA. If we added
> that into 6090bis, it would make it harder for the reader to make the
> historical distinctions.
> 
> Maybe we can progress 6090bis for its value of fixing bugs in 6090,
> and start a different document that only talks about the crypto that
> is different from 6090bis.

Or add an informative ref to the new stuff to 6090bis and say that
there is new stuff, but it's not covered here. Isn't it just the
normative refs that we need "old" in 6090bis?

But I guess I'm more interested in the other way about. While (again)
I don't mind what the right answer is, if someone started their ECC
reading with 6090bis and then went to draft-irtf-cfrg-curves, is there
something we should be doing to make their life easier? Or don't we
think that's a deal?

S.

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 30 Jun 2015 08:47:38 -0700

> needed if cfrg want to process it.)

Stream is unimportant to getting the information out.

> normative refs that we need "old" in 6090bis?

Correct. I can add that, and even if 6090bis gets published as an RFC before draft-irtf-cfrg-curves does, it would be a useful reference to add.

> something we should be doing to make their life easier? Or don't we

It would not hurt for draft-irtf-cfrg-curves to point to 6090 or 6090bis.

--Paul Hoffman

---

From: Watson Ladd <[email-masked]>
Date: Tue, 30 Jun 2015 08:49:17 -0700

> normative refs that we need "old" in 6090bis?

The point was to present patent free algorithms. Adding information from an
informative reference that is later would also be a problem, unless we're
just saying "new stuff is here".

> something we should be doing to make their life easier? Or don't we

Maybe? Until we get further along with both of those I'm not sure they are
ready to be read against each other yet.
>
> S.
>
>
>
> >
> > --Paul Hoffman
> >
>
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/cfrg