Subject: [Cfrg] Options?

From: Simon Josefsson <[email-masked]>
Date: Tue, 09 Jun 2015 12:58:02 +0200

Hello.

Perhaps this is a too simple question, but anyway.  What are the
alternatives for signature scheme that are on the table?  Quoting the
meeting minutes [1]:

 next: define a signature scheme for use with the new curves.
 Some options:
 - ECDSA on (twisted) Edwards form versions of the new curves
 - De-randomised ECDSA:
   - avoids common failure mode of ECDSA
   - generate r for ECDSA by hashing message and private key
   - generate r via prf.
 - EdDSA [BDLST'11]
   - variant of schnorr signature scheme

Are there any details how the first option would actually work?  Has
anyone tried implementing it?

The second alternative is not a completely new signature scheme, is it?
The idea looks similar to RFC 6979.

Are there other options available?

/Simon

[1] https://www.ietf.org/proceedings/92/minutes/minutes-92-cfrg

---

From: "Paterson, Kenny" <[email-masked]>
Date: Tue, 9 Jun 2015 11:01:33 +0000

Simon,

We'll be coming to that very question rather soon as chairs, once the
current poll is closed and we've analysed the results. Watch this space!

Everyone else: please just hold off for a couple of days.

Cheers

Kenny