Subject: Re: [Cfrg] RFC 5742 conflict review for draft-dolmatov-kuznyechik

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Mon, 1 Feb 2016 14:26:29 +0000

I concur with ‎Yoav. There is no conflict that I see. This RFC can be published.

Sent from my BlackBerry 10 smartphone on the Verizon Wireless 4G LTE network.
  Original Message  
From: Yoav Nir
Sent: Monday, February 1, 2016 08:56
To: Simon Josefsson
Cc: [email-masked]; Nevil Brownlee
Subject: Re: [Cfrg] RFC 5742 conflict review for draft-dolmatov-kuznyechik

> On 1 Feb 2016, at 3:09 PM, Simon Josefsson <[email-masked]> wrote:
> 
> I believe that publishing the document below would conflict with ongoing
> work in the IETF to provide secure block ciphers that we can use on the
> Internet. It is not in the best interest of the IETF nor the Internet
> at large to publish RFCs of national ciphers if there is no immediate
> desire to use them in Internet protocols.

Hi.

There definitely is a desire to use this cipher. True, all potential users come from the same country, but that should not be blocking.

As a vendor, we often get a request to provide an IPsec and/or TLS implementation with GOST ciphers, and this is the new GOST cipher.

OTOH there is no RFC describing AES either. We usually point to a NIST document. Similarly, there are GOST documents describing kuznyechik. They are even referenced by the draft. So I’m not sure what this draft is supposed to accomplish. Is it merely an English translation? Regardless, this is an algorithm that is going to be used on the Internet and documenting it is a good thing. I don’t see how this interferes with our goal or providing secure block and streamish ciphers.

Yoav

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Mon, 1 Feb 2016 19:53:44 +0300

Dear colleagues,

in my opinion,
- no strong arguments against Kuznyechik's security have been proposed;
- this RFC draft has nothing in common with concrete proposals of algorithm
usage in cryptographic protocols, so anyway we don't have potential
security risks that can immediately follow from adoption of this draft;
- a strong need of RFC with Kuznyechik exists due to the fact that in
several years it will become a №1 cipher in Russia and a reference problem
will be important for multi-algorithm cryptographic software development
and usage;
- the RFC draft itself is well-structured and complete.

I think the draft can be adopted in the current form.

Best regards,
Stanislav Smyshlyaev, Ph.D.,
Head of Information Security Department,
CryptoPro LLC

Alexey Melnikov <[email-masked]> writes:

> Dear CFRG participants,
>
> On February 4th the IESG will be doing the conflict review for a draft
> [1] that describes GOST R 34.12-2015: Block Cipher
> "Kuznyechik". Stephen Farrell is handling this document on behalf of
> IESG. Stephen asked for feedback from CFRG.
>
> Since national algorithms are typically documented as independent
> submission stream RFCs, I think this one does not represent a conflict
> with ongoing IETF work or process. If you disagree, please let Stephen
> and CFRG chairs know.
>
> Should someone want code points for using this algorithm in IETF
> protocols, that would of course go through the normal IETF consensus
> process. See RFC 5742 [2] for details of what this bit of process is
> about.
>
> If you have comments on the draft content then please send those to
> the authors and cc the independent submissions editor, Nevil Brownlee
> ([email-masked]).
>
> Best Regards,
> Alexey, on behalf of CFRG chairs.
>
> [1] https://datatracker.ietf.org/doc/draft-dolmatov-kuznyechik/
> [2] https://tools.ietf.org/html/rfc5742
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>