Subject: Re: [Cfrg] Adopting "AES-GCM-SIV: Nonce Misuse-Resistant Authenticated Encryption" as a CFRG document ---- Some clarifications

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Fri, 8 Apr 2016 12:40:27 +0000

BTW, what assembler is the optimized code supposed to work with?

I'm on Mac OSX (10.10.5 and 10.11.4) using Xcode 7.2.1 and 7.3 correspondingly. Both systems also have gcc-5.3 and clang-3.7. I also t‎ried nasm, yasm. Nothing works. Would like some guidance. 

Sent from my BlackBerry 10 smartphone on the Verizon Wireless 4G LTE network.
  Original Message  
From: Adam Langley
Sent: Thursday, April 7, 2016 19:55
To: Andy Lutomirski
Cc: Yehuda Lindell; [email-masked]; Adam Langley
Subject: Re: [Cfrg] Adopting "AES-GCM-SIV: Nonce Misuse-Resistant Authenticated Encryption" as a CFRG document ---- Some clarifications

On Fri, Apr 8, 2016 at 8:16 AM, Andy Lutomirski <[email-masked]> wrote:
> Can you clarify the draft?

Will do as soon as I'm able (which should be next week).

Cheers

AGL

-- 
Adam Langley [email-masked] https://www.imperialviolet.org

_______________________________________________
Cfrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/cfrg

---

From: "Gueron, Shay" <[email-masked]>
Date: Sun, 10 Apr 2016 13:35:23 +0000

>>> BTW, what assembler is the optimized code supposed to work with?

The code that is currently posted was compiled and tested under Red Hat 
Linux, Fedora release 23, using GCC 4.8.2 & GNU assembly version 2.25.

MAC OS does not easily chew this assembler syntax, and some work needs 
to be done around it. However, I will soon post a C (intrinsics) version 
of the code, that should compile on all platforms (of course, at the 
cost of giving up some performance that hand tuned assembler achieves).

Regards, Shay

------ Original Message ------
From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
To: "Adam Langley" <[email-masked]>; "Andy Lutomirski" 
<[email-masked]>
Cc: "Yehuda Lindell" <[email-masked]>; "[email-masked]" 
<[email-masked]>; "Adam Langley" <[email-masked]>
Sent: 4/8/2016 5:40:27 AM
Subject: Re: [Cfrg] Adopting "AES-GCM-SIV: Nonce Misuse-Resistant 
Authenticated Encryption" as a CFRG document ---- Some clarifications

>I'm on Mac OSX (10.10.5 and 10.11.4) using Xcode 7.2.1 and 7.3 
>correspondingly. Both systems also have gcc-5.3 and clang-3.7. I also 
>t‎ried nasm, yasm. Nothing works. Would like some guidance.
>
>Subject: Re: [Cfrg] Adopting "AES-GCM-SIV: Nonce Misuse-Resistant 
>Authenticated Encryption" as a CFRG document ---- Some clarifications
>
>Adam Langley [email-masked]://www.imperialviolet.org
>