Subject: Re: [Cfrg] Requirements for PAKE schemes

From: Евгений Алексеев <[email-masked]>
Date: Fri, 22 Apr 2016 17:33:00 +0300

Hello!
The R3 and R4 requirements seem to be very similar, as I understand. The requirement to show how to protect an implementation in hostile environment includes the requirement of the necessity to implement the scheme in constant time. Maybe it is resonable to formulate R3 and R4 together in the following way:

R4: It SHOULD be possible to implement the PAKE scheme in hostile environments safely, particularly to implement the PAKE scheme in constant time to protect from timing attacks.

-- 
Best regards,
Evgeny Alekseev,
Moscow State University, Technical committee for standardisation "Cryptography and security mechanisms" (ТC 26).

---

From: Schmidt, Jörn-Marc <[email-masked]>
Date: Tue, 26 Apr 2016 12:28:37 +0000

Hello Evgeny,

thank you for reading the document and your suggestion. It's true, those two requirements are pretty similar. I have separated them to stress that constant time is very important and everything above a "may". But you're right, I can merge these two and use SHOULD.

Best regards,

Jörn

-----Ursprüngliche Nachricht-----
Von: Евгений Алексеев [mailto:[email-masked]] 
Gesendet: Freitag, 22. April 2016 16:33
An: [email-masked]; Schmidt, Jörn-Marc; [email-masked]; alexey.melnikov
Betreff: Re: [Cfrg] Requirements for PAKE schemes

Hello!