Subject: Re: [Cfrg] OCB patents expired?

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Fri, 1 Apr 2016 15:24:21 +0000

> According to the USPTO, patents 7046802 and 7200227 on OCB mode have expired
> due to non-payment.
> 
> I'm aware there's already a TLS exemption, but this seems like it should open
> up OCB mode for use in all protocols.

I’d love to see OCB used wider.

---

From: William Whyte <[email-masked]>
Date: Fri, 1 Apr 2016 11:58:03 -0400

Is there any concern about the IAPM patents due to Jutla and owned by IBM?
I understand that ideas from IAPM underlie OCB, but I don't know if OCB can
be implemented without infringing on those patents.

The IAPM patent was filed in 2000, so expires in 2020, AFAIK.

William

On Fri, Apr 1, 2016 at 11:24 AM, Blumenthal, Uri - 0553 - MITLL <
[email-masked]> wrote:

> According to the USPTO, patents 7046802 and 7200227 on OCB mode have
> expired due to non-payment.
>
> I'm aware there's already a TLS exemption, but this seems like it should
> open up OCB mode for use in all protocols.
>
>
> I’d *love* to see OCB used wider.
>
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>
>

---

From: Greg Rose <[email-masked]>
Date: Fri, 1 Apr 2016 09:50:02 -0700

There are also patents in this area from Virgil Gligor, about the same time. I haven't looked at them recently.

Greg.

> On Apr 1, 2016, at 8:58 , William Whyte <[email-masked]> wrote:
> 
> Is there any concern about the IAPM patents due to Jutla and owned by IBM? I understand that ideas from IAPM underlie OCB, but I don't know if OCB can be implemented without infringing on those patents.
> 
> On Fri, Apr 1, 2016 at 11:24 AM, Blumenthal, Uri - 0553 - MITLL <[email-masked]> wrote:
> According to the USPTO, patents 7046802 and 7200227 on OCB mode have expired due to non-payment.
> 
> I'm aware there's already a TLS exemption, but this seems like it should open up OCB mode for use in all protocols.
> 

Phone:  +1 619 890 8236 
GPG/PGP:  1081A37C  232B EC8F 44C6 C853 D68F  E107 E6BF CD2F 1081 A37C

---

From: Aaron Zauner <[email-masked]>
Date: Wed, 6 Apr 2016 01:34:48 +0200

Hi,

> On 01 Apr 2016, at 17:58, William Whyte <[email-masked]> wrote:
> 

There's an IPR exemption for my draft on OCB cipher-suites in TLS [0] related to IAPM from Jutla/IBM: https://datatracker.ietf.org/ipr/2647/

HTH,
Aaron

[0] https://datatracker.ietf.org/doc/draft-zauner-tls-aes-ocb/

---

From: Aaron Zauner <[email-masked]>
Date: Wed, 6 Apr 2016 01:38:33 +0200

Hi,

> On 01 Apr 2016, at 18:50, Greg Rose <[email-masked]> wrote:
> 

These patents were filed after relevant OCB and IAPM patents. I'm not very familiar with US patent law nor am I a lawyer but I'm told that this makes any claims irrelevant.

See also: https://www.ietf.org/mail-archive/web/tls/current/msg18252.html

Aaron

---

From: Greg Rose <[email-masked]>
Date: Tue, 5 Apr 2016 17:23:42 -0700

> On Apr 5, 2016, at 16:38 , Aaron Zauner <[email-masked]> wrote:
> 
> Hi,
> 

I don't want to start a legal flame war, but at the time, the rules were "first to invent" not "first to file" (which is relatively recent to the US). It's theoretically possible that there is documentation supporting his patent. Anyway, I agree it's probably irrelevant.

Greg.

Phone:  +1 619 890 8236