Subject: Re: [Cfrg] Internet-Drafts: OCB and RC6 when block cipher != 128 bits

From: Ted Krovetz <[email-masked]>
Date: Fri, 11 May 2018 16:37:47 -0700

I have submitted an internet-draft that specifies the authenticated-encryption algorithm OCB for cases where the underlying blockcipher does not have a 128-bit blocksize.

https://datatracker.ietf.org/doc/draft-krovetz-ocb-wideblock/

I am announcing this work here in case anybody is interested in using the results of this effort. Any comments on the draft (here or through direct email) would be appreciated.

Thank you,
Ted Krovetz

> On Apr 11, 2018, at 10:37 AM, Ted Krovetz <[email-masked]> wrote:
> 
> Several months ago three different parties asked if OCB could be extended to uses block ciphers with block lengths other than 128 bits. Phil Rogaway and I conferred and decided that it was fairly straightforward. I am in the process of writing an RFC for the modified version.
> 
> For purposes of creating test vectors I needed block ciphers of various block-length. Since both RC5 and RC6 patents appear to be expiring and they support many block lengths, I decided to use them as exemplars. To this end, I am also developing an RFC for RC5 and RC6 using non-standard block sizes. A link to the RC5/RC6 internet draft is:
> 
> https://datatracker.ietf.org/doc/draft-krovetz-rc6-rc5-vectors/
> 
> I am announcing this work here in case anybody is interested in using any of the results. The OCB draft should be ready in a week or two and I'll announce when it goes live too. Any comments on either draft (here or through direct email) would be appreciated.
> 
> Thank you,
> Ted Krovetz

---

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Fri, 11 May 2018 23:54:26 +0000

Thank you! Very useful draft. At least some of us have been eagerly waiting for this.

The assumption is that it would cover both wide and narrow blocks.

Specific feedback after I have a chance to review it.

Regards,
Uri

Sent from my iPhone

> On May 11, 2018, at 19:37, Ted Krovetz <[email-masked]> wrote:
> 
> _______________________________________________
> Cfrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>