Subject: Re: [Cfrg] PAKE selection process: status after Phase 1 and following steps // Information regarding SPAKE2

From: Björn Haase <[email-masked]>
Date: Fri, 19 Jul 2019 07:47:16 +0000

Dear Watson,

I am having two remarks regarding your description of SPAKE2

1.) Regarding request 2:

>R2:
>There is a security proof in
>
>Abdalla, M. and D. Pointcheval, "Simple Password-Based
>              Encrypted Key Exchange Protocols.", Feb 2005.
>
>              Appears in A.  Menezes, editor.  Topics in Cryptography-
>              CT-RSA 2005, Volume 3376 of Lecture Notes in Computer
>              Science, pages 191-208, San Francisco, CA, US.  Springer-
>              Verlag, Berlin, Germany.
>in the ROM.

I would like to add the pointer to the recent paper of Becerra, Ostrev, and Skrobot
https://eprint.iacr.org/2019/351
This paper addresses the problem that the proof from Abdalla and Pointcheval did not cover  forward secrecy.
(I actually did not yet find time to review and analyze it in detail but it did pass peer review for ProvSec 2018.)
I.e. since 2018 SPAKE2 provides has a proofs regarding forward secrecy.

2.) "Trusted Setup"

I have the impression that we have a wording / language problem here. My understanding is the following: When using the term "trusted setup" most people on the list might explicitly be referring to special points as used in constructions such as TBPEKE, VTBPEKE, SPAKE2 (and CPace with patent circumvention from Appendix A of the AuCPace paper).

Agreeing on this wording aspect might be important for the discussion, because this (in my opinion) is the specific advantage of constructions such as J-PAKE.
My suggestion is: Lets agree on the wording  "Trusted setup" includes "Special points".

Mit freundlichen Grüßen I Best Regards 

Dr. Björn Haase 

Senior Expert Electronics | TGREH Electronics Hardware
Endress+Hauser Conducta GmbH+Co.KG | Dieselstrasse 24 | 70839 Gerlingen | Germany
Phone: +49 7156 209 377 | Fax: +49 7156 209 221
[email-masked] |  www.conducta.endress.com 

Endress+Hauser Conducta GmbH+Co.KG
Amtsgericht Stuttgart HRA 201908
Sitz der Gesellschaft: Gerlingen
Persönlich haftende Gesellschafterin:
Endress+Hauser Conducta Verwaltungsgesellschaft mbH
Sitz der Gesellschaft: Gerlingen
Amtsgericht Stuttgart HRA 201929
Geschäftsführer: Dr. Manfred Jagiella

Gemäss Datenschutzgrundverordnung sind wir verpflichtet, Sie zu informieren, wenn wir personenbezogene Daten von Ihnen erheben.
Dieser Informationspflicht kommen wir mit folgendem Datenschutzhinweis (https://www.endress.com/de/cookies-endress+hauser-website) nach.

Disclaimer: 

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you receive this in error, please contact the sender and delete the material from any computer. This e-mail does not constitute a contract offer, a contract amendment, or an acceptance of a contract offer unless explicitly and conspicuously designated or stated as such.

---

From: Watson Ladd <[email-masked]>
Date: Fri, 19 Jul 2019 07:48:25 -0700

> I.e. since 2018 SPAKE2 provides has a proofs regarding forward secrecy.

Thank you for the additional reference!

> My suggestion is: Lets agree on the wording  "Trusted setup" includes "Special points".

If we do want to address both I think 'parameter generation' would be
a reasonable phrasing including both. Trusted setup has implications
that don't apply to SPAKE2.

-- 
"Man is born free, but everywhere he is in chains".
--Rousseau.