Subject: [Cfrg] PAKE selection process: Maybe we need a modular approach for integrating authentication of human individuals with TLS?

From: Björn Haase <[email-masked]>
Date: Fri, 19 Jul 2019 09:45:03 +0000

Hello to all,

I am writing this mail in order to prepare the future steps regarding PAKE on and after the Montreal Conference.

My personal perception is that among the set of current nominations no protocol was proposed that is obviously inadequate. (I personally am somewhat sceptic regarding the proof situations for “SPAKE2+EE/BSPAKE” and “SPEKE”, but even for these two I don’t see  obvious flaws if integrated properly.) My expectation is that regarding the security-topics, we might reach consensus in the CFRG community quite easily, once we have established a common understanding of the design priorities regarding patents, round efficiency, computational efficiency and security-guarantees.

I believe that the main objections regarding PAKE will come from elsewhere: The people that would have to integrate it into larger systems like TLS, browsers, OS or password database management modules (such as PAM).

I see the urgent need to standardize a sound PAKE for human user authentication and I think that for this purpose we will need to consider the concerns and needs of the “system integration” people very seriously. Otherwise, we might not be successful with the project of improving security and usability.

When trying to “wear the hat” of these people, I came to the conclusion that we might need some kind of a modular system integration approach. I have spend quite some time and discussions on this topic. I would appreciate your feedback regarding the problem analysis and solution approach that I tried to summarize in the slides available at https://github.com/BjoernMHaase/fe25519/blob/master/Concept_For_Modularized_PAKE_integration_into_TLS.pdf .

Maybe somebody might also spread this link to the TLS working group people or discuss the topic of TLS integration of PAKE at the upcoming conference in Montreal. (There seems to be an issue with my mail accounts being blocked from posting to the TLS mailing list ☹).

I am looking forward to entering a discussion with you.

Yours,

Björn.

Mit freundlichen Grüßen I Best Regards 

Dr. Björn Haase 

Senior Expert Electronics | TGREH Electronics Hardware
Endress+Hauser Conducta GmbH+Co.KG | Dieselstrasse 24 | 70839 Gerlingen | Germany
Phone: +49 7156 209 377 | Fax: +49 7156 209 221
[email-masked] |  www.conducta.endress.com 

Endress+Hauser Conducta GmbH+Co.KG
Amtsgericht Stuttgart HRA 201908
Sitz der Gesellschaft: Gerlingen
Persönlich haftende Gesellschafterin:
Endress+Hauser Conducta Verwaltungsgesellschaft mbH
Sitz der Gesellschaft: Gerlingen
Amtsgericht Stuttgart HRA 201929
Geschäftsführer: Dr. Manfred Jagiella

Gemäss Datenschutzgrundverordnung sind wir verpflichtet, Sie zu informieren, wenn wir personenbezogene Daten von Ihnen erheben.
Dieser Informationspflicht kommen wir mit folgendem Datenschutzhinweis (https://www.endress.com/de/cookies-endress+hauser-website) nach.

Disclaimer: 

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you receive this in error, please contact the sender and delete the material from any computer. This e-mail does not constitute a contract offer, a contract amendment, or an acceptance of a contract offer unless explicitly and conspicuously designated or stated as such.

---

From: "Stanislav V. Smyshlyaev" <[email-masked]>
Date: Fri, 19 Jul 2019 11:58:49 +0200

Dear Björn,

Thank you very much!
In my opinion, you’re absolutely right about the importance of these
questions for the process - and, as you may see in the plan of the PAKE
selection process, during the following stages there will be a call for
experts for reviewing the candidate PAKEs regarding such questions as
integrating into TLS and other security protocols, including M2M protocols.

Personally, I believe that your materials will be very helpful for this.
Obviously, it will be important to share your slides on the Stage 4, when
those properties of the nominated PAKEs will be reviewed.

Best regards,
Stanislav

пт, 19 июля 2019 г. в 11:41, Björn Haase <[email-masked]>:

> My personal perception is that among the set of current nominations no
> protocol was proposed that is obviously inadequate. (I personally am
> somewhat sceptic regarding the proof situations for “SPAKE2+EE/BSPAKE”
> and “SPEKE”, but even for these two I don’t see  obvious flaws if
> integrated properly.) My expectation is that regarding the security-topics,
> we might reach consensus in the CFRG community quite easily, once we have
> established a common understanding of the design priorities regarding
> patents, round efficiency, computational efficiency and security-guarantees.
>
>
>
> I believe that the main objections regarding PAKE will come from
> elsewhere: The people that would have to integrate it into larger systems
> like TLS, browsers, OS or password database management modules (such as
> PAM).
>
>
>
> I see the urgent need to standardize a sound PAKE for human user
> authentication and I think that for this purpose we will need to consider
> the concerns and needs of the “system integration” people very seriously.
> Otherwise, we might not be successful with the project of improving
> security and usability.
>
>
>
> When trying to “wear the hat” of these people, I came to the conclusion
> that we might need some kind of a modular system integration approach. I
> have spend quite some time and discussions on this topic. I would
> appreciate your feedback regarding the problem analysis and solution
> approach that I tried to summarize in the slides attached to this mail
>  (also available at https://github.com/BjoernMHaase/fe25519 ).
>
>
>
> Maybe somebody might also spread this link to the TLS working group people
> or discuss the topic of TLS integration of PAKE at the upcoming conference
> in Montreal. (There seems to be an issue with my mail accounts being
> blocked from posting to the TLS mailing list ☹).
>
>
>
> ------------------------------
> ------------------------------
>
> ------------------------------
>
> Gemäss Datenschutzgrundverordnung sind wir verpflichtet, Sie zu
> informieren, wenn wir personenbezogene Daten von Ihnen erheben.
>
> Dieser Informationspflicht kommen wir mit folgendem Datenschutzhinweis
> <https://www.de.endress.com/de/cookies-endress+hauser-website> nach.
> ------------------------------
>
>
>
> Disclaimer:
>
> The information transmitted is intended only for the person or entity to
> which it is addressed and may contain confidential, proprietary, and/or
> privileged
> material. Any review, retransmission, dissemination or other use of, or
> taking of any action in reliance upon, this information by persons or
> entities
> other than the intended recipient is prohibited. If you receive this in
> error, please contact the sender and delete the material from any computer.
> This e-mail does not constitute a contract offer, a contract amendment, or
> an acceptance of a contract offer unless explicitly and conspicuously
> designated or stated as such.
>
>
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Sat, 20 Jul 2019 23:15:00 -0500

> Maybe somebody might also spread this link to the TLS working group people or discuss the topic of TLS integration of PAKE at the upcoming conference in Montreal. (There seems to be an issue with m…

I forwarded this message to [email-masked].

That said, my understanding is (and I decidedly do not speak with any
authority here) that previous discussions of integrating a PAKE or other
external mechanisms into the TLS handshake have run into stumbling blocks
if there is a need to modify the handshake message flow, e.g., even to add an
extra handshake message, let alone an extra flight (as a GSS-API
integration would need).  That, in turn (if true), would seem to limit us
to just a ClientHello extension and ServerHello response, which is ...
quite constraining.  But let's see where the discussion ends up.

-Ben