Subject: Re: [cicm] Document Structure

From: "Novikov, Lev" <[email-masked]>
Date: Fri, 6 Aug 2010 15:14:45 -0400

There's been some positive feedback on splitting the document as proposed below.

To wrap it up, I'm putting it out to the list for a consensus check:

"Should CICM be split into five documents as proposed below?"
(1) Yes / Agree
(2) No / Disagree

Please respond to this email with your choice by 2010-08-13 17:00 EDT (COB next Friday).

Thanks,
Lev

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Novikov, Lev
Sent: Thursday, July 15, 2010 4:08 PM
To: CICM Discussion List
Subject: [cicm] Document Structure

As I hinted to last week, I'd like to raise some issues about the document structure.

The current draft (-01) is long (315 pages) and combines 20+ pages of informative
text with hundreds of pages of normative text. Also, some people have also mentioned 
that we do not provide an explicit logical model.

More importantly, however, is that the current shape of the document makes it hard for people
to read and comment on it. This is likely to keep us from getting on the Standards Track
when members of the IETF at-large and other review groups, such as the Security Area Advisory Group 
aren't willing to read the document and give it the go-ahead.

Therefore, I'd like to propose that we split the text of CICM into several different documents:

1. An informative background document that provides an introduction to the space, 
   the terminology, and logical model. (See: http://tools.ietf.org/html/rfc3264 for an 
   example of this sort of document.)
   ~ 30 pages.

2. A normative base document that defines the basic types and the Conformance & Extension model.
   ~ 20 pages.

3. A normative document that defines Module Management capabilities.
   ~ 50 pages.

4. A normative document that defines Key Management capabilities.
   ~ 50 pages.

5. A normative document that defines Channel Management capabilities.
   ~ 130 pages. (Still long, but there's a lot to cover.)

Document #2 would actually reference documents #1, 3, 4, and 5 and would, therefore,
"be CICM". The other normative documents would be using the extension mechanism
to provide the definitions for the actual capabilities.

* What do people think about this proposal? Other ideas?

Lev
_______________________________________________
cicm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/cicm

---

From: "Kevin W. Wall" <[email-masked]>
Date: Fri, 06 Aug 2010 16:31:41 -0400

> Please respond to this email with your choice by 2010-08-13 17:00 EDT (COB next Friday).

Yes, as long as splitting it into 5 docs doesn't slow down it's
transition from IETF-draft to approved status.
-- 
Kevin W. Wall
"The most likely way for the world to be destroyed, most experts agree,
is by accident. That's where we come in; we're computer professionals.
We cause accidents."        -- Nathaniel Borenstein, co-creator of MIME

---

From: "Bourget, Dennis" <[email-masked]>
Date: Fri, 6 Aug 2010 13:35:36 -0700

(1) Yes / Agree

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Novikov, Lev
Sent: Friday, August 06, 2010 12:15 PM
To: CICM Discussion List
Subject: Re: [cicm] Document Structure

There's been some positive feedback on splitting the document as
proposed below.

Please respond to this email with your choice by 2010-08-13 17:00 EDT
(COB next Friday).

Thanks,
Lev

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Novikov, Lev
Sent: Thursday, July 15, 2010 4:08 PM
To: CICM Discussion List
Subject: [cicm] Document Structure

As I hinted to last week, I'd like to raise some issues about the
document structure.

The current draft (-01) is long (315 pages) and combines 20+ pages of
informative
text with hundreds of pages of normative text. Also, some people have
also mentioned 
that we do not provide an explicit logical model.

More importantly, however, is that the current shape of the document
makes it hard for people
to read and comment on it. This is likely to keep us from getting on the
Standards Track
when members of the IETF at-large and other review groups, such as the
Security Area Advisory Group 
aren't willing to read the document and give it the go-ahead.

Therefore, I'd like to propose that we split the text of CICM into
several different documents:

1. An informative background document that provides an introduction to
the space, 
   the terminology, and logical model. (See:
http://tools.ietf.org/html/rfc3264 for an 
   example of this sort of document.)
   ~ 30 pages.

2. A normative base document that defines the basic types and the
Conformance & Extension model.
   ~ 20 pages.

Document #2 would actually reference documents #1, 3, 4, and 5 and
would, therefore,
"be CICM". The other normative documents would be using the extension
mechanism
to provide the definitions for the actual capabilities.

Lev

---

From: Tony <[email-masked]>
Date: Sat, 07 Aug 2010 07:43:49 -0400

Hello Lev,

I vote yes.

Tony Martin

On 08/06/2010 03:14 PM, Novikov, Lev wrote:
> 2. A normative base document that defines the basic types and the Conformance&  Extension model.
>     ~ 20 pages.
>

---

From: [email-masked]
Date: Mon, 9 Aug 2010 17:44:48 -0400

I vote (1).

Jim Howard
Director and Chief Engineer - Information Assurance
L-3 Communications, Communication Systems - East
Phone: 856-338-3504
[email-masked]