Subject: Re: [clue] Definitions: Participant

From: Christer Holmberg <[email-masked]>
Date: Wed, 1 Jun 2011 12:56:23 +0200

Hi,

In my ears, "particiapant" has always been associated with a human.

Also, my understanding is that ITU-T defines participant as a human participating in a conference, and I strongly think we should avoid identical wording with different meaning - it will only cause problems sooner or later.

Why can't we simply talk about "endpoint" or "client" when talking about the SIP device (whether it's a full blown telepresence room or a small mobile phone)? That's wording that people are used to, so I don't see why we need to come up with something new...

Regards,

Christer

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Paul Kyzivat
> Sent: 1. kesäkuuta 2011 2:50
> To: [email-masked]
> Subject: Re: [clue] Definitions: Participant
> 
> I support using Participant in the 4353 sense.
> (Its really the only definition that most of the software can 
> use in a useful way. E.g. the conference roster is about 
> these automata. This becomes especially obvious when you have 
> the same "person" showing up multiple times in the roster.)
> 
> If there is need to talk about the human(s) associated with a 
> participant, then it would make sense to define another term for that.
> 
> 	Thanks,
> 	Paul (as individual)
> 
> On 5/31/2011 7:03 PM, Stephan Wenger wrote:
> > Hi all,
> > I thought I would quickly rev the definitions doc, and 
> found out that 
> > I cannot find agreements on a number of terms. This is the 
> first of a 
> > set of eamils that will hopefully lead us to close the 
> definitions on 
> > a few terms.
> > So this email is about "Participant".
> >
> > We have the odd definition that RFC 4353 lists participant 
> essentially 
> > as a piece of software and not as a human. To Song Haibin, Steve 
> > Botzko (and to me), Participants sounds like human, though.
> >
> > Several ways forward:
> >
> >    1. Use Participant in the 4353 sense only
> >    2. Use Participant in the sense of a human participating in a
> >       telepresence session only. That would mean that there 
> can be many
> >       participants at any endpoint, and endpoint can have 
> no participant
> >       (empty room or webcam), and so forth.
> >    3. Use Participant in the sense of 2) above, and add 
> remark that if
> >       4353 Participant is meant, this will be explicitely mentioned.
> >
> > My preference is 1. 2 and 3 have too much potential for confusion. 
> > Shame on 4353 for that.
> >
> > Opinions?
> >
> > Stephan
> >
> >
> >
> >
> > _______________________________________________
> > clue mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/clue
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>

---

From: "Mike Hammer (hmmr)" <[email-masked]>
Date: Wed, 1 Jun 2011 07:55:22 -0500

Option 4:  don't use participant at all, since it is ambiguous.

If you mean to talk about a human, then simply say Human.

Hopefully, that term is unambiguous.

Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Wednesday, June 01, 2011 6:56 AM
To: Paul Kyzivat (pkyzivat); [email-masked]
Subject: Re: [clue] Definitions: Participant

Hi,

Regards,

Christer

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 1 Jun 2011 10:12:40 -0400

And use "device" or "UA" instead of RFC 4353 participant?

Unfortunately (IMO), the use of participant in the RFC 4353 sense is pretty
widespread in RAI.  So we probably need to find a new word.

The text is frequently awkward if you use human as a noun.  And not all
humans are participants, some are operators or administrators (or possibly
even spectators).

The thesaurus doesn't help much:

*Synonyms* actor, partaker, participator, party, player, sharer
*Related Words* accessory (also accessary), aide, assistant, helper;
colleague, partner
*Near Antonyms* bystander, looker-on, observer, onlooker, spectator,
watcher; wallflower
*Antonyms* nonparticipant

I suppose we could use "human participant", and the traditional Alice,
Bob...

Stephen Botzko

On Wed, Jun 1, 2011 at 8:55 AM, Mike Hammer (hmmr) <[email-masked]> wrote:

> Also, my understanding is that ITU-T defines participant as a human
> participating in a conference, and I strongly think we should avoid
> identical wording with different meaning - it will only cause problems
> sooner or later.
>
> Why can't we simply talk about "endpoint" or "client" when talking about
> the SIP device (whether it's a full blown telepresence room or a small
> mobile phone)? That's wording that people are used to, so I don't see why we
> need to come up with something new...
>
> Regards,
>
> Christer
>
>
>
>
>
>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 01 Jun 2011 16:27:15 -0400

On 6/1/2011 6:56 AM, Christer Holmberg wrote:
> Also, my understanding is that ITU-T defines participant as a human participating in a conference,

Can you provide a reference?
And, is it something CLUE wants/needs to reference?

> and I strongly think we should avoid identical wording with different meaning - it will only cause problems sooner or later.

Which is why we are concerned about being consistent with RFC 4353.

(We have a more difficult problem if we have dependency on documents 
that have conflicting definitions for the term.)

	Thanks,
	Paul

---

From: Stephen Botzko <[email-masked]>
Date: Wed, 1 Jun 2011 16:59:14 -0400

in-line, addressing the question on ITU-T definitions.

Stephen Botzko

On Wed, Jun 1, 2011 at 4:27 PM, Paul Kyzivat <[email-masked]> wrote:

>> In my ears, "participant" has always been associated with a human.
>>
>> participating in a conference,
>>
>

The ITU has a definitions database (prototype) here:
http://www.itu.int/ITU-R/index.asp?redirect=true&category=information&link=terminology-database&lang=en&adsearch=&SearchTerminology=&sector=&language=all&part=abbreviationterm&kind=anywhere

According this database, there are 4 ITU-T recommendations that define
"participant".  Two of these recommendations define it is as human  -
I.254.5 (The served user or a conferee.) and T.124 (A person participating
in a conference at a node.)  The other two recommendations do not define it
as a human user (and none define it like RFC 4353).

Neither recommendation seems relevant to CLUE

>  and I strongly think we should avoid identical wording with different
>> meaning - it will only cause problems sooner or later.
>>
>
> (We have a more difficult problem if we have dependency on documents that
> have conflicting definitions for the term.)
>
>        Thanks,
>        Paul
>
>

---

From: Mary Barnes <[email-masked]>
Date: Wed, 1 Jun 2011 16:00:13 -0500

XCON also uses "participant" in the same context as RFC 4353.  So, I think
that consistency within the IETF context is more important than how other
SDOs might use the term.   References to humans in both RFC 4353 and XCON
are qualifications of "operator" and "participant" rather than a standalone
term.  I will also note that SIPREC documents use the term participant in
the same context as RFC 4353, although there are cases where it is used to
refer to the human.  But, the context makes that clear. So, my
recommendation is that we use "human participant" in cases where the
qualification is necessary.

We also use the term "user" in both RFC 4353 and XCON (and SIPREC) in the
context of actions that would be performed by a human (e.g., keypresses),
etc. However, that term is overloaded in that it also is used for the
logical representation of the physical/human user in the data
model/conference object. And, SIPREC seems to use "participant" and "user"
interchangeably (3rd para in the Into of requirements when it's discussing
notification and opt out of recording).

So, I still think that "human participant" is the best choice when a
qualification is necessary.

Mary.
(as an individual)

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 1 Jun 2011 23:02:57 +0200

Hi,

>Can you provide a reference?

I will look for it when I'm back in office on friday.

>And, is it something CLUE wants/needs to reference?

Not necessarily. I just think we should try to avoid definition conflicts. And, if we are aware of such conflicts, I think we should document them.

>that have conflicting definitions for the term.)

I'm not even sure if 4353 is always alligned with itself :)

For example, in one place it talks about "anonymous particiapant", and to me that sounds more like a user, rather than a piece of software. Some parts of the security text also seems to make a similar impression. 

But, maybe that's not important for CLUE, if we only refer to the definition part in 4353.

Also, the 4353 definition talks about software that connects *A* user to a conference. We would need to specify, that in the scope of our work, it can connect multiple users to a conference.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 01 Jun 2011 17:04:14 -0400

wfm

On 6/1/2011 5:00 PM, Mary Barnes wrote:
> XCON also uses "participant" in the same context as RFC 4353.  So, I
> think that consistency within the IETF context is more important than
> how other SDOs might use the term.   References to humans in both RFC
> 4353 and XCON are qualifications of "operator" and "participant" rather
> than a standalone term.  I will also note that SIPREC documents use the
> term participant in the same context as RFC 4353, although there are
> cases where it is used to refer to the human.  But, the context makes
> that clear. So, my recommendation is that we use "human participant" in
> cases where the qualification is necessary.
>
> We also use the term "user" in both RFC 4353 and XCON (and SIPREC) in
> the context of actions that would be performed by a human (e.g.,
> keypresses), etc. However, that term is overloaded in that it also is
> used for the logical representation of the physical/human user in the
> data model/conference object. And, SIPREC seems to use "participant" and
> "user" interchangeably (3rd para in the Into of requirements when it's
> discussing notification and opt out of recording).
>
> On Wed, Jun 1, 2011 at 3:27 PM, Paul Kyzivat <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>
>
>         and I strongly think we should avoid identical wording with
>         different meaning - it will only cause problems sooner or later.
>
>
>         Why can't we simply talk about "endpoint" or "client" when
>         talking about the SIP device (whether it's a full blown
>         telepresence room or a small mobile phone)? That's wording that
>         people are used to, so I don't see why we need to come up with
>         something new...
>
>         Regards,
>
>         Christer
>
>
>
>
>
>
>             From: [email-masked] <mailto:[email-masked]>
>             [mailto:[email-masked] <mailto:[email-masked]>] On
>             Behalf Of Paul Kyzivat
>             To: [email-masked] <mailto:[email-masked]>
>                 [email-masked] <mailto:[email-masked]>
>             [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 1 Jun 2011 23:24:24 +0200

Hi,

If we go for the 4353 definition of "participant", when then talking about humans/users, I would prefer "user" instead of "human participant".

Regards,

Christer

________________________________
From: Mary Barnes [[email-masked]]
Sent: Thursday, June 02, 2011 12:00 AM
To: Paul Kyzivat
Cc: Christer Holmberg; [email-masked]
Subject: Re: [clue] Definitions: Participant

XCON also uses "participant" in the same context as RFC 4353.  So, I think that consistency within the IETF context is more important than how other SDOs might use the term.   References to humans in both RFC 4353 and XCON are qualifications of "operator" and "participant" rather than a standalone term.  I will also note that SIPREC documents use the term participant in the same context as RFC 4353, although there are cases where it is used to refer to the human.  But, the context makes that clear. So, my recommendation is that we use "human participant" in cases where the qualification is necessary.

We also use the term "user" in both RFC 4353 and XCON (and SIPREC) in the context of actions that would be performed by a human (e.g., keypresses), etc. However, that term is overloaded in that it also is used for the logical representation of the physical/human user in the data model/conference object. And, SIPREC seems to use "participant" and "user" interchangeably (3rd para in the Into of requirements when it's discussing notification and opt out of recording).

So, I still think that "human participant" is the best choice when a qualification is necessary.

Mary.
(as an individual)

On Wed, Jun 1, 2011 at 3:27 PM, Paul Kyzivat <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

(We have a more difficult problem if we have dependency on documents that have conflicting definitions for the term.)

       Thanks,
       Paul

Regards,

Christer

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On
Behalf Of Paul Kyzivat
Sent: 1. kesäkuuta 2011 2:50
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [clue] Definitions: Participant

       Thanks,
       Paul (as individual)

Several ways forward:

Opinions?

Stephan

_______________________________________________
clue mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/clue
_______________________________________________
clue mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/clue

_______________________________________________
clue mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/clue

---

From: Paul Coverdale <[email-masked]>
Date: Wed, 1 Jun 2011 18:19:45 -0400

I wasn't familiar with RFC4353, so I took a quick look. It seems that they
did a great job of hi-jacking a perfectly good English word.

E.G.
"Participant" - a person who takes part in or becomes involved in a
particular activity.

So we will create a nice tautology if we talk about a human participant.
Unless we want to differentiate between in-human participants.

If we are going to treat the RFC4353 definition of "participant" as
sacrosanct, then I would support "user" as the next best choice for CLUE
purposes.

...Paul

>Sent: Wednesday, June 01, 2011 5:24 PM
>To: Mary Barnes; Paul Kyzivat
>Cc: [email-masked]
>If we go for the 4353 definition of "participant", when then talking
>about humans/users, I would prefer "user" instead of "human
>participant".
>
>Regards,
>
>Christer
>
>On Wed, Jun 1, 2011 at 3:27 PM, Paul Kyzivat
><[email-masked]<mailto:[email-masked]>> wrote:
>
>
>mobile phone)? That's wording that people are used to, so I don't see
>why we need to come up with something new...
>
>Regards,
>
>Christer
>
>
>
>
>
>
>From: [email-masked]<mailto:[email-masked]> [mailto:clue-
>[email-masked]<mailto:[email-masked]>] On
>Behalf Of Paul Kyzivat

---

From: Mary Barnes <[email-masked]>
Date: Wed, 1 Jun 2011 17:39:28 -0500

In the end, I think the context is what will be necessary to clarify the
meaning (human, non-human physical entity or logical entity) whether we use
participant or user, per my comment with regards to the XCON usage of the
latter term.  So, let's just pick one and ensure that it's clear in the
context that it's used.

Mary.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 01 Jun 2011 19:45:17 -0400

> did a great job of hi-jacking a perfectly good English word.

Well, if corporations can be people wrt free speech,
then UAs can be participants in conferences. :-)

(In XCON conferences anyway. I guess IETF82 is conference too, that has 
human participants - though they are more properly called "registrants" 
I think.)

Pretty much all of the conference/xcon stuff is about interactions among 
software entities. So its makes perfect sense to me to call those UAs 
that are involved in a conference 'participants' in the conference. (The 
people only interact with their UA.)

Even in CLUE, afaik the human participants will be pretty hard to 
identify in the resulting protocols. They are some blotchy things that 
show up in the field of view of cameras, but most likely the software 
can't distinguish a participant from an empty chair. And while its 
possible to decide which camera to display based on where there is audio 
energy, will clue facilitate identifying *who* is speaking, as distinct 
from which microphone the audio is coming from?

And regarding anonymous participants, I believe that those are the UAs 
whose From address is sip:[email-masked].

	Thanks,
	Paul

---

From: Paul Coverdale <[email-masked]>
Date: Wed, 1 Jun 2011 20:48:54 -0400

>From: Paul Kyzivat [mailto:[email-masked]]
>Sent: Wednesday, June 01, 2011 7:45 PM
>To: Paul Coverdale
>Cc: 'Christer Holmberg'; 'Mary Barnes'; [email-masked]

It's a philosophical point, I suppose, but would the typical "participant"
in IETF conferences consider themselves as a "person", or as a "software
element that connects a user or automata to a conference".

Actually, RFC 4353 got it right in one definition. I've noticed a few
"Conference-Unaware Participants".

...Paul

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 10 Jun 2011 13:30:41 -0700

Sorry I am late to the thread. I was out of the office a couple weeks
and having too much fun to check e-mail.
I prefer use participant in the RFC 4353 sense, as you never really know
how many humans, if any, are in a room or in the field of vision of a
camera, and the number may change without any signaling or other
indication.

Cheers,
Charles

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of Paul Kyzivat (pkyzivat)
> Sent: Tuesday, May 31, 2011 4:50 PM
> To: [email-masked]
> (Its really the only definition that most of the software can use in a
> useful way. E.g. the conference roster is about these automata. This
> becomes especially obvious when you have the same "person" showing up
> multiple times in the roster.)
> 
> > I thought I would quickly rev the definitions doc, and found out
that I
> > cannot find agreements on a number of terms. This is the first of a
set
> > of eamils that will hopefully lead us to close the definitions on a
few
> > terms.
essentially
> > as a piece of software and not as a human. To Song Haibin, Steve
Botzko
> > (and to me), Participants sounds like human, though.
> >
> > Several ways forward:
> >
> >       telepresence session only. That would mean that there can be
many
> >       participants at any endpoint, and endpoint can have no
participant
> >    3. Use Participant in the sense of 2) above, and add remark that
if
> > My preference is 1. 2 and 3 have too much potential for confusion.
Shame
> > on 4353 for that.

---

From: Roni Even <[email-masked]>
Date: Wed, 22 Jun 2011 14:01:05 +0300

In term of the use cases my experience is that the participant is the
endpoint itself, this is usually a fixed name like "conference room 1" or
"Roni's room system" and this is what typically appears when you call a
remote system or look at the conference roster. So RFC 4353 term is good.

There is also a need to be able to specify who is currently using the system
and any qualified name that will say that this are the current people in the
conference will serve. I am not sure that the current equipment makes it
easy to provide this information.
Roni Even

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Paul Coverdale
> Sent: Thursday, June 02, 2011 3:49 AM
> To: 'Paul Kyzivat'
> Cc: [email-masked]
> __________ Information from ESET NOD32 Antivirus, version of virus
> signature database 6174 (20110602) __________
> 
> The message was checked by ESET NOD32 Antivirus.
> 
> http://www.eset.com
> 
> 
> 
> 
> __________ Information from ESET NOD32 Antivirus, version of virus
> signature database 6175 (20110602) __________
> 
> The message was checked by ESET NOD32 Antivirus.
> 
> http://www.eset.com
>

---

From: "Paul Coverdale" <[email-masked]>
Date: Wed, 22 Jun 2011 13:46:10 +0200

I'm a bit confused now. The RFC4353 definition of participant doesn't talk
about an "end-point", but mentions "user" (although there is no definition
of user).

...Paul

>Sent: Wednesday, June 22, 2011 1:01 PM
>To: [email-masked]

---

From: Roni Even <[email-masked]>
Date: Wed, 22 Jun 2011 15:02:38 +0300

Paul,
I meant that it is the equipment (software element in RFC 4353) and not the
person who is currently using the system. This can be a video conferencing
system, MCU or gateway.
Roni

> From: Paul Coverdale [mailto:[email-masked]]
> Sent: Wednesday, June 22, 2011 2:46 PM
> To: 'Roni Even'; [email-masked]
> Subject: RE: [clue] Definitions: Participant
> 
> Of
> >and any qualified name that will say that this are the current people
> in
> >the