Subject: [clue] Meeting invitation: CLUE WG Design Team

From: Mary Barnes <[email-masked]>
Date: Mon, 27 Feb 2012 18:16:31 -0600

Let's have a meeting tomorrow and discuss the signaling options that are
being discussed on the mailing list:
http://www.ietf.org/mail-archive/web/clue/current/msg01076.html

Regards,
Mary.

===========================================

Topic: CLUE WG Design Team
Date: Tuesday, February 28, 2012
Time: 9:00 am, Central Standard Time (Chicago, GMT-06:00)
Meeting Number: 640 231 272
Meeting Password: 1234

-------------------------------------------------------
To join the online meeting (Now from mobile devices!)
-------------------------------------------------------
1. Go to
https://ietf.webex.com/ietf/j.php?ED=150507847&UID=0&PW=NYWQ0NzNhYmYy&RT=MiM3
2. If requested, enter your name and email address.
3. If a password is required, enter the meeting password: 1234
4. Click "Join".

To view in other time zones or languages, please click the link:
https://ietf.webex.com/ietf/j.php?ED=150507847&UID=0&PW=NYWQ0NzNhYmYy&ORT=MiM3

-------------------------------------------------------
To join the audio conference only
-------------------------------------------------------
Call-in toll number (US/Canada): +1-408-600-3600

Access code:640 231 272

-------------------------------------------------------
For assistance
-------------------------------------------------------
1. Go to https://ietf.webex.com/ietf/mc
2. On the left navigation bar, click "Support".

You can contact me at:
[email-masked]

To add this meeting to your calendar program (for example Microsoft
Outlook), click this link:
https://ietf.webex.com/ietf/j.php?ED=150507847&UID=0&ICS=MI&LD=1&RD=2&ST=1&SHA2=9b-045xLdAOgtFE7d/7fifMF2twrRz-mS2mPAmn79Bg=&RT=MiM3

The playback of UCF (Universal Communications Format) rich media files
requires appropriate players. To view this type of rich media files in the
meeting, please check whether you have the players installed on your
computer by going to https://ietf.webex.com/ietf/systemdiagnosis.php.

Sign up for a free trial of WebEx
http://www.webex.com/go/mcemfreetrial

http://www.webex.com

CCP:+14086003600x640231272#

IMPORTANT NOTICE: This WebEx service includes a feature that allows audio
and any documents and other materials exchanged or viewed during the
session to be recorded. By joining this session, you automatically consent
to such recordings. If you do not consent to the recording, discuss your
concerns with the meeting host prior to the start of the recording or do
not join the session. Please note that any such recordings may be subject
to discovery in the event of litigation. ****

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 27 Feb 2012 19:32:54 -0500

Do we have minutes from the interim ? Notes ?

Marshall

On Mon, Feb 27, 2012 at 7:16 PM, Mary Barnes <[email-masked]> wrote:
> and any documents and other materials exchanged or viewed during the session
> to be recorded. By joining this session, you automatically consent to such
> recordings. If you do not consent to the recording, discuss your concerns
> with the meeting host prior to the start of the recording or do not join the
> session. Please note that any such recordings may be subject to discovery in
> the event of litigation.
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue
>

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 27 Feb 2012 20:51:11 -0500

Sorry - I will post the notes shortly.

	Paul

On 2/27/12 7:32 PM, Marshall Eubanks wrote:
> On Mon, Feb 27, 2012 at 7:16 PM, Mary Barnes<[email-masked]>  wrote:

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 27 Feb 2012 22:31:01 -0500

> Do we have minutes from the interim ? Notes ?

I just posted raw notes from John and Allyn, at

http://www.ietf.org/proceedings/interim/2012/02/15/clue/minutes/minutes-interim-2012-clue-1.pdf

(Sorry about using PDF format - it was the path of least resistance to 
get a .doc file up there.)

Will try to get a somewhat cleaned up version with summary and action 
items, and maybe in some other format - later.

	Thanks,
	Paul

---

From: John Leslie <[email-masked]>
Date: Tue, 28 Feb 2012 10:58:42 -0500

Attending: John Leslie, Allyn, Paul Kyzivat, Mark Duckworth, Marshall Eubanks, Mary Barnes, Rob Hansen, Roni Even, Spencer Dawkins, Stephan Wenger

1005 CTO
Mary: trying to get host role
Mary: email thread on signaling options (trying to share)
1008 clue archives up
Mary: lost my WebEx screen... (archive showing again)
Mary: A1... A2... B... C... (variation on B)
Paul: intent to merely capture what we discussed at meeting; did I succeed? just a starting point for the discussion
Allyn: I thought it was good
Roni: I tried to do a bit of phrasing... we had some drafts in transport from Stephan; we're talking about three ways to convey the full media description; first issue is clue protocol... three options... tied to all of them, what part of the media description is in the SDP; this info relevant to all of them, where you carry the information about the media itself
Rob: inaudible... email on the 27th
Mary: focus of these, SDP as a tool, you did higher level
Paul: I don't disagree with what Roni said, different way of looking, we were talking essentially use-cases, Roni talking signaling, both are useful to talk about; my thought was we're trying to see how it plays out
Roni: on whiteboard... how do you end up setting all the channels eventually, do you offer 1 audio, 1 video, and later negotiate the rest? I tried to say what topics need to be discussed; missing in A) clue as part of the SDP, A1 in Paul's description
Rob: (hard to hear) that was the one we agreed we should avoid if possible
Mary: are we agreed we want to avoid that
Roni: that's OK
Mary: A1 is off the table
Mary: Roni, yours is more complete
Roni: break into topics... analyze what topics being discussed
Paul: we need both to express pieces of mechanism and call flow; offer-answer, symmetric pair... at end this has to impact offer-answer, one, two, or more... if you give up capability exchange you can probably make it work in one; your vanilla SIP device might have trouble with one offer-answer
Roni: may have problems sending grouping
Paul: whether we use bundle or not, one part might be more complex, we don't know yet
Roni: depends how you want to negotiate all the media channels... proposal using RTCP, (looking up draft) draft-lennox-clue-rtpusage
Allyn: which document that Roni wrote is he talking about?
Roni: similar to what bundle is doing... need to try to extend all those options, and code using those options... how to carry clue info, what does initial offer-answer carry, orthogonal; how many messages you need to set up a call, minimum everything in invite, 3264 response; each side has to describe what it can offer; for three modes of negotiation, work out number of messages
Paul: maybe we can figure out the worst case... initial invite, exchange 3 messages from each end, followed by another offer-answer, 12 messages; lots of optimizations possible; is 12 messages too many?
Roni: it's not 12 messages
Paul: possible it could be more... if you use info to do clue messages
Marshall: how long would it take, perhaps 800 msec
Roni: assumption after first exchange you have at least one audio; user experience, once you get an answer you expect to be able to talk (otherwise you hang up), important for the user experience
Marshall: how long it takes is more important than the number of messages
Paul: initial media offer structured to be benign (not what you really want to use), will two ends have something useful to exchange while they work on longer negotiation
Roni: you start out not knowing the other side talks CLUE... an application issue
Marshall: you don't need to receive media to have receiver display "wait for CLUE negotiation"
Paul: are we doing anything here that forces a bad user experience?
Stephan: one key problem, which screen is left vs. right; I don't call it a good user experience if things flicker up on the wrong screen; sufficient to bring up audio; shouldn't put up any video before the CLUE negotiation, it's normal to come up in mono audio
Roni: doesn't cause any problems, receiver will receive only one audio stream, it's normal for the quality of it to change
Paul: is the number of messages going to lead to excluding one or more alternatives? do we have to pick one now?
Stephan: I'd rather one RT more than limit future capabilities; IMHO it would be foolish not to allow capability messages; we're not talking about cell-phone, these things today take 10-20 seconds to come up
Paul: I'm hearing any of these techniques is potentially acceptable
Roni: preference for optimized if everything else equal
Marshall: RTT is useful to optimize, #messages is not
Paul: certain amount of piggybacking... at least two RTTs, may or may not be able to multiplex offer-answers on those, probably talking 3 to 4 RTTs minimum, need to work out the details; you can multiplex CLUE on offer-answer for some but not others; I'm hearing all these options are within an acceptable range
Roni: all of them can work, if all work, I prefer less RTTs; we strike out CLUE running in RTP, we need to describe all of them, how many RTTs, then make a decision; another issue is whether all negotiation should be on the signaling channel
Paul: I don't think we've gotten far enough to decide that -- can you get all your messages in one PDU
Roni: we're talking about end-to-end, not through an intermediary; we have problems opening TCP in those use-cases because of NAT traversal
Rob: RTCWEB considering that
Paul: we may be forced into ?? over UDP... hand-waving over fragmentation
Spencer: that's not the only scenario
Paul: convince yourself messages are small enough
Mary: let's try to close on this -- work out details of the options -- draft deadline for -00 is Monday
Roni: Stephan has transport draft, we'll try to update that to include all three options
Stephan: this draft intended to provide an analysis of available options, reasonable to discard not-usable options and provide details on the useful ones
1052
Marshall: I posted XML for Stephan's transport draft
Mary: we have two sessions; we may not need another call next Tuesday
Marshall: I'm co-chairing a BoF which conflicts with one of them
Mary: think we're done
1055 adjourn

--
John Leslie <[email-masked]>