Subject: Re: [clue] MC -> multiple streams - Review of framework-03

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 13 Feb 2012 10:23:38 -0800

Hi Roni,

A media capture may be encoded into multiple streams simultaneously, perhaps with different codecs or different encoding parameters.  For example simulcast of a video capture at CIF and 1080p resolutions.  Each of those could be a different stream.

>From section 8 of the draft framework-03:
"If there are multiple individual encodings in the group, then a single media capture can be encoded into multiple different streams at the same time, with each stream following the constraints of a different individual encoding."

Mark

======================================
From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni Even
Sent: Wednesday, February 08, 2012 8:49 AM
To: [email-masked]
Subject: [clue] Review of draft-ietf-clue-framework-03

1. In section 3 the definition of media capture say "A Media Capture (MC) may be the source of one or more Media streams."  What is the "more" in this case. Can you explain since my understanding of a media capture is that is one stream, can you give an example.

Thanks
Roni Even

---

From: "Roni Even" <[email-masked]>
Date: Tue, 14 Feb 2012 19:17:34 +0200

Hi Mark,
So do you see that the capture set may include a MC with a simulcast and a
different one with just one RTP stream. I think that goes to the discussion
we are having on mapping the SDP information to the MCs
Roni

> -----Original Message-----
> From: Duckworth, Mark [mailto:[email-masked]]
> Sent: Monday, February 13, 2012 8:24 PM
> To: Roni Even; [email-masked]
> Subject: RE: [clue] MC -> multiple streams - Review of framework-03
> 
> Hi Roni,
> 
> A media capture may be encoded into multiple streams simultaneously,
> perhaps with different codecs or different encoding parameters.  For
> example simulcast of a video capture at CIF and 1080p resolutions.
> Each of those could be a different stream.
> 
> "If there are multiple individual encodings in the group, then a single
> media capture can be encoded into multiple different streams at the
> same time, with each stream following the constraints of a different
> individual encoding."
> 
> Mark
> 
> 1. In section 3 the definition of media capture say "A Media Capture
> (MC) may be the source of one or more Media streams."  What is the
> "more" in this case. Can you explain since my understanding of a media
> capture is that is one stream, can you give an example.
> 
> Thanks
> Roni Even
>

---

From: "Duckworth, Mark" <[email-masked]>
Date: Tue, 14 Feb 2012 09:40:57 -0800

Hi Roni,
No, we did not intend to use different MCs for different ways of encoding the same thing.  If the consumer wants to get different encodings of the same MC, it asks for that when it sends the "configure encodings" message to the provider.  The consumer specifies which individual encodings to use, taken from the encoding group the provider advertised for that MC.
Mark

-----Original Message-----
From: Roni Even [mailto:[email-masked]] 
Sent: Tuesday, February 14, 2012 12:18 PM
To: Duckworth, Mark; [email-masked]
Subject: RE: [clue] MC -> multiple streams - Review of framework-03

Hi Mark,
So do you see that the capture set may include a MC with a simulcast and a different one with just one RTP stream. I think that goes to the discussion we are having on mapping the SDP information to the MCs Roni

> "If there are multiple individual encodings in the group, then a 
> single media capture can be encoded into multiple different streams at 
> the same time, with each stream following the constraints of a 
> different individual encoding."
> 
> Mark
>

---

From: "Roni Even" <[email-masked]>
Date: Wed, 15 Feb 2012 05:57:03 +0200

Hi Mark,
In my view you may need different m-lines or payload type numbers to
describe the two options, as for MCs this is a question if this is a
different semantic or a single one since they represent the same source like
left camera. Still the left camera may need to be mapped to different SDP
specified streams.
I do not think that the individual encoding should be used for it since this
will be a duplication of SDP. I already said in a different comment that I
see no value in individual encodes since they duplicate SDP but even if you
use them for constrains they should not be used for replacing SDP.
Roni

> Sent: Tuesday, February 14, 2012 7:41 PM
> No, we did not intend to use different MCs for different ways of
> encoding the same thing.  If the consumer wants to get different
> encodings of the same MC, it asks for that when it sends the "configure
> encodings" message to the provider.  The consumer specifies which
> individual encodings to use, taken from the encoding group the provider
> advertised for that MC.
> Mark
> 
> So do you see that the capture set may include a MC with a simulcast
> and a different one with just one RTP stream. I think that goes to the
> discussion we are having on mapping the SDP information to the MCs Roni
>