Subject: [clue] switch-policy attribute proposal

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 5 Mar 2012 11:51:19 -0800

At the interim meeting I think people generally agreed the clue framework should include a way for a provider to advertise site-switching and segment-switching policies, and for the consumer to request one or the other.  Here is a rough proposal.

Add a new "switch-policy" attribute for a capture scene entry (or capture set entry, using the framework-03 terminology) (note the attribute is for a capture scene entry not a media capture).

Switch-policy: {site-switch, segment-switch}
An attribute with enumerated values which identifies the policy the provider uses for how to switch the various media captures within the capture scene entry.
A value of 'site-switch' means all the media captures within the capture scene entry typically switch together, with the provider attempting to include all the media captures from the same site together.
A value of 'segment-switch' means the media captures in the entry switch independently of each other, so at any point in time the media captures could be originally sourced from different sites.

In a provider advertisement, the provider can include multiple values for the switch-policy attribute.  The provider is saying it can provide any one of those switch-policies it advertises.  When a consumer configures the provider, the consumer includes this attribute with only the single value for switch-policy that it wants to receive.

Regards,
Mark

---

From: "Roni Even" <[email-masked]>
Date: Tue, 6 Mar 2012 10:28:25 +0200

Mark,

I am OK with this. I assume this applies to the multipoint case, maybe add a
reference to the relevant use case in the use case draft.

I am not sure about the attribute name since there is no intent to make it
the general switch case for example "voice activated", "round robin"

Maybe change the attribute name to TP-switch-policy and emphasis the purpose
of the attribute.

Roni

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Duckworth, Mark
Sent: Monday, March 05, 2012 9:51 PM
To: [email-masked]
Subject: [clue] switch-policy attribute proposal

At the interim meeting I think people generally agreed the clue framework
should include a way for a provider to advertise site-switching and
segment-switching policies, and for the consumer to request one or the
other.  Here is a rough proposal.

Add a new "switch-policy" attribute for a capture scene entry (or capture
set entry, using the framework-03 terminology) (note the attribute is for a
capture scene entry not a media capture).

An attribute with enumerated values which identifies the policy the provider
uses for how to switch the various media captures within the capture scene
entry.

A value of 'site-switch' means all the media captures within the capture
scene entry typically switch together, with the provider attempting to
include all the media captures from the same site together.

A value of 'segment-switch' means the media captures in the entry switch
independently of each other, so at any point in time the media captures
could be originally sourced from different sites.

In a provider advertisement, the provider can include multiple values for
the switch-policy attribute.  The provider is saying it can provide any one
of those switch-policies it advertises.  When a consumer configures the
provider, the consumer includes this attribute with only the single value
for switch-policy that it wants to receive.

Regards,

Mark

---

From: Christian Groves <[email-masked]>
Date: Wed, 07 Mar 2012 21:17:36 +1100

Hello Mark,

Would a "site switch" policy only apply to an advertisement provided by 
an MCU?

Regards, Christian

On 6/03/2012 6:51 AM, Duckworth, Mark wrote:
>
> At the interim meeting I think people generally agreed the clue 
> framework should include a way for a provider to advertise 
> site-switching and segment-switching policies, and for the consumer to 
> request one or the other. Here is a rough proposal.
>
> Add a new “switch-policy” attribute for a capture scene entry (or 
> capture set entry, using the framework-03 terminology) (note the 
> attribute is for a capture scene entry not a media capture).
>
> An attribute with enumerated values which identifies the policy the 
> provider uses for how to switch the various media captures within the 
> capture scene entry.
>
> A value of ‘site-switch’ means all the media captures within the 
> capture scene entry typically switch together, with the provider 
> attempting to include all the media captures from the same site together.
>
> A value of ‘segment-switch’ means the media captures in the entry 
> switch independently of each other, so at any point in time the media 
> captures could be originally sourced from different sites.
>
> In a provider advertisement, the provider can include multiple values 
> for the switch-policy attribute. The provider is saying it can provide 
> any one of those switch-policies it advertises. When a consumer 
> configures the provider, the consumer includes this attribute with 
> only the single value for switch-policy that it wants to receive.
>
> Regards,
>
> Mark
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 7 Mar 2012 12:03:16 -0800

Hi Christian,
In practice that might be the way it works out, but I don't see a reason to restrict it in the document.
Mark

> -----Original Message-----
> Christian Groves
> Sent: Wednesday, March 07, 2012 5:18 AM
> To: [email-masked]
> Subject: Re: [clue] switch-policy attribute proposal
> 
> Hello Mark,
> 
> Would a "site switch" policy only apply to an advertisement provided by an
> MCU?
> 
> Regards, Christian
> 
> > Add a new "switch-policy" attribute for a capture scene entry (or
> > A value of 'site-switch' means all the media captures within the
> > A value of 'segment-switch' means the media captures in the entry

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 21 Mar 2012 08:16:25 -0700

Hi Roni,

Thanks for the suggestions, I agree.

When I looked back at section 3.3 Multipoint meeting in the use cases, I see it gives a good description of site switch, segment switch, and also describes a possibility with neither of those, for example using continuous presence without switching.

It seems to make sense to change this proposal a bit, to better match the use case.  I think the point of this attribute is about the whole scene, not just a particular media capture.  So maybe the attribute should be named "scene-switch-policy" (rather than "switch-policy") and values could still be {site-switch, segment-switch}.  If the provider wants to advertise a capture scene entry that is neither site-switch nor segment-switch,  it should just omit this attribute.  What do you think?

I agree with you we should make it clear that this attribute is about the policy of coordinating multiple captures in a capture scene entry, not about the criteria for deciding when to switch something.  If the group generally agrees with all this, I could update the proposal with more specific text.

Mark

From: Roni Even [mailto:[email-masked]]
Sent: Tuesday, March 06, 2012 3:28 AM
To: Duckworth, Mark; [email-masked]
Subject: RE: [clue] switch-policy attribute proposal

Mark,
I am OK with this. I assume this applies to the multipoint case, maybe add a reference to the relevant use case in the use case draft.

I am not sure about the attribute name since there is no intent to make it the general switch case for example "voice activated", "round robin"
Maybe change the attribute name to TP-switch-policy and emphasis the purpose of the attribute.

Roni

From: [email-masked] [mailto:[email-masked]] On Behalf Of Duckworth, Mark
Sent: Monday, March 05, 2012 9:51 PM
To: [email-masked]
Subject: [clue] switch-policy attribute proposal

Regards,
Mark