Subject: Re: [clue] differentiating between multiple capture scenes - was Proposal to combine capture scene and capture set

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 7 Mar 2012 12:03:15 -0800

Yes multiple capture scenes are allowed in a single provider advertisement.

Brian - there is no 'purpose' attribute on a capture scene.  The purpose attribute is on media captures.  I'm not sure a purpose attribute makes sense on a scene, we would have to think about it.  It could conflict with the attribute on media captures.  Are you proposing something new?

Roni - about differentiating between capture scenes - what information do you propose to use to differentiate them?  My view is they are differentiated by the media captures (described by attributes) that are contained in the capture scene entries, and that is all we need.  If you think there needs to be more information, what do you propose?

Mark

From: Brian Baldino (bbaldino) [mailto:[email-masked]]
Sent: Tuesday, March 06, 2012 5:11 AM
To: Roni Even; Duckworth, Mark; [email-masked]
Subject: RE: [clue] Proposal to combine capture scene and capture set

Hey Roni,
I think this is just a vocabulary change-multiple capture scenes are still allowed.  The idea was that the 'purpose' attribute of the capture scene would be used to differentiate them.

-Brian

From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni Even
Sent: Tuesday, March 06, 2012 12:23 AM
To: 'Duckworth, Mark'; [email-masked]
Subject: Re: [clue] Proposal to combine capture scene and capture set

Hi Mark,
I do not care how we call it. What I am missing is the top level.
Does a provider advertise one capture scene composed of multiple capture scene entries. My understanding so far was that there can be  more than one if we substitute set with scene.
Can there be more than one capture scene in the advertisement in which case how do you differentiate between them, is there a scene identifier and how does the consumer know what is the scene.
Roni Even

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Duckworth, Mark
Sent: Monday, March 05, 2012 9:16 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [clue] Proposal to combine capture scene and capture set

At the interim meeting, there was some support for combining the concepts of "capture scene" and "capture set" into a single concept.  So here is a rough proposal for doing that, essentially using the term "capture scene" to replace the previous term "capture set", and eliminating the original separate capture scene concept.

Definitions:

*Capture Scene: a structure representing the scene that is captured by a collection of capture devices.  A capture scene includes one or more capture scene entries, with each entry including one or more media captures.

*Capture Scene Entry: a list of media captures of the same media type that together form one way to represent the capture scene.

Text for section 6.2 Capture Scene (was 6.2 Capture Set):

A capture scene represents, for example, the video image of a group of people seated next to each other, along with the sound of their voices, which could be represented by some number of VCs and ACs in the capture scene entries. A middle box may also express capture scenes that it constructs from media streams it receives.

A media provider arranges media captures in a capture scene to help the media consumer choose which captures it wants.  The capture scene entries in a capture scene are different alternatives the provider is suggesting for representing the capture scene.  The media consumer can choose to receive all media captures from one capture scene entry for each media type (e.g. audio and video), or it can pick and choose media captures regardless of how the provider arranges them in capture scene entries.

A capture scene may include more than one type of media.  For example, a capture scene can include several capture scene entries for video captures, and several capture scene entries for audio captures.

(This text would be worked into section 6.2, not replace it completely.  Other things in section 6.2 and elsewhere would need to be edited to be consistent with the new terminology in this proposal)

Regards,
Mark

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 07 Mar 2012 15:50:37 -0500

On 3/7/12 3:03 PM, Duckworth, Mark wrote:
> Brian – there is no ‘purpose’ attribute on a capture scene. The purpose
> attribute is on media captures. I’m not sure a purpose attribute makes
> sense on a scene, we would have to think about it. It could conflict
> with the attribute on media captures. Are you proposing something new?

Hmm. I had fallen into that trap.

> Roni – about differentiating between capture scenes – what information
> do you propose to use to differentiate them? My view is they are
> differentiated by the media captures (described by attributes) that are
> contained in the capture scene entries, and that is all we need. If you
> think there needs to be more information, what do you propose?

I think the problem is that when you have captures from multiple scenes 
there don't seem to be enough attributes to make sense of what you have. 
One or more attributes on the scene could help with that.

Within a scene you can understand the captures by purpose and area of 
capture. But once you have more than one scene that isn't sufficient. 
The reason is that area of capture is based on the coordinate space for 
the scene, and two scenes are unrelated. So, if I have captures of 
purpose 'main' from both scene-1 and scene-2, I have no basis to decide 
which of them I want.

Some useful attributes on the scene would help. Just something like a 
description of what/where the scene is. E.g. scene-1 is Cisco-SJ and 
scene-2 is Polycom-Andover.

It might also be useful to know when multiple scenes are sourced by the 
same endpoint. E.g. that a scene containing captures from cameras (e.g. 
purpose=main) came from he same endpoint as the scene containing a 
capture with purpose=presentation. While these come from the same 
endpoint, they may need to be separate scenes because they have 
differing coordinate spaces.

	Thanks,
	Paul

> Mark
>
> *From:*Brian Baldino (bbaldino) [mailto:[email-masked]]
> *Sent:* Tuesday, March 06, 2012 5:11 AM
> *To:* Roni Even; Duckworth, Mark; [email-masked]
> *Subject:* RE: [clue] Proposal to combine capture scene and capture set
>
> Hey Roni,
>
> I think this is just a vocabulary change—multiple capture scenes are
> still allowed. The idea was that the ‘purpose’ attribute of the capture
> scene would be used to differentiate them.
>
> -Brian
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf
> Of *Roni Even
> *Sent:* Tuesday, March 06, 2012 12:23 AM
> *To:* 'Duckworth, Mark'; [email-masked]
> *Subject:* Re: [clue] Proposal to combine capture scene and capture set
>
> Hi Mark,
>
> Does a provider advertise one capture scene composed of multiple capture
> scene entries. My understanding so far was that there can be more than
> one if we substitute set with scene.
>
> Can there be more than one capture scene in the advertisement in which
> case how do you differentiate between them, is there a scene identifier
> and how does the consumer know what is the scene.
>
> Roni Even
>
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] <mailto:[mailto:[email-masked]]>
> *On Behalf Of *Duckworth, Mark
> *Sent:* Monday, March 05, 2012 9:16 PM
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* [clue] Proposal to combine capture scene and capture set
>
> At the interim meeting, there was some support for combining the
> concepts of “capture scene” and “capture set” into a single concept. So
> here is a rough proposal for doing that, essentially using the term
> “capture scene” to replace the previous term “capture set”, and
> eliminating the original separate capture scene concept.
>
> Definitions:
>
> *Capture Scene: a structure representing the scene that is captured by a
> collection of capture devices. A capture scene includes one or more
> capture scene entries, with each entry including one or more media
> captures.
>
> *Capture Scene Entry: a list of media captures of the same media type
> that together form one way to represent the capture scene.
>
> A capture scene represents, for example, the video image of a group of
> people seated next to each other, along with the sound of their voices,
> which could be represented by some number of VCs and ACs in the capture
> scene entries. A middle box may also express capture scenes that it
> constructs from media streams it receives.
>
> A media provider arranges media captures in a capture scene to help the
> media consumer choose which captures it wants. The capture scene entries
> in a capture scene are different alternatives the provider is suggesting
> for representing the capture scene. The media consumer can choose to
> receive all media captures from one capture scene entry for each media
> type (e.g. audio and video), or it can pick and choose media captures
> regardless of how the provider arranges them in capture scene entries.
>
> A capture scene may include more than one type of media. For example, a
> capture scene can include several capture scene entries for video
> captures, and several capture scene entries for audio captures.
>
> (This text would be worked into section 6.2, not replace it completely.
> Other things in section 6.2 and elsewhere would need to be edited to be
> consistent with the new terminology in this proposal)
>
> Regards,
>
> Mark
>
>
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue