Subject: [clue] Simultaneous set, or mutually exclusive set?

From: "Duckworth, Mark" <[email-masked]>
Date: Mon, 19 Mar 2012 15:05:18 -0700

This is a follow on to the email thread with subject 'propose "mutually exclusive" attribute to replace simutaneous sets'.  It seemed like that thread didn't have any agreement.  So I'll suggest a simpler change to see what you think.  This is motivated by a discussion at the interim meeting where I thought a few people were in favor of this.

Instead of conveying the information about which media captures can be used at the same time with "simultaneous sets", do it instead with "mutually exclusive sets".  The purpose is to have a more concise way to indicate which media captures cannot be used at the same time, which we believe scales better than the simultaneous set idea when there are multiple mutually exclusive constraints.

Here is an example of the difference.  Suppose a provider is advertising six video captures.  The provider wants to say that VC1 and VC2 can't be used at the same time.  And VC3 and VC4 can't be used at the same time.  And VC5 and VC6 can't be used at the same time.

In simultaneous sets it would be expressed like this:
{VC1, VC3, VC5}
{VC1, VC4, VC5}
{VC1, VC3, VC6}
{VC1, VC4, VC6}
{VC2, VC3, VC5}
{VC2, VC4, VC5}
{VC2, VC3, VC6}
{VC2, VC4, VC6}

With mutually exclusive sets, it would be expressed like this:
{VC1, VC2}
{VC3, VC4}
{VC5, VC6}

Does anybody see any advantage or disadvantage to this?

Mark

---

From: "Allyn Romanow (allyn)" <[email-masked]>
Date: Mon, 19 Mar 2012 20:44:41 -0700

Hi-

It seems that the advantage is it's more parsimonious and I don't see
any disadvantages.

Allyn

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Duckworth, Mark
Sent: Monday, March 19, 2012 3:05 PM
To: [email-masked]
Subject: [clue] Simultaneous set, or mutually exclusive set?

This is a follow on to the email thread with subject 'propose "mutually
exclusive" attribute to replace simutaneous sets'.  It seemed like that
thread didn't have any agreement.  So I'll suggest a simpler change to
see what you think.  This is motivated by a discussion at the interim
meeting where I thought a few people were in favor of this.

Instead of conveying the information about which media captures can be
used at the same time with "simultaneous sets", do it instead with
"mutually exclusive sets".  The purpose is to have a more concise way to
indicate which media captures cannot be used at the same time, which we
believe scales better than the simultaneous set idea when there are
multiple mutually exclusive constraints.

Here is an example of the difference.  Suppose a provider is advertising
six video captures.  The provider wants to say that VC1 and VC2 can't be
used at the same time.  And VC3 and VC4 can't be used at the same time.
And VC5 and VC6 can't be used at the same time.

{VC1, VC3, VC5}

{VC1, VC4, VC5}

{VC1, VC3, VC6}

{VC1, VC4, VC6}

{VC2, VC3, VC5}

{VC2, VC4, VC5}

{VC2, VC3, VC6}

{VC2, VC4, VC6}

{VC1, VC2}

{VC3, VC4}

{VC5, VC6}

Mark

---

From: "Espen Berger (espeberg)" <[email-masked]>
Date: Wed, 21 Mar 2012 21:05:10 +0100

The mutually exclusive set are easier to understand and more compact as
listed in the example. 

-Espen 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Allyn Romanow (allyn)
Sent: 20. mars 2012 04:45
To: Duckworth, Mark; [email-masked]
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

Hi-

Allyn

{VC1, VC3, VC5}

{VC1, VC4, VC5}

{VC1, VC3, VC6}

{VC1, VC4, VC6}

{VC2, VC3, VC5}

{VC2, VC4, VC5}

{VC2, VC3, VC6}

{VC2, VC4, VC6}

{VC1, VC2}

{VC3, VC4}

{VC5, VC6}

Mark

---

From: "Roni Even" <[email-masked]>
Date: Thu, 22 Mar 2012 10:12:57 +0200

Hi Mark,

This is a good example for shorter Mutual exclusive set but taking the
example from the framework draft

{VC0, VC1, VC2, VC3, VC4, VC6}

      {VC0, VC2, VC5, VC6}

Will have as exclusive set

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

As far as I remember my Boolean algebra the optimized number of entries may
be different if we limit ourselves to use either representations. So if we
really want to optimize the number of entries we can use Boolean equations
to represent the relations. Otherwise it does not matter which method you
choose and we should look at how we use this information.

The important issue in not only the representation but it  is how to do does
the selection.

In the case of simultaneous set you choose a line or part of it, very
simple!!!

In the case of mutually exclusive set it is not easy since you cannot just
select one MC from each row (not in your example which is one case but in
the example from the framework draft), you will need to combine them to
Mutual exclusive sets. 

This is what I claimed in the previous email you sent, and why I prefer
simultaneous set. I strongly object to using mutually exclusive sets unless
you can explain how you can have an easy select criteria. 

The capture sets are not providing a full picture but just a subset of the
full options that are recommended by the provider.

Roni

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Duckworth, Mark
Sent: Tuesday, March 20, 2012 12:05 AM
To: [email-masked]
Subject: [clue] Simultaneous set, or mutually exclusive set?

This is a follow on to the email thread with subject 'propose "mutually
exclusive" attribute to replace simutaneous sets'.  It seemed like that
thread didn't have any agreement.  So I'll suggest a simpler change to see
what you think.  This is motivated by a discussion at the interim meeting
where I thought a few people were in favor of this.

Instead of conveying the information about which media captures can be used
at the same time with "simultaneous sets", do it instead with "mutually
exclusive sets".  The purpose is to have a more concise way to indicate
which media captures cannot be used at the same time, which we believe
scales better than the simultaneous set idea when there are multiple
mutually exclusive constraints.

Here is an example of the difference.  Suppose a provider is advertising six
video captures.  The provider wants to say that VC1 and VC2 can't be used at
the same time.  And VC3 and VC4 can't be used at the same time.  And VC5 and
VC6 can't be used at the same time.

{VC1, VC3, VC5}

{VC1, VC4, VC5}

{VC1, VC3, VC6}

{VC1, VC4, VC6}

{VC2, VC3, VC5}

{VC2, VC4, VC5}

{VC2, VC3, VC6}

{VC2, VC4, VC6}

{VC1, VC2}

{VC3, VC4}

{VC5, VC6}

Mark

---

From: "Espen Berger (espeberg)" <[email-masked]>
Date: Thu, 22 Mar 2012 15:16:59 +0100

I think that mutual exclusive sets can be used to model the example 11.1
in the framework document.  A snippet from the document <<VC5 cannot be
used at the same time as VC1 or VC3 or  VC4.>> 

In the example the main thing to model is that a selection of VC5 has
side effects and basically exclude some of the other alternatives 

*          VC5 exclude VC1; VC1 and VC5 is the same physical camera so
they cannot be sent at the same time. 

*         VC5 excludes VC3; Since the middle camera does not capture the
middle segment anymore, and segment switching into middle segment is not
possible anymore

*         VC5 excludes VC4; A composed view cannot be rendered since VC1
does not capture the middle segment anymore. 

In other terms; Selecting VC5 excludes usage of capture VC1, VC3, VC4
which could be written as

{VC5, [VC1, VC3, VC4] }   // or some other nice syntax 

Cheers 

-Espen  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Roni Even
Sent: 22. mars 2012 09:13
To: 'Duckworth, Mark'; [email-masked]
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

As far as I remember my Boolean algebra the optimized number of entries
may be different if we limit ourselves to use either representations. So
if we really want to optimize the number of entries we can use Boolean
equations to represent the relations. Otherwise it does not matter which
method you choose and we should look at how we use this information.

The important issue in not only the representation but it  is how to do
does the selection.

In the case of mutually exclusive set it is not easy since you cannot
just select one MC from each row (not in your example which is one case
but in the example from the framework draft), you will need to combine
them to Mutual exclusive sets. 

This is what I claimed in the previous email you sent, and why I prefer
simultaneous set. I strongly object to using mutually exclusive sets
unless you can explain how you can have an easy select criteria. 

The capture sets are not providing a full picture but just a subset of
the full options that are recommended by the provider.

Roni

{VC1, VC3, VC5}

{VC1, VC4, VC5}

{VC1, VC3, VC6}

{VC1, VC4, VC6}

{VC2, VC3, VC5}

{VC2, VC4, VC5}

{VC2, VC3, VC6}

{VC2, VC4, VC6}

{VC1, VC2}

{VC3, VC4}

{VC5, VC6}

Mark

---

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 22 Mar 2012 07:42:22 -0700

It is simple to represent this using the mutually exclusive idea, with no more complicated syntax:
{VC1,VC5}
{VC3,VC5}
{VC4,VC5}
Meaning that VC5 cannot be used simultaneously with any of VC1, VC3, or VC4.

Roni wrote: "In the case of simultaneous set you choose a line or part of it, very simple!!!"
That is true, but also (and usually even simpler IMHO) the consumer can choose a capture scene entry or part of it.  If the consumer chooses from capture scene entries, then it doesn't even have to look at the simultaneous (or mutually exclusive) sets.

Mark

From: Espen Berger (espeberg) [mailto:[email-masked]]
Sent: Thursday, March 22, 2012 10:17 AM
To: Roni Even; Duckworth, Mark; [email-masked]
Subject: RE: [clue] Simultaneous set, or mutually exclusive set?

I think that mutual exclusive sets can be used to model the example 11.1 in the framework document.  A snippet from the document <<VC5 cannot be used at the same time as VC1 or VC3 or  VC4.>>

In the example the main thing to model is that a selection of VC5 has side effects and basically exclude some of the other alternatives

*          VC5 exclude VC1; VC1 and VC5 is the same physical camera so they cannot be sent at the same time.

*         VC5 excludes VC3; Since the middle camera does not capture the middle segment anymore, and segment switching into middle segment is not possible anymore

*         VC5 excludes VC4; A composed view cannot be rendered since VC1 does not capture the middle segment anymore.

In other terms; Selecting VC5 excludes usage of capture VC1, VC3, VC4 which could be written as
{VC5, [VC1, VC3, VC4] }   // or some other nice syntax

Cheers

-Espen

From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni Even
Sent: 22. mars 2012 09:13
To: 'Duckworth, Mark'; [email-masked]
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

Hi Mark,
This is a good example for shorter Mutual exclusive set but taking the example from the framework draft

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

As far as I remember my Boolean algebra the optimized number of entries may be different if we limit ourselves to use either representations. So if we really want to optimize the number of entries we can use Boolean equations to represent the relations. Otherwise it does not matter which method you choose and we should look at how we use this information.

The important issue in not only the representation but it  is how to do does the selection.

In the case of simultaneous set you choose a line or part of it, very simple!!!

In the case of mutually exclusive set it is not easy since you cannot just select one MC from each row (not in your example which is one case but in the example from the framework draft), you will need to combine them to Mutual exclusive sets.

This is what I claimed in the previous email you sent, and why I prefer simultaneous set. I strongly object to using mutually exclusive sets unless you can explain how you can have an easy select criteria.

The capture sets are not providing a full picture but just a subset of the full options that are recommended by the provider.

Roni

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Duckworth, Mark
Sent: Tuesday, March 20, 2012 12:05 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [clue] Simultaneous set, or mutually exclusive set?

Mark

---

From: "Roni Even" <[email-masked]>
Date: Thu, 22 Mar 2012 17:08:18 +0200

Hi Espen,

This is different since now you have a combination  of simultaneous set  and
mutual exclusive. Like {VC5 OR (VC1 AND VC3 AND VC4)}   

This is not what Mark was proposing and this expands the representation to
be more in line with Boolean algebra in which case we will need to define
the syntax for (AND, OR, XOR,..)

This will allow having Mark example as 

{VC1 OR VC2} AND {VC3 OR VC4} AND {VC5 OR VC6}

The selection becomes one from each OR and all or some of the AND.

Do we want to go to this syntax?

Roni

From: Espen Berger (espeberg) [mailto:[email-masked]] 
Sent: Thursday, March 22, 2012 4:17 PM
To: Roni Even; Duckworth, Mark; [email-masked]
Subject: RE: [clue] Simultaneous set, or mutually exclusive set?

I think that mutual exclusive sets can be used to model the example 11.1 in
the framework document.  A snippet from the document <<VC5 cannot be used at
the same time as VC1 or VC3 or  VC4.>> 

In the example the main thing to model is that a selection of VC5 has side
effects and basically exclude some of the other alternatives 

.          VC5 exclude VC1; VC1 and VC5 is the same physical camera so they
cannot be sent at the same time. 

.         VC5 excludes VC3; Since the middle camera does not capture the
middle segment anymore, and segment switching into middle segment is not
possible anymore

.         VC5 excludes VC4; A composed view cannot be rendered since VC1
does not capture the middle segment anymore. 

In other terms; Selecting VC5 excludes usage of capture VC1, VC3, VC4 which
could be written as

Cheers 

-Espen  

From: [email-masked] [mailto:[email-masked]] On Behalf Of Roni
Even
Sent: 22. mars 2012 09:13
To: 'Duckworth, Mark'; [email-masked]
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

{VC1, VC3, VC5}

{VC1, VC4, VC5}

{VC1, VC3, VC6}

{VC1, VC4, VC6}

{VC2, VC3, VC5}

{VC2, VC4, VC5}

{VC2, VC3, VC6}

{VC2, VC4, VC6}

{VC1, VC2}

{VC3, VC4}

{VC5, VC6}

Mark

---

From: "Duckworth, Mark" <[email-masked]>
Date: Thu, 22 Mar 2012 08:18:40 -0700

I would rather not complicate this with Boolean algebra.
Mark

From: Roni Even [mailto:[email-masked]]
Sent: Thursday, March 22, 2012 11:08 AM
To: 'Espen Berger (espeberg)'; Duckworth, Mark; [email-masked]
Subject: RE: [clue] Simultaneous set, or mutually exclusive set?

Hi Espen,
This is different since now you have a combination  of simultaneous set  and mutual exclusive. Like {VC5 OR (VC1 AND VC3 AND VC4)}
This is not what Mark was proposing and this expands the representation to be more in line with Boolean algebra in which case we will need to define the syntax for (AND, OR, XOR,..)
This will allow having Mark example as
{VC1 OR VC2} AND {VC3 OR VC4} AND {VC5 OR VC6}

Roni

Cheers

-Espen

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Roni Even
Sent: 22. mars 2012 09:13
To: 'Duckworth, Mark'; [email-masked]<mailto:[email-masked]>
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

Mark

---

From: "Espen Berger (espeberg)" <[email-masked]>
Date: Thu, 22 Mar 2012 17:20:39 +0100

No Boolean algebra is needed. I do not think we need that complexity in
what we want to describe. 

I agree with marks suggestion to write it up like this: 

{VC1,VC5}

{VC3,VC5}

{VC4,VC5}

Cheers 

-Espen 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Duckworth, Mark
Sent: 22. mars 2012 16:19
To: [email-masked]
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

Mark

Hi Espen,

This is different since now you have a combination  of simultaneous set
and mutual exclusive. Like {VC5 OR (VC1 AND VC3 AND VC4)}   

This is not what Mark was proposing and this expands the representation
to be more in line with Boolean algebra in which case we will need to
define the syntax for (AND, OR, XOR,..)

 

Roni

Cheers 

-Espen  

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

{VC1, VC3, VC5}

{VC1, VC4, VC5}

{VC1, VC3, VC6}

{VC1, VC4, VC6}

{VC2, VC3, VC5}

{VC2, VC4, VC5}

{VC2, VC3, VC6}

{VC2, VC4, VC6}

{VC1, VC2}

{VC3, VC4}

{VC5, VC6}

Mark

---

From: Roni even <[email-masked]>
Date: Thu, 22 Mar 2012 19:58:42 +0000

Espen,

I am confused now since for the example from the framework you suggested a mix of simultaneous and mutual exclusive {VC5, [VC1, VC3, VC4] } the ones in the [] are simultaneous while the one in {} are mutual exclusive.

Roni

________________________________
From: [email-masked] [[email-masked]] on behalf of Espen Berger (espeberg) [[email-masked]]
Sent: Thursday, March 22, 2012 18:20
To: Duckworth, Mark; [email-masked]
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

No Boolean algebra is needed. I do not think we need that complexity in what we want to describe.

Cheers

-Espen

From: [email-masked] [mailto:[email-masked]] On Behalf Of Duckworth, Mark
Sent: 22. mars 2012 16:19
To: [email-masked]
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

From: Roni Even [mailto:[email-masked]]
Sent: Thursday, March 22, 2012 11:08 AM
To: 'Espen Berger (espeberg)'; Duckworth, Mark; [email-masked]<mailto:[email-masked]>
Subject: RE: [clue] Simultaneous set, or mutually exclusive set?

Hi Espen,

Roni

From: Espen Berger (espeberg) [mailto:[email-masked]]
Sent: Thursday, March 22, 2012 4:17 PM
To: Roni Even; Duckworth, Mark; [email-masked]<mailto:[email-masked]>
Subject: RE: [clue] Simultaneous set, or mutually exclusive set?

•          VC5 exclude VC1; VC1 and VC5 is the same physical camera so they cannot be sent at the same time.

•         VC5 excludes VC3; Since the middle camera does not capture the middle segment anymore, and segment switching into middle segment is not possible anymore

•         VC5 excludes VC4; A composed view cannot be rendered since VC1 does not capture the middle segment anymore.

Cheers

-Espen

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

This is a follow on to the email thread with subject ‘propose "mutually exclusive" attribute to replace simutaneous sets’.  It seemed like that thread didn’t have any agreement.  So I’ll suggest a simpler change to see what you think.  This is motivated by a discussion at the interim meeting where I thought a few people were in favor of this.

Instead of conveying the information about which media captures can be used at the same time with “simultaneous sets”, do it instead with “mutually exclusive sets”.  The purpose is to have a more concise way to indicate which media captures cannot be used at the same time, which we believe scales better than the simultaneous set idea when there are multiple mutually exclusive constraints.

Here is an example of the difference.  Suppose a provider is advertising six video captures.  The provider wants to say that VC1 and VC2 can’t be used at the same time.  And VC3 and VC4 can’t be used at the same time.  And VC5 and VC6 can’t be used at the same time.

Mark

---

From: "Espen Berger (espeberg)" <[email-masked]>
Date: Thu, 22 Mar 2012 21:29:42 +0100

Roni, in my example I only ment to express that VC5 cannot be sent at
the same time as VC1, VC3 or VC4. I did not intend [] to indicate
simultaneous.  

So Marks suggested notation is compact, easy to understand and cover the
example from the framework. 

-Espen 

From: Roni even [mailto:[email-masked]] 
Sent: 22. mars 2012 20:59
To: Espen Berger (espeberg); Duckworth, Mark; [email-masked]
Subject: RE: [clue] Simultaneous set, or mutually exclusive set?

Espen,

I am confused now since for the example from the framework you suggested
a mix of simultaneous and mutual exclusive {VC5, [VC1, VC3, VC4] } the
ones in the [] are simultaneous while the one in {} are mutual
exclusive.

Roni

From: [email-masked] [[email-masked]] on behalf of Espen
Berger (espeberg) [[email-masked]]
Sent: Thursday, March 22, 2012 18:20
To: Duckworth, Mark; [email-masked]
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

{VC1,VC5}

{VC3,VC5}

{VC4,VC5}

Cheers 

-Espen 

Mark

Hi Espen,

 

Roni

Cheers 

-Espen  

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

{VC1, VC3, VC5}

{VC1, VC4, VC5}

{VC1, VC3, VC6}

{VC1, VC4, VC6}

{VC2, VC3, VC5}

{VC2, VC4, VC5}

{VC2, VC3, VC6}

{VC2, VC4, VC6}

{VC1, VC2}

{VC3, VC4}

{VC5, VC6}

Mark

---

From: Roni even <[email-masked]>
Date: Fri, 23 Mar 2012 05:30:49 +0000

Espen,

This is not true!!!.  using mark suggesting it will look like

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

If you want it to look like

{VC5, [VC1, VC3, VC4] }

you will need to define something which is not only mutual exclusive. But also simultaneous at the same time since [vc,vc3,vc4] are simultaneous in this case

Roni

________________________________
From: Espen Berger (espeberg) [[email-masked]]
Sent: Thursday, March 22, 2012 22:29
To: Roni even; Duckworth, Mark; [email-masked]
Subject: RE: [clue] Simultaneous set, or mutually exclusive set?

Roni, in my example I only ment to express that VC5 cannot be sent at the same time as VC1, VC3 or VC4. I did not intend [] to indicate simultaneous.

So Marks suggested notation is compact, easy to understand and cover the example from the framework.

-Espen

Espen,

Roni

________________________________
From: [email-masked]<mailto:[email-masked]> [[email-masked]] on behalf of Espen Berger (espeberg) [[email-masked]]
Sent: Thursday, March 22, 2012 18:20
To: Duckworth, Mark; [email-masked]<mailto:[email-masked]>
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?
No Boolean algebra is needed. I do not think we need that complexity in what we want to describe.

Cheers

-Espen

Hi Espen,

Roni

Cheers

-Espen

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

Mark

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 23 Mar 2012 06:25:09 -0700

Hi Roni,
Maybe I'm not being clear about my suggestion.
With my mutually exclusive set suggestion, for this example, the mutually exclusive sets are:
{VC1,VC5} - meaning VC1 and VC5 cannot be used at same time
{VC3,VC5} - meaning VC3 and VC5 cannot be used at same time
{VC4,VC5} - meaning VC4 and VC5 cannot be used at same time

I don't know what you mean by adding something like {VC0} into the list of mutually exclusive sets.  In my proposal, that has no meaning.

Mark

From: Roni even [mailto:[email-masked]]
Sent: Friday, March 23, 2012 1:31 AM
To: Espen Berger (espeberg); Duckworth, Mark; [email-masked]
Subject: RE: [clue] Simultaneous set, or mutually exclusive set?

Espen,

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

{VC5, [VC1, VC3, VC4] }

Roni

-Espen

Espen,

Roni

Cheers

-Espen

Hi Espen,

Roni

Cheers

-Espen

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

Mark

---

From: Roni even <[email-masked]>
Date: Fri, 23 Mar 2012 13:38:47 +0000

Mark,

the discussion is about the example in the framework draft and how it should be specified using only mutual exclusive set

Simultaneous set

{VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

________________________________
From: [email-masked] [[email-masked]] on behalf of Duckworth, Mark [[email-masked]]
Sent: Friday, March 23, 2012 15:25
To: [email-masked]
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

Hi Roni,
Maybe I’m not being clear about my suggestion.
With my mutually exclusive set suggestion, for this example, the mutually exclusive sets are:
{VC1,VC5} – meaning VC1 and VC5 cannot be used at same time
{VC3,VC5} – meaning VC3 and VC5 cannot be used at same time
{VC4,VC5} – meaning VC4 and VC5 cannot be used at same time

I don’t know what you mean by adding something like {VC0} into the list of mutually exclusive sets.  In my proposal, that has no meaning.

Mark

Espen,

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

{VC5, [VC1, VC3, VC4] }

Roni

-Espen

Espen,

Roni

Cheers

-Espen

Hi Espen,

Roni

Cheers

-Espen

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

Mark

---

From: Roni even <[email-masked]>
Date: Fri, 23 Mar 2012 14:11:25 +0000

Mark,

You need the whole set of relations even {vc0} to have the complete set of dependencies

The simultaneous set is 2 lines wile the mutual exclusive is 3 or 5 lines depending on how you want to present it

My claim is that in the general case you cannot have an optimal solution using only "OR" or only "AND" you may need a mixture so selecting only one of them does not provide an optimal solution

My view is that by using simultaneous set it is easier for a consumer to select a set it wants to receive since he only need to select a line and ask for all of it or part of it. For the mutual exclusive he will need first to build the simultaneous sets

Roni

________________________________
From: [email-masked] [[email-masked]] on behalf of Roni even [[email-masked]]
Sent: Friday, March 23, 2012 15:38
To: Duckworth, Mark; [email-masked]
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

Mark,

Simultaneous set

{VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

Hi Roni,

Mark

Espen,

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

{VC5, [VC1, VC3, VC4] }

Roni

-Espen

Espen,

Roni

Cheers

-Espen

Hi Espen,

Roni

Cheers

-Espen

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

Mark

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 23 Mar 2012 07:21:00 -0700

Hi Roni,
It sounds like you are making an alternative proposal of your own, because a mutually exclusive set of {VC0} has no meaning in my proposal.
My view is that a consumer that wants to make an easy simple choice should select a capture scene entry and ask for all or part of it.  The simultaneous sets or mutually exclusive sets are irrelevant if the consumer chooses from a capture scene entry.
Mark

From: Roni even [mailto:[email-masked]]
Sent: Friday, March 23, 2012 10:11 AM
To: Duckworth, Mark; [email-masked]
Subject: RE: [clue] Simultaneous set, or mutually exclusive set?

Mark,

Roni

Mark,

Simultaneous set

{VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

Mark

Espen,

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

{VC5, [VC1, VC3, VC4] }

Roni

-Espen

Espen,

Roni

Cheers

-Espen

Hi Espen,

Roni

Cheers

-Espen

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

Mark

---

From: Roni even <[email-masked]>
Date: Fri, 23 Mar 2012 14:44:57 +0000

Mark,

I am objecting to your proposed change in the framework from simultaneous set to alternative set

the reasons are:

1. It is not shorter - this is Boolean algebra you have a set of Boolean conditions here, it depends on the conditions that will specify what will have short number of equation and elements in the equations. (I think it is Karnaugh maps that help simplify Boolean algebra expressions)

2. Capture scene do not supply all the simultaneous options since they are suggestions but the full set is the simultaneous sets

3. Anyhow you can get the full simultaneous set from the mutual exclusive set but this require computation.

If you really want to optimize than define a syntax that will have both mutual exclusive and simultaneous in one description, similar to what Espen suggested for the framework example {VC5,[VC1,VC2,VC3}} which even though he claimed that the values in [] are not simultaneous, practically they are since they can be sent at the same time. This will help with shorter representation since you have two operator to use but is not simple.

This is why I think that we should keep the framework as is.

Roni

________________________________
From: [email-masked] [[email-masked]] on behalf of Duckworth, Mark [[email-masked]]
Sent: Friday, March 23, 2012 16:21
To: [email-masked]
Subject: Re: [clue] Simultaneous set, or mutually exclusive set?

Hi Roni,

Mark,

Roni

Mark,

Simultaneous set

{VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

Mark

Espen,

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

{VC5, [VC1, VC3, VC4] }

Roni

-Espen

Espen,

Roni

Cheers

-Espen

Hi Espen,

Roni

Cheers

-Espen

Hi Mark,

      {VC0, VC2, VC5, VC6}

{VC0}

{VC1,VC5}

{VC2}

{VC3,VC5}

{VC4,VC5}

{VC6}

Roni

Mark

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 23 Mar 2012 11:21:32 -0400

Mark, Roni,

It seems clear to me that the two of you are not understanding one another.

Looking at Mark's original comparison of simultaneous sets vs. mutually 
exclusive sets, I think one thing is missing from the proposal for 
mutually exclusive sets:

In addition to listing which captures are mutually exclusive, there is a 
need to enumerate all the captures that are being advertised. Something 
like:

Captures: {V1, V2, V3, V4, V5, V6}
Mutual Exclusion: {VC1, VC2}, {VC3, VC4}, {VC5, VC6}

Of course there can be a number of ways to optimize the representation 
of this. For instance, all the captures listed in mutual exclusion sets 
can be assumed to be advertised, so perhaps it is only necessary to 
additionally advertise those that aren't so listed. In your case all 
have been listed in mutual exclusion sets so no others need be listed. 
But that need not always be the case. This would be especially obvious 
when there are no mutual exclusion rules.

	Thanks,
	Paul (as individual)

On 3/23/12 10:21 AM, Duckworth, Mark wrote:
> Hi Roni,
>
> It sounds like you are making an alternative proposal of your own,
> because a mutually exclusive set of {VC0} has no meaning in my proposal.
>
> My view is that a consumer that wants to make an easy simple choice
> should select a capture scene entry and ask for all or part of it. The
> simultaneous sets or mutually exclusive sets are irrelevant if the
> consumer chooses from a capture scene entry.
>
> Mark
>
> *From:*Roni even [mailto:[email-masked]]
> *Sent:* Friday, March 23, 2012 10:11 AM
> *To:* Duckworth, Mark; [email-masked]
> *Subject:* RE: [clue] Simultaneous set, or mutually exclusive set?
>
> Mark,
>
> The simultaneous set is 2 lines wile the mutual exclusive is 3 or 5
> lines depending on how you want to present it
>
> My claim is that in the general case you cannot have an optimal solution
> using only "OR" or only "AND" you may need a mixture so selecting only
> one of them does not provide an optimal solution
>
> My view is that by using simultaneous set it is easier for a consumer to
> select a set it wants to receive since he only need to select a line and
> ask for all of it or part of it. For the mutual exclusive he will need
> first to build the simultaneous sets
>
> Roni
>
> ------------------------------------------------------------------------
>
> *From:[email-masked] [[email-masked]] on behalf of Roni
> even [[email-masked]]
> *Sent:* Friday, March 23, 2012 15:38
> *To:* Duckworth, Mark; [email-masked]
> *Subject:* Re: [clue] Simultaneous set, or mutually exclusive set?
>
> Mark,
>
> the discussion is about the example in the framework draft and how it
> should be specified using only mutual exclusive set
>
> Simultaneous set
>
> ------------------------------------------------------------------------
>
> *From:[email-masked] [[email-masked]] on behalf of
> Duckworth, Mark [[email-masked]]
> *Sent:* Friday, March 23, 2012 15:25
> *To:* [email-masked]
> *Subject:* Re: [clue] Simultaneous set, or mutually exclusive set?
>
> Hi Roni,
>
> I don’t know what you mean by adding something like {VC0} into the list
> of mutually exclusive sets. In my proposal, that has no meaning.
>
> Mark
>
> *From:*Roni even [mailto:[email-masked]]
> *Sent:* Friday, March 23, 2012 1:31 AM
> *To:* Espen Berger (espeberg); Duckworth, Mark; [email-masked]
> *Subject:* RE: [clue] Simultaneous set, or mutually exclusive set?
>
> Espen,
>
> you will need to define something which is not only mutual exclusive.
> But also simultaneous at the same time since [vc,vc3,vc4] are
> simultaneous in this case
>
> Roni
>
> ------------------------------------------------------------------------
>
> *From:*Espen Berger (espeberg) [[email-masked]]
> *Sent:* Thursday, March 22, 2012 22:29
> *To:* Roni even; Duckworth, Mark; [email-masked]
> *Subject:* RE: [clue] Simultaneous set, or mutually exclusive set?
>
> *From:*Roni even [mailto:[email-masked]]
> *Sent:* 22. mars 2012 20:59
> *To:* Espen Berger (espeberg); Duckworth, Mark; [email-masked]
> *Subject:* RE: [clue] Simultaneous set, or mutually exclusive set?
>
> Espen,
>
> ones in the [] are simultaneous while the one in {} are mutual exclusive.
>
> Roni
>
> ------------------------------------------------------------------------
>
> *From:[email-masked] <mailto:[email-masked]>
> [[email-masked]] on behalf of Espen Berger (espeberg)
> [[email-masked]]
> *Sent:* Thursday, March 22, 2012 18:20
> *To:* Duckworth, Mark; [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [clue] Simultaneous set, or mutually exclusive set?
>
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] *On Behalf Of *Duckworth, Mark
> *Sent:* 22. mars 2012 16:19
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [clue] Simultaneous set, or mutually exclusive set?
>
> *From:*Roni Even [mailto:[email-masked]]
> *Sent:* Thursday, March 22, 2012 11:08 AM
> *To:* 'Espen Berger (espeberg)'; Duckworth, Mark; [email-masked]
> <mailto:[email-masked]>
> *Subject:* RE: [clue] Simultaneous set, or mutually exclusive set?
>
> Hi Espen,
>
> *From:*Espen Berger (espeberg) [mailto:[email-masked]]
> *Sent:* Thursday, March 22, 2012 4:17 PM
> *To:* Roni Even; Duckworth, Mark; [email-masked] <mailto:[email-masked]>
> *Subject:* RE: [clue] Simultaneous set, or mutually exclusive set?
>
> ·VC5 exclude VC1; VC1 and VC5 is the same physical camera so they cannot
> be sent at the same time.
>
> ·VC5 excludes VC3; Since the middle camera does not capture the middle
> segment anymore, and segment switching into middle segment is not
> possible anymore
>
> ·VC5 excludes VC4; A composed view cannot be rendered since VC1 does not
> capture the middle segment anymore.
>
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] *On Behalf Of *Roni Even
> *Sent:* 22. mars 2012 09:13
> *To:* 'Duckworth, Mark'; [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [clue] Simultaneous set, or mutually exclusive set?
>
> Hi Mark,
>
> This is a good _example_ for shorter Mutual exclusive set but taking the
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] *On Behalf Of *Duckworth, Mark
> *Sent:* Tuesday, March 20, 2012 12:05 AM
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* [clue] Simultaneous set, or mutually exclusive set?
>
> This is a follow on to the email thread with subject ‘propose "mutually
> exclusive" attribute to replace simutaneous sets’. It seemed like that
> thread didn’t have any agreement. So I’ll suggest a simpler change to
> used at the same time with “simultaneous sets”, do it instead with
> “mutually exclusive sets”. The purpose is to have a more concise way to
> six video captures. The provider wants to say that VC1 and VC2 can’t be
> used at the same time. And VC3 and VC4 can’t be used at the same time.
> And VC5 and VC6 can’t be used at the same time.
>
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 23 Mar 2012 08:38:31 -0700

Hi Paul,

Yes, there would be a list of all the captures somehow, possibly derived from the captures referenced in the capture scenes.  I think this will become more clear as we progress the data model we started discussing at the last meeting.  As you say below, the list of all the captures would be distinct from the mutual exclusion sets.

I do understand Roni's objections from his last posting, so thank you Roni for clarifying that.

Personally, I am only mildly in favor of using mutually exclusive sets instead of simultaneous sets.  So it is okay with me if the group decides not to make the change.  But a few other people also expressed preference for mutually exclusive, so maybe there should be more discussion.

Mark

> -----Original Message-----
> Paul Kyzivat
> Sent: Friday, March 23, 2012 11:22 AM
> To: [email-masked]
> exclusive sets, I think one thing is missing from the proposal for mutually
> exclusive sets:
>
> In addition to listing which captures are mutually exclusive, there is a need to
> enumerate all the captures that are being advertised. Something
> like:
>
> Of course there can be a number of ways to optimize the representation of
> this. For instance, all the captures listed in mutual exclusion sets can be
> assumed to be advertised, so perhaps it is only necessary to additionally
> advertise those that aren't so listed. In your case all have been listed in
> mutual exclusion sets so no others need be listed.
> But that need not always be the case. This would be especially obvious when
> there are no mutual exclusion rules.
>
>       Thanks,
>       Paul (as individual)
>
> > My claim is that in the general case you cannot have an optimal
> > solution using only "OR" or only "AND" you may need a mixture so
> > selecting only one of them does not provide an optimal solution
> >
> > My view is that by using simultaneous set it is easier for a consumer
> > to select a set it wants to receive since he only need to select a
> > line and ask for all of it or part of it. For the mutual exclusive he
> > will need first to build the simultaneous sets
> >
> > Roni
> >
> > I don't know what you mean by adding something like {VC0} into the
> > list of mutually exclusive sets. In my proposal, that has no meaning.
> >
> > Mark
> >
> > I am confused now since for the example from the framework you
> > suggested a mix of simultaneous and mutual exclusive {VC5, [VC1, VC3,
> > VC4] } the ones in the [] are simultaneous while the one in {} are mutual
> exclusive.
> >
> > Roni
> >
> > This is not what Mark was proposing and this expands the
> > representation to be more in line with Boolean algebra in which case
> > we will need to define the syntax for (AND, OR, XOR,..)
> >
> > I think that mutual exclusive sets can be used to model the example
> > 11.1 in the framework document. A snippet from the document <<VC5
> > cannot be used at the same time as VC1 or VC3 or VC4.>>
> >
> > *VC5 exclude VC1; VC1 and VC5 is the same physical camera so they
> > *VC5 excludes VC3; Since the middle camera does not capture the middle
> > *VC5 excludes VC4; A composed view cannot be rendered since VC1 does
> > not capture the middle segment anymore.
> >
> > This is a good _example_ for shorter Mutual exclusive set but taking
> > the example from the framework draft
> >
> > As far as I remember my Boolean algebra the optimized number of
> > entries may be different if we limit ourselves to use either
> > representations. So if we really want to optimize the number of
> > entries we can use Boolean equations to represent the relations.
> > Otherwise it does not matter which method you choose and we should
> look at how we use this information.
> >
> > just select one MC from each row (not in your example which is one
> > case but in the example from the framework draft), you will need to
> > combine them to Mutual exclusive sets.
> >
> > This is what I claimed in the previous email you sent, and why I
> > prefer simultaneous set. I strongly object to using mutually exclusive
> > sets unless you can explain how you can have an easy select criteria.
> >
> > This is a follow on to the email thread with subject 'propose
> > "mutually exclusive" attribute to replace simutaneous sets'. It seemed
> > like that thread didn't have any agreement. So I'll suggest a simpler
> > change to see what you think. This is motivated by a discussion at the
> > interim meeting where I thought a few people were in favor of this.
> >
> > "mutually exclusive sets". The purpose is to have a more concise way
> > to indicate which media captures cannot be used at the same time,
> > which we believe scales better than the simultaneous set idea when
> > there are multiple mutually exclusive constraints.
> >
> > Here is an example of the difference. Suppose a provider is
> > advertising six video captures. The provider wants to say that VC1 and
> > VC2 can't be used at the same time. And VC3 and VC4 can't be used at the
> same time.

---

From: Michael Hammer <[email-masked]>
Date: Fri, 23 Mar 2012 14:56:23 -0400

So this is the NOT AND (NAND) solution.

Could  NOT OR (NOR) solution be far behind?  :)

Mike

On Fri, Mar 23, 2012 at 10:11 AM, Roni even <[email-masked]> wrote:

> using only "OR" or only "AND" you may need a mixture so selecting only one
> of them does not provide an optimal solution
>
>
>
>  ------------------------------
> *From:* [email-masked] [[email-masked]] on behalf of Roni
>  ------------------------------
> *From:* [email-masked] [[email-masked]] on behalf of
> I don’t know what you mean by adding something like {VC0} into the list of
> mutually exclusive sets.  In my proposal, that has no meaning.
>
>
>
> Mark
>
>
>
> *From:* Roni even [mailto:[email-masked]]
> you will need to define something which is not only mutual exclusive. But
> also simultaneous at the same time since [vc,vc3,vc4] are simultaneous in
> this case
>
>
>
> Roni
>
>
>   ------------------------------
>
> *From:* Espen Berger (espeberg) [[email-masked]]
> Roni, in my example I only ment to express that VC5 cannot be sent at the
> same time as VC1, VC3 or VC4. I did not intend [] to indicate simultaneous.
>
>
>
>
> *From:* Roni even [mailto:[email-masked]]
> I am confused now since for the example from the framework you suggested a
> mix of simultaneous and mutual exclusive {VC5, [VC1, VC3, VC4] } the ones
> in the [] are simultaneous while the one in {} are mutual exclusive.
>
>
>
> Roni
>  ------------------------------
>
> *From:* [email-masked] [[email-masked]] on behalf of Espen
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Duckworth, Mark
> *From:* Roni Even [mailto:[email-masked] <[email-masked]>]
>
> *From:* Espen Berger (espeberg) [mailto:[email-masked]<[email-masked]>]
>
> *To:* Roni Even; Duckworth, Mark; [email-masked]
> ·          VC5 exclude VC1; VC1 and VC5 is the same physical camera so
> ·         VC5 excludes VC3; Since the middle camera does not capture the
> ·         VC5 excludes VC4; A composed view cannot be rendered since VC1
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Roni Even
> *To:* 'Duckworth, Mark'; [email-masked]
> This is a good *example* for shorter Mutual exclusive set but taking the
> may be different if we limit ourselves to use either representations. So if
> we really want to optimize the number of entries we can use Boolean
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Duckworth, Mark
> thread didn’t have any agreement.  So I’ll suggest a simpler change to see

---

From: "Roni Even" <[email-masked]>
Date: Sat, 24 Mar 2012 23:00:36 +0200

Mark,

Just an example to prove my point about the using only OR  for description
will not necessarily create the shortest list  for those who still believe
the using Mutual Exclusive will always create a shorter description.

Supposes VC1 cannot be used with VC2 or VC3 or VC4 or VC5 or VC6

Simultaneous

{VC1}

{VC2,VC3,VC4,VC5,VC6}

Mutual exclusive

{VC1,VC2}

{VC1,VC3}

{VC1, VC4}

{VC1,VC5}

{VC1,VC6}

Roni

{VC1, VC3, VC5}

{VC1, VC4, VC5}

{VC1, VC3, VC6}

{VC1, VC4, VC6}

{VC2, VC3, VC5}

{VC2, VC4, VC5}

{VC2, VC3, VC6}

{VC2, VC4, VC6}

{VC1, VC2}

{VC3, VC4}

{VC5, VC6}

Mark