Subject: Re: [clue] Ticket #36 removing pixels per second from framework encoding and encoding group

From: Paul Kyzivat <[email-masked]>
Date: Tue, 01 Oct 2013 17:49:54 -0400

Mark,

On 9/30/13 1:18 PM, Duckworth, Mark wrote:

> I propose keeping the first three paragraphs as is.  And change the rest
> to something like this:
>
> ==== begin proposed========================================
>
>     <first three paragraphs unchanged>
>
>     Individual Encoding parameters are represented in SDP [RFC4566], not
> in CLUE messages.  For example, for a video encoding using H.26x
> compression technologies, this can include parameters such as:
>
> ·Maximum bandwidth;
>
> ·Maximum picture size in pixels;
>
> ·Maxmimum number of pixels to be processed per second;
>
> The bandwidth parameter is the only one that specifically relates to a
> CLUE Advertisement, as it can be further constrained by the maximum
> group bandwidth in an Encoding Group.
>
> ==== end proposed ========================================

The above is dependent on encodings being expressed only in SDP.
That is still up in the air. Rob is in the process of analyzing the 
pros/cons of having them SDP and having them in the Advertisement.

I think a final resolution of *this* will have to wait until that is 
decided. But you can still do this for now, and change later if need be.

	Thanks,
	Paul

---

From: "Duckworth, Mark" <[email-masked]>
Date: Wed, 2 Oct 2013 05:58:45 -0700

Thanks Paul.
When I was writing this, I was wondering if it would make sense to include some of the encoding parameters in the CLUE advertisement in addition to having them in SDP.
Mark

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Paul Kyzivat
> Sent: Tuesday, October 01, 2013 5:50 PM
> To: [email-masked]
> Subject: Re: [clue] Ticket #36 removing pixels per second from framework
> encoding and encoding group
> 
> Mark,
> 
> > I propose keeping the first three paragraphs as is.  And change the
> > rest to something like this:
> >
> >     Individual Encoding parameters are represented in SDP [RFC4566],
> > not in CLUE messages.  For example, for a video encoding using H.26x
> > *Maximum bandwidth;
> > *Maximum picture size in pixels;
> >
> > *Maxmimum number of pixels to be processed per second;
> >
> That is still up in the air. Rob is in the process of analyzing the pros/cons of
> having them SDP and having them in the Advertisement.
> 
> I think a final resolution of *this* will have to wait until that is decided. But
> you can still do this for now, and change later if need be.
> 
> 	Thanks,
> 	Paul
> 
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue