Subject: [clue] Clarify availability of inputs to a mixer vs. output

From: John Leslie <[email-masked]>
Date: Fri, 9 May 2014 10:36:04 -0400

Clarify the separate availability (if any) of the inputs to a mixer
vs. the output of a mixer
====

   audioCaptureType should include a way to distinguish microphones from
mixer outputs.

   This is needed to satisfy REQMT-2b, IMHO.

   We now have the <composed> boolean to indicate that an audioCapture
is a mix of streams, and contentType to list the captureIDREFs and/or
sceneEntryIDREFs which go into the mix; but this is awfully hard to find.

   AFAICT, you have to search the simultaneousSets to find whether a
particular mediaCapture is available to be sent. This might require a
_very_ long list of simultaneousSets.

   ISTM that audioCaptureType could include a separately-available
boolean.

--
John Leslie <[email-masked]>

---

From: "Duckworth, Mark" <[email-masked]>
Date: Fri, 9 May 2014 15:05:36 -0700

Hi John,

There is a simple way to advertise a capture that you can't send (such as one that is just an input to a mixer).  You just don't give an encoding group for that capture.  Does this give you what you are looking for?

Mark

> -----Original Message-----
> From: clue [mailto:[email-masked]] On Behalf Of John Leslie
> Sent: Friday, May 09, 2014 10:36 AM
> To: [email-masked]
> Subject: [clue] Clarify availability of inputs to a mixer vs. output
> 
> Clarify the separate availability (if any) of the inputs to a mixer vs. the output
> of a mixer ====
> 
>    We now have the <composed> boolean to indicate that an audioCapture is
> a mix of streams, and contentType to list the captureIDREFs and/or
> particular mediaCapture is available to be sent. This might require a _very_
> long list of simultaneousSets.
> 
>    ISTM that audioCaptureType could include a separately-available boolean.
> 
> --
> _______________________________________________
> clue mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/clue

---

From: John Leslie <[email-masked]>
Date: Sun, 11 May 2014 21:59:41 -0400

Duckworth, Mark <[email-masked]> wrote:
> 
> There is a simple way to advertise a capture that you can't send
> (such as one that is just an input to a mixer). You just don't give
> an encoding group for that capture. Does this give you what you are
> looking for?

   Quite possibly it does... I wasn't able to grok encodingGroup from
the data-model-schema. :^(